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1 Introduction
Avid has provided a Graphic Device Service plug-in SDK for their MediaCentral® | Command 
system, which Vizrt has used to create a plug-in for basic playout of Viz Pilot and Viz Trio 
graphics.

This guide describes integration of the Vizrt iNEWS Command Plug-in with Avid’s MediaCentral® | 
Command workstation. In addition, it describes how to use MediaCentral® | Command to achieve a 
basic Vizrt graphics workflow.

1.1 Related Documents
For complementary information, see the following documents:

Avid MediaCentral® | Command Installation and Configuration Guide: How to install and 
configure the Avid MediaCentral® | Command workstation.
Viz Engine Administrator Guide: How to setup Viz Engine as an output channel.
Viz Pilot User Guide: How to install, configure and use Viz Pilot.
Viz Template Wizard User Guide: How to create templates, assign template variants to 
categories, and categories to channels for multiple output channel playout.
Viz Trio User Guide: How to install, configure and use Viz Trio.

1.2 Feedback And Suggestions
We welcome your feedback and suggestions regarding Vizrt products and this documentation.

To give feedback and/or suggestions, please contact your local Vizrt customer support team 
at http://www.vizrt.com.

1.3 Legal

1.3.1 Trademarks
Avid MediaCentral® is a trademark or registered trademark of Avid Technology, Inc. or its 
subsidiaries in the United States and/or other countries.
Avid iNEWS® is a trademark or registered trademark of Avid Technology, Inc. or its 
subsidiaries in the United States and/or other countries.

http://www.vizrt.com/
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2 Installation And Configuration
This section describes the basic steps you need to perform in order to successfully integrate your 
Vizrt graphics workflow with Avid’s MediaCentral® | Command and how to configure Viz Pilot in 
order to operate multiple output channels.

The following sections describe how to install and configure Vizrt’s iNEWS Command Plug-in and 
Viz Pilot/Viz Trio with Avid MediaCentral® | Command.

This section contains information on the following topics:

Requirements
Licensing Information
Installation
Configuration
Output Configuration
Configuration for https

2.1 Requirements

2.1.1 Vizrt iNEWS Command Plug-in Version 3.1
The following software requirements must be met in order to successfully install, configure and 
use the Vizrt iNEWS Command Plug-in version 3.1:

Avid MediaCentral® | Command version 2020.9.2 or later.
Media Sequencer version 5.4.0 or later.
Pilot Data Server 8.8.0 or later.
Viz Artist 4.4.1 or later
Viz Pilot 8.7.0 or later.
Viz Preview Server 4.5 or later.
Viz Trio 3.2.6 or later.

2.2 Licensing Information
License information for third-party software used by the Vizrt iNEWS Command Plug-in becomes 
available when clicking the Licensing information button on the Vizrt Plug-in Settings tab in the 
Avid Service Configuration.

2.3 Installation
This section describes how to install the software necessary to integrate your Vizrt graphics 
workflow with Avid’s MediaCentral® | Command:

Prerequisites
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Installation of the Vizrt iNEWS Command Plug-in

2.3.1 Prerequisites
The Vizrt Avid iNEWS Command plugin requires the following server and client side installation:

Avid MediaCentral® | Command server installation with Avid Service Framework.
Avid MediaCentral® | Command client with an Avid Graphic Device Service 01.

Make sure that the client installation of Avid MediaCentral® | Command is completed on the 
machine.

If you are running a firewall, you should open it and allow the Avid Graphic Device Service 01 to be 
allowed for all networks.

The Graphic Device Service (GDS) should not run on the same machine as the Avid MediaCentral® | 
Command Server. This setup can lead to problems with redundancy, because the GDS is not a 
redundant service, and would fail if the MediaCentral® | Command Server failed.

2.3.2 Installation of the Vizrt iNEWS Command Plug-in

To Install the Vizrt iNEWS Command Plug-in
Run the VizrtiNewsCommandPlugin-<major.minor>.msi file.

To Re-start All Services
Open the Avid Workgroup Properties application.
Click the Stop button.
Click the Start button.

Note: A client version of Avid Service Framework is required for the Avid MediaCentral® | 
Command client install.





Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  9

•
•
•
•
•

2.4 Configuration
This section describes how to successfully configure the integration between your Vizrt graphics 
workflow and Avid MediaCentral® | Command:

Configuration for iNEWS® and Viz Pilot Plug-in
Configuration of Viz Pilot Edge
Configuration of the Playout Profile in Viz Pilot and Viz Trio
Configuration of the Vizrt iNEWS Command Plug-in
Configuration of Avid MediaCentral® | Command workstation

2.4.1 Configuration for iNEWS® and Viz Pilot Plug-in 
This chapter contains configuration for Star CG Syntax elements and elements dragged from Viz 
Pilot (MOS Syntax elements).

Note: The configuration for SYSTEM/MAP is common for both Star CG Syntax and elements 
dragged from VCPTemplateFiller.
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SYSTEM/MOS-MAP
Using Viz Pilot from iNews requires you to configure the device name the elements that are 
dragged and dropped from this control should be attached to.

Do this by mapping the MOS ID. The MOS ID used is configured using the Viz Pilot configuration. If 
no MOS ID is specified, it defaults to PILOT.

After setting the MOS ID the VCPTemplateFiller uses, mapping from MOS ID to device name is done 
in iNews SYSTEM/MOS-MAP. The illustration below shows a SYSTEM/MOS-MAP that maps the MOS 
ID PILOTGRAPHIC to pilotdev.
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SYSTEM/MAP
Configuration in SYSTEM/MAP is required to use an iNews rundown with Avid MediaCentral®| 
Command. In the illustration below we see that for rundown show.cfl.rundown the device named
pilotdev is configured, using the default channel for *cg elements.

The style in the example is set to VCP. This bases star cg elements entered into this rundown on 
the templates of the Pilot external ID feed.

To instead base the hand-entered elements of the rundown on templates from a Viz Trio show, set 
the path of the show, including the shown name.

The example shown below shows Viz Trio with the show commandshow in the folder /shows/

moreShows/ . The style to set in iNews SYSTEM/MAP is then /shows/moreShows/commandshow
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In the illustration below we see that for rundown show.cfl.rundown4  the above mentioned show 

is configured as the ‘template pool’ for star cg syntax elements.

2.4.2 Configuration of Viz Pilot Edge
If Viz Pilot Edge is used as plug-in in the newsroom, then the MOS ID can be set as a query 
parameter to the URL. This URL is set when installing Show Edge. In the following example, mosid
is set to pilotgraphic: http://bgo-msecommanddev:8177/app/pilotedge/PilotEdge.html?
mosid=pilotgraphic

2.4.3 Configuration of the Playout Profile in Viz Pilot and Viz Trio
The playout profile you want to use for the Vizrt iNEWS Command Plug-in must be configured in 
Viz Pilot or Viz Trio. In the illustration below, a profile named mse1 is configured with channel X
for program and channel P for preview.

It is possible to configure the system for MultiChannel playout, see Avid MediaCentral® | Command 
Channel Switching and Playout.

Note: ‘No’ denotes that style check is off. Please refer to the Configuring Style section for 
details on this setting.



Note: The query parameter name mosid is case sensitive and must be written in lowercase 
letters.



http://bgo-msecommanddev:8177/app/pilotedge/PilotEdge.html?mosid=pilotgraphic
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2.4.4 Configuration of the Vizrt iNEWS Command Plug-in
The Vizrt iNEWS Command Plug-in can be configured using the Avid Service 
Configuration application.

Open Avid Service Configuration > MACHINE NAME (with the graphic service) > Graphic Device 
Service.

On the Plug-In Chooser page, make sure the plug-in selected is set to Vizrt.

On the Graphic Settings page, choose device profile Vizrt (note that this tab is only available when 
the graphic device service has been recently installed).
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Click Apply. The service/plug-in restarts for the changes to take effect.

Setting the Device Name and Channel Count
Open the plug-in configuration again (Open Avid Service Configuration > MACHINE NAME (with the 
graphic service) > Graphic Device Service). Select the Device Settings tab.

Specify the Device Name. The device name is the value we specified in SYSTEM/MOS-MAP and/or 
SYSTEM/MAP. In this example ’pilotdev’. In Avid Service Configuration the selected graphics device 
service is also post-fixed with the device name (in this example Avid Graphic Device Service 01 - 
pilotdev).

Specify the number of channels. This number is the number of program channels.

Click Apply. The service/plug-in restarts for the changes to take effect.

Note: If the service does not restart automatically (usually within 15 seconds), open the 
Avid Workgroup Properties application and restart all services by clicking Stop, and then 
Start.
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2.
3.

4.
5.
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Specifying the Media Sequencer and the Profile
Open the plug-in configuration again (Open Avid Service Configuration > MACHINE 
NAME (with the graphic service) > Graphic Device Service.).
Select the Vizrt Plug-in Settings > Connection Settings tab.
Specify the URL to the Media Sequencer service document from the Media Sequencer REST 

interface. This URL is http://HOSTNAME:port/ where the port is 8580  (unless the Media 

Sequencer has been set up using a port other than the default).
Click Look up.
Select the profile from the Profile drop-down.
Map the channel indices to the correct channel name. The indexing begins on 0. In this 
example, we specified 1 and only one channel will be available, the channel with index 0. 
Select X for this channel.

http://HOSTNAMEport
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7. Click Apply.

2.4.5 Configuration of Avid MediaCentral® | Command workstation
Avid MediaCentral®| Command must be set up with correct settings.

Configuring Playout Channel
Select Tools > System Settings > Channel > Indices. Add one or more playout channels to this list.

In the illustration below, the playout channel X has the index 5.

Note: The number of channels in the Channel mappings list must equal the Channel 
count number specified on the Device Settings tab.
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Click Apply.

Configuring Device Channel
Open Avid MediaCentral®| Command. Select Tools > System Settings > Channel > Device Channels.

Click the Add button and add the playout channel to the device name. Remember that the device 
name is the name of the Graphic Device Service (in our example, the device name is pilotdev). 
Enter the device name (you can write into the drop-down component). The channel we want to add 
is X. Use Other Graphics as Device type.

Click OK. Click Apply.

If you want to add more channels to the device name, the channel index must be incremented.

 
The illustration below shows the playout channel X added to device pilotdev on index 0.
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Configuring Channel Group
Open Avid MediaCentral®| Command. Select System Settings > Channel > Groups, and click the 
Add button. Provide a name for the channel group.
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Click the Add button for adding a playout channel to the channel group. In the illustration below 
the channel X (on device pilotdev- using index 0) is selected.
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Click OK. Then click the Apply button in the System Settings window. The illustration below shows 
that the group pilotdev is added and has one channel named X.
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See Also

Viz Pilot User Guide
Viz Trio User Guide

2.5 Output Configuration
To play out Vizrt graphics you need one or several Viz Engines depending on your use case.

This section describes how to configure the output channel(s) in order to play out graphics from 
the Avid MediaCentral® | Command workstation.

This section contains information on the following topics:

To Create an iNEWS Playlist Containing Vizrt Graphics
To Configure an Output Channel
To Configure Multiple Output Channels

http://docs.vizrt.com/viz-pilot.html
http://docs.vizrt.com/viz-trio.html
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7.

2.5.1 To Create an iNEWS Playlist Containing Vizrt Graphics

Create and configure a new playlist in iNEWS.
Add your stories to the new playlist.
Open a story for editing.
Start Viz Pilot Newsroom Component (Tools > Plugins > VCPTemplateFiller Control).

This starts Viz Pilot.

Open a template, make the necessary changes and save it as a new data element.
Drag and drop the element into your story. Data elements can be added from the Template 
editor and data element list.
Monitor and load the playlist to see it in Avid MediaCentral® | Command.

Note: VCPTemplateFiller Control is called Viz Pilot.
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10.

11.

1.
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2.5.2 To Configure an Output Channel
Start the Media Sequencer you have configured for Avid MediaCentral® | Command.
Start the Viz Engine(s) you will use as your output channel(s).
Start Viz Pilot (or Viz Director from Viz Pilot 6.1 and onwards).
From Viz Pilot’s Tools menu, select Profile Configuration... (CTRL + M).

Add a new profile.
Add a new channel (for example X).
Add the Viz Engine you will use as your output channel.
Drag the newly added Viz Engine onto the newly created channel.
Start the Avid Service Configuration tool installed on the Media Sequencer machine.
Select the graphic device and under the Vizrt Plug-in Settings, click the Look up button.

Select the profile you just created, and click Apply.

2.5.3 To Configure Multiple Output Channels

Start Viz Template Wizard.
From the Tools menu, select Categories and Channels.
In the Categories and Channels dialog box do the following:

Define the categories (for example FullScreen and Thirds).
Define the channels (for example X and P).

Note: This procedure only applies to Auto Channel configurations.
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Define the custom channels by assigning a channel to the newly created categories.

From the Tools menu, select Template Manager (requires a running Viz Engine).
Select and edit a template variant and set a category for it.
Click Save.
Start Viz Pilot.
Repeat the procedure above (To Configure an Output Channel); however, this time add two 
channels with the channel names defined in Viz Template Wizard (for example X and P).

See Also

Avid MediaCentral® | Command Channel Switching and Playout
Viz Pilot User Guide
The Template Wizard section in the Viz Pilot User Guide

2.6 Configuration For Https
The Vizrt iNews Command plugin and other Vizrt components can communicate using Hypertext 
Transfer Protocol Secure (HTTPS). Vizrt iNews Command Plugin communicates with Viz Pilot's Data 
Server (PDS),  Media Sequencer, and Preview Server.

This section consists of:

Setting up HTTPS communication towards Pilot Data Server running behind caddy 2 server
To register the certificate with the java environment:

Configure the PDS URL for use by Media Sequencer
Notice for the Pilot Data Server install

The Transport Layer Security (TLS) version supported is v1.2.

http://docs.vizrt.com/viz-pilot.html
http://docs.vizrt.com/viz-pilot.html
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2.6.1 Setting up HTTPS communication towards Pilot Data Server 
running behind caddy 2 server

This is an example of Pilot Data Server that runs behind a Proxy (Caddy 2 server). This setup is 
relevant as the Pilot Data Server might be running behind a caddy 2 server as part of a Viz Story 
setup.

A sample caddy configuration file is shown below:

{
http_port 80
https_port 443
}
 
(mytls) {
tls C:/certificates/pdshost.pem C:/certificates/key.pdshost.unencrypted.pem {
    protocols tls1.2
    ciphers  TLS_RSA_WITH_AES_256_CBC_SHA TLS_RSA_WITH_AES_128_GCM_SHA256 
TLS_RSA_WITH_AES_256_GCM_SHA384 TLS_AES_128_GCM_SHA256 TLS_AES_256_GCM_SHA384 
TLS_CHACHA20_POLY1305_SHA256 TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA 
TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA 
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 
TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256 
TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256 
}
}
 
https://pdshost {
  
    ## Configure logging
    log {
        output file "C:/ProgramData/Vizrt/requests-Caddy2.log" {
            roll_keep_for 90d # Keep rotated files for 90 days
            roll_size 50Mib # Rotate after 50 MB
            roll_keep 20 # Keep at most 20 log files
        }
    }
    import mytls
     
    # Backend services
 
    handle /.proxy {
        reverse_proxy localhost:82 {
        }
    }
 
    handle /pds/* {

Note: HTTPS setup without Caddy 2 is also possible.
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        reverse_proxy localhost:8177 {
        }
    }
  
    handle /preview/* {
        reverse_proxy localhost:21098 {
        }
    }
  
    ## Mist ##
    handle /* {
        header Vary Origin
        reverse_proxy localhost:82
    }
 
}

The certificate that the caddy server will present to its clients is set in the configuration file for the 
caddy server. This certificate must be recognized by both:

The java environment in which the plugin is running.
The java environment in which the plugin's configuration panel is running.

For a default install, the java environment for the configuration panel is found here: C:\Program 
Files (x86)\Avid\Service Framework\jre\ 
and the Java environment for the plugin is found here: C:\Program Files (x86)\Avid\iNEWS 
Command\jre\.

To register the certificate with the java environment:
Open a Command prompt with admin rights (right-click > run as administrator)
Use the java tool 'keytool.exe' to import the certificate.  This tool is found in the bin folder 
of java:  Example import: 

C:\Program Files (x86)\Avid\Service Framework\jre\bin>keytool.exe -import
 -trustcacerts -alias TRUST_PDS_MACHINE -file C:\certificates\pdshost.pem 
-keystore ..\lib\security\cacerts

And the same procedure for the second java installation: 

In this example, the Pilot Data Server and the caddy 2 server runs on machine 'pdshost'. 
The Pilot Data Server service document is available on: https://pdshost:443/pds/.



Note: The Avid installer for Media Central installs both of these Java environments. 
The certificate must be registered with the java environment's trust store, known as 
'cacerts.'



https://bgo-cflw2.vizrt.internal/pds/
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C:\Program Files (x86)\Avid\iNEWS Command\jre\bin>keytool.exe -import
 -trustcacerts -alias TRUST_PDS_MACHINE -file C:\certificates\pdshost.pem 
-keystore ..\lib\security\cacerts

Graphic Device Service must be restarted after the certificate has been installed.

A successful Pilot Data Server configuration looks like this:

2.6.2 Configure the PDS URL for use by Media Sequencer
To configure the PDS URL for Media Sequencer either :

Viz Pilot's Director with the Media Sequencer configuration app "VdomConfig", or 
Only with VdomConfig.

Here is an example using Director and VdomConfig:

Open Director and go to Tools > Media Sequencer Configuration. 
Select the Database tab then Pilot Data Server
Fill in the Host and the Port of the PDS server
Click Apply

Note: The default password for the java cacerts is 'changeit'. As the name suggests, it is 
advisable to change it.
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5.

6.

7.

8.

Open a browser and go to http://'MS_HOST':8580/app/vdomconfig/vdomconfig.html

On the left side of the VdomConfig window click on Scheduler > vcp_service which will show 
an XML configuration on the right side

Correct the URL in the <service_document>  tag to use HTTPS instead of HTTP and add the 

postfix if a base URL is used for PDS
Click Apply

Note: The MS_HOST is the host where Media Sequencer is running. If the Media 
Sequencer is e.g accessible on a different port or via HTTPS, make the necessary 
changes to this URL.



http://msehost:8580/app/vdomconfig/vdomconfig.html
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Keep note of the following:

The machine the Media Sequencer is running on needs to trust the certificate provided by 
the caddy 2 server.  Example of installation on a Windows machine:

Double click the .crt file of the certificate.
Click on “Install certificate”.
Follow the instructions.  If the certificate has not been correctly installed, the 
vcp_service handler might show an error like this:  

status="error: Could not reach service document: 'https://pdshost:443/
pds/': SSL peer certificate or SSH remote key was not OK 

If the Media Sequencer running has a version number lower than 5.5.0, certificate validation 
needs to be turned off.  Do this by adding the following XML entry to the XML configuration 

of the vcp_service handler, as a direct child of the <handler>  entry: 

  <insecure_https>yes</insecure_https>  

2.6.3 Notice for the Pilot Data Server install
In the above example, the Pilot Data Server was installed with support for the Base URL: https://
pdshost/pds

 See the Pilot Data Server Administrator Guide for more information.

http://pdshost/pds
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3 Getting Started

3.1 Plug-In Usage
After having installed and configured the Vizrt iNEWS Command Plug-in (see Installation and 
Configuration), the plug-in is ready to be used.

The playlist can either be created in iNEWS by dragging elements from Viz Pilot 
(see MOS Syntax), or by entering elements directly with the *cg method (see Star CG Syntax). When 
you start the monitor on the playlist, it becomes visible in Avid MediaCentral® | Command.

When the user locks the channel group, the plug-in, if configured, sends an initialize command to 
the Media Sequencer.

On cue of an element, the read operation is sent to the Media Sequencer. This causes a preview to 
be made of that element on the preview channel that has been configured (if any).

On play of an element, the take operation is sent to the server. This causes the element to be 
played on the program channel.

See Also

Troubleshooting
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4 Features
This section contains information on the following topics:

Star CG Syntax
MOS Syntax
Thumbnails
Avid MediaCentral® | Command Channel Switching and Playout
Stop-point Count-down
Timed Playout
Initialize on Viz Engine
Preview

4.1 Star CG Syntax
In this version of the Vizrt iNEWS Command Plug-in, elements are either added as *cg elements, or 
they are added from Viz Pilot (explained in MOS Syntax). This section describes how to use *cg
syntax in the Vizrt iNEWS Command Plug-in. The *cg syntax makes it possible to map a *cg code to 
an Viz Pilot external template ID or a Viz Trio show template.

This section contains information on the following topics:

Configuration
Inventory
Providing an External ID for a Template
Add Star CG Element to Story in iNEWS
Star CG and Combo Templates
Edit CG Element Data Using Avid MediaCentral® | Command
Known Limitations for CG Elements

4.1.1 Configuration

Setup in iNEWS
Each RUNDOWN in iNews can be configured to support set of templates for star cg syntax. The 
configuration for this in iNEWS SYSTEM/MAP is explained in Configuration.

The additional setting for style check is explained in Style Check and Preload.

Plug-in Configuration
If any of the rundowns are set to use the external ID templates, then the Enable VCP external ID 
templates check box must be enabled, and you must set the URL for the REST service document of 
the Viz Pilot Data Server. For example:
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4.1.2 Inventory
You should be able to see templates for CG elements in the inventory in Avid MediaCentral® | 
Command. The templates, if any, appear when starting the plug-in or when a playlist is loaded into 
Avid MediaCentral® | Command (monitor on in iNews).

Note: Configuring this setting is not required if only Viz Trio CG elements are used. In 
which case select the option Use Viz Trio templates only and click Apply.
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For star CG elements based on templates from the Viz Pilot external templates feed, the ID shown 
in the inventory is the external ID prefixed with VCP:v. The prefix is added because Avid 
MediaCentral® | Command requires the ID to be alphanumeric (it has to contain at least one letter) 
if the user should be able to add data.

For star CG elements based on templates from a Trio show, the ID shown in inventory is the name 
of the template prefixed with show path. A v is added in front of the template name if the name is 
pure numeric, for the same reason as for VCP ext id templates.

Style Check and Preload
Set style check to On or Off for a rundown in iNews SYSTEM/MAP.

The image below shows style check turned off, with no as a value (style check is on if no value is 
provided).
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1.
2.

If the iNews user writes a template name incorrectly (by referring to a template not in inventory) 
with style check set to on, the graphic element will not load into Avid MediaCentral® | Command 
on monitor on. An error appears in iNews, and the Avid MediaCentral® | Command user does not 
see the element.

If the iNews user writes a template name incorrectly with style check set to Off, the graphic 
element still loads into Avid MediaCentral® | Command. The element, however, appears with an 
error in Avid MediaCentral® | Command.

Preloading CG templates is required if style check is on:

When Using CG Elements Based on Templates from the Pilot External Feed
Select Vizrt Plug-in Settings tab > Connection Settings tab > Pilot Data Server Connection > Preload 
Pilot external ID feed and click Apply:

When Using CG Elements Based on Template from a Trio Show, Ensure the Show is 
Found in the Preload List for Viz Trio Shows

Open the Vizrt Plug-in Settings tab.
Click the Trio show template preload tab.
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3.

4.

Drag and drop the relevant show from the left side tree view to the right side list, as shown 
here:

Click Apply after changing settings.

4.1.3 Providing an External ID for a Template
A Viz Pilot template can be given an external ID using Viz Template Manager (open Viz Template 
Wizard and select Tools > Manager). Note that the template must also be given a description. 
Example:
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After saving the template, it is listed in the external ID atom feed: http://<pilot data server 
host>:8177/external_ids.

The Vizrt iNEWS Command Plug-in reads this feed on load of a playlist that contains *cg elements 
with VCP style.

4.1.4 Add Star CG Element to Story in iNEWS
To add a *cg element to a story in iNEWS, right-click the story and select Insert production cue (or 
alternatively press ALT + INSERT).

Tip: It is possible to allow for automatic use of title as the template identifier for Viz Pilot 
CG’s. To do so, select the corresponding check box in the Vizrt Plug-in Settings tab. Note 
that the user must make sure the title is unique for every template, and also that iNews’ 
restrictions for allowed template names are followed.
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Then insert the element on the format (example element has two values):

*DEVICENAME ID 
value1 
value2

The example below is using devicename pilotdev where ID is v<external ID>:

Use Tools > Monitor to monitor the playlist.

The playlist looks like this in Avid MediaCentral® | Command:



Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  39

•
•

1.
2.
3.
4.

4.1.5 Star CG and Combo Templates

About Combo Templates
Using Viz Template Wizard the user can create a template that controls several layers (e.g. banner
and lower). This is known as a Combo Template.

There can be several states per layer, which can be selected when creating a data element. 
However, as the user of iNews does not have the necessary information to make this selection, the 
command plug-in selects automatically according to the following rules.

State Selection for Combo Templates Using Star CG
Per layer:

If the layer has more than one choice that is non-empty, ignore the layer (select empty).
If the layer has only one choice which is non-empty, select this one.

4.1.6 Edit CG Element Data Using Avid MediaCentral® | Command

To Edit CG Element Data
Double click a graphic in the playlist in Avid MediaCentral® | Command.
The graphic item appears in the Media Editor.
The graphic’s editable data text fields, if applicable, appear.
Edit the text in the fields.

Here is an example:

Note: Viz Pilot uses the same selection algorithm.
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3.

To Enable Editing CG Elements
Editing CG elements in Avid MediaCentral® | Command is disabled by default. To enable editing:

Navigate to Vizrt Plug-in Settings > Options.
Select Allow editing of cg elements from Avid MediaCentral® | Command in the configuration 
settings for the Vizrt Avid Command plug-in.
Click Apply.

Note: Restarting Avid services on the Avid Server is required for changes to this 
setting to take effect.
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4.1.7 Known Limitations for CG Elements

Cannot Insert Data to Star CG Element Created Using Avid MediaCentral® | 
Command
In Avid MediaCentral® | Command the user can press ALT + INSERT (or right-click the playlist and 
then select Insert > New item).

A pop-up window appears where the user can add a *cg element. Example:

Currently it is not supported that the user modifies editable fields for the new data item.

Video or Image in Graphics Element Not Supported
If Viz One is configured for Viz Pilot in iNEWS, the user is not able to add such elements to the 
rundown using *cg syntax.

Default Template Values Not Supported for Star CG Elements
If the user provides no data for a *cg syntax element (where the template has data fields), then the 
fields are empty.

4.2 MOS Syntax
Elements are either added as Star CG Syntax elements, or they are added from Viz Pilot (explained 
in this section).

This workflow type is called MOS elements because when the user drags an element from Viz Pilot 
to iNEWS, the data transfer is in form of MOS-XML.

Note: The Vizrt iNEWS Command Plugin prior to version 2.0 also supported the Broadcast 
Control Solution (BCS) mode, however this mode is no longer needed.
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You can test this by dragging an item from Viz Pilot to for example WordPad. It is also possible to 
drag XML from WordPad to iNEWS.

 
This section contains information on the following topics:

Configuration
Example Element

4.2.1 Configuration
For the MOS type elements to work, the following configuration must be set up:

Database Settings
For the Vizrt iNEWS Command Plugin, the following settings must be set in the Viz Pilot database:
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Viz Pilot Database Settings

Name Value Note

ax_use_avid_timing n Timing information in the MOS XML will be 
given in frames.

ax_remove_objSlug n The slug must be present.

The Viz Pilot settings can be accessed from http://PILOTDATASERVER:8177/settings or in Viz Pilot
( Options > Preferences > Advanced).

Viz Pilot Registry Settings

The insertBCSTag must be set to 0  (see illustration below).

The UseVCPDM setting must also be set to 0 .

Note: For the 2.0 version of the Vizrt 
iNEWS Command Plugin, this value had 
to be set to y.



http://PILOTDATASERVER:8177/settings_
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2.

4.2.2 Example Element
The following illustration shows a screen shot of iNEWS when the two elements named 
stop_points_blue_ball and stop_points_vizrt_logo are added to a story.

4.3 Thumbnails
The Vizrt iNEWS Command Plug-in can be used together with the Preview Server to provide 
thumbnails for both *cg and MOS type elements (dragged to the iNEWS rundown from Viz Pilot).

This section contains information on the following topics:

Installation and Configuration of the Preview Server
Setting up Avid MediaCentral® | Command for Thumbnails
Enable Thumbnails, Plug-in Configuration
Thumbnail Status
Status for CG Elements
Troubleshooting

4.3.1 Installation and Configuration of the Preview Server
Install the Preview Server.
Open the Preview Server homepage/configuration page: Start > Vizrt > Preview Server 
Config. On the configuration page you can specify the host and port of the Viz Engine for 
which the Preview Server should connect to (see the illustration below).
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4.

Configure the Viz Pilot settings to use the installed preview server:
Open Start > Vizrt > Pilot Data Server Web Interface
Click Settings in the top menu.
For the preview_server_uri setting, provide the URL to the preview server, for example 
http://HOSTNAME:54000/ (see illustration below).

After applying this URL, restart Media Sequencer and then restart the Vizrt Avid iNEWS 
Command Plug-in.

4.3.2 Setting up Avid MediaCentral® | Command for Thumbnails
To be able to view thumbnails, you must select the Show thumbnails check box in Tools > Options 
> Playlist and Shotbox Viewers > Playlist Viewer as seen in the illustration below:

Note: Use Google Chrome or Firefox to view this page. Using Internet Explorer is not 
recommended.



http://HOSTNAME:54000/_


Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  46

You must also select this option it in the Playlist Viewer > Columns settings as seen in the 
illustration below:

It is possible to rename the column in these settings too. Now you should be able to view the 
thumbnails in the column. If they do not appear for some reason, try to resize the column by 
expanding the header.
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You can also view the thumbnails in the Media Viewer frame:

4.3.3 Enable Thumbnails, Plug-in Configuration
For the Vizrt iNEWS Command Plug-in to fetch thumbnails from the Preview Server, the following 
steps must be performed:

Open the Avid Service Configuration.
Select the graphic service.
Select the Vizrt Plug-in > Connection Settings tab.
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•

Select the Use Preview Server to load the thumbnails check box, and enter the URL of the 
Preview Server atom service document in the text box, see illustration below:

4.3.4 Thumbnail Status
The graphic’s status is shown at the right side of the thumbnail for MOS-type elements.

A red bar appears on the right side of the thumbnail of the graphic if any monitored 
resource (a staged image by Graphic Hub ImEx Agent, for example) of the graphics item is 

Note: Click Look up to verify that the preview server URL can be accessed. Then click 
Apply.
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unavailable for playout.

An orange warning bar appears on the right side of the thumbnail of the graphic if the 
graphics monitored resources are available but not fully loaded in the memory of the Viz 
Engine.

A green OK bar appears if the graphics and their resources are available to the Viz Engine.

4.3.5 Status for CG Elements
Thumbnail status is not yet supported for CG elements. However, a workaround is available. It is 
possible to select to show a textual status in the page column.
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The following statuses are shown:

If any monitored resources (for example a staged image by Graphic Hub ImEx Agent) of the 
graphics item is unavailable for playout, the page text of the graphic is NOT READY.
If the graphics monitored resources are available, but not fully loaded in the memory of the 
Viz Engine, the page column is shown as AVAILABLE.
If the graphics and its resources are available and fully loaded, READY is shown.

To Enable Showing a Textual Status in the Page Column
Open Vizrt Plug-in Settings tab > Options tab.
Select Show status for cg elements in the page column.
Click Apply. 

For the page column to show, it must be selected in Avid MediaCentral® | Command in Tools > 
Options, as shown here:
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4.3.6 Troubleshooting
If you want to clear old thumbnails, you can clear the cache with the following steps on the server:

Close the playlist in Avid MediaCentral® | Command Workstation.
Stop the Inventory Manager with Avid Workgroup Properties (see the following illustration).

Delete the thumbnail cache folder (<Program Files>\Avid\iNEWS 
Command\inventorymanager\state\thumbnailcache).
Restart the Inventory Manager.
After the alert shows in Command Workstation that the Inventory Manager is available again, 
re-open the playlist.
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4.4 Avid MediaCentral® | Command Channel Switching And 
Playout

This section contains information on the following topics:

Setting up Avid MediaCentral® | Command for Channel Switching
Assign Channel in iNEWS (to MOS Type Element)
Default Channel for Star CG Elements
Default Channel for MOS Elements
Troubleshooting
Categories and Channels
Channel Playout Example
Auto Channel

4.4.1 Setting up Avid MediaCentral® | Command for Channel 
Switching

In Avid MediaCentral® | Command, create all necessary channels: Tools > System Settings > 
Channel > Groups > Edit > Add.

In the illustration below, two channels have been added (notice the index numbers, we will get 
back to them later):

Note: The Vizrt iNEWS Command Plug-in also has a cache. When restarting the plug-
in, this cache is cleared.
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In the Avid Service Configuration’s Device Settings panel, set the channel count to the number of 
channels that you would like to use (see the illustration below):
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The index numbers for the channels, which are found in the Avid Service Configuration’s 
Connection settings tab in the Vizrt Plug-in Settings panel, are relevant here:
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 Avid MediaCentral® | Command does not have a simple way to let the user map from the external 
channels fetched from the profile and the list of channels in its system settings. We have solved 
this by letting the user select which channel should be associated with the index numbers from the 
drop-down list.

When the channels have been selected from the drop-down list, click the Apply button to save.

Remember to provide the channels’ playout machines. This is done in the profile configuration in 
Viz Pilot or Viz Trio.
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The channel can now be changed in Avid MediaCentral® | Command:

Click the channel-column for an element and select the desired channel from the drop-down list. 
The element is updated so that multi-channel playout is possible.

4.4.2 Assign Channel in iNEWS (to MOS Type Element)
It is possible to assign a channel for a MOS story item using iNEWS by right-clicking an element 
and select Assign channel).
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Channel assigning in iNEWS sets the <itemChannel> mos-tag.

4.4.3 Default Channel for Star CG Elements
The default channel for a *cg type element is set in iNEWS in the SYSTEM/MAP file. In the example 
illustration below the default channel is set to X:

4.4.4 Default Channel for MOS Elements
The default channel for MOS type elements is the channel assigned to index 0 in the Vizrt plug-in 
settings.

4.4.5 Troubleshooting
If you experience any problems with channel switching, check Avid Diagnostics for errors.



Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  58

•
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4.4.6 Categories and Channels
Note that setting a default channel using the Categories and Channels in Template Manager does 
not directly apply for the Vizrt iNEWS Command Plug-in.

Reason
The Categories and Channels will set the <channel></channel> tag in mosExternalMetaData, 
which is not used by the plug-in. The Avid Command SDK interprets the <itemChannel> tag. If no 
itemChannel is set, the channel defaults to the channel on index 0.

4.4.7 Channel Playout Example
This section gives an example of multi-channel playout.

In the following example, two channels are configured:

Channel X
Channel Z

No preview is configured in this example.

When loading elements from iNEWS to Avid MediaCentral® | Command, MOS type elements are by 
default assigned to the channel with index mapping 0. CG elements are assigned to the default 
channel in iNews SYSTEM/MAP. (See Avid MediaCentral® | Command Channel Switching and 
Playout). In this example, all items are assigned to channel X.

Note: To use Categories and Channels it is necessary to assign to a channel the name 
AUTO, see Auto Channel.
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It is possible to alter the channel for an item (selecting from the drop-down menu in the channel 
column) both before and after locking the playlist.
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4.4.8 Auto Channel
As Categories and Channels for Viz Pilot are not directly supported by the Vizrt iNEWS Command 
Plug-in, the plug-in does special handling for a channel named AUTO. The AUTO channel can be 
used with Categories and Channels.

If you configure a channel in Avid MediaCentral® | Command to have the name AUTO, then the 
Vizrt iNEWS Command Plug-in does not set any Media Sequencer channel on such an element, and 
the element is played out on its default channel.

Configuring the Vizrt iNEWS Command Plug-in
Add a channel AUTO on the configuration page for the Vizrt iNEWS Command Plug-in using the 
Avid Service Configuration. Remember to set the correct number of channels on the Channel count
setting on the Device Settings tab (see illustrations below).

 

IMPORTANT! It is not possible to use the AUTO channel with Trio CG elements. Another 
channel must therefore be assigned to Trio CG elements.
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Configuring Avid MediaCentral® | Command
Configure the Avid MediaCentral® | Command channel settings to have the AUTO channel (see the 
illustrations below).



Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  62

 

 



Vizrt iNEWS Command Plug-in Administrator Guide -  3.1

Copyright © 2023  Vizrt                                                          Page  63

Example Using Categories and Channels
In this example the Categories and Channels has been configured (using Viz Template Wizard > 
Tools > Categories & Channels) to have a category for the X channel and one for the Z channel.
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The List template is placed into the category that plays out on channel X (using Template Manager, 
see illustration below). The side right template has been put into the category that plays out on 
channel Z.
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Story in iNEWS
A story was created in iNEWS and two elements were added (created from the mentioned 
templates). Note that both elements were manually assigned the channel AUTO in iNEWS. If you 
want to have the AUTO as default, you can configure the AUTO channel on index 0 in the Vizrt 
iNEWS Command Plug-in configuration.
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•

•
•
•

•

The illustration below shows the playlist loaded in Avid MediaCentral® | Command. The first AUTO
element plays on channel X. The second AUTO element plays on channel Z.

See Also

To Configure Multiple Output Channels

4.5 Stop-Point Count-Down
Avid MediaCentral® | Command supports continue-counting of graphics with stop-points.

This section contains information on the following topics:

Setting up Avid MediaCentral® | Command for Stop-points
Troubleshooting
Count-down Example

4.5.1 Setting up Avid MediaCentral® | Command for Stop-points
Avid MediaCentral® | Command displays graphic trigger counts (stop-points) that are set in Viz 
Pilot.

To display the graphic trigger counts, go to Tools > Options > Playlist and Shotbox Viewers > 
Playlist Viewer > Columns.

Once here you can:

Click SHOW to display the trigger counts column.
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• Edit the HEADER column to change the display name of the column.

The above configuration displays as follows:

4.5.2 Troubleshooting
Enable Avid Diagnostics to check if any errors occur during runtime.

Note: Stop-point count-down is not supported for Trio-type CG elements.
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4.5.3 Count-down Example
This section explains how to playout elements with count-down (stop-points).

Manual Playout
In this example, manual playout of an element with continue count is shown (see the illustration 
below). When locking the graphics channel group, the first element in the playlist is cued (read) on 
the preview channel if it is set in the profile in Viz Pilot/Viz Trio.

Clicking the play button makes the Vizrt logo appear on the program channel (a play/take 
operation is issued). The continue count goes to 1.

Note: In this example, the autocue functionality for Avid MediaCentral® | Command is 
enabled.
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•

The graphic item has more continue points and the item is in paused state. For the next three 
times the user clicks the play button, there is a continue command is sent to the program channel 
for the relevant item.

Clicking the Play button for this item the last time initiates two procedures:

Continue is sent to the program channel and the animation will go to its fourth stop point, 
and
The next graphic item in the playlist is cued (read) on the preview channel if autocue for 
Avid MediaCentral® | Command is enabled.

Note: The user must make sure the animation between the continue points is finished 
before pressing a new play. Otherwise the animation progress and continue-count in Avid 
MediaCentral® | Command gets out of sync.
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•

•
•
•
•
•

See Also

Read the Variant section of Template Manager in the Viz Pilot User Guide to learn about 
setting stop points in Viz Pilot.

4.6 Timed Playout
This section explains the playout of graphics timed relative to a video. For using timed playout, 
a Database Settings is needed. A video device is also needed. For testing, the video emulation 
device 'Avid Video Emulation Service' can be installed. 

Note that timing relative to a video is possible for MOS elements. There is no support for adding 
timing information to *cg syntax elements.

This section contains information on the following topics:

Add Element with Timing Information Using Viz Pilot
Template Settings
Viz Pilot DB Configuration
Avid Video Emulation Service
Known Restrictions

4.6.1 Add Element with Timing Information Using Viz Pilot
An element in Viz Pilot can be saved with start time (relative to the start of the video) and duration, 
see the illustration below.

Note: Timed Playout does not support trigger count.

http://docs.vizrt.internal/viz-pilot.html
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4.6.2 Template Settings
For the timing information to be present for a template in Viz Pilot, the template must have the 
information component (TTWTemplateInfoControl) added to it. In the information component, the 
setting ShowGraphicEventTiming must be set to stShow, see the illustration below. Use Viz 
Template Wizard to add this component to templates you want to have timing information for.
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•

1.
2.

4.6.3 Viz Pilot DB Configuration
The setting in the Viz Pilot database ax_use_avid_timing is disabled. This means that the timing is 
given in fields per second in the MOS XML.

4.6.4 Avid Video Emulation Service
The Avid Video Emulation Service (or a real video device) is needed if we want to test the timing of 
graphics (in Avid MediaCentral® | Command). The graphic timing is relative to the start of the 
previous video in the same story. Graphic timing is ignored if there is no video.

4.6.5 Known Restrictions
Timed playout does not support trigger count.

See Also

Database Settings

4.7 Initialize On Viz Engine
Graphics resources can be loaded into a Viz Engine’s memory for them to play out smoothly on the 
Viz Engine. This procedure is named initialize. The status of the initialize operation is visualized 
with color codes on the thumbnail for mos-type elements, see Thumbnail Status for more 
information.

The following checkbox must be selected in the Vizrt plug-in settings to enable initialize for 
graphics items in Avid MediaCentral® | Command:

To enable the check box:

Open the Vizrt Plug-in Settings tab.
Click the Options tab.
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3.

4.
5.

Select the Enable initializing of a playlist or item in a playlist check box.

Click Apply.
The elements in the playlist are initialized when the channel group is locked.

In Avid MediaCentral® | Command, it is also possible to right click on a graphics element and 
select Graphics > Initialize Item / Graphics > Initialize Playlist.

Note: This only has an effect when the channel group is locked.
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•

See Also

Status for cg Elements

4.8 Preview
A preview channel can be configured in the Viz Pilot profile configuration (Tools > Profile 
Configuration).

Only one external preview can be configured per profile.

If autocue is enabled in Avid MediaCentral® | Command (Avid MediaCentral® | Command > Tools > 
System Settings > Playout > Autocue) then the Avid system automatically queues the next item in 
the playlist.

If autocue is not enabled, the user of Avid MediaCentral® | Command is manually cuing items, and 
one preview channel is enough even though multiple playout channels are available.

Note: Viz Trio can also be used to configure a preview Viz Engine. See the Output section 
in the Viz Trio User Guide for more information about this procedure.



https://docs.vizrt.com/viz-trio
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5 Playout Of Vizrt Graphics
This section describes how to successfully play out Vizrt graphics from Avid MediaCentral® | 
Command.

5.1 Controls
The system plug-in keeps track of which element is currently running (paused, in Avid-terms). If 
you click Play on the current element it results in a CONTINUE, while a play on all other elements 
results in a TAKE on the corresponding element (see To Play out from Avid MediaCentral® | 
Command).

The Avid MediaCentral® | Command controls map to the following behavior when triggering Vizrt 
graphics:

5.1.1 Control Buttons on Playout Toolbar

Icon Action

Cue manually cues the item. If autocue is on, the next graphics element is 
cued automatically on TAKE .

Play does a TAKE if the element you click Play on is not already taken. 
Clicking Play immediately results in a pause icon for the current element 
to allow a CONTINUE on consecutive actions for the same graphics 
element. The stop icon appears at the end of a sequence of stop points in 
a graphic element.

Pause has no function.

Stop results in a TAKE OUT.
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1.
2.
3.
4.

•
•
•

5.2 To Play Out From Avid MediaCentral® | Command

Start Avid MediaCentral® | Command workstation.
Open the playlist you loaded in iNEWS.
Click the lock to operate the playlist.
Click the Play button to load and play out the graphics.

If the scene use Continue points, click the Play button to continue the animation.
If the scene should be played again, click the Stop button and then the Play button.
If the scene should be taken Off Air (hard cut), click the Stop button.

5.3 Set Last Played Item As Done
On playout of Vizrt graphics from Avid MediaCentral® | Command, graphics are set to the Done
state after they are played out. The exceptions are CG graphics based on the same template, in 
which case only the last graphic is set to the Done state.
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5.4 The Appearance Of The Graphic Is Set According To The 
Options Settings In Avid MediaCentral® | Command

 
A stop icon is used in Avid MediaCentral® | Command to show the Done state, in addition to the 
selected colors and font.

Selecting Vizrt Plug-in Settings > Options > Only mark last played graphic as done (per 
channel) will label the last played item (per channel) with the Done state.
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Note: Avid MediaCentral® | Command users can easily see which element was played last if 
a special color is used for the Done state.
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•

6 Troubleshooting
The following section is a troubleshooting section for the Vizrt integration with Avid 
MediaCentral® | Command.

The information is based on experience gained by Vizrt during development and testing.

This section contains information on the following topics:

Known Limitations
Usage Related Troubleshooting
Avid Troubleshooting Tools
Verification of the Configuration
Known Issues

6.1 Known Limitations
The following are the known limitations of the Vizrt iNEWS Command Plug-in. The limitations are 
based on functionality most users expect from a Vizrt graphics workflow; hence, the basic playout 
and control of Vizrt graphics, when compared to Vizrt control applications, is a bit different.

When using *cg syntax: No default values are present for *cg elements with no input data.

*cg v1003

Standalone playlists and shotbox: Standalone playlists and shotbox functionality are not 
supported in this version.
Timed graphics being played out relative to a video, does not have support for continue 
count.
No support for video elements.
If a playlist created by the plug-in is deleted in Viz Pilot, the Avid Graphic Device Service 
must be restarted.
If the Media Sequencer is restarted, the Avid Graphic Device Service must be restarted.

See Also

Vizrt iNEWS Command Plug-in Release Notes

6.2 Usage Related Troubleshooting
If there are errors in the channel configuration, the item in the playlist is displayed in red 
and labeled with CHANNEL DOWN.

Example: External template v1003 has two input text fields where default values 
have been set in Viz Pilot, then the following syntax gives a data element with empty 
values:
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b.

•
•
•
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To acquire the Avid Graphic Device service logs:
Start Avid Diagnostics.
Click the ‘wand’ icon. A dialog named Package Remote opens.

6.3 Avid Troubleshooting Tools
Before you start troubleshooting, you should familiarize yourself with the following Avid tools:

Avid Workgroup Properties
Avid Diagnostics
Avid Service Configuration
Avid Health Monitor

All these Avid tools use magic auto-discovery, so your plug-in/device should show in all of them if 
configured correctly, and started.

6.3.1 Avid Workgroup Properties
With Avid Workgroup Properties you can (among other things) start and stop services.

Initially, it is important that the Lookup service has been defined (correctly) in the Avid Workgroup 
Properties, like this:

If you have problems with Avid MediaCentral® | Command, you can use the System Check tab to 
see if there are any problems:
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6.3.2 Avid Diagnostics
Avid Diagnostics is a logging framework that enables you to view logs of different Avid products 
across the network. Your Vizrt device should show up there as an Avid Graphics Device Service.
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6.3.3 Avid Service Configuration
With Avid Service Configuration you can configure the different services, like the Vizrt iNEWS 
Command Plug-in, across the network.
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6.3.4 Avid Health Monitor
Use the Avid Health Monitor to view different health statuses related to the services.
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•
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6.4 Verification Of The Configuration
Configuration is OK
Configuration is Not OK

6.4.1 Configuration is OK
The following tells you that the configuration is OK:

You create a rundown in Avid MediaCentral® | Command, with elements corresponding with 
your Vizrt device (for example cg44).
You monitor the device, and it shows up in the Avid MediaCentral® | Command workstation.
You open the rundown and click the lock. If autocue is on, the first graphic per channel is 
cued.
Thumbnails are showing and trigger counts are working properly.
You select and click Play for one of the elements, and the graphic is played out On Air.
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6.4.2 Configuration is Not OK
The following tells you that the configuration is not OK:

The Device Is Installed but It Doesn’t Appear in Any Avid Tools
Check the firewall on the computer you installed it on.
Does it show up using any of the Avid tools on the local computer (the same as you installed 
it on).
If you are running Windows Vista or 7 (or anything newer than XP) you should probably set 
service to run in Compatibility mode (see Installation and Configuration).

Right-click AvidGraphicsDeviceService01.exe, and select properties.
Click the pane for Compatibility.
At the bottom, click the button to set for all users.
Check the box Run this program in compatibility mode for: Windows XP (Service pack 
3).

Device Not Usable in Avid MediaCentral® | Command and Displays Alert
A typical scenario, when you select the device in the Avid MediaCentral® | Command workstation, 
you get no Inventory, and an error-message saying "No inventory found".
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Check to see that the device is running.
Does is show up in any of the Avid tools? If not, see point 1.
Have you configured the device in the Avid Service Configuration tool to use the Vizrt plug-

in, and not the default None  plug-in (see Plug-in Chooser tab)?

The Avid Health Monitor can give some additional information:
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•

The Available status should be true and not false (see illustration above). If this is not the 
case you should check whether the Avid MediaCentral® | Command server can access 
your Avid MediaCentral® | Command workstation where you installed the plug-in. Also 
disable firewalls to check for potential port connection issues.

Check the  Avid Diagnostics tool and look at the log-messages from the device.
Select the device and enable logging for it.
Restart the service using Avid Workgroup Properties.
It should log a lot of messages, look out for anyone containing Vizrt.
Check for SEVERE errors.
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It should look somewhat like this: 

Playlist in Avid MediaCentral® | Command Workstation Is Empty
I have inventory, but my playlist is empty in the Avid MediaCentral® | Command workstation.

Check that the device name (for example pilotdev) configured in Avid Service 
Configuration matches the device name configured in iNEWS. If the latter is correctly 
configured the device name in iNEWS should match the inventory name seen in iNEWS 
Command.
A typical iNews rundown might look something like this in System > Map:

pilotmos should match your device name.
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VCP is the style being used.
One of your elements in the rundown might look like this (MOS type element):

Changes in iNEWS Are Not Affecting the Playlist in Avid MediaCentral® | Command
Try Monitor > OFF and Monitor > Load again, and turn on and off the lock in Avid MediaCentral® | 
Command a few times.

Cannot Configure the Device Using the Avid Service Configuration Tool
If the device shows up, but you get an error message when trying to click it and open the GUI, see 
the next point on DNS related issues.

Service Doesn’t Show up with Inventory in iNEWS or Can’t Open Configuration 
Panel
You have installed the service, configured it to run in compatibility mode, started it, but it does not 
show up correctly with Inventory in Avid MediaCentral® | Command workstation, and you get 
errors when trying to open the configuration panel.

This may be caused by wrong reverse lookup in DNS.
Use the Avid Health Monitor and check the following:

Try to access the Codebase URL, and check that it is the right hostname for your 
service.
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Try to access the Codebase URL from the Avid MediaCentral® | Command server (ref. 
Lookup Locator).

Cannot See the Playlist in the Viz Pilot Client
Your playlist in iNEWS Command displays all elements that were added in iNEWS, but you cannot 
see the playlist in the Viz Pilot client. If you have deleted the playlist in Viz Pilot you must restart 
the Avid Graphic Device Service XX.

6.5 Known Issues
This section describes various known issues:

DNS Trouble
The Thumbnail is Not Displayed in the Column in Avid MediaCentral® | Command
The List Containing All the Playlists is Getting too Large
Cannot Lock the Playlist
Playlist Controller Disconnects

Symptom
What to Check

System Check has Warnings for VM-ware Adapters
No Default Values Present from Viz Trio Template for Viz Trio CG Element

6.5.1 DNS Trouble
You’ve installed the service, configured it to run in compatibility mode, started it, but it does not 
show up correctly with Inventory in Command Workstation, and you get errors when trying to open 
the config-panel.

Look in Avid Workgroup Properties under System Check whether you have something similar to 
this:
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This is likely caused by a wrong reverse lookup in DNS.

You install on a computer called avidcommandplugin.
The plugin seems to ask the DNS for its hostname, based on IP (like nslookup).
The DNS replies with a different/wrong hostname (e.g. vizrtvizlink1).
The plug-in broadcasts to the Avid Services "Hey, you can contact me at vizrtvizlink1"
The services tries this, and fails.

It seems that this can be discovered using the Health Status tool:

Navigate to your plug-in, and look at the Codebase URL. As you see in the screenshot below, the 
codebase URL does not match the hostname.

(By accident or luck, the hostname in the Codebase URL reported in this example resolves to the 
correct IP of the computer, so it happens to work.)
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6.5.2 The Thumbnail is Not Displayed in the Column in Avid 
MediaCentral® | Command

Simply resize the header to make it appear. Normally this fixes the issue.
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1.
2.
3.

4.

6.5.3 The List Containing All the Playlists is Getting too Large

This should not affect how the program works. Still, you can remove the playlists by simply right-
clicking them and selecting Delete. If this does not work, you can delete them manually by 
following these steps:

Monitor off your rundown.
Stop all services on the Command server.
On the Command server, navigate to C:\Program Files\Avid\iNEWS 
Command\playliststore\state\playlists, select all the files and delete them.
Start all the services on the Command server.

Duplicate playlist generation can be avoided by always unlocking the playlist before loading it 
again from iNews.

6.5.4 Cannot Lock the Playlist
If you suddenly cannot lock the playlist, try to unlock another playlist and then lock your playlist 
again.

6.5.5 Playlist Controller Disconnects

Symptom
The Playlist Controller is unavailable’ alert in the alert list in Avid Command.
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•

•

1.
2.
3.
4.

What to Check
Lookup settings: Check that the lookup tab in Avid Workgroup contains the machine that 
runs the lookup service. Do not add machines here that do not run a lookup service! Usually 
the lookup service runs at the machine with the command server install. This means all the 
workstations must have this machine (with fully qualified name) added to the lookup list on 
the lookup tab. The ’lookup’ tab setting on the service machine itself must also have this 
setting set.
Server sleep mode: Turning off sleep mode for the server machine helps.

6.5.6 System Check has Warnings for VM-ware Adapters
Problem: System check has warnings for vm-ware adapters.

Solution: If the VMware adapters need to be active, do the following, which should remedy the 
problem.

Control Panel, Network, Change adapter settings (for W7).
Press the ALT key to get the menu bar.
Click Advanced, Advanced Settings.
Move the real NIC to the top of the binding order.
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5. Restart services (via workgroup properties) and the Command workstation.

6.5.7 No Default Values Present from Viz Trio Template for Viz Trio 
CG Element

A manually-entered element in iNews with no values assigned to it has an empty data set in its 
data fields. It does not use the default values in the template.
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