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1 Introduction
 This is the Graphic Hub Administrator Guide, which provides the information needed to configure 
and operate the Graphic Hub.

This page contains the following topics:

Feedback and Suggestions
Graphic Hub Log Files

Graphic Hub Component Logs
Graphic Hub REST Log Files
Graphic Hub ImEx Log Files

1.1 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

1.2 Graphic Hub Log Files
A Graphic Hub overall report, which contains all Graphic Hub log files and additional system 
information, can be generated in the Graphic Hub Terminal.

All services installed on the same machine will be included in the export.

If there is no Graphic Hub terminal running on the workstation where the Graphic Hub Deploy 
Agent is running select and generate these log files:

Graphic Hub Log files
Location: <current Graphic Hub data directory>/LogFiles
Purpose: Graphic Hub runtime and error information.

System Event Log
Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
Name: System
Purpose: Information from the current windows system.
To create: Right click on System and select Save all Events as...

Application Event Log
Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
Name: Application
Purpose: Windows crash information of programs
To create: Right click on Application and select Save all Events as...

Vizrt Event Log 
Graphic Hub Deploy Agent system log (only exists if Graphic Hub Deploy Agent is installed).

Location: Start > Run... > eventvwr.exe > Event Viewer > Applications and Services 
Logs

http://www.vizrt.com/


Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  11

•
•
•

•
•

•
•

•
•

Name: Vizrt
Purpose: Deploy agent event log.
To create: Right click on Vizrt and select Save all Events as...

1.2.1 Graphic Hub Component Logs
In general, all Graphic Hub Components log files containing important information:

Location: %PROGRAMDATA%\vizrt\COMPONENTNAME
Purpose: Configuration and logs of the Graphic Hub component

1.2.2 Graphic Hub REST Log Files
A Graphic Hub REST report, which contains all relevant log files and additional system information 
according to Graphic Hub REST, can be generated in the Graphic Hub REST web interface.

If this is not possible select and generate these log files:

Location: %ProgramData%\vizrt\Viz GH Rest\logs
Purpose: Connection, error and event logs of the Graphic Hub REST.

1.2.3 Graphic Hub ImEx Log Files
A Graphic Hub ImEx Report, which contains all relevant log files and additional system information 
according to Graphic Hub ImEx, can be generated in the Graphic Hub ImEx web interface.

If this is not possible select and generate these log files:

Location: %ProgramData%\vizrt\Viz GH ImEx Agent\logs
Purpose: Connection, error and event logs of the Graphic Hub ImEx Agent.
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2 Graphic Hub Administrator Guide
This is the Graphic Hub Administrator Guide, it covers the information needed to configure and 
operate the Graphic Hub and its related components:

Graphic Hub Administrator Guide
Graphic Hub Deploy Agent
Graphic Hub ImEx Agent
Graphic Hub Manager
Graphic Hub REST
Graphic Hub Terminal

2.1 System Installation
The Graphic Hub can be installed in a Cluster, a Multi User (see Server Requirements) or a Single 
installation mode (see Workstation Requirements). For more information on the different 
installation options, see Which Graphic Hub Mode. The initial mode selection is performed during 
installation. The Graphic Hub mode can also be changed and configured, once the Graphic Hub 
Terminal has been started (see Graphic Hub Modes).

All Graphic Hub configurations are installed from one installation bundle, which includes the 
Graphic Hub and the Graphic Hub Terminal.

This section contains information on the following topics:

Installation Prerequisites
System Requirements
Installing Graphic Hub Applications
Licensing Graphic Hub

2.1.1 Installation Prerequisites
Before installing, upgrading or removing the Graphic Hub, make sure that you have gone through 
this check-list:

Shut down the Graphic Hub, and stop the GH Terminal service.
Optional: When upgrading create a backup of the data directory by copying it. The cluster 
solution is the only server setup with real-time data replication capabilities. For all other 
system configurations, backup procedures must be executed manually.

When upgrading Graphic Hub, make sure that there are no open transactions on either of 
the existing systems (see Check There are no Open Transactions).

Note: Backup operations can only be done when the server is shut down.

Note: The Open Transactions setting is only available for servers in a Cluster 
environment.
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In a Cluster configuration, the Graphic Hub version number must be identical on the Main 
and Replication machines. Mixed versions of Graphic Hub are not supported. Failure to heed 
this can lead to serious system failure and data loss.
In a Cluster configuration, the Main and Replication machines must be started in mode Main 
or Replication. Mixed Graphic Hub modes in a cluster are not supported. Failure to heed this 
can lead to serious system failure and data loss.
Make sure that the data directories of the main and replication servers are exclusive, so that 
no other Graphic Hub or process uses these directories.
Do not use Windows Remote Desktop to install and/or work with Graphic Hub on versions 
below 3.0.0. Instead, use another remote tool, for example VNC.
Make sure that no other applications on the server workstations can cause performance 
problems. Some examples of situations when databases should not be installed are:

The general CPU usage is above normal.
Viz Artist is used on the same machine.
Other databases run on the same machine.
The network traffic is extensive.

The performance of the database depends upon the performance of the physical machine the 
database runs on. As system performance increases, so does the database performance. This is 
why it is highly recommended to use a server with high performance.

Software Prerequisites
Prior to installation the following prerequisites are required for all Graphic Hub applications:

Microsoft .NET Framework 4.8.0 (or newer): https://www.microsoft.com/net/download/
framework
Visual Studio 2010 x64 redistributable (installed by the Graphic Hub bundle installer)
Visual Studio 2015-2022 x64 redistributable (installed by the Graphic Hub bundle installer)

Check Open Transactions
From Graphic Hub 3.0, the status of open transactions is shown in the GH Terminal main screen:

Note: Running a virus scanner on the Graphic Hub machine can decrease the performance 
of the database.



https://www.microsoft.com/net/download/framework
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If required, the Graphic Hub Console can also be opened to check for open transactions. In the 
Graphic Hub Terminal, click Report > Graphic Hub Console.

For all previous Graphic Hub versions, use the following procedure:

Open Graphic Hub Manager on both the machines (Main and Replication).
From the main menu, select Tools > Monitor Servers.
Check that Open Transactions are at zero.

2.1.2 System Requirements
This section details the requirements for multiple clients to access a Graphic Hub (installations 
with more than one server), which includes Multi User, Main Server and Replication Server 
configurations, as described in the Graphic Hub Modes section.

This page contains the following topics:

Graphic Hub Requirements
Graphic Hub as Viz Pilot Backend System

Small Installations
Medium Installations
Large Installations

Deploy Agent Requirements
Graphic Hub REST Requirements
ImEx Agent Requirements
Workstation Requirements

Hardware Requirements
Deploy Agent Requirements
Graphic Hub REST Requirements
Graphic Hub ImEx Agent Requirements

Service Dependencies

Graphic Hub Requirements
These are the minimum requirements for the Graphic Hub:

Warning: Do not proceed with an upgrade if there are any open transactions!

Note: Support for any specific operating system or service pack version is only provided by 
Vizrt as long as it is officially supported by Microsoft. Support end dates are announced in 
the release notes for new versions of all Graphic Hub components. Other Vizrt products 
may be supported on other platforms and the documentation and release notes for the 
product in question should be consulted separately.
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Component Minimum Requirement

System Microsoft Windows Server™ 2016 (64-bit)
Microsoft Windows Server™ 2019 (64-bit)
Microsoft Windows Server™ 2022 (64-bit)
The above operating systems as virtual machine on ESXi 6.0 
Update 2 (build 3620759) or higher. 

No other applications may be installed on the server machine.
Anti-virus software without endpoint protection and excluding 
the following Graphic Hub processes:

VizGH.exe
VizGHNamingservice.exe
VizGHTerminalService.exe

Browser Browser requirements (minimum and recommended versions):

Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)

CPU Eight cores with 2.4 GHz base frequency

RAM 8 GB DDR4-1866

On virtualized environments snapshot tools (for 
example, VEEAM) or migration (VMotion) of VMs are 
not supported. Main/Replication setups make only 
sense when separated on different ESXI hosts.



IMPORTANT! All data directories must be excluded from 
anti-virus scan operations and monitoring.
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Component Minimum Requirement

HDD Hard disk performance has a noticeable impact on the overall 
performance of the Graphic Hub. Therefore, the recommended 
hard disk setup is a RAID 10 configuration over all disks, with 
indexing service disabled for the directory containing the Graphic 
Hub data:

Expand priority: Medium
Rebuild priority: High
Cache Usage: 50% Read, 50% Write

The amount of disk space depends on the amount of data to be 
stored, but should be at least 400 GB for data.

In addition, 40 GB is required as a separate Operating System 
partition.

Network A redundant (teamed) setup with two Gigabit network adapters is 
recommended.

Power Supply A redundant power supply is highly recommended.

Graphic Hub as Viz Pilot Backend System
When the Graphic Hub is used as the data back end for Viz Pilot, the following requirements need 
to be considered in addition to the Graphic Hub Requirements. In general, the CPU, RAM and hard 
disk requirements are highly dependent on the amount of graphics, Pilot data (VCP data elements, 
templates, variants and concepts) the database contains, and how many parallel clients (Viz Artist/
Viz Engine, VCP/ActiveX, Viz Story, Viz Pilot Edge) are active.

For a the list of compatible versions, see Viz Pilot Database Management.

Small Installations
Small setups run on a single machine with all the necessary components installed: Graphic Hub 
5/4 Free, Graphic Hub REST, Data Server and Media Sequencer. Such an installation can serve up to 
five Viz Artist/Engine clients based on IP, and up to three VCP/ActiveX clients. Depending on the 

Note: It is not possible to use mapped network drives for 
the Graphic Hub data directory for performance and data 
integrity reasons.



Warning: Running the Graphic Hub on a system without 
enough available hard disk space can cause warnings, 
unexpected behavior, and data loss. Make sure to stay 
well within the limits as described in Warning and Error 
Thresholds.
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hardware specifications, performance is limited by the amount of VCP data elements, templates, 
variants and concepts.

Component Minimum Requirement

CPU Eight cores with 3 GHz base frequency.

RAM 16 GB DDR4-1866

HDD The amount of disk space depends on the amount of data to 
be stored.

Medium Installations
Medium Installations run Graphic Hub in Multiuser mode and Graphic Hub REST on one physical 
server.
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Component Minimum Requirement

CPU 12 cores with 3 GHz base frequency.

RAM 16 GB DDR4-1866

HDD The amount of disk space depends on the amount of data to 
be stored.
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Large Installations
For customers with larger installations, it is required to run Graphic Hub and Graphic Hub REST on 
separate and more powerful hardware. If performance issues occur, the Graphics and VCP content 
should also be separated. For an optional failsafe system, at least two instances of Graphic Hub 
REST and an HTTP Proxy are required.

Minimum suggested configuration:

Component Minimum Requirement

CPU 16 cores with 3 GHz base frequency

RAM 32 GB DDR4-1866

HDD The amount of disk space depends on the amount of data to 
be stored.

This is an illustration of an example installation scenario, of a Graphic Hub cluster with redundant 
Graphic HUB REST service. The HTTP proxies are optional, and only needed for complete 
redundancy of the Graphic Hub REST service.

IMPORTANT! The hardware configuration for a large installation needs to be defined in 
collaboration with Vizrt based on the individual customer’s requirements.
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Deploy Agent Requirements
This section details the requirements for the Deploy Agent:

Component Minimum Requirement

System Microsoft Windows Server™ 2016 (64-bit)
Microsoft Windows Server™ 2019 (64-bit)
Microsoft Windows Server™ 2022 (64-bit)
The above operating systems as virtual machine on ESXi 6.0 
Update 2 (build 3620759) or higher.
Anti-virus software without endpoint protection and 
excluding the Deploy Agent process:
VizGHDeployAgentService.exe.

CPU Four cores with 2.4 GHz base frequency.

RAM 4 GB DDR4-1866

HDD 80 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System 
partition.

Graphic Hub REST Requirements
This section details the requirements for the Graphic Hub REST:

Note: This illustration covers redundancy of Graphic Hub and Graphic Hub REST only. It 
does not cover redundancy for Viz Pilot or Media Sequencer.



Note: Support for any specific operating system or service pack version will only be 
provided by Vizrt as long as it is officially supported by Microsoft. Support end dates will 
be announced in the release notes for new versions of Graphic Hub. Other Vizrt products 
may be supported on other platforms, however, and the documentation and release notes 
for the product in question should be consulted separately.
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Component Minimum Requirement

System Microsoft Windows Server™ 2016 (64-bit)
Microsoft Windows Server™ 2019 (64-bit)
Microsoft Windows Server™ 2022 (64-bit)
The above operating systems as virtual machine on ESXi 6.0 
Update 2 (build 3620759) or higher.
Anti-virus software without endpoint protection and 
excluding the Graphic Hub REST process:
VizGHRESTService.exe.

No other applications, except the Graphic Hub in 5/4 Free or 
Localhost configurations, may be installed on the server 
machine.

Browser Browser requirements (minimum and recommended versions):

Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)

CPU Eight cores with 2.4 GHz base frequency.

RAM 4 GB DDR4-1866

HDD 400 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System 
partition.

ImEx Agent Requirements
This section details the requirements for the ImEx Agent:

Component Minimum Requirement

System Microsoft Windows Server™ 2016 (64-bit)
Microsoft Windows Server™ 2019 (64-bit)
Microsoft Windows Server™ 2022 (64-bit)
The above operating systems as virtual machine on ESXi 6.0 
Update 2 (build 3620759) or higher.
Anti-virus software without endpoint protection and 
excluding the ImEx Agent process:
VizGHImExAgentService.exe.

Note: If you also want to run this machine as your general web server, Vizrt cannot make 
specific recommendations regarding hardware requirements.
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Component Minimum Requirement

CPU Four cores with 2.4 GHz base frequency.

RAM 4 GB DDR4-1866

HDD 5 GB of free disk space for temporary data on the operating 
system partition.

Workstation Requirements
This section details the requirements for installations on laptops and desktop workstations 
running the Graphic Hub in Localhost or 5/4 Free mode or for demonstration purposes.

Hardware Requirements
The following hardware is required:

Component Minimum Requirement

System Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

Browser Browser requirements (minimum and recommended versions):

Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)

CPU Two cores with 2.4 GHz base frequency.

RAM 4 GB DDR4-1866

HDD The amount of disk space depends on the amount of data to be 
stored, but should be at least 50 GB for data.

In addition, 40 GB is required as a separate Operating System 
partition.

Deploy Agent Requirements
The following hardware is required for the Deploy Agent:

Component Minimum Requirement

System Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

CPU Two cores with 2.4 GHz base frequency.
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Component Minimum Requirement

RAM 4 GB DDR4-1866

HDD The amount of disk space depends on the amount of data to be 
stored, but should be at least 5 GB for data.

In addition, 40 GB is required as a separate Operating System 
partition.

Graphic Hub REST Requirements
The following are required for the Graphic Hub REST:

Component Minimum Requirement

System Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

Browser Browser requirements (minimum and recommended versions):

Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)

CPU Two cores with 2.4 GHz base frequency.

RAM 4 GB DDR4-1866

HDD 200 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System 
partition.

Graphic Hub ImEx Agent Requirements
The following are required for the Graphic Hub ImEx Agent:

Component Minimum Requirement

System Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

Browser Browser requirements (minimum and recommended versions):

Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)

CPU Two cores with 2.4 GHz base frequency
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Component Minimum Requirement

RAM 4 GB DDR4-1866

HDD 5 GB of free disk space for temporary data on the operating 
system partition.

Service Dependencies
The different components of the Graphic Hub depend on certain system services. If the services 
are not running during installation, a notification appears with information about the required 
services. The services are enabled by default on pre-configured systems, but may have been 
disabled to comply with your organizations IT policy.

The following table lists the service dependencies for each Graphic Hub component:

Graphic Hub Component Service Name Service Display Name

Graphic Hub Terminal LanmanServer Server

HTTP HTTP

RpcSS Remote Procedure Call (RPC)

Graphic Hub Deploy Agent LanmanServer Server

RpcSS Remote Procedure Call (RPC)

Graphic Hub REST LanmanServer Server

RpcSS Remote Procedure Call (RPC)

Graphic Hub ImEx Agent LanmanServer Server

HTTP HTTP

RpcSS Remote Procedure Call (RPC)

2.1.3 Installing Graphic Hub Applications
This page contains the following topics and procedures:

To Install a Graphic Hub
Graphic Hub REST Installation
GH Deploy Agent Installation

http://docs.vizrt.internal/graphic-hub-guide/trunk/_graphic_hub_terminal.html
http://docs.vizrt.internal/graphic-hub-guide/trunk/_graphic_hub_deploy_agent.html
http://docs.vizrt.internal/graphic-hub-guide/trunk/_graphic_hub_rest.html
http://docs.vizrt.internal/graphic-hub-guide/trunk/graphic_hub_imex_agent.html
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Graphic Hub Manager Installation
Graphic Hub ImEx Agent Installation
Unattended Installation of Graphic Hub Applications

This section details the installation of the Graphic Hub, including a Cluster configuration, which 
installs a Main and a Replication server.

Please be aware that:

Multiuser, Main and Replication modes require a Graphic Hub Core license.
The Image Library Extension functionality requires a Graphic Hub Image Library Extension 
license.
To setup a cluster configuration capable of handling failover situations, a combination of 
Main and Replication servers must be configured.

To Install a Graphic Hub
To install the Graphic Hub with the MSI installer use in the following installation order:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework
vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
openslp_2.0.0_0_x64.msi Service location protocol daemon
VizGraphicHub_64bit-XX.msi
optional: HASPUserSetup.exe Dongle driver (required for GH Multiuser, Main and Replication 
modes)

To install the Graphic Hub with the bundle installer (installs 2-5 listed above) use in the following 
installation order:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework
VizGraphicHubBundle-x64-XX.exe

The installation wizard reports the version and build number of the bundle about to 
be installed. If an existing Graphic Hub installation is located, the installer reports the 
version and build number of the existing installation as well.

Select the mode and data directory for the Graphic Hub installation.

Note: During upgrade installations, the currently installed mode and data 
directory are suggested automatically by the installer.



https://www.microsoft.com/net/download/framework
https://www.microsoft.com/net/download/framework
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If required, click Additional Settings to install the Graphic Hub to a custom location or 
with a custom HTTP port for the Graphic Hub Terminal.

For first time installations, the OpenSLP, Sentinel Runtime and CodeMeter 
Runtime checkboxes are automatically checked. In the event that any of these 
packages have been installed on the system previously, it is not possible to select 
them for installation.
The installation wizard also automatically installs the Microsoft C++ Redistributable 
Package.
After the installation has completed successfully, the Graphic Hub Terminal opens in 
the default web browser. The contents of the Graphic Hub Terminal window depends 
on the selected Graphic Hub configuration.

Optional: Silent installation

The -s  or -silent  option means that there is no user interaction necessary. 

The Bundle window is still displayed.

Cluster Server Installation
To use a Graphic Hub in a Cluster configuration (Main and Replication servers), two separate 
servers must be available and a Graphic Hub dongle must be applied to each machine.
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The Main server is installed and configured on one machine. The Replication server is installed and 
configured on the other.

To Install And Configure A Graphic Hub Cluster

Install the Graphic Hub on both servers as described above in To Install a Graphic Hub. 
Select Main Server as mode for the server which is intended to run as Main, and Replication 
Server for the other one.
When the installation finishes, the Graphic Hub Terminal automatically opens on both 
servers. Select the servers that will act as GH Main Server and GH Replication Server from the 
respective drop-down lists, and click Create.

Enter the configuration for the Main Server:

Graphic Hub: Enter the Server name and set the Data directory.
Connections settings: Select the Port, Network Adapter and Server Port.

IMPORTANT! When the Graphic Hub is upgraded from a different mode the same content 
must be used (data directory). As such, the underlying data directory must be copied first 
to both machines (see also Graphic Hub Mode Configurations).



Note: If the Graphic Hub has been installed previously, the new installation defaults 
to the same data directory, unless a new one is selected during installation or 
configuration.
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8.

Click Next and enter the configuration for the replication server, then click Finish.

If required, click Configuration to change any settings.
If required, click Automatically start of partner server to automatically start the 
Replication server.

Click Start Server for both the Main and Replication servers.

Graphic Hub Cluster Upgrade

Shut down Deploy Agent or Agents.
Shut down the Graphic Hub Cluster.
Remove Deploy Agent or Agents.
Install new version of the Deploy Agent or Agents (see GH Deploy Agent Installation).
Install new version of Graphic Hub on the Main and Replication Server (see Graphic Hub 
Installations).
Optional: Remove all occurrences of the Graphic Hub Manager. Install new version of the 
Graphic Hub Manager (see Graphic Hub Manager Installation).
Start the Graphic Hub Cluster.
Start any Deploy Agents.

IMPORTANT! When upgrading a Graphic Hub cluster, make sure that all connections to the 
Graphic Hub are closed by checking active sessions and that there are no open 
transactions.



Note: Graphic Hub clients and servers are designed to be inter-operable between versions, 
but may lack new features. This means old clients work on older and newer Graphic Hub 
versions and there is usually no need to upgrade clients when upgrading the Graphic Hub, 
except when certain features are required or critical bugs have been fixed.
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Graphic Hub REST Installation
This section details the installation of the Graphic Hub REST.

The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data 
to and from Graphic Hub via HTTP requests.

Important Before Installation
Graphic Hub REST requires Graphic Hub 2.3.1 or higher.
Graphic Hub REST requires Graphic Hub 3.0.0 (recommended 3.0.2) or higher for Pilot data 
access (see Viz Pilot Database Management for details).
For performance reasons, do not install Graphic Hub REST on a Main server in a Graphic Hub 
cluster environment.

 For best performance and compatibility, use Google Chrome version 28 or higher to configure 
Graphic Hub REST. The Graphic Hub REST Web-UI also works with:

Recommended Browser Version Requirement (minimum and 
recommended)

Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25, 41+

Microsoft Edge 96+

Also Tested on

Microsoft Internet Explorer™ 9, 10+

Apple Safari™ 5, 6

Opera™ 15, 36+

To Install the Graphic Hub REST
Follow this installation order to install Graphic Hub REST:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework
vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
openslp_2.0.0_0_x64.msi Service location protocol daemon
VizGHREST_64bit.XX.msi

IMPORTANT! Any other web browser or versions older than the ones listed above are not 
officially supported.



https://www.microsoft.com/net/download/framework
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1.

Optional: Check the details for:
Graphic Hub Naming Service
Graphic Hub Server Name
Graphic Hub Port
Graphic Hub REST HTTP Port

Optional: Silent installation

The -s  or -silent  option means that there is no user interaction necessary. 

The Bundle window is still displayed.
Optional: Enable the SSL configuration:

Check the Enable SSL Encryption checkbox.
Enter the location of the Certificate and Private Key files.
Enter the password.

After the installation has completed successfully, the Graphic Hub REST Web-UI opens 
in the default web browser.

GH Deploy Agent Installation
This section details the installation of the Graphic Hub Deploy Agent. The Deploy Agent is required 
to run scheduled Deploy Tasks. This is useful to replicate data for safekeeping or distribution on a 
regular basis.

To install the Graphic Hub Deploy Agent use in the following installation order:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework
vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
VizGHDeployAgent_64bit.XX.msi

This creates two Deploy Agent icons in the Start menu, under Programs > Vizrt > Viz Graphic Hub 
> Deploy Agent.

The Deploy Agent is now configurable with the Graphic Hub Manager.

Graphic Hub Manager Installation
This section details the installation of the Graphic Hub Manager. 

To Install the Graphic Hub Manager
To install the Graphic Hub Manager use in the following installation order:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

IMPORTANT! The certificate files must be configured during the installation of 
GH REST.



Note: Make sure that the browser type and version is supported by Graphic 
Hub REST (see Important Before Installation).



https://www.microsoft.com/net/download/framework
https://www.microsoft.com/net/download/framework
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vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
VizGHManager_64bit.XX.msi

Graphic Hub ImEx Agent Installation
This section details the installation of the Graphic Hub ImEx Agent.

The Graphic Hub ImEx Agent is a media asset (image) import service from HTTP sources for the 
Graphic Hub.

Important Before Installation
Before installing the Graphic Hub ImEx Agent, make sure to familiarize yourself with the Service 
Dependencies. Also, observe the following requirements:

Dependencies Required Components

Graphic Hub 3.0.1 or newer

GH REST 2.0.1 or newer

Recommended Browser Version Requirement (minimum and 
recommended)

Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25, 41+

Microsoft Edge 96+

Also Tested on

Microsoft Internet Explorer™ 9, 10+

Apple Safari™ 5, 6

Opera™ 15, 36+

To Install the Graphic Hub ImEx Agent
To install the Graphic Hub ImEx Agent use in the following installation order:

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

IMPORTANT! Any other web browser or versions older than the ones listed above are not 
supported.



https://www.microsoft.com/net/download/framework
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vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
VizGHImexAgent_64bit.XX.msi

Optional: Configure IMEX HTTP port. The default port number is 19390 . The port 

number can also be changed in the configuration of the Graphic Hub ImEx Agent after 
installation.
When the installation completes, the web-based user interface opens in the default 
browser, for initial Graphic Hub ImEx Agent configuration.

Recommended Browser Version Requirement (minimum and 
recommended)

Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25, 41+

Microsoft Edge 96+

Also Tested on

Microsoft Internet 
Explorer™

9, 10+

Apple Safari™ 5, 6

Opera™ 15, 36+

Unattended Installation of Graphic Hub Applications

Installation Parameters

Parameter name Default Value Available values

VizGraphicHub MSI

INSTALLDIR_GH %\Program Files%
\Vizrt\VizGH\

DATADIR_DB C:\VizGHData\

TERMINAL_HTTP_PORT 19399

GH_MODE 2 1, 2, 3, 4, 5
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PLATFORMTYPE 54free  "localhost", "54free ", "multiuser", 
"mainserver", "replicationserver"

VizGHREST MSI

INSTALLDIR_REST %\Program Files%
\Vizrt\VizGH\REST\

REST_NAMING_SERVICE LOCALHOST

REST_SERVER_NAME VizDbServer

REST_SERVER_PORT 19396

REST_HTTP_PORT 19398

SSL_ACTIVE No yes

SSL_CERTIFICATE_FILE null

SSL_PKEY_FILE null

SSL_PKEY_PASSWORD null

VizGHImexAgent MSI

INSTALLDIR_AGENT %\Program Files%
\Vizrt\VizGH\ImexAgent\

IMEX_HTTP_PORT 19390

VizGHManager MSI

INSTALLDIR_MANAGER %\Program Files%
\Vizrt\VizGH\Manager\

DO_LAUNCHAPPONEXIT 0 1

VizGHDeployAgent

INSTALLDIR_AGENT %\Program Files%
\Vizrt\VizGH\DeployAgent\
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Example

Description Command

Install Graphic Hub silently with no UI using the 
msi in Multiusers mode
Install Graphic Hub to path C:\Vizrt\GH
GH Data Directory configured to D:
\Vizrt\GHDataDir

GH terminal service to run on port 19300
Installation log in verbose mode named 
instgh_mode.log and deployed to path C:\Temp

msiexec /i VizGraphicHub.msi 

PLATFORMTYPE="multiuser" 

INSTALLDIR_GH="C:\Vizrt\GH" 

DATADIR_DB="D:\Vizrt\GHDataDir" 

TERMINAL_HTTP_PORT="19300" /lv c:

\Temp\instgh_mode.log /qn

Install Graphic Hub silently using the Graphic 
Hub bundle installer in localhost mode
Install Graphic Hub to path C:\Temp

VizGraphicHubBundle-x64.exe --

silent --

GraphicHub="PLATFORMTYPE=localhost 

INSTALLDIR_GH='C:\temp'"

See Also

SSL in REST

2.1.4 Licensing Graphic Hub
There are five possible modes to run Graphic Hub (see Graphic Hub Modes):

Modes working without a license
Viz Graphic Hub Localhost
Viz Graphic Hub 5/4 Free

Modes that require a Dongle/License
Viz Graphic Hub Multiuser
Viz Graphic Hub Main Server
Viz Graphic Hub Replication Server

This section describes how to license Graphic Hub using a Graphic Hub Sentinel license dongle or 
WIBU License, which is required for Graphic Hubs running in Multiuser, Main or Replication mode.

For more information on how to apply licenses, check the Vizrt Licensing Guide in the Vizrt 
documentation center or for details on how to setup the licensing system to be used by Graphic 
Hub.

This page contains the following topics and procedures:

Using WIBU Licensing of Graphic Hub

Information: The Graphic Hub installer parameters GH_MODE and PLATFORMTYPE cannot 
be combined in one command, only one of them can be used at a time.
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Using WIBU Licensing of Graphic Hub 
Graphic Hubs can be licensed with a special WIBU License. The required WIBU Runtime Software 
comes with the Graphic Hub Bundle installer and is mandatory for the modes Multiuser, Main and 
Replication.

If a WIBU License is found and bound it sticks to this license container and can only be changed by 
a restart of the Graphic Hub.

License expiration messages are logged to the Graphic Hub Journal as usual (alerts, expiration 
warning 30 days prior to expiration and if license is expired or invalid). The WIBU license 
information (license id, license server, container id) is logged to the Graphic Hub log file upon 
status changes.

Currently supported WIBU licenses:

Graphic Hub Core license with ID 1300000 (license format v2, supported since version 3.1.0) 
and 130000 (license format v3, supported since version 3.8.0).
Graphic Hub Image Library Extension license with ID 130100 (license format v3, supported 
since 3.8.0) to enable the Image Library write capabilities.

Basic steps to enable WIBU licensing with Graphic Hub:

Setup a WIBU license container as described in the Vizrt Licensing Guide in the Vizrt 
documentation center.
Install the Graphic Hub with the CodeMeter Runtime. See System Installation for details.
Configure the WIBU settings and the appropriate location of the license container in GH 
Terminal  Configuration > ADVANCED SETTINGS > License Settings. See Graphic Hub Mode 
Configuration for details.

To verify if the license is applied correctly, please check either the:



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  36

•

•

GH Terminal Graphic Hub license information (reached via About > Graphic Hub License in 
GH Terminal):

GH Terminal Graphic Hub log file (reached via Show GH Log in GH Terminal):
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GH Manager license information (reached via Info > License info... in GH Manager):

GH Manager monitor (reached via Tools > Monitor servers... in GH Manager):

2.2 Overview
The Graphic Hub is a database solution where all Viz Artist elements are stored. Files can be 
Scenes, Geometries, Images, Materials, Fonts, and so on.

To start Viz Artist successfully, a Graphic Hub must be running. The Graphic Hub can either be a 
local instance, where only one User can log in, or it can be a Multi-User database as described in 
Graphic Hub Modes.

This section contains the following topics:

Graphic Hub Applications
Graphic Hub Modes
Selecting a Graphic Hub Mode

Note: License changes (for example, setting a new license key) are not supported for WIBU 
Licenses. Setting a new license string does not work in GH Terminal and GH Manager, since 
these changes must be performed in the CodeMeter Runtime.
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General Database Information
Graphic Hub Naming Service

2.2.1 Graphic Hub Applications
The Graphic Hub solution consists of these applications:

Graphic Hub
Graphic Hub Terminal
Graphic Hub Manager
Graphic Hub REST
Graphic Hub Deploy Agent
Graphic Hub ImEx Agent
Graphic Hub Naming Service

Graphic Hub
The physical back end server where the database content is stored (see General Database 
Information).

Graphic Hub makes the database available to clients in a network. To log in and work with Viz 
Artist, a User must connect to a running Graphic Hub, on a machine in the network. In normal 
circumstances a Graphic Hub is started through the Graphic Hub Terminal, and shut down, logged 
in to or logged out of, from the Graphic Hub Manager. 

Various parameters can be defined in the Graphic Hub Terminal before a Graphic Hub is started, 
for example the name and the data directory to where the database should have its root folder.

The integrated multi-user database serves as the central point for storing all assets of a standalone 
machine or for all machines. This asset management database provides efficient file-handling 
while maintaining data consistency.

Consistent data storage: Objects are always aware of their references and stay consistent 
where ever you move them. Accidental deletions of objects are prevented and scenes remain 
usable.
Reference model: Guarantees that changes of a special object/type affects all scenes using 
it, such as a corporate logo or font-style.
Flexible data organization: Organizing scenes and all relevant objects together in projects, 
simplifies the task of handling complex designs.
Data locking: Exclusive access to scenes or objects is assured by applying a lock.
Audio: Supports audio streaming.
Administrative tool Graphic Hub Manager: Serves to migrate archives and data pools from 
version 2.x. Graphic Hub Manager also serves as a tool for adding users, keywords, 
permissions, statistical information regarding disk usage, connected users and server traffic 
as well as assisting the user in finding duplicates.
User management: Enables you to protect crucial assets and track changes.
Search functionality: All object properties can serve as search criteria and new search 
keywords can be included.
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Messaging/notification: Broadcast information to all connected clients via a customized 
notification system and/or online collaboration between single users.

Graphic Hub Terminal
The Graphic Hub Terminal is the user interface used to configure, start, stop and restart both 
Graphic Hub and the Graphic Hub Naming Service. See Graphic Hub Terminal.

A Graphic Hub Terminal is installed along with every Graphic Hub and provides the following 
functionality:

Starting, stopping and monitoring Graphic Hub and the Graphic Hub Naming Service 
processes.
Configuring Graphic Hub.
Status Display and monitoring.
Execution of scheduled tasks: shutdown (with automated backup), deletion of Journal 
Entries, deletion of expired items, cleanup of Viz Pilot data elements, cleanup of Viz Pilot 
changelog.
Backup and Restore.
Emailing.
Report generation.

Graphic Hub Manager
The Graphic Hub Manager is used to administer one or more Graphic Hubs. For example, the 
server files and access levels for users and groups can be managed from this application. See 
Graphic Hub Manager.

Graphic Hub Manager serves to:

Migrate Viz Pilot data from Oracle to Graphic Hub.
Migrate archives and data pools from version 2.x.
As a tool for adding users, keywords, permissions, statistical information regarding disk 
usage, connected users and server traffic as well as assisting the user in finding duplicate.

When you are running in a Main/Replication Cluster, you can check Server differences and Copy via 
DDC from one server to another.

Graphic Hub REST
The Graphic Hub REST is a web-service for a Graphic Hub. It is an interface to retrieve and send 
data to and from a Graphic Hub through HTTP requests. See Graphic Hub REST.

Supports browsing, administration, simple manipulation of datasets, monitoring, deploy agents, 
and much more. It provides the access to all data on a Graphic Hub. A client is able to retrieve any 
kind of metadata from Scenes, Images, etc., like Owner, Creation Date, etc. Also, all metadata, like 
Users, Types, Keywords, can be retrieved.

Graphic Hub REST is also an open HTTP API to Graphic Hub. Any skilled web developer and 
designer can build an application based upon the Graphic Hub Interface Agent. For example, if a 
scene from the Super Bowl contains an image of the quarterback, this image can be retrieved by an 
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external application, like a blog, by a search on the Graphic Hub Interface Agent. The blogger is 
also able to insert this in an article and publish to the web.

Graphic Hub Deploy Agent
Upgrades the Graphic Hub solution with a powerful service to copy directories/projects/files with 
all necessary data (referenced directories/projects/files) from one server to another. See Graphic 
Hub Deploy Agent.

Graphic Hub Deploy Agent upgrades your Graphic Hub solution with a powerful Service to copy 
directories/projects/files with all necessary data (referenced files, directories/projects) from one 
server to another with different options of deployment. It is possible to have more than one agent 
running in your network environment. To copy between your servers, you can create tasks in 
Graphic Hub Manager. In these tasks you define the source and destination servers and properties 
of the deploy task. 

It is possible to deploy to multiple destination servers. Every task can have different schedule 
modes. These modes are Once, Recurring, Recurring forever and Real-Time. So it is possible to 
distribute your Graphic Hub content according to schedule to all your servers automatically day by 
day.

Graphic Hub ImEx Agent
The Graphic Hub ImEx Agent (Import / Export agent) is a service that imports image media assets 
from file-system folders or HTTP sources to Graphic Hub. See Graphic Hub ImEx Agent.

Graphic Hub ImEx Agent upgrades your Graphic Hub solution with a powerful Service to stage 
(import) external media assets (images) available through HTTP through the Media Sequencer 
(MSE) to Graphic Hub through Graphic Hub REST. It is possible to have more than one agent 
running in your network environment that can utilize multiple Graphic Hub RESTs.

Dedicated destination directories can be configured. The import can be parallel on multiple 
Graphic Hub RESTs bound to the same Graphic Hub.

Graphic Hub Naming Service
The Graphic Hub Naming Service monitors all applied servers in the network. See Graphic Hub 
Naming Service.

See Also

Graphic Hub Modes
General Database Information
Graphic Hub Naming Service

2.2.2 Graphic Hub Modes
Graphic Hub Terminal can operate in these modes:

Localhost
5/4 Free
Multiuser
Main Server
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Localhost
Localhost is a single connection to a Graphic Hub (no dongle required). See Localhost, 5/4 Free, 
and Multiuser Configuration.

5/4 Free
The 5/4 Free configuration provides five concurrent TCP/IP connections to a Graphic Hub (no 
dongle required, five TCP/IP connections excluding GH Terminal, GH Manager, GH Deploy Agent 
connections). See Localhost, 5/4 Free, and Multiuser Configuration.

Multiuser
The Multiuser configuration provides multiple concurrent connections to a Graphic Hub (dongle 
required). See Localhost, 5/4 Free, and Multiuser Configuration.

Main Server
The Main Server, as with the Multiuser configuration, provides multiple concurrent connections to 
a Graphic Hub. The difference is that the Main Server provides a mirror service to a running a 
Replication Server. In a failover situation, the system automatically redirects all clients from the 
Main server to a Replication server (dongle required). See Cluster Configuration.

Replication Server
The Replication Server is use with the installation of a Main Server. A Replication Server is a 
duplication of the Main server. See Cluster Configuration.

Replications in a Graphic Hub mean that every transaction on the primary server is immediately 
mirrored on a Replication Server. In a failover situation, where the main server becomes 
unavailable, the system automatically redirects all clients from the Main Server to the Replication 
Server.

A failover situation occurs when one of the servers become unavailable due to hardware failure, 
software errors, power loss, etc. A Main server crash results in a failover situation, where the Main 
server switches to a Replication Server, in real-time.

On the Main server machine, the Graphic Hub Terminal shows Cluster Not Connected, and if the E-
mail functionality is enabled, one or more error E-mails are sent.

Usually, a Graphic Hub in a Cluster configuration runs in real-time replication. In cases of a 
network overload, loss of another server in the Cluster, or other serious system instabilities, the 
Graphic Hub automatically switches to Recovery Mode. This means that one server buffers all 
necessary transactions, for example, saving files. The Graphic Hub then deploys these files to the 
other server in the Cluster when the resources are available again. After 15 seconds of no 
incoming transactions, the Graphic Hub switches to real-time replication again, and the data 
structure is updated, so that it is reflected on both servers.

If clients were directed to another server than the primary, during the down-time, the clients are 
re-directed to the primary server again.
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See Also

Graphic Hub Applications
Selecting a Graphic Hub Mode
General Database Information
Graphic Hub Naming Service

2.2.3 Selecting a Graphic Hub Mode
When a Graphic Hub is installed a mode must be selected. This section details information on the 
different modes, to help with the selection. Depending on the mode which is to be installed, a 
Graphic Hub license dongle may be required.

The Graphic Hub can be installed for a Cluster, Multi User or Single User:

Cluster
Multi User
Single User

Cluster
A Cluster installation is an installation with multiple servers for multiple clients to access a Graphic 
Hub. To install a Graphic Hub as a Cluster, use the Main Server and Replication Server modes.

Multi User
The 5/4 Free and Multiuser configurations give access to multiple concurrent TCP/IP connections 
to a Graphic Hub.

5/4 Free provides up to five connections and is recommended for sharing content in small 
Viz Artist work-groups. For example, installations on laptops and single workstations. This 
mode does not require a license dongle.
Multiuser provides up to 800 (if required) connections (dongle required) and is 
recommended for all scalable Viz Artist work-groups. This mode requires a license dongle.

Single User
A Localhost configuration is a single connection to a Graphic Hub. This mode is for local Viz Artist 
installations, without a permanent network connection, and without the requirement of a license 
dongle. For example, installations on laptops and single workstations.

See Also

Graphic Hub Terminal
Graphic Hub Applications
Graphic Hub Modes
General Database Information
Graphic Hub Naming Service
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2.2.4 General Database Information
Viz Artist uses a database to store Elements that clients work with. The Elements can be of these 
types, among others:

Scenes
Geometries
Materials
Advanced materials
Images
Fonts
Audio files

The individual elements are stored in the Graphic Hub data directory as files.

The database manages the files in terms of properties and Universally Unique Identifiers (UUIDs). 
These are visualized in Graphic Hub Manager as folders and projects. These folders and projects 
are only virtual, and cannot be treated in the same way as folders in Microsoft Windows.

Clients can work with and organize files through Viz Artist in a logical project and folder structure 
provided by the database. Although each file can be listed in/referenced from more than one 
folder, it resides in the database in a single instance. A checksum is calculated for each file, so 
that duplicate files can be easily found (see Locate Duplicate Files).

This page contains the following topics:

File Properties
Projects and Folders
Links and References
Folder Links
File References
File Links
Keywords
Data Locking
Session Lock
Check Out
Access Rights

File Properties
Various properties are associated to each individual file in the database, for example:

Properties Properties (continued)

NamePathFile typeFile sizeChecksum UUIDRightsKeywordsFile-linksReferences

Note: For more information about the various element types, see the Viz Artist User 
Guide.



http://documentation.vizrt.com/viz-artist-guide/3.7/
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For more information about the properties, see Working with Files.

Projects and Folders
The database is able to maintain a logical structure composed of projects and folders. This helps 
Viz Artist users to keep an overview of the files they work on. The tree of folders is only virtual, the 
files are not actually stored on the hard disk with such a structure. All the folders a file is shown 
in, are stored in the properties of the file. The main benefit of this virtual structure is that the file 
itself is stored only once in the database, with links to it. The hard disk space is then kept low and 
the administration of files is much easier.

Links and References
In the database, files are linked and referenced. Every file knows which folder it is placed in, which 
other files it uses, and also by which other files it is used. For example, in a scene, fonts and 
images are used. If one of the files that are used in the scene changes, the scene uses the file in its 
new state. Every file holds a list of links and references in its properties.

Three types of links and references are handled by the database: folder-links, file-references, and 
file-links.

Folder Links

 Every file in the database holds information about the folders it is placed in. These entries are 
called folder-links. Each file can hold as many folder-links as necessary. The file is physically stored 
in the database only once, but it can be virtually available in various folders. The UUID of the file is 
identical in all folders. If a file is deleted within a folder, only the folder-link to this folder is 
removed. The file remains in the database, unless every folder-link is removed. When the last 
folder-link is removed, the file is deleted from the database.

 In the Explorer, a file that holds more than one folder-link is shown as an icon with an arrow.

File References
In everyday use, it is necessary for a file to reference other files. For example, a scene can contain 
images. The root file must be linked to all the files it uses. The file-reference feature keeps track of 
all other files being used by this file.

File Links
In everyday use, it is also necessary for a file to be referenced by other files. The root file must be 
linked to all the files it is used by. The file-links feature keeps track of all other files the file is used 
by.

Keywords
To help users organize their work, keywords can be applied to files. Up to 20 keywords can be 
applied to each file. Every file holds a list of keywords in its properties.
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Data Locking
Three different types of data locking exist within the database: session lock, check out, and access 
rights.

Session Lock
As long as the session lock is active, only the user who has locked the file is able to save it in the 
database. Other users can only view the file. A locked file is marked in Viz Artist and Graphic Hub 
Manager (if the files view type is set to icons) with a keyhole icon.

A session lock is automatically applied to a file when a user opens it in Viz Artist. The session lock 
is removed once the file is closed. A session lock is valid as long as the user who has locked the 
file is connected to the server. When the user disconnects, the lock is opened. To end a session 
lock, the user who locked it, or the administrator, can manually unlock it.

Check Out
As long as the check out is active, only the user who has checked out the file is able to save it in 
the database. Other users can just view the file. A checked out file is marked in Viz Artist and 
Graphic Hub Manager (if the files view type is set to icons) with a stop icon.

Every file in the database can be checked out. The check out of a file is valid until it is checked in 
again. Check in can be performed by the user who checked out the file, or the check out can be 
canceled by the administrator.

Access Rights
The database is able to maintain rights on files and folders. Individual rights for user, group, and 
world can be set either to allow or disallow reading and/or writing rights.

User: Sets the rights for the owner of a file or folder.
Group: Sets the rights for all the members of the group the owner belongs to.
World: Sets the rights for all database users.

See Also

User and Group Management
Graphic Hub Applications
Graphic Hub Modes
Graphic Hub Naming Service

Tip: Keywords can be used as a database search criteria.

IMPORTANT! Viz Artist 3.3.x cannot handle access rights. It is strongly inadvisable to make 
changes in the server that may impact work on the clients.
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2.2.5 Graphic Hub Naming Service
There can be many Graphic Hubs running on the same network. A Graphic Hub Naming Service is 
used to monitor and keep track of all servers on the network. The Graphic Hub server cannot run 
without a Naming Service.

A Naming Service can be started together with a server, or the Graphic Hub server can connect to a 
naming service on the network. When a server configured with this naming server is started, the 
remote Naming Service is informed. The Naming Service is aware that the Graphic Hub server is 
available for client connections.

The Naming Service application is started and shut down from the Graphic Hub Terminal. The port 
used for the communication between the Naming Service and the clients can be defined in the 
terminal before startup.

When a Graphic Hub server is bound to an already running Naming Service, the server name must 
be unique. If a server with the same name is already running, the Graphic Hub exits with an error. 
The exit code and error message are written to the log file.

To avoid having a single point of failure for Main and Replication server configurations, each 
instance must have its own separate Naming Service.

Supported Configurations
Both the Graphic Hub Naming Service and a Graphic Hub can run independently of each other, 
even on separate physical machines. The following two configuration scenarios are supported:

Each Server Connected to its own Naming Service
Multiple Servers Connected to one Naming Service

Each Server Connected to its own Naming Service
In this type of configuration, the clients are able to connect to only one server. Such a 
configuration is used when working in single-user mode. In single-user mode, the server, Naming 
Service, and all other Viz 3 products that connect to the database must be installed on the same 
physical machine. As the server is working on the “localhost” in this configuration, other clients 
cannot see the Naming Service or server.

This type of configuration is typically used when working on a stand-alone computer.

Note: Server names are case sensitive.

IMPORTANT! The server's network adapter statuses and IP addresses cannot be changed 
while the Graphic Hub or the Naming Service are running.



IMPORTANT! Although a localhost can never be accessed from client applications such as 
Viz Artist, it is possible to monitor and start/stop localhost servers/naming services by 
enabling this in the Graphic Hub Manager.
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Multiple Servers Connected to one Naming Service

 
In this type of configuration, the clients are able to connect to all servers managed by the defined 
Naming Service. In multi-user mode, the server and Naming Service are available to all clients in 
the network. The Naming Service uses the host name of the computer it runs on as its name. By 
default, the name of the server is Graphic Hub, but this can be modified in Graphic Hub Terminal 
before startup (see Graphic Hub Terminal).

See Also

Graphic Hub Applications
Graphic Hub Modes
General Database Information

2.3 Security Advisory

2.3.1 Recommendations
After installation of the software, please proceed with the following advisories:

Change the default password for Graphic Hub Admin user: GH Manager Tools > Administer 
users & groups.

IMPORTANT! Scheduled tasks do not trigger when the Graphic Hub and Naming Service are 
not running on the same host (Naming Service only mode)!
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Enable http authentication in GH Terminal: Options > Advanced Settings.
Change Graphic Hub Terminal password (see above): Options > Change Terminal password.
Use SSL encryption for Graphic Hub Rest.
Disable Remote Access for WiBu Codemeter Webadmin and use SSL (Configuration > Basic > 
Webadmin)
Remove any unneeded services.

2.3.2 Ports used by Graphic Hub and Components
The Graphic Hub server requires a limited number of open network ports. The following table lists 
the ports used for Graphic Hub server connectivity:

Port Number Protocol Used for

Other components

427 TCP, UDP OpenSLP

22352 TCP, UDP Codemeter 

Graphic Hub & Graphic Hub Terminal

19394 UDP Manager for Terminal 2

19395 TCP Terminal 2

19396 TCP, UDP Naming service

19397 TCP, UDP Graphic Hub

19399  (configurable) TCP Terminal 3 (HTTP)

Graphic Hub REST Service

19398  (configurable) TCP REST service (HTTP)

Deploy Agent

19391 TCP, UDP Deploy Agent High Availability
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19392 UDP Deploy Agent

19393 TCP Deploy Agent

ImEx Agent

19390  (configurable) TCP ImEx Agent (HTTP)

Additional Ranges

Since Graphic Hub Deploy Agent 2, Graphic Hub Manager 5, GH REST 2, and Viz Artist 3.8.2, these 
clients do not require any port exemption rules on the client side firewall configuration. However, 
for earlier versions, all ports must be open on the client side.

2.4 Startup And Shutdown
This section details the startup and shutdown procedures for the Graphic Hub, the Graphic Hub 
Manager and servers.

This section contains information on the following topics:

Graphic Hub Startup
Graphic Hub Shut Down
Graphic Hub Emergency Shutdown

2.4.1 Graphic Hub Startup
This section details the procedures to start and shutdown the Graphic Hub and the startup of a 
configured Graphic Hub database. All Graphic Hub configurations are started through the Graphic 
Hub Terminal.

To log in and use a Graphic Hub, see Graphic Hub Login and Log Out.

To Start a Graphic Hub
Open the Graphic Hub Terminal:

Click Start > All Programs > Vizrt > Graphic Hub > GH Terminal, or
Double-click the Graphic Hub Terminal desktop icon. The Graphic Hub Terminal opens 
in the default web browser.
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Start a Graphic Hub Server:
The last used server configuration is available.
Click Start Server.
or
Click Mode.
Select the required Graphic Hub mode (see Graphic Hub Modes and Selecting a 
Graphic Hub Mode).
Click Load and run configuration > Select configuration.

Note: Each time the Viz GH Terminal desktop icon is double-clicked a new 
Graphic Hub Terminal instance is opened.



Note: From the same menu, select Load Configuration to load and modify a 
configuration. Then start that configuration.
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Localhost, 5/4 Free and Multiuser Startup Screen

Cluster Startup Screen
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2.4.2 Graphic Hub Shut Down
This section details the options for shut down of one or more Graphic Hubs, without the 
requirement to log off completely or exit the Graphic Hub Manager.

Shutdown options are:

A normal shutdown: Through the Graphic Hub Manager.
A scheduled normal shutdown: A scheduled shutdown can be configured in the Graphic Hub 
Terminal or the Graphic Hub Manager.
A Cluster configuration shutdown: For system maintenance or network configuration work in 
a Cluster system, the best type of shutdown operation is to shut down the Cluster, through 
the Graphic Hub Manager.
It is also possible to Limit and Shut Down Sessions.

A Graphic Hub is shut down from the Graphic Hub Manager.

A normal shutdown operation takes much longer than an Emergency Shutdown, but is far safer for 
data retention.

This page contains the following topics and procedures:

To Do a Normal Shutdown
To Schedule a Server Shutdown Using Graphic Hub Terminal
To Schedule a Server Shutdown Using Graphic Hub Manager
To Shut Down a Cluster

Limit and Shut Down Sessions
To Limit the Number of Sessions
To Disconnect a Selected Session

To Do a Normal Shutdown
In the Graphic Hub Manager open the Server Shutdown panel:

Click Server > Shutdown..., or press CTRL + W or F10.
In the Server drop-down box, select the server to shutdown.
Option: Send a message to all users of the server:

In the Message field write a message to all users of this server to inform them that the 
server is about to be shut down.
Click Send.

Click Shutdown.
Click Yes.
Click Close.

Note: In emergency situations, you can shut down the Graphic Hub using the Graphic Hub 
Terminal (see Graphic Hub Emergency Shutdown).
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To Schedule a Server Shutdown Using Graphic Hub Terminal
Open Graphic Hub Terminal and go to Options > Scheduled Tasks.
Select the Shutdown task.
Check the Schedule shutdown box.
Select a Mode:

Once.
Recurring.
Recurring forever.

Select a Start at and End after date.

If Mode is set to Recurring or Recurring forever, set the interval in Each.
Set a Notification time. Options are:

Do not notify at all.
Just notify five minutes before shutdown.
Notify 15 minutes before - every five minutes.
Notify 30 minutes before - every 10 minutes (but at least five minutes before).
Notify 60 minutes before - every 15 minutes (but at least five minutes before).

The Info line confirms the next scheduled shutdown time.

To Schedule a Server Shutdown Using Graphic Hub Manager
In the Graphic Hub Manager open the Server Shutdown panel:

Click Server > Shutdown, or
Press CTRL + W or F10.

Click Schedule...

In the Mode drop down box, select one of these options:
Once.
Recurring.
Recurring forever.

In the Start at drop down box, click to select a date from the calendar.
If required, adjust the time.

Note: A shutdown task cannot be started in the past.
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If Recurring is selected:
In the End after drop down box, click to select a date from the calendar.
If required set a time.

Select a Notification option. Options are:
Do not notify at all.
Just notify five minutes before shutdown.
Notify 15 minutes before - every five minutes.
Notify 30 minutes before - every 10 minutes (but at least five minutes before).
Notify 60 minutes before - every 15 minutes (but at least five minutes before).

Click OK.

To Shut Down a Cluster
In the Graphic Hub Manager, log in to the Main server.
Open the Server Shutdown panel:

Click Server > Shutdown, or
Press CTRL + W or F10.

Click Shutdown Cluster.

Limit and Shut Down Sessions
Active sessions on the server can be limited by the limitation of the number and/or shut down of 
individual sessions. If a Graphic Hub is to be shutdown, clients can be notified (message, email, 
walk-in, etc.) and then not allow them to reconnect (no new connections = nobody is removed, but 
nobody new can come in).

A limit of one connection can be set, if only a Deploy Agent is used.

A disconnect stops client access immediately.

To Limit the Number of Sessions
In the Graphic Hub Manager open the Server Shutdown panel:

Click Server > Shutdown, or
Press CTRL + W or F10.

Select a server in the Server drop-down box.
Click Modify...

Select one of the following options:
System default
User defined (and enter a numerical value)
No new connections

Note: Schedule tasks can not begin the past.
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No new connections (except Graphic Hub Deploy)
Click OK.

To Disconnect a Selected Session
In the Graphic Hub Manager open the Server Shutdown panel:

Click Server > Shutdown, or
Press CTRL + W or F10.

Select a session, or sessions, in the Sessions list.
Right-click and select Disconnect selected sessions...
Click Disconnect.
Click Close.

2.4.3 Graphic Hub Emergency Shutdown
A Graphic Hub emergency shutdown terminates a Graphic Hub almost immediately. If the Graphic 
Hub server is a Main server in a Replication environment, the emergency shutdown causes a 
failover to the Replication server.

Emergency shutdowns can only be executed from the Graphic Hub Terminal, and should be used 
sparingly.

Warning: Index re-organization and vacuum of tables is skipped when performing an 
emergency shutdown. Please perform a normal shutdown through GH Manager to avoid 
performance reduction and to free disk space.
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To Do an Emergency Shutdown
In the Graphic Hub Terminal main window, click Emergency Shutdown.

To continue with the emergency shutdown, click Yes.

See Also

Graphic Hub Startup

Note: If an automatic backup has been configured this warning message shows. 
Check the checkbox to disable an automatic backup on this emergency shutdown.
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Graphic Hub Shut Down
Backup and Restore

2.5 Database Management

This section contains information on the following topics:

Main and Replication Servers with Failover
User and Group Management
Test a Replication Server
Data Errors
Import External Images
Locate Duplicate Files
Add Metadata
Replace File References
Direct Deploy Copy
Graphic Hub Search
Server Information
Daily Backup Using a Second Graphic Hub
Detect and Solve Server Differences

2.5.1 Main and Replication Servers with Failover

Adding failover servers adds another level of redundancy to the Graphic Hub cluster. This is useful 
in situations in which the cluster becomes unavailable, for example due to maintenance or 
hardware failure. This section describes how to configure a Graphic Hub cluster with an arbitrary 
number of failover servers in multiuser mode, and contains the following information:

Note: For Pilot data back end systems using Deploy Agent 2.2.0 or later and GH Manager 
5.2.0 or later, it is recommended to backup Pilot data using Pilot data deploy tasks, 
see Resolve Viz Pilot Data Differences Between Graphic Hubs.
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To Configure a Cluster with Failover Servers
Perform a Cluster Server Installation, setting up both the Main and Replication server.
Install the number of Graphic Hubs to act as failover server in multiuser mode. The failover 
server has to be able to handle the number of clients connected to the cluster, in case the 
cluster becomes unavailable.
Set up one or more Deploy Agents with real time deployment from the Main server to the 
failover server(s).
Create a corresponding amount of real time deploy tasks from the cluster to the failover 
servers to keep them in sync. In setups using multiple failover servers, the recommended 
configuration is to deploy from the Main server in the cluster to the first failover server, then 
from the first failover server to the second failover server, etc.
In the Deploy Agent Properties, open the Configuration Panel and configure enable 
emergency pause of real time tasks in the case of deletion of 1% of all objects or 1 item. 
This prevents the deploy task on the cluster from accidentally deleting content created while 
the cluster has been unavailable, in case the cluster becomes available again.
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Configure the clients, such as Viz Artist or GH REST, to use one or multiple of the failover 
multiuser servers. If the cluster becomes available, the clients only connect to the failover 
servers if the client is configured correctly. For details on configuring the client for failover, 
refer to the respective product documentation.

To Check Client Connections
Log on to the cluster and the failover server(s) with Graphic Hub Manager.
Open the Active sessions window. This provides an overview of all logged in users and active 
sessions, and to which host they are connected.

Resume Normal Operation after Failure of Main or Whole Cluster
After a failure of the main server, all clients are automatically redirected to the replication server. 
When the cluster has returned to real time replication mode, the clients are automatically returned 
to the Main server.

After a failure of the cluster, all clients are automatically redirected to the failover server(s). 
However, they do not automatically return to the cluster once the cluster has been brought back 
online. Before bringing the clients back to the cluster, a manual merge of the data from the 
failover server is needed to re-synchronize the cluster. This is required in order to avoid possible 
loss of data created by the clients during the cluster downtime period.

Before restarting the Deploy Agent service after the cluster is back up, make sure that the server 
differences have been successfully merged, and that all clients are back on the cluster again.

See Also

System Installation
Graphic Hub Terminal
Graphic Hub Manager
Graphic Hub Deploy Agent

2.5.2 User and Group Management
From the Administer Users and Administer Groups windows it is possible to manage all the users 
and groups in Graphic Hub.

Every user that works with the Graphic Hub, either directly or from a client application, must:

Have their own user profile.
Belong to a Group.

The User and Group management system monitors who creates files, who owns files, and who has 
rights to modify the various files in the Graphic Hub.

The permission settings on group level are the default settings for all assigned users, but it is 
possible to change the permission on user level afterwards. It is possible that one specific user has 

Tip: Shut down the Deploy Agent service on the cluster before restarting the cluster. This 
makes sure nothing gets deleted or overwritten when the cluster is brought back up.
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1.

more or less permissions as the original defined base permission settings of the underlying group 
(like a super-user or restricted user).

User and Group permission settings are always related to a folder or file permission setting.

Groups

To Open the Administer Groups Window
Click Tools > Administer Users and Groups > Administer groups.

To Create a New Group
Open the Administer Groups window.

Example: User 1 of Group A has, on User and Group level, ‘no world write rights’ activated. 
This means that it is not possible to override or delete a file or folder which is owned by 
another User from a different Group.



Example: User 2 of Group A has, on Group level, 'group write rights' activated but not on 
User level (restricted user). This means that User 2 is only permitted to overwrite or delete 
their own files in their own folder structure.



Note: All Graphic Hub Manager users can view Users and Groups. Only an 
administrator can create new Users or Groups, or modify existing ones
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Select New... or right click and select Create new group... from the context menu.

Select the destination server from the Server drop down box.

The new group ID value is automatically generated.
Check or uncheck the Active box to make the new group active or inactive.

In the Name box give the new group a unique name.
Specify the user account access rights:

User rights:  User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a 
member of.
World rights: User may overwrite files which belong to anyone.

Click OK.

To Edit a Group

Open the Administer Groups window.
Right click and select Edit selected group... from the context menu.
Check the Active box to make the new group active, if required. If changed from active to 
inactive or inactive to active the modified check box is checked. If the modified check box is 
unchecked, the change is ignored.

Note: If the group-list is filtered, the server cannot be changed.

Note: If a group is inactive, no members can be added.

Note: Only available with administrator privileges and with a single server selected.

Note: You cannot add members to inactive groups.
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In the Name box enter a new unique group name, if required. If changes are made in the 
text box the modified check box is checked. If the modified check box is unchecked, the 
change is ignored.
Specify the user account access rights, if required:

User rights:  User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a 
member of.
World rights: User may overwrite files which belong to anyone.

Click the View member button to see all the group members
Click OK.

To Delete One or Multiple Groups
Administrators can delete groups that do not contain members.

Open the Administer Groups window.
Select the Group or Groups to be delete. Select a Group, or hold CTRL to select multiple 
groups.
Press Delete.
Click OK.

To View a Group

Open the Administer Groups window.
Click on the group or groups to be viewed.
Right click and select View selected group... from the context menu.
The Group window opens. No files can be edited.
Click the View member button to see all the group members
Click Close.

Users

To Open the Administer Users Window
Click Tools > Administer Users and Groups > Administer users... , or
Press CTRL + F9, or
Press CTRL + U.
The Users window shows all available users on all active servers.

Note: Only available if logged in with no Administration rights or if there are multiple 
users, over different servers.



Note: To narrow the users list first select a Server then select a Group from the Server and 
Group drop down boxes.





Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  63

1.
2.

•
•
•

3.

4.
5.

To Create a New User Account
Open the Administer Users window.
Select either:

New... 
Right click, and click Create new user... from the context menu,
Press F6 or Insert.

Select the destination server from the Server drop down box.

The new group ID value is automatically generated.
Check or uncheck the Active box to make the new user account active or inactive.

Note: If the user list shows users of one server only, the server is preset and cannot 
be changed.
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In the Group box select which group the new user belong too.

In the Nickname box, give the new user a unique nickname.
In the Full name box, enter the new user’s full name.
Enter a user Password. Repeat the password in the Re-enter the password box.

Specify the new user account access rights:
User rights:  User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a 
member of.
World rights: User may overwrite files which belong to anyone.

Click OK.

To Edit a User Account

Open the Administer Users window.

Note: If the user account is inactive, the user cannot log in or work with the files in 
the database.



Note: If user list is filtered to show only users of a specific group, this group is 
preset and cannot be changed.



Note: Leave both the Password and Re-enter password boxes empty if no password 
is required.



Note: Only available with administrator privileges.
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Select Edit... or right click and select Edit selected user... from the context menu.

The user account Server cannot be changed.
The user account ID value cannot be changed.
Check or uncheck the Active box to make the new user account active or inactive, if 
required.

In the Group box select the group the user account belongs too, if required.
In the Nickname box give the user a new unique nickname, if required.
In the Full name box change the user’s full name, if required.
Enter a new user Password, if required. Repeat the password in the Re-enter the password
box.

Change the user account access rights, if required:
User rights:  User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a 
member of.

Note: If user account is inactive, the user cannot log in or work with the files in the 
database.



Note: Leave both the Password and Re-enter password boxes empty if no password 
is required.





Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  66

•
11.

12.

1.
2.

3.
•
•
•

4.

5.

World rights: User may overwrite files which belong to anyone.
If required, click the Delete viz user settings button to delete the user account settings 
which are, by default, saved together with the user profile.

Click OK.

To Delete a User Account

Open the Administer Users window.
Click the User(s) to be deleted (press CTRL and click to multi select).

Select either:
Delete... or
Right-click on the selection and click Delete selected users..., or
Press DELETE.

Click OK.
A User cannot be deleted if they own an object(s) in the Graphic Hub. If a User to be deleted 
owns any objects the Choose user... window opens when OK is clicked on. Use this window 
to transfer object ownership to another User.

In the Choose user... window select the User to be assigned the object(s), from the drop 
down box.

Note: Delete viz user settings is only available if one user is to be edited. If more 
than one user is selected, this button does not show.



Note: Only available with administrator privileges.

Note: The built-in administrator cannot be deleted.

Note: Users on multiple servers cannot be deleted in one step.
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Click OK to open the Setting owner... window.

Click Set owner.
Click Close.

To View a User Account

Open the Administer Users window.
Click on the user or user’s accounts to be viewed.
Select either:

View... or
Right click and select View selected user... from the context menu, or
Click on a user account and press F4.

The User window opens. No files can be edited.

2.5.3 Test a Replication Server
This section details how to check a running replication server, including failover. It is strongly 
recommended that the replication server is tested in a production environment.

IMPORTANT! The Choose user... window puts all objects, of the selected User, in an 
Action Log window (Setting owner...), where ownership changes.



IMPORTANT! The owner change must be done before delete can continue. If the User 
still owns an object(s), the delete fails.



Note: Only available if logged in with no Administration rights or if there are multiple 
users, over different servers.





Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  68

1.

2.

a.
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To Test a Replication Server
From a third computer, start the Graphic Hub Manager and log on to both the Main and 
Replication server as administrator.

Open the properties of the data directory on both machines (right-click the data folder, and 
then from the menu that shows, select Properties), and make sure that the UUIDs on both 
machines are identical. If they are not identical, shut down the servers.

If the data directories on both the Main and Replication servers are empty, delete both 
data directories. Use the Graphic Hub Terminal to create new data directories on both 
servers, then start the cluster.
If the data directory is not empty, delete the data directory on the Replication server 
only. Copy the data directory from the Main server to the Replication server. Use the 
Graphic Hub Terminal to configure the copied data directory as a new data directory 
for the Replication server, then start the server. To use the data directory on the 
Replication server as data directory for the cluster, repeat the above steps copying the 
data directory from the Replication server to the Main server, and configure the main 

IMPORTANT! Before a test, make sure that no clients are working on any of the servers in 
the Cluster. Also, check that the Graphic Hub solution is a fresh setup of a Replication 
Cluster.
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server with the copied data directory.

In Graphic Hub Manager, select Tools > Monitor Servers . Check that the Health LED is green.
From the main menu, select View > Messages (Chat) .
Unplug the network cable on the main machine, and then wait for a few seconds.

 
The Graphic Hub Manager chat panel should show that the main server is down and that the 
replication server has automatically taken over.

 
The main server name in the Servers and Folders should also be colored red.
Plug the network cable in on the main machine again. To prevent data loss and 
configuration corruptions in the cluster environment, the main server should shut down. 
Wait for the shutdown to complete, and then start the main server from the Graphic Hub 
Terminal.
If no users have been working with the system while the main server was down, proceed to 
the next step. Otherwise, wait a minute or two for the system to refresh.
The Graphic Hub Manager chat panel should now show that the main server is up and 
running again, and that the main server has automatically taken over as the primary server 
in the cluster.

 
If the steps above have been carried through correctly, the cluster configuration has been 
tested sufficiently and is ready to work in a real production environment.
Query the Journal log for replication-related errors.

2.5.4 Data Errors
Like the Check Disk feature in Windows, Graphic Hub Manager allows the database administrator 
to search for and repair data errors in the Graphic Hub.
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The Server Check  menu is used to scan for errors and inconsistencies in the server’s internal 

structure. Various checks are available, and can be set On  or Off  as required. Any errors 

discovered during the check are displayed with a description of the errors and how they possibly 
can be resolved. Some types of errors must be fixed manually, while others can be fixed 
automatically. This is displayed in the list of errors.

After finishing or canceling a server check, results can be exported to a file or copied to the 
clipboard from the error list context menu. If the process is paused, it is not be possible to check 
the file properties, or to copy or export the results.

To Find Data Errors
Open the Check Server window.
In the Servers and Folder panel, right-click the server to be checked and select Check server 
<server name>

In the left panel, choose the options to check for.

Options are:
Check folder links
Check file links
Check references

Note: Server Check requires Administrator user rights.

Note: If this window was opened with Server > Check, select the server to be checked 
from the Server drop-down box.
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Check folders

Click the Check button. You are advised that checking for data errors can be time 
consuming and resource heavy, and should not be done at peak hours.
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Click Yes to proceed. Any errors found are shown in the right panel. Clicking on an error 
shows more detailed information in the bottom panel.

To Fix Data Errors
If you do not require a log of errors that have been fixed, check Automatically remove fixed 
entries.

Click the Fix all! button.

Note: You also have the option of selecting only certain errors in the right panel, 
right-clicking, and fixing only the selected entries or trying to Verify and Restore 
files.
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Any errors that cannot be fixed remain in the right panel. Click the entry and follow the 
instructions in the bottom panel.

2.5.5 Import External Images
External images can be imported from Windows Explorer directly into a connected Graphic Hub 
using Graphic Hub Manager. It is recommended that imported images are of sufficient quality to 
be worked on in Viz Artist. However, you do have the option to compress images when they are 
imported.

To Import External Images
Select one or more images in Windows Explorer.

Note: Checksum 11 means that a client failed (disconnected/crashed) during a Save 
operation. The Graphic Hub still has the old content and clients can load this old content, 
but to indicate that the scene was not saved correctly the checksum is set to 11. To reset 
this state and clean up temporary data of the failed Save operation, open the affected file 
in Viz Artist and save it.
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Drag the selected images to a folder or the explore panel.

Select the import settings:

 
Image Compression: Set the default image compression during import. The following 
options are available:

None: No compression.
Select automatically: If the source image has an alpha channel, DXT5 is used. If the 
source image does not have an alpha channel, DXT1 is used.
DXT1: Works best on images without an alpha channel.
DXT5: Works best on images with an alpha channel.
Import quality: The quality defines the compression for .png and .jpg images.

Import bilevel matte type images as RGBA: Applies to monochrome images only. When set, the 
luminance of monochrome images is treated as an alpha channel. When disabled, the alpha 
channel is treated as RGBA, while images without alpha channel are treated as RGB.
Overwrite existing images: Check this checkbox to overwrite images with duplicate file names in 
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the target directory during import. Otherwise, an extension to the file name is added to the newly 
imported images.

Click Import. This opens the Import external files window:

Set the desired options for the import by checking the appropriate checkboxes, and click 
Import to perform the operation.
After the import process has finished, the results can be investigated in the main section of 
the import window. Any files that failed to import are marked with a red cross next to the 
path. If an image fails to import, verify that it is among the supported image formats for 
import.

Click Close to close the import window.

Graphic Hub Manager Supported Image Formats for Import
The following image formats are supported for direct import using the Graphic Hub Manager and 
GH REST upload:

File Type Note

.bmp

Tip: Importing images to the Graphic Hub using Viz Artist support a wider range of 
file formats.
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File Type Note

.gif

.jpg

.png

.tga No alpha 32

.tiff No CMYK and LAB

.exr

.hdr

2.5.6 Locate Duplicate Files
When files are copied from one folder to another, such as when creating linked or duplicate files, 
the copy exists as a duplicate of the original file. As long as neither the original file nor the copy is 
modified, they remain duplicates, since the checksum of both objects is the same.

To Locate Duplicates in a Graphic Hub
Click View > Duplicates, or press CTRL + N, or CTRL + F5. The duplicates window is shown.

The duplicates window lists all the duplicates in the selected server, sorted by the names of 
the files. If duplicates carry different names, this is also shown.

Tip: The files can be renamed, and still remain duplicates.
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Right-click a duplicate for more information about it. This will open a menu with the 
following options:

Open Containing Folder in Explorer: Jumps to the folder in the Servers and Folders, 
where the selected file is placed.
Properties: Opens the File Properties window, which shows detailed information about 
the selected file.

2.5.7 Add Metadata
Graphic Hub supports keywords and add-ons that work like metadata, to help you to dynamically 
organize your files better and enhance search capabilities.

Keywords
Up to 20 keywords can be assigned to any file, to enhance search capabilities.

Select Tools > Administer Keywords to open the Administer Keywords window.

To View Files which Use a Selected Keyword
Open the Administer Keywords... window.
Click on a keyword(s).
Double click a keyword to view files assigned to it.
All files assigned with the selected keywords show in the right side panel.

To Create a Keyword
Open the Administer Keywords window.
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Click the New button. In the left panel, a new keyword is created.

Enter a name for the new keyword, and press ENTER.

To Delete a Keyword
A keyword can only be deleted if it is not assigned to a file or folder. Look in the No. of Obj. field 
to verify how many files or folders the keyword(s) are assigned to.

Open the Administer keywords window.
In the left panel, click on the keyword(s) to delete.
Click the Delete button.
Click Yes in the delete confirm window.

To Assign a Keyword to a File
Right-click a file in the File panel and select Properties from the context menu.

Note: If multiple keywords are selected, only the keywords with no assigned files or folders 
are deleted.
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Click on Keywords in the Properties for <file name> window that opens.

Select/find a keyword(s) to assign to the file:
Enter a keyword name in the search box.
Click on Search, or Show All to see all available keywords

Click a keyword, in the Assignable keywords panel, to select it.
Click the < Add button.

Click OK.

To Assign a Keyword with the File Context Menu
To assign a keyword(s) with the file context menu is better for on-the-fly keyword additions, but 
does not show any other data about the keyword(s) which are assigned.

Right-click a file in the File panel to open the file context menu and select Add keywords...

Search for available keywords by entering the name of a specific keyword, or asterisk ( * )
to show all available keywords.
Select the required keyword(s).
Click Add...
Click Add in the Add keywords... window.
Click Close.

Tip: Wildcards such as * or ? are allowed in the keywords search string.

Note: Up to 20 keywords can be assigned to one file.
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To Remove a Keyword from a File
With this procedure a keyword(s) is first selected then the file(s). The advantage to that method is 
greater visibility of information regarding each keyword and where it is used.

Open the Administer Keywords... window.
Click on a keyword(s) in the list of available keywords.
Double click a keyword to view the files assigned to the selected keyword. All files assigned 
with the selected keyword(s) show in the right side panel.
Right-click on the file(s) from which the keyword is to be removed.
Click Remove keyword(s).
Click Remove.... in the Remove keywords from <file name>... window.
Click Remove in the Remove keywords... window.
Click Close.

To Remove a Keyword with the File Context Menu
To remove a keyword(s) with the file context menu is better for on-the-fly keyword removal, but 
does not show any other data about the keyword(s) which are to be deleted.

Right-click a file in the File panel to open the file context menu, and select Remove 
Keywords...

Select the keyword(s) to be removed.
Click Remove....
Click Remove in the Remove keywords... window
Click Close

Add-ons
Add-ons are a solution for creating templates to assign custom metadata to objects in the Graphic 
Hub. This provides another dimension for searching, tagging and organizing objects. Add-ons 
work similarly to Keywords, but are actually more extensible.

Simple Add-on Use Case and Conceptional Workflow
Images of people need to be tagged with the first name, last name, gender, and age. 

Add-on template with corresponding fields is created and published. Only published add-ons 
can be assigned to files.
The add-on is assigned to a file and the values wanted are entered.
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Afterwards, the search grants the ability to view this information, for example, all files with a 
specific add-on or gender male assigned are retrieved.

A typical add-on assigned on a specific file could look like:

Add-On: Vizrt Meta Data
Title: My Metadata Element 01
Alternative title: Add-on Example 01
Synopsis: Add-on use case
Rights: Rights reserved and held by creator and contributors
Date: 20-02-2018
Language Code: ENGLISH
Media Type: Production Element
Creators: various

Add-ons are administered from the Add-ons window. They are assigned from the Add-ons Panel.

Tip: Add-ons assigned to files are exportable and importable through Archives and are 
deployed with Graphic Hub Manager and the Deploy Agent.
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Each add-on can have several entries. Entries can be numbers, strings, UUID, date and XML (for use 
by external applications). Each entry also has a Proposal, which sets out the options for the add-on 
in an eventual drop down box. You can also add informational text for a tool tip, which is shown 
when you mouse over the region of its name in the add-ons window.

One use case for add-ons is approval states. You can create an add-on with the parameters of 
Draft, Pending, and Approved. If an art director does not want any scene on the design cluster to 
be make it to the playout engine, they can use the Import External Images functionality to take all 
new scenes, assign the add-on, and then only deploy scenes that he has personally approved to 
the playout engine.

To Create a New Add-on
Open the Graphic Hub Manager
Open the Administer add-ons window:

Click Tools > Administer add-ons..., or
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7.

Press CTRL + SHIFT + F8.
Open the Create add-on window:

From the Administer add-ons window, click the Create new add-on... button , or 
right-click in the Add-ons quadrant and select Create new add-on... 

In the Name field, enter a name for the add-on.
From the Group drop down box, select from:

ungrouped: The new add-on is not in a group.
<group name>: Select a group to put the new add-on.

Check the Allow transfer via DDC, if required (when checked, the add-on is transferred 
through DDC (Direct Deploy Copy)).
Check the Allow transfer via archive export/import, if required (when checked, the add-on 
may be transferred via Archives (exported/imported)).
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Click the Add... button. The Create entry of add-on window is shown.

In the Name field, enter a name for the add-on entry.
From the Data Type drop down box, select one of the following options:

Number: Only manual proposals supported.
String: Supports manual proposals and having all registered users as a proposal 
option.
Date: No proposals supported, namely selecting a date from a calendar.
UUID: No proposals supported.
XML: No proposals supported.

Check the Mandatory check box for it to be mandatory for this entry to have a value. 
Uncheck it for the entry to be optional.
From Proposal drop down box, make sure Manual is selected.

In the Add field, enter an option that is available for selection and click the Add button. 
Repeat for as many options as you want to have in your proposal. You can also remove 
options by clicking the Remove button, as well as changing the order in which options 
appear by clicking the Up, Down, Top and Bottom buttons.
Check the Restrict check box to restrict the proposal entries to what you have added above. 
Uncheck it to allow user-defined entries in addition to your proposal options.
From the Default value drop down box, select one of the following options:

<none>: There is no default value assigned. Not available if the entry is restricted.
<user defined>: The value is defined when assigning the add-on. Not available if the 
entry is restricted.

Note: If the Data Type is String, the option of selecting <all users> as the Proposal is 
available. In this case, no further Proposal configuration is required.
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<current user>: The logged-in user is the default value. The other proposal values are 
also available.
<current time>: The current date and time are the default value. Only valid if the Data 
Type is Date.
Any of the other proposals you have defined above.

In the Info field, enter any text that you wish to appear as a tool tip when mousing over the 
add-on once it has been published.

Click OK.

To Create an Add-on Group
Open the Graphic Hub Manager.
Open the Administer add-ons window:

Click Tools > Administer add-ons...
Open the Create add-on group window:

In the Administer add-ons window click the Create new add-on group... button , or 
right-click in the Add-ons quadrant and select Create new add-on group...

In the Name field, enter a name for the add-on group

Click the OK button. The new Add-on group shows in the Add-ons quadrant.

To Publish an Add-on

In the Add-ons quadrant of the Add-ons window, right-click the add-on and select Publish 
add-on. You are queried if you are sure you want to publish this add-on.
If the add-on is ready for use, click Yes.

Caution: Any text you enter in this field is exposed to end users.

Note: Make sure that the new Group name is unique.

Note: Add-ons can be dragged from group to group as required.

IMPORTANT! Add-ons are automatically saved during the creation process and can be 
modified as required. But the Add-on cannot be assigned until it has been published. As 
long as the Add-on is assigned to any file on the server, it cannot be deleted. If the Add-on 
is not (no longer) assigned to any file on the server, it can be deleted.
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To Filter Add-ons by Type
In the Add-ons quadrant of the Add-ons window, from the Filter by type drop down box, 
select one of the following options:

All: All add-ons.
User-defined: All add-ons created by any users.
Viz: External metadata created by another Viz application.
System: All Graphic Hub server-delivered add-ons.

To Filter Add-ons by Stage
In the Add-ons quadrant of the Add-ons window, from the Filter by stage drop down box, 
select one of the following options:

All: All add-ons.
Draft: Unpublished add-ons.
Published: Published add-ons.
Retired: Add-ons retired from active use (because they can be withdrawn from service 
but not deleted from the system).
Imported: Metadata exported to Graphic Hub by other Viz applications.
Copied: Transferred in a deploy operation.
From archive: Add-ons exported by Viz Engine and re-imported from a Viz Artist 
archive to the Graphic Hub.

To Sort Add-ons and Add-on Groups
Click Tools > Administer add-ons... to open the Administer add-ons window.
In the Add-ons panel, select on an Add-on or an Add-on Group.
Drag the Add-on or an Add-on Group to its new location.

To Assign an Add-on
Enable the Add-ons Panel.
Select one or more files and drag them into the add-ons header. To remove a file from the 
add-ons header, click it and press Delete.
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Click the Edit tab.
Add-ons available for assignment are shown.

Click the button to the left of an add-on to expand it.
Check the check box beside the add-on to select it.
Do one of the following:

Select a value from the proposals drop down box.
Enter a value in the field (allowed only if the add-on is unrestricted).
Click the E button to the right of the add-on to edit the proposals (allowed only if the 
add-on is unrestricted).
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Select a date (allowed only if the add-on is for the Date data type).

Click Apply.

To Retire an Add-on
In the Add-ons quadrant of the Add-ons window, right-click the add-on and select Retire add-
on. You are queried if you are sure you want to publish this add-on.
If the add-on is ready for use, click Yes. The add-on is no longer available for use.

2.5.8 Replace File References
By replacing references it is possible to replace, for example, Images or Fonts referenced by 
Scenes or Geometries, with different Images or Fonts. It is only possible to replace an Image with 
an Image, or a Font with a Font.

To replace references is practical, for example, when rebranding a corporate identity.

Note: With multiple files selected, where some have add-ons with different 
values, the entries that have different values displays <mixed values!>.



Caution: Do not replace references at random. Make sure that the replacement files are 
compatible in terms of size, scale, color, and other Viz Artist properties used for playout. 
Research and test before replacing references.
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To Replace References
In the Graphic Hub Manger, right-click the required file or files and select Replace 
References... 
The Replace References wizard opens.

Optional: In the Filter panel select which type of object to replace from the drop down box. 
Options are:

All
Image
Font
Geometry
Audio

Caution: Use the replace file references feature with care, as it can potentially be harmful. 
For example, if the image to be replaced is in a Scene which is currently on-air.



Warning: There is no UNDO to this procedure. Be very careful, and try this procedure first 
on one or two Scenes only.



Note: References in one file must be unique. It is not possible to replace multiple 
references with the same file (UUID). If multiple references (e.g. fonts) need to be replaced 
with the same file then this needs to be done in Viz Artist.
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Click Next.

Drag replacement files onto the listed files of the same type.
Click Finish. The Action Log for replacing references is shown.
Click Replace.

2.5.9 Direct Deploy Copy
The Direct Deploy Copy (DDC) function deploys one or more folders/projects/files:

Multi Server Deploy: Deploys one or more folders/projects/files in exactly the same folder 
structure to two or more selected servers.
Server to Server Deploy: Deploys one or more folders/projects/files to another server using 
one of three methods:

Rebuild the original structure.
Copy the folders/projects/files to the target folder.
Rebuild the structure under the target folder.

For Multi server deploy, rebuilding the original structure is the only available method.

Direct Deploy Copy (DDC) tasks can also be scheduled and run, as and when required (see Graphic 
Hub Deploy Agent).
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Multi Server Deploy
Multi Server Deploy deploys one or more folders/projects/files in exactly the same folder structure 
to two or more selected servers.

To Replicate on Multiple Servers
In Graphic Hub Manager, log on to two or more servers.
Right-click a folder, project, or file, in the Servers and Folders or Files panel, and 
select Deploy.
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The Deploy Direct Copy window opens and the analysis process begins.

In the list, select the target servers where the folders/projects/files should be deployed.

Enable/disable the following options:
Overwrite existing objects (does not apply to referenced files).
Overwrite existing references.
Overwrite owner.
Overwrite creation date.

Tip: The servers can be sorted by clicking the Top, Up, Down, or Bottom buttons. 
This increases/decreases the priority level of a specific server.
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Overwrite modification date.
Select one of the following processing options:

Deploy all files to the first target server, then the next server in the queue, and so on.
Deploy one file to all target servers, then the next file in the queue, and so on.

Click the Continue button.
The Action Log for deploying files is activated.

Click Deploy. The folders/projects/files are then deployed. When the deploy process is 
finished, check the Action Log for possible errors, and if necessary, attempt to redeploy any 
unsuccessful files.

Server to Server Deploy
Server to Server Deploy deploys one or more folders, projects, and files, to another server using 
one of three methods:

Rebuild the original structure.
Copy the folders/projects/files to the target folder.
Rebuild the structure under the target folder.

To Replicate on One Target Server
In Graphic Hub Manager, log in to two servers.

Tip: You can predefine the options in Steps 4 and 5 by clicking Tools > Edit 
Preferences > Deploy Direct Copy . Once defined, these preferences are set as 
defaults for every deploy operation you configure. Note, however, that Rebuild 
original structure cannot be redefined for Multi server deploy.
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2. In the Explorer panel, select source files/folders/files, and then drag them to the target 
folder in the required server.

Tip: For single folder or project deployment, the Servers and Folders panel can also 
be used.
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The Deploy Direct Copy window opens and the analysis process begins.
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Select one of these options:
Rebuild Original Structure: Copies an exact replicate of all selected folders/projects/
files and its references from source to destination server.
Copy to Target Folder Only: Copies all selected folders/projects/files and its 
references from the source server to the destination folder on the destination server.
Rebuild structure under target folder: Copies an exact replicate of all selected folders/
projects/files and its references from the source server to the destination folder on 
the destination server.

Enable/disable these options:
Overwrite existing objects (does not apply to referenced files).
Overwrite existing references.
Overwrite owner.
Overwrite creation date.
Overwrite modification date.
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Click the Continue button. The Action Log for deploying files is activated.

Click Deploy. The folders/projects/files are then deployed.
When the deploy process is finished, check the Action Log for possible errors, and if 
necessary, attempt to redeploy any unsuccessful files.

2.5.10 Graphic Hub Search
The Graphic Hub Manager’s search functions can search for files, folders, and projects, on one or 
more servers.

Tip: You can predefine the options in Steps 3 and 4 by clicking Tools > Edit 
Preferences > Deploy Direct Copy . Once defined, these preferences are set as 
defaults for every deploy operation you configure.
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There are two primary types of searches available in the Graphic Hub Manager: Free text search 
(which includes a Quick search), and Standard search. In addition, it is possible to search for files 
in the available databases by universally unique identifiers (UUIDs).

If the search panel is not open, enable it under View > Panels > Search. Search results are shown in 
the Results panel and results can be filtered per server, if the search included more than one 
server.

Free Text Search
The free text search searches for files, folders or projects and can include any or all of these 
search strings:

File names
Folder names
File owners
File UUID (on Graphic Hub version 2.3.2 and higher)
File type (geometry, font, images, etc.)
Assigned keywords
Created time
Modified time
Add-ons (metadata)
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To Search Using Free Text Search
In the Search panel, select Freetext in the Name / Freetext drop-down list:

Enter the search parameters in the Freetext field. To achieve the best search results, refer to 
the Search string syntax.
The Type drop-down list is used to narrow the search to a specified set of file types only. 
The type field can be used to include or exclude one or more of the following types:

Any type- the default mode, all elements are included.
AUDIO_CLIP
BASE_FONT
FONT
FONT FACE and FONT Files (for Viz Engine 4.x and higher)
GEOM
IMAGE
MATERIAL
MATERIAL_ADVANCED
MATERIAL_DEFINITION (for Viz Engine 4.x and higher)
SCENE
SHARED_MEMORY_MAP
SUBSTANCE
VIDEO_CLIP

Right clicking the type excludes it from the search, identified by a dimmed check mark. For 
example, here the BASE_FONT type is explicitly excluded, while the FONT type is included in 
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the search:

Select where to search in the Where drop-down list:
Everywhere (objects and Add-ons)
In objects (files and folders only)
In add-ons (metadata only)

If the GH Manager is logged on to more than one server, the Search on checked servers only
box can be used to specify which server(s) the search is performed on. If checked, at least 
one server needs to be selected for the search to run.
If the GH Manager is logged on to only one server, or if multiple servers are logged on to 
and only one is selected in Search on checked servers only, the folder which is to be 
searched can be specified as required:

Check the Search in specified folder check box.
Select the folder to be searched.
Check the Search in Sub-folders check box to run a recursive search.

To search by last modified date or date of creation, check the Search by advanced properties
check box. The search by date approach can be narrowed further by specifying from date, 
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until date, and between dates:

Press ENTER or click on the search icon  to run the search.

Search using all available search criteria can only be performed on one server at a time.

Quick Search
The Quick Search function gives a quick means to search for a file, folder or project.

To View the Quick Search Bar
In the main tool bar click on View > Toolbars > Quick search .
Click on Quick search to open or close the Quick search toolbar.

To Use the Quick Search Function
In the Quick search tool bar click in the Servers drop down list and select the server or all 
servers to be searched.
In the text field enter the search string.

Press ENTER or click on the search icon .

Deploy Search Results
The Freetext search results can be used to create a deploy task. This can be useful for creating 
deploy tasks for daily additions or modifications, for example.

Note: Click on the  icon to expand or collapse the search criteria selection for 
each category.
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Perform a Free text search.
In the search results, select the result that matches the requirements for the deploy task and 
press CTRL + D, or right click and select Deploy.
Proceed to Create a New File Based Deploy Task.

Standard Search
The Standard search searches for files with more detailed search options. Search by one or a 
combination of different search criteria.

To Search with Standard Search
In the Search panel, select Name in the Name / Freetext field.

In the Name field enter name search parameters, if required.
From the Type drop down box, select the file type to be searched for.
Click on the check boxes to add search criteria as required.

To Search by Specified Folder
To Search by Advanced Properties
To Search by Selected Keywords
To Search by References

Press ENTER or click on the search icon .

If Search on checked servers only is checked, at least one server must be selected.

To Search By Specified Folder

Check the Search in specified folder check box.
Select a folder to search in.
If required, check the Search in subfolders check box.
If required, add more search criteria.

Press ENTER or click on the search icon  to search.

To Search By Advanced Properties

Check the Search by Advanced Properties check box.
Enter search parameters as required:

Note: If more than one server is open or selected, only the Advanced Properties 
criteria is available.



Note: To open or hide search criteria, click on the  icon to the right of each search 
criteria.
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Size: Searches for files that are either at least, at most, or between the defined size(s) 
in KB.
Created: Searches for files created either after, before, or between the defined date(s).
Modified: Searches for files modified either after, before, or between the defined 
date(s).
Expiration: Search for files expired either after, before, or between the defined date(s).
Use group instead of users: If selected, the next four options apply to groups instead 
of users.

Owned by: Searches for files owned by user.
Modified by: Searches for files that was last modified by the defined user.
Checked out by: Searches for files checked out by the defined user.
Search by access rights: If selected, searches for files that have write permission either 
on user (UW), group (GW), or world (WW) level.

If required, add more search criteria.

Press ENTER or click on the search icon  to search.

To Search By Selected Keywords

Check the Search by selected keywords check box.
In the upper field enter the first characters of the keyword, or enter *** to list all available 
keywords.
A list of available keywords that match the characters then shows in the keywords list.
Select one or more keywords that match the search criteria.
Check or uncheck the All checkbox:

Checked: Search for Scenes or Geometries which contain all search files.
Not checked: Search for Scenes and Geometries which contain at least one of the 
search files.

If required, add more search criteria.

Press ENTER or click on the magnifying glass  to search.

Note: Only registered users/groups are available from the lists.
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To Search By References

Check the Search by Referenced/Referencing Files check box.

Drag and drop a file or files into the drop area.

Make sure that the Reference check box is checked.
Check or uncheck the All check box:

Checked: Search for Scenes or Geometries which contain all search files.
Not checked: Search for Scenes and Geometries which contain at least one of the 
search files.
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If required, add more search criteria.

Press ENTER or click on the search icon  to search.

Search by UUID
The Graphic Hub keeps track of all items in the database by assigning Universally Unique 
Identifiers (UUIDs). This also applies to deployed items, which means that if an item is deployed 
from one server to another, it has the same UUID on both servers. When the UUID of an item is 
known, it can be looked up very quickly using the Search UUID on server.

To Search by UUID on Server
Open Graphic Hub Manager, and log on to the server(s) that is to be searched.
From the Tools menu, select Search by UUID.... This opens the Search by UUID on server
window.

If you have logged on to more than one server, select the server to perform the search on in 
the Server drop-down list.
Enter the UUID in the editable text field. This text field accepts valid alphanumeric 

characters only. Valid input are digits in the range 0-9 , and letters in the range A-F . The 

search is not case sensitive, and dashes are added automatically:

Click Properties... to perform the search.

Tip: Use Search by References to search and replace Images or Fonts referenced by 
several Scenes or Geometries, with different Images or Fonts. For example, if a 
company logo changes, search for the image references, select each required Scene 
and replace the image (see Replace File References).
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If an item with the provided UUID is found, its Properties page opens.
If no item on the database matches the provided UUID, you are alerted by a popup 
window.

Search String Syntax
Free text search string syntax is very similar to the search string syntax of other comparable web 
search engines.

Example 1: zebra scene -project -folder

In example 1, the search is conducted on any file names, file owners, UUIDs, file types, and 

keywords that include the string zebra  and scene . This search excludes projects and folders, 

plus any of the other searched files that include the words project  and folder .

Example 2: giraffe -image -geometry

In example 2, the search is conducted on any file names, file owners, UUIDs, file types and 

keywords that include the string giraffe . This search excludes images and geometries, plus any 

of the other searched files that include the words image  and geometry .

Wildcard Text Description
If the full Name is not known then text Wildcards can be used to make a search:

* : Match any characters. For example: Element

? : Match any single character. For example: El?me?t

[ ] : Match a range or a list of characters. For example:

Elem[b-g]nt

Elem[shje]nt

< >  or { }: Match a specific project, folder or file:

Searching for a specific UUID, for example <6E6D3467-0A37-4D35-

B80683B3A929772D>  or { 6E6D3467-0A37-4D35-B80683B3A929772D }, returns the 

specific UUID.

Searching for a partial UUID, for example <6E6D , also includes the underlying UUID.

Best Practices for Searches
The Graphic Hub Manager search capabilities are powerful enough to replace the need to browse 
for files in the server tree. This is meant to make your Graphic Hub work faster and easier.

Example 1: If a Scene has been created on the design cluster, and saved as soccer, search for 

scene soccer.  From the search results, drag the scene to deploy it to a Graphic Hub for the Viz 

Engine.

Example 2: Use the search feature to clean up a server. If the tree structure is complex, it can be 
cumbersome to find all the correct scenes. In this case, create a new and elegant tree structure 
and then find all the scenes in the old tree structure with a search by date and size. In this way, 
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the new structure can be populated with relevant objects, in a logical order, and files that are too 
old or too large, etc., can be removed.

To Export Search Results
To export or copy search results for external use one can:

Copy (CTRL + C) from explorer view (files and folder/projects) and search results (explorer 
and archive search) to the clipboard to be able to paste it to external applications (for 
example, Excel).

Export CSV search result (explorer and archive search) by right clicking into search result 
view and selecting Export search result... and selecting the location where the .csv file 
should be written to.

2.5.11 Server Information
This page details the different methods to monitor a sever and its details.

Terminals Monitor
Active Sessions
Monitor Servers
Server Properties
Chat with Artists
Object Types

Information: The Copy/Paste option is only available on a certain server, not not on 
the "All Servers Tab"
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Terminals Monitor
The Terminals monitor window provides an interface to view all on line terminals within the 
network. A terminal is the physical machine where the Graphic Hub Terminal application is 
running.

To Open the Terminals Window
Click Server > Terminals. The following columns are available:
Terminal: Shows the hostname of the physical machine where the Naming Service and/or 
server are installed. An icon represents the status of the server and Naming Service:

 Both the Naming Service and server are down.
 The Naming Service is running, but the server is down.
 The Naming Service is down, but the server is running.
 Both the Naming Service and server are running.

Server info: Shows <Graphic Hub Server>@<Graphic Hub Naming Service>:<port the naming 
service is listening to>. A plus sign is added if you are logged on to the displayed server.
Naming Service info: Shows <Graphic Hub Naming Service>:<port the naming service is 
listening to>.
Connection: Shows if Graphic Hub Manager has a valid connection to the Graphic Hub 
Terminal.
Server: Shows the name of the server.
S. host: Shows the hostname of the physical machine where the server is installed.
S. port: Shows the port number the server communicates through.
S. up: Shows if the server is running. This is also indicated by the icon in the Terminal 
column.
S. in: Shows if you are logged into this server.
Naming Service: Shows the name of the Naming Service.
Ns. port: Shows the port number the Naming Service communicates through.
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Ns. up: Shows if the Naming Service is running. This is also indicated by the icon in the 
Terminal column.
T. TCP-port: Shows the TCP port number, which can be used to start the server remotely 
from Graphic Hub Manager.
Terminal host network IP: Shows the IP address of the Terminal machine.
The following additional options are available:

Show single user servers on other computers: If selected, also shows servers/naming 
services in the network that are running in single-user mode (localhost).
Advanced options: Open the Terminals Advanced Options window. Alternatively, press ALT + 
A.

UDP-Port: Set the UDP port where Graphic Hub Manager searches for Terminals 

(default: 19394 ).

Timeout: Define how long the Graphic Hub Manager should listen for Terminals before 
timing out. The value is set in milliseconds.

Refresh: Updates the list. Alternatively, press ALT + R.
Login: To log in to a server, select the required server from the list, and then click the Login 
button. Alternatively, press ALT + L. This opens the Login window.

Start server: If the server on a listed Terminal is not running, it is possible to start the server 
from this window. To do so, select the required server from the list, and click the Start 
Server button. Alternatively, press ALT + S.
Start Naming Service: If the Naming Service on a listed Terminal is not running, it is possible 
to start the Naming Service from this window. To do so, select the required server from the 
list, and click the Start Naming Service button. Alternatively, press ALT + N.

Note: The terminals window can only be used with pre-web-based Graphic Hub 
Terminal (version 2.4.2 or older). The UDP port must be the same as the port 
that the Graphic Hub Terminal listens to. To check the port number, go to the 
Graphic Hub Terminal and check in Naming Service, which UDP port is set.



Note: It is not possible to log into a Graphic Hub installation by remote in single-user 
mode (localhost) from other physical machines.
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Active Sessions
From the Active Sessions window it is possible to monitor all logged in users and active sessions. 
When faced with network or connection problems, checking active sessions can provide important 
clues. Likewise, performance problems in general are easy to spot in the Active Sessions window, 
since you can see hosts and servers. In sum, for a good clue as to where to find connection, 
network and performance problems, look in the Active Sessions window.

To Open the Active Sessions Window
Click View > Active Sessions. The following options are available:

Server: If logged in to more than one server, select which server to monitor from the Server 
list.
Running since: Shows how long the selected server has been running, counting upwards in 
hours, minutes, and seconds.

Started at: Shows the time and date when the server was started.
Refresh interval: Defines the interval for when information should be refreshed. It can be set 
to a value between one and ten seconds.
Message: To send a message to all clients that are logged in to the selected server, type a 
text in the Message box, and then click the Send button.

The Sessions list shows detailed information about the sessions that are active on the selected 
server. The following columns are available in the Sessions list:

User: Shows the name of the user that activated the session.
Host: Shows the host name of the machine that the session was started from.
Application: Describes the application and operation that the session belongs to.

Tip: The time relates to the system time on the server machine.
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Logged in since: Shows how long the user has been logged in to the server, counting 
upwards in hours, minutes, and seconds.
Last activity before: Shows the last time an operation was performed in the session.
No. of open files: Shows the number of files that are open in the system.
No. of locked files: Shows the number of files that are session locked.
Login time: Shows the time and date when the user logged in to the server.
Last activity: Shows the time and date of the last time an operation was performed in the 
session.
Priority: Set the priority of the sessions for the correct load balancing.
Session rights: Shows the access (read/write) rights for the session.
Notifications: Description used by the clients, for example to inform that files have been 
created.

Monitor Servers
From the Monitor servers window it is possible to view and analyze all servers that are currently 
logged in to.

To Open the Monitor Servers Window
Click Tools > Monitor Servers. The left part of the Monitor Servers window lists all available 
servers.

The right part of the window shows details about one or more selected servers. If all the available 
servers are working within the required parameters, this overview is hidden. If one or more servers 
are in warning state, the overview for these servers open automatically.

To View Server Details
Double-click the server in the Overview panel or right-click the server, and select Open 
Overview.
Select Open All Overviews to show details of all available servers.

Overview
The Overview frame shows a quick overview of all the parameters. A green light next to the 
parameter indicates that all systems are normal. A yellow light indicates that there are non-critical 
problems. A red light indicates that system limitations have been reached or there are serious 
errors.



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  112

•
•
•
•
•
•

 
The overview shows this basic information for the following parameters:

License
Disk
Memory
Health
Cluster
Activity

License
The License frame shows the status of the Graphic Hub license.

 
The status shows license limitations or remaining number of days until the license expires. If your 
license expires, you receive instant chat messages with increasing frequency to that effect.

Disk
The Disk frame shows the status of the currently used partition where the data directory is located 
on the hard disk of the physical machine.

 
The status shows total, used, and free disk space, and also the warning limit. If the free disk space 
reaches this limit, you receive an Alerts to this effect. The warning is also logged in the Journal 
Panel. The warning limit is defined in the Preferences window.

Memory
The Memory frame shows an overview of the physical memory of the server both in numeric values 
and over time.
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Health
The Health frame shows various Graphic Hub status parameters.

Deadlocks: Shows the number of deadlocks in the system. Any deadlocks necessitate the a 
restart of Graphic Hub.
Active sessions: Shows the number of current sessions.
File opens: Shows the total number of opened files.
Files: Shows the total number of files stored in the system.

Files in memory: Shows the number of currently open files. If it remains greater than 1  for 

an extended period of time, this may indicate locked files. In such cases, refer to the 
following procedures:

Restoring Corrupted Files
Graphic Hub Manager and Viz Artist Troubleshooting

Open transactions: These are transactions that need to be deployed to the other server in 
the replication environment. If the number is too high, stop working until it is back to zero.

Cluster
If you are logged into both main and replication servers, you are presented with a Monitor Servers 
screen that reflects this.
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Title bar: Shows each server’s title bar shows its current status.
Cluster: Shows if the cluster is connected and healthy.
Open transactions: These are transactions that need to be deployed to the other server in 
the replication environment. If the number is too high, stop working until it is back to zero.

Activity
The Activity frame shows an overview of the server activity both in numeric values and over time.

Calls: Shows the total number of calls made by any application to the Graphic Hub Server.
Calls/sec: Shows the average number of calls per second.
Peak: Shows the highest amount of calls during one second.
Ø calls/sec: Shows the average number of calls during one second for the total run time of 
the server.
Ø peak: Shows the highest amount of calls during one second for the total run time of the 
server.

Server Details
This window shows information about the folders and files stored in the Graphic Hub and loaded 
into the memory.
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To View Server Details

In the Monitor servers window, click the Details button.

From the Refresh Rate drop down box it is possible to set the interval of when the 
information should be updated.
Selecting the Show Functions check box shows additional information used for debugging 
purposes.

Note: Only users with administrator rights can access this window.
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The Total frame shows the following information:

Projects: Shows the total number of projects in the Graphic Hub.
Folders: Shows the total number of folders in the Graphic Hub.
Files: Shows the total number of files in the Graphic Hub.
Size: Shows the amount of storage space used by the data.
Memory: The memory pane displays the currently open files, counted per type.

Warning and Error Thresholds
Certain conditions that may cause problems or lead to errors are signaled by the Graphic Hub 
when certain thresholds are crossed. An orange or red signal in the Overview indicates an issue 
that should be investigated by the administrator as soon as possible. In addition, the Graphic Hub 
provides a warning on shutdown, if one or more of the following conditions apply:

Less than 1,600 MB hard disk space is available.
More than 99 % physical memory is used.
Less than 100 MB virtual memory is available.
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In the Overview, Warning level issues are indicated by an orange parameter light, and 
suggests that a restart is recommended. Critical level issues are indicated by a red 
parameter light, and suggests that a restart is necessary. Check the log files for further 
details. The following table lists the most critical limits and warnings:

Hardware Limit Mode Usage Limit, Journal Warning

Less than 1,000 MB free disk space Localhost, 5/4 
Free, 
Multiuser

Critical disk space error. Only read 
access, no write operations 
permitted

Less than 10,000 MB free disk space Main/
Replication

Critical disk space error. Only read 
access, no write operations 
permitted

Less than 2 % free disk space or less 
than 5 % free disk space if 1 % of total 
disk space is less than 10,000 MB

All Journal warning: Hard disk limit 
almost reached

95 % or more physical memory used All Journal Warning: Suggests a restart 
is recommended

100 % Physical memory used All Journal Fatal Error: Suggests a 
restart is necessary

250 MB or less virtual memory available All Journal Warning: Suggests a restart 
is recommended

100 MB or less virtual memory available All Journal Fatal Error: Suggests a 
restart is necessary

In addition to the situations described in the above table, the following conditions produce a 
journal warning:

25 or more main/replication server switchbacks have occurred.
250,000 or more total open transactions have been processed.
7,500,000 or more critical calls have occurred (file created, truncated, written, replaced, 
copied, references changed).
9,000 or more total number of files (index information) in memory
48,000,000 or more total file opens.
2,000,000,000 or more total calls.
Main, folder, keyword or file index data file size exceeds 1,536 MB.

The following conditions produce a journal critical error:

IMPORTANT! If less than 50 MB disk space is available, Graphic Hub does not allow 
any write operations, such as file create, truncate, or copy.
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30 or more main/replication server switchbacks have occurred
500,000 or more total open transactions have been processed
8,000,000 or more critical calls occurred (file created, truncated, written, replaced, copied, 
references changed).
10,000 or more total number of file (index information) in memory.
50,000,000 or more total file opens.
2,100,000,000 or more total calls.
A deadlock has been detected.
Main, folder, keyword or file index data file size exceeds 1,740 MB.

Server Properties
The Server Properties window shows the following types of information:

General server information.
Checksum information. To view Server Properties, right-click the server and select Properties
from the Servers and Folders panel.
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General Server Information

 
In addition to the server’s name, type and version, general server information includes:

License
Disk
Memory
Health
Server details

Checksum Information
View the checksum when you want to compare two or more Graphic Hub servers to see how 
identical they are. This is useful after having performed replication operations or when you have a 

real-time Deploy Agent. Empty servers have a checksum of 00 .
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Use the Refresh button to update the checksum information for the servers currently logged on to. 
Checksum information includes:

Total server checksum
Folder structure (including file data)
File data only
File references only
Pilot tables

Empty servers have a checksum of 00 . When logged on to more than one server, right-clicking in 

the checksum information window brings up the contextual menu, which gives access to:

Open differences...: Opens the Server Diff window. From this window, it is possible to detect 
differences between the servers (see Detect and Solve Server Differences).
Open differences and execute...: Opens the Server Diff window and executes the Diff all
operation.

Open Pilot differences...: Opens the Pilot data differences window. See Resolve Viz Pilot Data 
Differences Between Graphic Hubs. This option only appears when connected to a server 
that contains Pilot data.
Properties: Opens the General server information window for the selected server.

Note: Execution time of Diff all varies depending on the database size and the 
amount of differences between the servers being compared.
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Chat with Artists
Users can communicate with each other while logged in to Graphic Hub. This chat functionality is 
also used to receive global messages from Graphic Hub, such as information about a system 
shutdown. The messages that are sent and received are saved throughout the session. If your 
dongle expires or is otherwise invalid, you receive messages in the chat panel with increasing 
frequency until you renew it.

To Open the Chat Panel
Click View > Messages (Chat).

To Send an Instant Message
Open the Chat panel.
Select the recipient from the left side of the panel.
Type a message text in the text box, and press ENTER. The message is sent to the selected 
Graphic Hub Manager and/or Viz Artist user(s).

Object Types
From this window you can view all the folders and file types on a selected server.

Tip: The chat feature is available from both Graphic Hub Manager and Viz Artist.

Note: If receiving a message while the Chat panel is hidden, the panel automatically 
opens.



Tip: Messages sent to Global Message are delivered to everyone. Messages sent to a 
group are delivered to every group member currently logged in.
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To View Objects
Click View > Object Types . 

If logged in to more than one server, select which database to monitor from the Server list.
Each folder or file type is shown with its corresponding ID. Once an object is in the database, 
its type is added to the object types list. The type remains in the list even if all files of that 
type is deleted later on.

2.5.12 Daily Backup Using a Second Graphic Hub
Adding a backup server adds another level of redundancy to the Graphic Hub server. This section 
describes how to configure and restore from a Graphic Hub backup server in running in 5/4 
Free mode.
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To Configure a Graphic Hub Backup Server
Install a Graphic Hub server in 5/4 Free mode on an extra machine.
Open Backup Configuration in the Graphic Hub Terminal, by clicking Backup and 
selecting Show configuration from the Backup and Restore menu.
Configure the server To Do an Internal Backup or To Do an External Backup.
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Make sure to check both the Automatic backup after successful shutdown and Start after 
backup checkboxes.

Start the backup server.
Using Graphic Hub Terminal, Graphic Hub Manager or Graphic Hub REST, configure a shut 
down task to shutdown the Graphic Hub periodically, for example once per day or once per 
week, depending on the requirement.
Install a Graphic Hub Deploy Agent on the failover system. If there is no failover system in 
place, the replication server should be used.
Create a real time deploy task from the cluster towards the backup server, without 
emergency pausing.

To Restore from Graphic Hub Backup Server
Pause the deploy task on the cluster.

Caution: Because of the resource requirements for the Deploy Agent, it is not
recommended to install the Deploy Agent on a cluster’s main server.
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Perform an emergency shut down of the backup system. Make sure to check the Temporary 
disable backup after shutdown checkbox:

To go back to a specific backup, create a restore data directory from the Graphic Hub 
Terminal restore points. Then configure the Graphic Hub backup server to start using that 
data directory.
Log on to the cluster and backup servers with Graphic Hub Manager.
Click Server in the main menu and select Differences... to open the Server diff window. 
Deploy all differences from the backup server to the cluster.

2.5.13 Detect and Solve Server Differences
If a Graphic Hub in a Cluster environment switches from real-time replication to recovery mode, or 
the replication server has been performing a cluster rebuild, the data on the servers may differ. In 
such situations, the Graphic Hub may be unable to do an automatic rebuild.

To Detect and Solve Server Differences
Make sure that the Main and Replication servers are up and running.
Open Graphic Hub Manager on a third machine, and log on to the Main and Replication 
servers. The user account on the Replication server must be an administrator user. Check 

Warning: If the backup after shutdown task is not disabled, the backup task runs and 
restarts the server afterwards, which can result in possible loss of data.



Tip: Use the Manager to search for specific files and copy them from the backup 
server to the cluster, if not all differences are to be restored.
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the As system administrator checkbox in the Login window when logging on to the server:

From the main menu, select Server > Differences.

In the Server Diff window, click Diff All. This scans all files on the selected servers.
Sort the entries on both servers by size (click the Size columns), and then delete all files with 
a size of 0.00 KB.
Click Diff All again.
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Now sort the entries by type, and then select all entries of type Scene, where the row on the 
opposite side is labeled missing.

Right-click the scene entries, and then from the menu that appears, select DDC To or Verify/
restore...
In the Deploy Direct Copy window that opens, click Continue. Or analog to this click Verify in 
the Verify/restore... window.
The Action Log for deploying files is activated. In the resulting window that opens, click 
the Move button.
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The entries are deployed from one server to the other.

Repeat steps 7-10, and this time sort the entries by type Geom.
Repeat steps 8-10 for all other entry types.

2.6 Viz Pilot Database Management
This chapter describes management of Viz Pilot databases when the Graphic Hub is used as a Pilot 
data back end server.

In this section, you find the following information:

Important Pre-installation Information
Schema Changes
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2.6.1 Important Pre-installation Information
Before setting up Graphic Hub as a back end database for Viz Pilot, observe the following:

The server must meet the minimum hardware requirements for Graphic Hub as Viz Pilot 
back end system which may vary depending on the size of the installation.
Viz Pilot requires Graphic Hub REST . The server running the GH REST service needs to meet 
the Graphic Hub REST Requirements.

The schema version is bound to the Graphic Hub version:

Graphic Hub Version Pilot Schema Version Import Using

Graphic Hub 3.6.0 - 3.7.0 6, 7, 8.0, 8.3.0, 8.4.0 and 8.7.0

 Use Graphic Hub REST 2.6.0 or 
later to expose all 8.7.0 schema 
changes. 

Graphic Hub Manager
version 5.6.0

Graphic Hub 3.4.0 - 3.5.2  6, 7, 8.0, 8.3.0 and 8.4.0

 Use Graphic Hub REST 2.4.2 or 
later, as 2.4.0 and 2.4.1 fail to 
expose all 8.4.0 schema changes. 

Graphic Hub Manager
version 5.4.2 through 5.5.2

Graphic Hub 3.2.0 and
3.3.0

6, 7, 8.0 and 8.3.0 Graphic Hub Manager
version 5.2.0 or 5.3.0

Graphic Hub 3.0.2 - 3.1.1 6, 7 and 8 Graphic Hub Manager
versions 5.0.2 
through 5.1.1.

Graphic Hub 3.0.0
and 3.0.1,

6 and 7  Graphic Hub Manager 5.0.1

Graphic Hub 3.4.0 - 3.4.2 To clean the schema Graphic Hub 
Manager 5.4.2, 5.4.1
or 5.4.0

Graphic Hub 
3.2.0 and 3.3.0

To clean the schema Graphic Hub Manager 5.2.0
or 5.3.0 

Graphic Hub 3.0.2 - 3.1.0 To clean the schema Graphic Hub Manager 5.1.0
or 5.0.2

Graphic Hub 3.0.0
and 3.0.1

To clean the schema Graphic Hub Manager 5.0.1
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All Pilot data is stored in the configured data directory. It is included in the Graphic Hub 
Terminal internal backup, and when the data directory is copied.
The schema is automatically upgraded when the Graphic Hub is started on a data directory.

Graphic Hub Version Upgrade to Schema 

Graphic Hub 3.6.0 - 3.7.0 8.7.0

Graphic Hub 3.4.0 - 3.5.2 8.4.0

Graphic Hub 3.2.0 and 3.3.0 8.3.0

Graphic Hub 3.0.2 - 3.1.0 8

Graphic Hub 3.0.0 and 3.0.1 7

In general, old Pilot clients can work on newer Graphic Hub and Graphic Hub REST versions, 
but newer Pilot clients cannot work on older versions.

Schema 7 clients (VCP 7, 7.1, 7.2) and 8 clients (VCP 8, Pilot Edge) can work on GH 
REST 2.0.2/GH 3.0.2 and higher.
Schema 8 clients (VCP 8, Pilot Edge) can not work on GH REST 2.0.1/GH 3.0.1 and 
lower.
Schema 8.3.0 clients can work on GH REST 2.2.0/GH 3.2.0 and higher.
Starting with PDS 8.4 and Pilot 8.5, all future Pilot releases will be able to work with all 
future GH versions greater than version 3.3.0,
with potentially reduced functionality when used with older GH/GHRest versions. 
Therefore it is recommended to keep the versions aligned.

Version Requirement Summary

Pilot Schema Version
Pilot Client Version

Graphic Hub
Version

GH REST
Version

GH Manager Version
to Import / Clean 
Schema 

8.7.0, Pilot 8.5.0 or 
newer, Pilot Edge using 
8.7.0 schema

3.6.0, 3.7.0 2.6.0, 2.7.0 5.6.0-5.7.0 can import 
schema 6, 7, 8, 8.3.0, 
8.4.0, 8.7.0

Important! Make sure to have the documentation for Graphic Hub and Viz Pilot at hand 
before proceeding with the installation. The latest documentation is available 
at www.vizrt.com.



http://documentation.vizrt.com/broadcast.html
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Pilot Schema Version
Pilot Client Version

Graphic Hub
Version

GH REST
Version

GH Manager Version
to Import / Clean 
Schema 

8.4.0, Pilot 8.5.0, Pilot 
Edge using 8.4.0 schema

3.4.2, 3.4.1 (avoid 
3.4.0)

2.4.2 (avoid 2.4.1, 
2.4.0)

5.4.0, can import 
schema 6, 7, 8, 8.3.0, 
8.4.0

8.3.0, Pilot 8.3.0, Pilot 
Edge using 8.3.0 schema

3.2.0 or 3.3.0 2.2.0 or 2.3.0 5.2.0 or 5.3.0, can 
import schema 6, 7, 8, 
8.3.0

8.0.0, Pilot 8, Pilot Edge 
using 8.0.0 schema

3.0.2 through 3.1.1 2.0.2 through 2.1.1 5.1.1 or 5.0.2, can 
import schema 6, 7, 8

7.0.0, Pilot 7, Pilot 7.1, 
7.2

3.0.0 or 3.0.1 2.0.0 or 2.0.1 5.0.1, can import 
schema 6, 7

2.6.2 Schema Changes
The following schema changes are performed automatically on Graphic Hub startup.

7.0.0 (Graphic Hub 3.0.0, 3.0.1) to 8.0.0 (Graphic Hub 3.0.2 or higher)
Adds three additional columns to the templates table:

authored_model STRING NULL WITH DEFAULT NULL
master_template_modified DATE NULL WITH DEFAULT NULL
authored_model_modified DATE NULL WITH DEFAULT NULL

8.0.0 (Graphic Hub 3.0.2 to 3.1.1) to 8.3.0 (Graphic Hub 3.2.0 or higher)
Adds an additional column to the templates table:

template_kind SHORT NOT NULL WITH DEFAULT = 0

•
•

•
•

Important: Always use the correct versions as listed above. Do not import Pilot data or 
clean the schema on Graphic Hub 3.0.2 or higher with GH Manager 5.0.1 or 5.0.0, as this 
writes the wrong schema version to the Graphic Hub.
Manager 5.0.0 with Graphic Hub 3.0.2 or higher:

Clean: Sets schema version number to 7.0.0.
Import: Sets schema version number to 6.0.0.

Manager 5.0.1 with Graphic Hub 3.0.2 or higher:
Clean: Sets schema version number to 7.0.0.
Import: Does not overwrite present schema version.
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•
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•
•

•
•
•
•
•

•

•

8.3.0 (Graphic Hub 3.20 or 3.3.0) to 8.4.0 (Graphic Hub 3.4.0 or higher)
Adds an additional column to the templates table:

master_template_xml STRING NULL WITH DEFAULT NULL

Adds additional columns to the template_concepts table:

template_thumbnail_type SHORT NOT NULL WITH DEFAULT = 0
template_thumbnail_text STRING NULL WITH DEFAULT NULL
thumbnail_last_modified DATE NULL FOREIGN KEY WITH DEFAULT NULL

8.7.0 (Graphic Hub 3.6.0 or higher)
Adds an additional template_script_html table with the following columns:

template_id BIGINT NOT NULL PRIMARY KEY
type_script STRING NULL
java_script STRING NULL
created DATE NULL WITH DEFAULT SYSDATETIME
created_by STRING NULL WITH DEFAULT = 'PILOT'
modified DATE NULL WITH DEFAULT SYSDATETIME FOREIGN KEY,
modified_by STRING NULL WITH DEFAULT = 'PILOT' FOREIGN KEY

See Also

Viz Pilot official documentation
Pilot Clients Have No Database Connection

2.6.3 Key Features and Workflow of Graphic Hub 3 as Viz Pilot Back-
end System

Key Features and Workflow of Graphic Hub 3 as Viz Pilot Backend System
Centralized storage for both Viz Engine graphics and Viz Pilot data.
Easy setup of main and replication in terms of redundancy and fail-over.
Easy installation without any extensive database knowledge or upgrade procedures.
Easy import of data from Oracle to Graphic Hub using GH Manager.
Cloud-ready back end based on REST. Note regarding security: GH REST supports SSL. Key 
creation and certificate distribution is not handled by the Graphic Hub, and is the 
responsibility of the customer.
Easy UI-driven import from a running Oracle database on Viz Pilot schema version 6, 7 or 8 
to the Graphic Hub via the Graphic Hub Manager. The import only has to be done one time 
in the transition phase. Note that re-import deletes all previously imported data and all 
changes.
The feel of working with data on a Graphic Hub is exactly the same as using the back end 
database on Oracle.

http://documentation.vizrt.com/viz-pilot.html
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1.

2.
3.

4.
5.

Notable Limitations
Graphic Hub as pilot back end requires Graphic Hub REST and specific versions (see Viz Pilot 
Database Management).
One schema per Graphic Hub instance. Graphic Hub can run a single Pilot schema on same 
instance as graphics data, as opposed to Oracle, which can run multiple.
The schema version is bound to the Graphic Hub version.
No support for master-to-master replication through Graphic Hub Deploy Agent. A manual 
backup solution is possible with Graphic Hub manager (see Data backup solution). Since 
Deploy Agent 2.2.0, it is possible to schedule deploy tasks which automatically backup Pilot 
data to other Graphic Hub instances.
VOS (Viz Object Store) is not supported in Graphic Hub.

Basic Setup
These are the steps to set up Viz Pilot with Graphic Hub as back end with existing Pilot data 
schema version 6, 7 or 8:

Install Graphic Hub (see To Install a Graphic Hub. You may configure a new and empty data 
directory or use an existing one.
Install Graphic Hub REST (see To Install the Graphic Hub REST.
When both installations are complete, the configuration windows for Graphic Hub Terminal
and Graphic Hub REST open automatically in the browser.
In the Graphic Hub Terminal window, click Start Server to start the Graphic Hub server.
Switch to the Graphic Hub REST configuration window. Select the local Graphic Hub (if 
desired) as Graphic Hub server, and click Apply:
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6.

7.

8.

9.

10.

Log on to the Graphic Hub as Admin . The default password is VizDb :

Install the Graphic Hub Manager and start the application from the Start menu when the 
installation has finished.
Log on to the Graphic Hub server running on LOCALHOST as Admin:

Go to Pilot > Import...

Proceed to Import Viz Pilot Data Schema.
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11.
12.
13.

All data from Oracle is now in the Graphic Hub. Click Finish.
Install Viz Pilot Data Server.
In the installer select Graphic Hub as database connection and enter the connection details 
of GH REST.

Note: Requires that the Pilot data schema is at least version 6, 7 or 8, depending on 
the software versions in use.



Note: The specified User ID must be a Graphic Hub user without a password, and 
minimum Write user rights.
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14.

15.

Add Graphic Hub REST as search provider in the Data server settings.

Set disable_built_in_vos_search .

This enables the Director to search the Graphic Hub for media.
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16.

17.
18.
19.
20.

Install Viz Pilot 7 or newer. When the installation finishes, the Pilot configuration opens. 
Select GH as Database and enter the connection details for the Graphic Hub REST.

Configure the other options, such as Preview, as required.
Install Media Sequencer 4 or newer.
Install Preview Server 3 or newer.
Start Director, then go to Tools > Media Sequencer Configuration.
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21.

1.
•

•

•

•
•

•
•
•

In the Database tab, Select Pilot Data server.

Restart Director. The following icon should appear in the bottom right: 
Director has already had a status icon in the bottom right corner that told the user 
about the status of the database connection of the Media Sequencer. It is still there 
and works regardless of the configured back end system. It uses a new icon, but 
works the same way. When green, it means the Sequencer is connected to a Pilot 
database. However, the icon is also green when the connected database is different 
from the one that Director connects to. For example, Director may connect to Graphic 
Hub, while the Sequencer connects to Oracle. In this case, the configuration needs to 
be changed. If the icon is not green, there is a problem with the Media Sequencer's 
database connection. Check the Sequencer logs for further troubleshooting details.
If the Media Sequencer Configuration's Database tab in Director looks the same as 
prior to upgrading to Pilot 7 or newer, it is because it is connected to an older Media 
Sequencer that does not support connecting to a Pilot Data Server. Media Sequencer 4 
or newer is required for Pilot 7 or newer.

Notes
With the Graphic Hub setup, the Media Sequencer, clients, and Pilot Data Server need to be 
able to Graphic Hub REST across the network.
Media Sequencer needs access to the Pilot Data Server.
The Graphic Hub database connection needs to be configured in three locations:

For client applications by using the Pilot Configuration tool, as outlined above.
For Pilot Data Server by using the installer, as outlined above.
For the Media Sequencer by using Director configuration, formerly known as External 
Interfaces.
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When started, Director and Template Wizard now uses Graphic Hub as the back end 
system.

2.6.4 Main and Replication Servers

Pilot Data High Availability Cluster Solution (Main/Replication)
As with previous Graphic Hub versions, each modifying statement in a cluster environment is 
replicated towards the Replication server to guarantee real-time redundancy. This means that all 
items, including the Pilot data on the main instance, are replicated to a second Graphic Hub 
instance in real-time. In case of a fail-over situation, all connected clients on the main instance are 
automatically redirected to the replication server. As soon as the main server resumes operation, 
all items created or modified in the meantime are automatically transferred from the replication 
server to the main server.

To check if main and replication are in sync, connect to both Graphic Hubs as an administrator 
user using the Graphic Hub Manager, then proceed to check for Pilot Server Differences.
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2.6.5 Import Viz Pilot Data Schema
This section details the import of an Oracle Viz Pilot Schema to the Graphic Hub. For information 
on the use of the imported Oracle Viz Pilot Schemas, refer to the Viz Pilot documentation.

http://documentation.vizrt.com/broadcast.html
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1.

To Import a Viz Pilot Schema from Oracle
Click Pilot > Import to open the Import Pilot data window:

IMPORTANT! You must be logged on to the Graphic Hub as an administrator to import Pilot 
data.



IMPORTANT! Always use the correct software versions as listed in Viz Pilot Database 
Management. Do not use GH Manager 5.0.1 or 5.0.0 to import Pilot data or clean the 
schema on Graphic Hub 3.0.2, as this writes the wrong schema version to the Graphic Hub.



Tip: The Import History shows a log of previously imported Viz Pilot schema.
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2.

•

•
•
•
•
•

3.

4.

5.
•
•

Enter the parameters to access a Viz Pilot schema on an Oracle database:

Host: Enter hostname or IP address for the Oracle database. IP address is 
recommended.
Protocol: Select the connection protocol: TCP or UDP.
Port: Enter the port number of the Oracle database.
Service: Enter the database name of the Oracle instance.
User/Password: The user credentials required for the schema to be imported.
Connection string: (Optional) Check the connection string checkbox and enter an 
Oracle database string to connect to the Oracle database:

In the Server to import to drop-down menu, select the Graphic Hub to import to. A dimmed 
drop-down menu means the menu is unavailable because the Manager is logged on to only 
one Graphic Hub.

Click Verify Connection... to verify the connection details and check if an import can be 
done. If the connection details are verified, this connects the Manager to the Oracle 
database.

Select the Import Settings:
Delete Pilot data: Erase all data and sets up a clean Viz Pilot schema.
Delete and import Pilot data: Clean all and import new data.

Example: Data Source=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)

(HOST=10.211.2.11)(PORT=1521))

(CONNECT_DATA=(SERVICE_NAME=VIZRTDB)));User 

Id=pilotdb;Password=pilotdb;



Note: An import does not work if the schema version does not match the Graphic 
Hub version, or the Graphic Hub version is below 3.0.0.
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•

6.

•
•

7.

Only import library data elements: When checked, only Data Elements marked as 
Library Element are imported.

Click Next to view the elements marked for import to or deletion from the Graphic Hub 
database:

 
The Pilot data import progress window displays the number of entries that will be cleaned or 
imported from the database tables, as well as a progress log. Depending on the selected 
Import settings, this stage have an Import or Clean button:

If Delete Pilot data was selected, the button is labeled Clean....
If Delete and import Pilot data was selected, the button is labeled Import....

Click Import or Clean depending on the selected task. The time to completion of this task 
depends on the number of tables and elements to be cleaned or imported. The progress bar 
provides a quick overview of the process, as well as the start and estimated end times.
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8.

9.

When the import is finished, an alert window pops up with information about any errors 
encountered during the import:

Click OK to return to the import Pilot data window. If any errors were reported, click the 
Open log directory... button to access the import log files.
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10.

•

•

•

11.

Click Next to open the Delete old Pilot elements window:

The Summary pane provides an overview of the total number of elements older than 1 
year, 1 month and 1 week, respectively. It also lists the number of library elements in 
each age category.
The Cleanup of old Pilot data elements pane can be used to run a cleanup task on the 
Graphic Hub to delete elements older than a specified number of weeks, months, or 
years. Library elements are not deleted unless the delete library elements checkbox is 
checked. Check the integrity cleanup checkbox to perform an integrity cleanup 
operation during the deletion.

Use the Schedule Pilot data cleanup and Cleanup Pilot changelog panes to create 
scheduled cleanup tasks.

Click Finish to return to the Manager. A popup window reminds the user to enable the Pilot 
cleanup tasks.

Tip: The number of elements that can be deleted is displayed in red text. The 
number is updated depending on the older than setting.
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1.
2.
3.

 
These may be configured at any time in the Advanced Settings of the Graphic Hub Terminal.

2.6.6 Resolve Viz Pilot Data Differences Between Graphic Hubs
The Pilot differences window in the Graphic Hub Manager is used to view and resolve differences in 
Viz Pilot data between two or more Graphic Hub servers. This can be the main and replication 
servers in a cluster environment, or other Graphic Hub servers that contain Pilot data, such as a 
backup server.

To Check for Pilot Data Differences
In Graphic Hub Manager, log on to the servers that you want to compare.
Click Pilot > Differences… to open the Pilot data differences window.
Select the servers to compare in the Overview section, then click Check for differences. This 
compares the Viz Pilot content on the selected servers, and you can now perform a manual 
backup or resolve potential cluster differences.

IMPORTANT: Graphic Hub Versions below 3.0.3: Using the Thumbnail generator with Pilot 
Datasets larger than 5000 elements generates many requests for retrieving all data 
elements. This causes performance instability in form of timeouts and blocking Pilot calls. 

Be sure to limit the Datasets to a maximum of 5000  elements or upgrade Graphic Hub 

Version to at least 3.0.3 to grant performance stability and non-blocking calls.
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•

•

•

•

•

•

Understanding the Viz Pilot Data Differences Window

Tables left/right (1): The two panes Tables left and Tables right show a listing of all 
database tables that are compared between the two servers.
Overview (2): The Overview pane provides a quick overview of the differences between two 
servers:

Drop-down menu: If the Manager is logged on to more than two servers, all servers 
are selectable from the drop-down menus to the left and right of the Check for 
differences button.
Check for differences: Click to compare the selected servers. This initiates a 
checksum-based comparison of the table data between the servers. In the left and 
right panes, identical tables are marked with a green check mark icon. Tables that 
differ are marked with an orange warning icon. The Overview is populated with a 
summary of the differences. Any changes made after the last click are indicated by a 
counter, and a timer indicates the time passed since the latest change.
Lock/Unlock database: Click to lock or unlock the databases. When the database is 
locked, read operations are permitted, while write operations are not. Locking the 
databases starts a timer that shows how long the database has been locked, and the 
button changes to Unlock database.

Lock & deploy << | >>: Use lock and deploy to lock the databases for changes and 
deploy any elements required to bring the two servers into identical states. The arrows 
indicate if the deployment is from the right server to the left server (<<), or from left 
to right (>>). When clicked, a confirmation dialog appears, where you must confirm 
the deployment direction. A progress bar with an estimated time for the deployment is 
displayed during the process.

Table Details (3): Double click a table in the Left or Right table panes to open a detailed view 
of the selected table in the Details pane. Multiple tables can be opened, and are added as 
separate tabs within the pane. Right clicking a table in either pane opens a context menu 

Caution: Lock & deploy overwrites content on the destination server and 
cannot be undone. Make sure to double check the direction of the deployment 
with the selected servers.
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from which data can be loaded. Select Show differences to load only the entries that differ in 
the Details pane, or Show all to load all entries in the selected table. Select Lock & deploy all
to lock the database on both servers, and deploy all tables from the selected server.

Scheduled Tasks
All Viz Pilot cleanup tasks can be configured and activated via Graphic Hub Terminal. Open the 
Graphic Hub Terminal, then select Options > Scheduled tasks. Scroll down the task list to find the 
Viz Pilot related tasks.

 
To enable the tasks, click Options -> Advanced settings in the Terminal and go to the CLEANUP 
SETTINGS pane. Check the checkboxes to enable each task:

 
Cleanup of Viz Pilot Data Elements
Click on the task to open the configuration properties for the task:

Tip: In addition to the tasks described here, it is highly recommended to periodically 
perform a normal shutdown when using Graphic Hub as Viz Pilot data back end. The 
recommended interval is once monthly.
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•
•
•
•

•

•
•
•

1.

 
The following properties can be specified:

Start time: Defines the first execution of the task.
Interval: Defines the interval on which the task is executed.
Older than: Cleans up all elements older than the specified time span.
Cleanup of library elements: Includes library elements during deletion when checked.
Integrity cleanup: Deletes all rows that violates Viz Pilot data integrity to provide data 
consistency when checked..  
Cleanup of Pilot data elements: Can also be configured using the Graphic Hub Manager. 
However, it needs to be activated using the Graphic Hub Terminal. The Wizard appears after 
a successful schema import. Refer to Key Features and Workflow of Graphic Hub 3 as Viz 
Pilot Back-end System for further details.

Cleanup of Pilot Changelog
Click on the task to open the configuration properties for the task:

 
The following properties can be specified:

Start time: Defines the first execution of the task.
Interval: Defines the interval on which the task is executed.
Older than: Cleans up all elements older than the specified time span.

Graphic Hub Manager Integrity Cleanup
The Graphic Hub Manager provides a tool to perform an integrity check of Viz Pilot data and clean 
data integrity violations:

Click Server > Check to open the Check Server window.
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2.

3.

1.
2.

In the Check section, check the Check Pilot tables checkbox:

 
This includes a check for data consistency in the Viz Pilot tables during server check. If any 
violations are found, these are listed in the Pilot Data tab:

If any violations are found, click the Fix all button in the Fix panel to delete those violations:

 
The integrity cleanup can also be included during the execution of the data element deletion 
task (see Viz Pilot Tasks on how to include it) If it is included, all integrity violations are 
cleared during task execution.

Multiple Graphic Hubs and Viz Pilot Data
The Pilot differences dialog in the Graphic Hub Manager can be used to perform a manual backup 
of one server to another. However, merging the database content is not possible. The data is 
always overwritten on the destination server, to ensure that the content is identical to the source.

Log on to both the active and backup Graphic Hub servers.
Open the Pilot differences dialog and select these servers in the overview section.
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Check for differences and deploy in the correct direction for backing up the data. Only the 
Viz Pilot data that has been changed after the latest backup is deployed.

Since GH Manager 5.2.0 and Deploy Agent 2.2.0, it is possible to automate Viz Pilot data backups 
via time-steered deploy tasks. Create a Viz Pilot deploy task via one of the following workflows in 
GH Manager:

Either navigate to Pilot > Create Pilot deploy task... to configure a deploy task which only
deploys Viz Pilot data. 
This option can also be used in addition to an existing real time file deploy task, so that 
there are regular updates of the Viz Pilot data plus real time updates of the file data on the 
destination server.
Or create a file-based deploy task as usual and check the Sync Pilot data option in the 
task's Schedule configuration window. Use this option if it is preferred to have a copy of the 
data where the Viz Pilot and file data are widely consistent at a certain point in time (for 
example, for backup purposes).

Viz Pilot Data Backup Solution
Using Graphic Hub Manager in Graphic Hub 3, Viz Pilot data can be backed up manually to a 
Graphic Hub server in 5/4 Free or Multiuser mode. Using Graphic Hub Manager and Graphic Hub 
Deploy Agent in Graphic Hub 3.2, Viz Pilot data can also be backed up automatically via Viz Pilot 
deploy tasks as outlined in the previous section. On the backup server, the Graphic Hub Terminal
can then be used as a tool for creating full or incremental backups of the underlying data directory 
on Graphic Hub, using a scheduled shutdown task with backup after shutdown and server restart.

Note: In this case, there must not be any parallel real time file deploy task running 
between the two servers, as then conflicts occur which cause the tasks to fail.



•

•

•

•

•

Note: The following restrictions apply:
As with Pilot differences, the used databases only allow read-operations while Viz 
Pilot data is actively being deployed. No Viz Pilot data can be created or changed in 
the meantime.
Also, while actively deploying Viz Pilot data, the task cannot be paused, cancelled or 
restarted.
Be sure to check if the correct source and destination Graphic Hubs are selected for 
deploy. All Viz Pilot data on the destination Graphic Hub is overwritten.
The database schema versions of source and destination Graphic Hubs need to 
match.
To periodically backup Viz Pilot data, configure a recurring task which deploys 
changes at desired intervals. It is currently not possible to deploy Viz Pilot data via 
real-time tasks.
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See Also

Key Features and Workflow of Graphic Hub 3 as Viz Pilot Backend System
Graphic Hub Manager
Graphic Hub Terminal
Graphic Hub Deploy Agent

2.7 Image Library Extension
This chapter describes the Graphic Hub Image Library Extension functionality.

In this section, you find the following information:

Introduction
Important Pre-installation Information
Key Features of the Image Library Extension
Notable Limitations
Basic Setup
User Interface
Administrative Tasks
Troubleshooting
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2.7.1 Introduction
The Image Library Extension offers the following functionality related to still images with browser 
based UIs:

Ingesting of images.
Metadata editing and assignment on/to images.
Searching for images including the assigned metadata.
Import of existing Viz Object Store image images and metadata.

It requires the following Graphic Hub components: 

Graphic Hub ImEx Agent: Provides HTTP APIs and serves the browser based UI components. 
Imports images in the native Viz Engine format into Graphic Hub through Graphic Hub REST.
Graphic Hub REST: To import images in the Viz Engine format into a destination directory on 
the Graphic Hub.
Graphic Hub: For storage of metadata and images. The metadata and original image data is 
stored isolated form the existing file content. An image in the native Viz Engine format is 
created in a destination directory, as it is done with the Graphic Hub ImEx Agent distribution 
plans and watch folder workflow. The native Viz Engine images are read by Viz Engine 
during playout.

2.7.2 Important Pre-installation Information
Before setting up the Graphic Hub Image Library, observe the following:

The server must meet the minimum Graphic Hub hardware requirements.
It requires Graphic Hub REST and Graphic Hub ImEx Agent. The server running those must 
meet the Graphic Hub REST and Graphic Hub ImEx Agent Requirements.
The feature requires a license and is only available in modes multiuser, Main and 
Replication. See Licensing Graphic Hub.
Clients like Pilot Edge, Pilot Data Server and Media Sequencer need to be able to access 
Graphic Hub ImEx Agent across the network.
The Graphic Hub ImEx Agent open search endpoint needs to be configured in the Pilot Data 
Server Search Provider settings.

The Image Library functionality is bound to specific Graphic Hub component versions:

Functionality and Features Required Versions

Image Library - Initial release Graphic Hub 3.8.0 
Graphic Hub ImEx Agent 1.8.0 
Graphic Hub REST 2.8.0

All data is stored in the configured data directory. It is included in the Graphic Hub Terminal
internal backup, and when the data directory is copied.
The internal file formats are automatically upgraded when the Graphic Hub is started on a 
data directory.
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In general, old clients can work on newer versions, but newer clients cannot work on older 
versions.

2.7.3 Key Features of the Image Library Extension
Centralized storage for both Viz Engine graphics and playout relevant images. Does not 
require a network share or mapped drive.
Easy setup of main and replication in terms of redundancy and fail-over.
Easy installation without any extensive database knowledge or upgrade procedures.
Easy import of data from Viz Object Store (metadata from Oracle, images from the network 
share).
Easy UI-driven import from a running Oracle database via a browser based UI hosted by 
Graphic Hub ImEx Agent. The import only has to be done one time in the transition phase. 
Note that re-import deletes all previously imported data and all changes.
Provide Core functionality with new standalone Web-UIs.

Ingest UI (basic UI to ingest single images).
Metadata editing/assignment UI (basic UI to edit/assign metadata on/to images).
Search UI and OpenSearch endpoints to cover basic search needs (image, person).

Shared browser based UI components served by Graphic Hub ImEx Agent.
Compatibility with existing Products (if possible).
Images support background loading in Viz Engine, as they are imported in the native Viz 
Engine image format. 
Content is failsafe redundant on the Graphic Hub cluster.
Content is deployable with Graphic Hub Deploy Agent/Graphic Hub Manager.

2.7.4 Notable Limitations
Image Library content must be administered through the provided browser based UIs.

Searching in the image library metadata is only possible through the provided search 
UI or the search provider (opensearch) exposed by Graphic Hub ImEx Agent.
Deletion of images and metadata must be done through the Image Library UIs. When 
an image is deleted on the Graphic Hub with Viz Artist or Graphic Hub Manager is is 
staged again from the Image Library system.

Focus is on search/ingest and Pilot Edge workflows.
Image Library functionality requires specific Graphic Hub component versions (see above).
The provided API versions and UI components are bound to the Graphic Hub component 
versions.
Currently no support for synchronization on the metadata through Graphic Hub Deploy 
Agent in this initial version.

The imported image content stored on the Graphic Hub file part and are used by Viz 
Engine for playout are deployable and can be synchronized.

Important: Always use the versions as listed above. 
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A manual backup solution is possible.
Metadata models are static in the initial release (the model can not be changed).

Static metadata also means searchable fields cannot be changed.
Ingesting only works with drag and drop and likely not with mobile devices
Ingesting has limited support for file types and might not work with some. Missing a list for 
supported file types.
Director search: Person search in Director has issues with displaying details and displays 
errors.
Image library Synchronization / Indices: No visual feedback about the current status when 
executing a differences / sync server / check indices/ fix indices.

2.7.5 Basic Setup
These are the steps to set up the Graphic Hub Image Library:

Install Graphic Hub (see To Install a Graphic Hub). You may configure a new and empty data 
directory or use an existing one.
Install Graphic Hub REST (see To Install the Graphic Hub REST).
When both installations are complete, the configuration windows for Graphic Hub Terminal
and Graphic Hub REST open automatically in the browser.
Create a new configuration for mode Multiuser or Main/Replication and enable the allocation 
of the Image Library Extension license (see Graphic Hub Mode Configuration, Licensing 
Graphic Hub).

In the Graphic Hub Terminal window, click Start Server to start the Graphic Hub server.
Switch to the Graphic Hub REST configuration window. Select the local Graphic Hub (if 
desired) as Graphic Hub server, and click Apply:
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Log on to the Graphic Hub as Admin . The default password is VizDb :

Install Graphic Hub ImEx Agent (see To Install the Graphic Hub ImEx Agent).
After the Graphic Hub ImEx Agent is configured, create a new destination directory (see 
Graphic Hub ImEx Agent Manage Imports).

Configure the used Graphic Hub REST by selecting the Endpoint in the dropdown 
menu or editing the input

Use the user Admin . The default password is VizDb
Select a destination directory by clicking on the "..." icon

An Image Library distribution plan is created to process imports for the Viz Engine 
native image format.

Configure the Image Library by navigating to "Import → Image Library"



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  157

1.
2.

3.
4.

a.
b.

•
•
•
•
•
•

•

•

•

•
•

•

•

Select the previously created destination directory and save the changes with "Apply"
The Image Library Web-UIs can be accessed at http://127.0.0.1:19390/imagelibrary/
index.html .
Install Viz Pilot Data Server.
Add the Graphic Hub Image Library as search provider in the Data server settings. This 
enables search of media in Pilot Edge.

Service Document URL: http://HOST:19390/restvos/service
Currently no username and password is required.

2.7.6 User Interface

General Concepts
One Web application to serve all Image Library topics.

Ingesting
Editing (images + metadata)
Importing (from external sources)
Searching
Administrative tasks

Image states: Images can have multiple states depending on the current progress in 
processing.

Image is stored on Graphic Hub Image Library storage, meaning only available for 
Image Library clients.
Image is processing, meaning it is currently converted to the native Viz Engine image 
format and imported to a destination directory.
Image is available, meaning Viz Engine can load the native format from Graphic Hub.

Metadata:
The metadata structure is represented as a model based on the Vizrt Data Format 
(VDF).

This is fixed in the initial version and not user editable.

http://127.0.0.1:19390/imagelibrary/index.html
http://HOST:19390/restvos/service
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The metadata content is represented as a payload which is validated against the 
model. 

This can be edited by the user and assigned to images.
Reactive:

When tasks are executed in the background or by other clients the views are instantly 
updated.

Uploading an image with another client, makes the image immediately available 
in the main view, if image status changes, those changes are automatically 
reflected in the UI.

Snackbars:
Snackbars display updates from the back-end regarding current tasks or errors.
They are visible until the user closes them.

Tasks:
Tasks are asynchronously running background operations.
Currently there exist three tasks: import, delete and analyze.
These tasks can't run simultaneously.
They are shown by a progress bar.

For delete task and import task the progress bar is at the main menu at the top 
and shows the current item that is being imported or deleted.
For the analyze task the progress bar is displayed below the API configuration 
fields on the import view and shows which field is being analyzed.

View: How to Browse Images and View Metadata
Viewing current Image Library content in the main view where all other views are visible. Most of 
the necessary tasks should be done here.

All available files are displayed in the main view.
You can execute all actions (searching, ingesting, editing).
Able to filter and order files on certain properties.

Refine your filters and ordering when browsing or serching
The filters are grouped and can be combined
Selected filters, ordering and active search are indicated with blue buttons
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Has pagination and displays the total number of files and currently viewed page.
Amount of displayed files is defined by the screen space, and therefore dynamic.
Images can be selected, and have an overlay to display their status.
Images details can viewed by clicking on them:

Display the metadata.
Display the image properties
Display the image with an higher resolution.

Ingest: How to Add Images
Ingesting is the process in which a user uploads one or more an images to the Graphic Hub Image 
Library and assigns metadata. 
This can be done by using the Upload/Import button on the main menu.

At the "Ingest" page the user can upload one or multiple images by dragging and dropping 
an image onto the upload pane

The ingest will automatically try to fill metadata by the file name, please revise!
Required metadata fields must be filled by the user, this can be done by clicking on the 
specific image

Confirm the upload of all selected image by pressing "Import"
The image is uploaded to Graphic Hub and is immediately available for usage in the Image 
Library and Asset search in Pilot Edge



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  160

•

•

Graphic Hub ImEx Agent automatically schedules an import and conversion to the Viz Engine 
native image format through Graphic Hub REST. This is indicated with the "processing" state.
When the image is converted and ready for playout by Viz Engine it is in the "available" state.

Editing: How to Edit Metadata
Editing metadata can be done in the main and search view by selecting an image.

Information: Required fields need to be filled, a red box indicates required fields when 
saving.



Information: You can edit Persons much better by selecting a field in the person editor and 
pressing ALT + ENTER. Now you can edit more fields and also add an organization.
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Deleting: How to Delete an Image
This can be done in the main and search view by selecting one or multiple images and then 
clicking Delete.

Searching: How to Search for Images
The search bar is used to search for images.

Simple search based on all required metadata fields
Title
Description
Person:

TV Name
First Name
Last Name

Tags
The search is case insensitive and narrows by combining words. i.e.: "Lionel Messi" will find 
only images with the searchable fields "Lionel" and "Messi"
Total found results will be displayed under the page view
You can also order and Filter the search result
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Searching: How to Search for Images with Pilot Edge
The open search endpoint needs to be added as search provider in the Pilot Data Server 
configuration. Please consult the Pilot Manual for instructions.

Importing: How to Import an Existing Viz Object Store Database
Importing is a one stop process which allows to connect to an Viz Object Store Oracle database 
and import existing images (from the network share) and metadata once. 

It requires the Oracle access settings (hostname, username, password, database) and access 
to the network share used.
Steps:

Provide configuration and credentials for:

Information: An active search is indicated with blue search button. Clear the search result 
by deleting the search or hitting the "x"



Information: The default service document to add for the Image Libary is: http://
HOSTNAME_IMEX:19390/restvos/service



Information: Importing is only available in "Administrative View". The process should only 
be executed once for an initial import! Map your VOS image share network drive properly 
before starting this task: How to Map a Network Share into a Drive and Access it from 
Windows Services for Import!
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Hostname: Host where Oracle is running.
Username and Password: Oracle username and password.
Database service: The Oracle DB service instance (typically pilot or vizrtdb).

Server port: The Oracle service port (typically 1521 ).

Click Check connection. It should show Database Connection Successful
Edit the analyze options:

Edit Image Shares: Shows all image locations (network shares) found in the 
Oracle database.

From these paths the images are read and imported.
You are able to edit every individual path by editing the "Replace path 
with" part
You can replace all paths by adding applying a part of the path and its 
replacement in the first fields

Full search: use all database entries, even if the image is not available on the 
network share

By default this setting is disabled, meaning only content is analyzed 
where an image is available.
Enabling this will only analyze and display the image entries, they will be 
ignored during the import because no image is available.

Click Analyze Database: Starts to analyze the database content and the available 
images.

This can be done several times when the configuration is changed (for example, 
when editing the Image Shares mapping). 
The Oracle database content and available images are analyzed, which can take 
some time.
If there are no results:

Please check that the network share is accessible for a service (Map it 
correctly)!
Refine your Image Share mapping by editing the image shares

Select a subset or all images to import by clicking Select (top left) > Select All.
Start the import by clicking Action (top left) > Import.
The import process starts and runs asynchronously on the Graphic Hub ImEx Agent.
The import process might take some time and the UI is locked and allows to view the 
progress and cancel the import.

Note that staging into the processing of the Viz Engine native format is done 
asynchronously and may lag behind.
It is recommended to have only one client active to avoid constant reloading of 
clients due to the massive amount of updates sent during the import.
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How to Map a Network Share into a Drive and Access it from Windows Services for 
Import
This section outlines how to map a network share into a mapped drive to a Windows service 
permanently for the task of importing the images from a Viz Object Store network share. For 
network shares to be accessible by the Graphic Hub ImEx Agent service, the need to be mapped to 
a drive as the NT AUTHORITY\SYSTEM account.

To do this:

Download the Sysinternals Suite from Microsoft and unzip it to a directory (for example, C:
\SysInternals).
Launch a command prompt as Administrator.

Execute: cd C:\SysInternals

Execute: psexec -i -s cmd.exe . This launches a new command prompt window using 

the system account.

In the newly opened command prompt execute: net use X: \\ServerOrIP \ folder  /

u: username  /persistent:yes . Provide the credentials of the provided username that 

can access the shared folder.

Remove the mapping after the Viz Object Store import is finished:

Launch a command prompt as Administrator.

Execute: C:\SysInternals .

Execute: psexec -i -s cmd.exe . This launches a new command prompt window using 

the system account.

In the newly opened command prompt, execute: net use X: /delete

2.7.7 Administrative Tasks

Duplicates: View and find duplicates.
Import Progress/Status:

Currently uploading and processing images of the Graphic Hub ImEx Agent 
distribution plan.
Import status: Displays the status of the last import and analyze task.

Database Lock: Allows to exclusively lock the database for writes. Shows a red lock on the 
top right to all users when activated.
Distribution Plan: View the status of currently importing items to the Viz Engine native file 
format 

Information: Adminstrative tasks are only available in the "Adminstrative view", you are 
able to access this by adding ?admin=true to the URL. For example, http://
localhost:19390/imagelibrary/index.html#/?admin=true.



http://technet.microsoft.com/en-us/sysinternals/bb842062.aspx
http://localhost:19390/imagelibrary/index.html#/?admin=true
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Server: Displays multiple options to check 
Analyzes and compares content between two Graphic Hubs (Main/Replication). Allows 
to synchronize two Graphic Hubs.
Shows the differences of "Models", "Images" & "Payloads" 

The Differences can be "Missing" (on either Graphic Hub) or "Changed".
One can "Lock" + "Unlock" the database.
One can "Sync" it with another Graphic Hub, which can be used to bring Main and 
Replication in sync.
One can "Drop" the whole database on the right server in the view. Needed if sync 
errors happen. Meaning one drops the database first and then synchronizes it again.

2.7.8 Troubleshooting

Image Library Page has connection errors / Fresh installation / ImEx hangs
Image Library might not have been configured properly. Mostly those errors are because:

Missing / Misconfigured License.
ImEx Image Library is not configured to a destination directory.
ImEx destintion directory is not properly configured.
Graphic Hub REST is not properly configured.

Images are not found in search
Check if the image you are searching has the searched metadata.
The search index might be broken, you can fix that by following these steps:

Use the Image Library Administrative UI > Server page.
Database Indices > Select your server.
Check Indices: Will lock the Image Library for any write operation and run a task in the 
background.

When the task of checking the indices is done you will see that Last Updated changed.
If "Search Differences" is more than 0 and "Search Index Working" is not 0 you should 
fix the indices.
If "Search Index Working" is also larger than 0 you should wait some time and check 
indices again.

If you have differences and use fix differences the server will try to fix the differences.
After a while you can check the differences again.
Don't forget to unlock the server again.

Image library cannot import / ingest images

Check if you have the license properly configured . The Icon should not be red.
Main and Replication need a licence, please check both servers.

Check if there is enough disk space available on Graphic Hub.
Ingesting does not allow all file types with every format. Make sure you are importing a 
common file type.
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Make sure the Image library is not in "Locked" mode . The Lock should not be red.

In my cluster there are missing images or metadata is incomplete
Main and Replication might have differences due to a network issues.
Main and Replication might have differences due one server has not been available

Use built in tools to solve the differences:

Make Sure both servers are running and are in their native mode, with no open transactions.
Use the Image Library Administrative UI > Server page.
Server Synchronization > Select your server replication graphic hub (your ImEx should always 
be connected to the main server).
Show Differences: Will lock the Image Library for any write operation and run a task in the 
background.

After the task is done, a list of differences between both servers appears.
Hit Sync Servers to synchronize both servers again.
Don't forget to unlock the servers again.

Image library is not deployed via deploy agent, I need a backup solution!
There are multiple ways of making a backup:

Shutdown:
Shutdown you Servers properly at a service interval and let Graphic Hub Terminal 
handle the backup.
Shutdown your Servers properly and backup the data directory.

Manual Server Synchronization
You can synchronize your servers manually to a Multiuser server with a valid Image 
Library License.
Server Synchronization > Enter your destination server instead of choosing one: 
VizDbServer@Hostname:19396.
Show Differences: Will lock the Image Library for any write operation and run a task in 
the background.

After the task is done a list of differences between both servers appears.
Hit Sync Servers to synchronize both servers again.
Don't forget to unlock the servers again.

Images are not available for Playout / Cannot find images in the Graphic Hub
The images are only available in the Graphic Hub when they have been converted to the native Viz 
Engine format. They will not contain any "usable" name, because they are only intended for 
automated playout.

You should not be using those images for Designing Scenes, etc...

If your playout cannot load these images make sure to have a look in the Distribution plan:

You can view the distribution plan for the Image library in the ImEx configure web interface.
You can view the distribution plan for the Image library in the Image Library Administrative 
view:
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If there are Pending imports, you need to either wait for the ImEx to import the 
images.
Check the errors by clicking on the status bar.
Check your Graphic Hub for corrupted files.
If the Import does not continue, Restarting Graphic Hub ImEx Agent & Graphic Hub 
REST triggers a complete fresh import.

Distribution Plan does not continue upload / shows errors
The distribution plan is not continuing and stops without recovery might happen for various 
reasons:

Check your Graphic Hub for corrupted files.
Restart Graphic Hub REST Service.
Restart Graphic Hub ImEx Agent Service.

2.8 Graphic Hub Archives
This section contains details about the archive functionality of the Graphic Hub Manager.

In the Archives Panel, archives can be imported and exported with drag and drop. It also offers 
other functionality:

An archive search function.
View the contents of an archive.
Import single files from an archive.
View archive details.

In the Tool bar click on View > Archives to open the Archive panel.
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The Archives panel consists of:

Archives View (1): Shows archives in folders (User selected (see Archives View).
Search View (2): Search in all or selected archives.
Archive Contents View (3): Shows the content of the selected archive.
Archive Details View (4): Shows the details of a selected archive.

This section contains the following topics:

Archives View
Search View
Contents View
Details View
Archive Folders
Import Archives
Export Archives
Import Viz 2.x Data and Archives

2.8.1 Archives View
The Archives view shows added folders, both watched and not watched (see Archive Folders), and 
all archives inside those folders. Three different views are available for each archive.

IMPORTANT: Graphic Hub Manager versions earlier than 5.1.0 may produce corrupted 
archives. This happens if the Archive was created by Viz Artist and content was added 
afterwards using Graphic Hub Manager. Importing such an Archive displays an error: File 
seems to be corrupted: invalid checksum (-32642) archive error. Be sure to update your 
Graphic Hub Manager to at least version 5.1.0 as there is no way to restore this kind of 
corrupted archive.
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3.
4.

5.

Archive folder location (1): Shows the archive folders where the archives are located. The 
folder can be watched or not watched.
The Archive (2): Click on the archive to show the archive details, in the Details View.
Archive View Options: Expand the tree node to access the following:

Content View: Shows all files contained within an archive (without any additional folder 
information).
Entry Point View: Shows the archive content structured in a way that reflects how it 
was exported.
Folder View: Shows the archive content with its folder structure from the Graphic Hub.

To Add a New Empty Archive
Right-click anywhere in the Archives panel.
In the context menu select New Archive 

Select a folder where the new archive is to be created.
Select an archive template for automatic naming of the archive, or manually enter a name for 
the new archive.
Click OK. The new, empty, archive shows in the archives panel in the selected folder. If a 
new folder location was selected, it shows as a not watched folder.

Tip: The archive icon color provides key information about the archive. 
A red icon indicates a corrupted archive. 
An orange icon indicates that the archive is Read only on the Windows file 
system.
(A lock overlay icon  indicates that the archive is Password protected).
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To Add an Archive
Highlight a folder where the archive is to be added.
Right-click any where in the archive panel.
In the context menu select Add Archive.
Click the archive to import.
Click Open. The archive shows in the archives panel in the selected folder. If the archive was 
selected from a new folder location, the new folder shows as a not watched folder.

To Set a Folder as Watched or Not Watched
Right-click the folder.
In the context menu, select Add or Remove <folder location>, respectively.
The folder shows   when it is set as a watched folder, and  when it is not watched.

To Add a Watched Folder
Right-click anywhere in the Archives panel.
In the context menu select Add watched folder.
Select an archive folder to be watched.
Click Select Folder. The folder is added to the Archives panel as a watched folder (see 
Archive Folders).

To Remove a Watched Folder
Select the watched folder to be removed.
Right-click the folder.
Select Remove <folder location> from watched folders.
Right-click the folder again.
Select Remove <folder location> and all its archives from view. See Archive Folders.

To Apply a Password Protection on an Archive
Navigate to View > Archives to display Archives Panel.
Right-click the Archive.
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Apply password.

Password protection is indicated by the archive lock overlay icon:

To Remove Content from an Archive

To Delete Selected Folder-link
Navigate to Archives Panel.
Select file in folder in archive.
Right-click.
Select Delete.

Tip: If password protection is applied to an archive, the archive must be unlocked by 
entering the correct password to import or modify it. To remove password-protection, just 
apply an empty password.



Tip: Deletion of single items, folders or projects from an archive is possible.
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Only the selected folder-link of the file is deleted (if the deleted file is under a folder). If this is the 
only link name of the file, or if the file does not have a folder the file is deleted with ALL link 
names from the archive.

To Delete Everywhere
Navigate to Archives panel.
Select file in folder in archive.
Right-click.
Select Delete everywhere else.

2.8.2 Search View
The Search Tab provides options to search in the archives. The following file types can be 
searched:

Scenes
Geometries
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4.

Materials
Advanced materials
Images
Fonts
Audio files

When the search tab is selected, by default all folders and archives are selected as search areas. 
Deselect folders and archives as required to narrow a search.

To Search for a File in an Archive Folder
Click on the Search tab.
In the Freetext box, type text to search for.
Search results are shown in the Search result panel.

Double-click a file in the Search results list to see the file properties.

2.8.3 Contents View
The Archive Contents Panel shows the content of the selected archive in three views. Select which 
view in the Archives View.

Tip: Or right-click the selected file and select Properties.
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Files listed in the archive Content View can be imported to a Graphic Hub by drag and drop (see 
Import External Images).

2.8.4 Details View
The Details view displays all available data for the archive selected in the Archives View.

Caution: If a file or files are deleted in the archives view, the file or files are deleted from 
the archive completely. This includes the file itself as well as all its folder links.
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2.8.5 Archive Folders
The folders listed in the Archives view can be Watched or Not Watched folders:

Watched Folders: All changes to watched folders are monitored and reflected in the Archive 
view.

Not Watched Folders: Folders added to the archives, but not monitored.

2.8.6 Import Archives
Viz archive files (*.via), containing folders and/or files, can be imported to the Graphic Hub 
through the Archives Panel.

Note: Once added, folders can be set to not watched if required.
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To Import All or Selected Folders and Files from an Archive
Archived files and or folders can be imported from the Archive panel or the Search result panel.

Select Archive or Search view.
Select a folder or a file:

In the Archive view: Select an Archive and select the required folder(s) or file(s) from 
the view panel. Multiple selections are possible.
In the Search result view: Select a folder or file, or multi-select.

Drag a selected Archive folder or file to a Graphic Hub folder in the Servers and Folders.

Note: Import of archives only works properly for content located in the /data root project 
and assumes that any data is stored inside the specified data-root location. Archives do not 
store the /data root part with the objects path, otherwise Viz Engine (or any other client, 
using the data-root setting) would not be able to correctly import it again.



Tip: Any file or folder that can be seen in the Archive panel or Search result panel can be 
imported with drag and drop.



Note: The Archive or file can be dragged to the Explorer panel as well. Make sure the 
correct folder is selected first in the Servers and Folders.
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5.

Complete the Import from Archive window as required.

Click Continue.
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Click Import. 

Context Menu Import
Use Import from the context menu to import an archive directly to the selected server.

To Import an Archive
In the Servers and Folders panel, right-click the target server.
Select Import from archive.

Tip: If a password protected archive is imported, the password must first be entered.
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Click Browse to select a source folder.

Select the archive.
To check for objects that exist with the same name (but a different UUID), check Determine 
existing objects by same name instead of UUID.
To overwrite objects that exist with the same UUID, check Overwrite existing objects.
Click Import.

2.8.7 Export Archives
Folders and/or files can be exported out of the Graphic Hub as Viz archive files (*.via) through the 
Archives Panel.

To Export a Folder or a Single File

Select the folder or file to be exported as an archive:
In the Servers and folders panel select a folder, or
In the Explorer panel select a file or folder

Note: Export of archives only works properly for content located in the /data root project 
and assumes that any data is stored inside the specified data-root location. It does not 
store the /data root part with the objects path, otherwise Viz Engine (or any other client, 
using the data-root setting) would not be able to correctly import it again.



Note: Folders and files can be multi selected in the Explorer panel.
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2. Drag the selected folder or file to an archive in the Archives panel.
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Fill-in the Export to Archive panel, as required.

Click Continue.

Note: Export all linknames to the archive: All link names are exported (default). 
When unchecked, only link names from the folder/project from where the file was 
dragged, are exported to the archive. Link names in sub-folders are also added.
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Click Export. 

Context Menu Export

To Export a Folder or a Single File
Right-click the folder, project, or file to be exported.
Select Export to archive.
Click Browse to select a destination folder.

Enter a name for the archive.
Click Apply password to generate a password-protected archive.



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  183

6. Click Export.

2.8.8 Import Viz 2.x Data and Archives
To use files from other data directories, they must be imported into the Graphic Hub. In Graphic 
Hub Manager either data directories or archives created with Viz Artist 2.x. can be imported.

Expert Settings
In the Import Window, there are a number of optional Expert Settings that can be used for import 
operations.

Note: If password protection is enabled, the archive must be unlocked by entering 
the correct password to import or modify it. The user is automatically asked to enter 
the password during at import or modification. Password protection can also be 
added on an existing archive by context-menu View > Archives > Apply password. To 
remove password-protection, leave an empty password.



Note: Creating an archive via Graphic Hub Manager on a network drive needs a 
mapped network drive, do not use UNC Paths (for example, //SERVER/DRIVE/
sharedfolder/)



Tip: When single files are imported from a data directory or an archive, referenced files are 
also imported.
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Expert Settings Properties

Expert settings: Tick the tick box to enable Expert Settings.
No. of instances: Number of import threads allows to run asynchronously.
Show instances: Shows all currently configured import threads when check.

IMPORTANT! Expert Settings must only be used by experienced and qualified personnel.
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Overwrite existing files: Select this option before starting the import operation if you want 
imported files to overwrite Viz 2.x files on the Graphic Hub.
Restart after: Enter a value representing the number of objects after which the import 
executable restarts.
Timeout: Restarts the import if the import executable takes longer than the value specified 
here.

Import Viz 2.x Data Directories

To Import a Viz 2.x Data Directory
Click Server > Import > Viz 2.x data.
Select a Viz 2.x data folder to import from, and click Open.
In the Import Window select the files to be imported, in the left panel.

Click Import.

Click Modify and select a directory.
Select the Convert all objects to lower case check box. This gives full Viz 3.x compatibility 
with Viz Artist and Viz Trio.
Click OK.

Import Viz 2.x Archives
Viz Artist 2.x archive files (*.eva) can be imported into a Viz 3.x system with the Graphic Hub 
Manager.

Note: If the directory is big, the import process can take some time. The import 
window show the import status.
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To Import a Viz 2.x Archive or Selected Items
Click:

For complete archives: Server > Import > Viz 2.x archive(s).
For selected items from one or more archives: Server > Import > Manually selected Viz 
2.x archive(s).

Open the selected archive or files:
For complete archives: Select a folder housing archives to import, and click Open.

For selected items from one or more archives: Select an .eva  archive file, and click 

Open.

Select the required files from the left panel.
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Click Import.

Click Modify and select a directory.

Select, if required:
Convert all objects to lower case check box (this gives full Viz 3.x compatibility with 
Viz Artist and Viz Trio).
Import external references (if accessible)

Click OK.

Resume a Canceled/Crashed Import Operation
If an error occurs and the import procedure crashes, or the import is canceled, it is possible to 
resume from where the import ended. When an import operation does not complete, an import 
backup file is automatically created. This backup file is used to resume the import procedure.

To Resume a Canceled/Crashed Import Operation
Click Server > Import > Resume from canceled or crashed import.
Select a backup file to import.

IMPORTANT! A warning shows to make sure that it is correct to modify the file.

Note: If the directory is large, the import process can take some time. The import 
window shows the import status.



Note: As the log file for an import is created on the hard disk of the physical machine, the 
import can only be resumed on the machine it has been canceled on.
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Click Open.
Click Import.
Click OK.

2.9 Troubleshooting
This section contains information on the following topics:

Known Limitations, Problems and Workarounds
Troubleshooting Networks, Virtual Adapters and Session Disconnects
Restoring Corrupted Files
Graphic Hub Manager and Viz Artist Troubleshooting
Replication Troubleshooting
Deploy Troubleshooting
Graphic Hub Terminal Server Startup Issues
Pilot Clients Have No Database Connection
Troubleshooting Graphic Hub REST
Browser Troubleshooting
List of Ports Used for Graphic Hub Network Connectivity
Frequently Asked Questions

2.9.1 Known Limitations, Problems and Workarounds

General
Antivirus and Firewalls

A Windows firewall exception is added during the installation.
Running a firewall and/or an antivirus program on the same systems where any Graphic Hub 
component is installed could lead to serious issues and performance problems when the 
firewall or antivirus product is not configured properly.
Problems observable:

Graphic Hub Server cannot be found by any application - like Graphic Hub Manager or 
Viz Artist.
Graphic Hub Server could experience data or performance loss due to an antivirus 
application scanning the data directories and locking files.
Graphic Hub Terminal Web-UI cannot be accessed.

Note: If the directory is large, the import process can take some time. The import 
window show the import status.



Tip: If resuming from a crashed import, check the selection of files to prevent the 
crash from happening again. Also, it is possible to automatically start the import 
when resuming, by enabling the Import option in the Preferences window.
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Graphic Hub Deploy Agent cannot be found by Graphic Hub Manager.
Graphic Hub Deploy Agent could experience data or performance loss due to antivirus 
application scanning the data directories.
Graphic Hub Manager will not find any Graphic Hubs.
Graphic Hub Manager will not find any Graphic Hub Deploy Agents.

Windows: UAC and Non-administrative Accounts

Only default level and lower of UAC is supported.
Graphic Hub Deploy Agent will not work as expected if UAC is enabled on Deploy Agent 
versions lower than 2.0.0!

Windows C++ Redistributables

Problem: Graphic Hub, GH REST service or Deploy Agent service do not start on Windows 10.
Background:

Redistributables are only installed by the Graphic Hub Bundle Installer. For GH 
REST, GH Deploy Agent and GH Manager the redistributable needs to be 
installed manually prior to installing the MSI.
C++ Redistributable 14.0.24245 (or earlier) fail to install properly on Windows 
10 (VIZGH-7498).

Resolution:
Install the Visual Studio 140-143 redistributable 14.31.21103 or newer (is 
included in the Graphic Hub Bundle Installer and available eon the FTP).

Graphic Hub
General: Graphic Hub will not start when the data directory used is from a newer Graphic Hub 
version.

General: When copying data directories always ensure that the source Graphic Hub version is the 
same or lower as the destination Graphic Hub version.

General: On virtualized environments snapshot tools (for example, VEEAM) or migration (VMotion) 
of VMs are not supported.

Background: System/program freeze and interrupted networking render the VM not 
reachable during snapshot generation. In addition, all connected sessions may drop due to 
timeouts and files currently written may get corrupted in the snapshot. It is not 
recommended to take memory/state snapshots of the running Graphic Hub currently, as it 
can cause inconsistencies and may cause data corruption (for example, a snapshot that is 
restored and was captured while a file was written).

Problem: Long login times from clients when multiple network interfaces are used (VIZGH-6777)

Background: Graphic Hub by default registers on all available IP addresses in the Naming 
Service. The NS delivers the list in no specific order, so that clients might try an address first 
which is not reachable to them. This leads to timeouts.
Workaround: Configure Graphic Hub to register on one specific NIC only using Graphic Hub 
Terminal.
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Problem: Graphic Hub cannot be accessed if networking configuration changes while the Graphic 
Hub is running (VIZGH-5575, VIZGH-3157)

Background: Graphic Hub registers with the naming service at startup and cannot 
dynamically detect changes in the network interface configuration or connectivity.
Workaround: Restart Graphic Hub (single server or cluster).

Problem: Data synchronization is not working because of an intersystem corruption.

Workaround:
Shutdown the cluster.
Remove the folder VizDbRecover from the current data directory on both Computers.
Copy the health data directory to the second host.
Restart the cluster (Main first).

Problem: Graphic Hub Manager server view states 'Restart server/Cluster necessary'.

Solution:
Use Viz Graphic Hub Manager to shut down the server/cluster.
Wait until the server/cluster shut down is finished!
If you’re running a replication environment start the main server first.
Wait until the main server is started.
Start the replication server.

Problem: Manual or automated file copy destroyed data content on Graphic Hub.

Solution:
Never copy single files from data directories! Copy the whole data directory instead.
Shutdown the server/cluster.
Backup the destroyed data directory.
Delete the destroyed data directory.
Copy a working backup of your data directory to the previous deleted data directory.
Start the server/cluster again.

Hardlock/Sentinel Dongle: You should never disconnect a dongle from a machine where Graphic 
Hub is still running. Never plug in more than one Viz Artist/Viz Engine Hardlock/Sentinel dongle to 
your Viz Graphic Hub computer at the same time!

Graphic Hub Terminal
Scheduled Shutdown Task: When a shutdown task is scheduled at the same time with a cleanup 
task (for example, Pilot data element cleanup task) the Graphic Hub Terminal service may shut 
down and restart (VIZGH-7565). When a backup is configured it is not triggered in this case, and 
Graphic Hub is not started when Restart Graphic Hub after successful backup is configured.

Graphic Hub Deploy Agent
Problem: Deploy tasks using the option "Rebuild structure under target folder" can cause issues.

The following issues can be observed:
Keywords will not be deployed unless the file has changed (checksum different) or is 
created in all task modes.
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Pausing real-time deploy tasks before their start time ("Start at") can delay a following 
continue up to five minutes.
Pausing of deploy tasks.
Deletion of all data on the destination server!

Solution: Avoid using "Rebuild structure under target folder", don't use "Remove deleted 
objects on target server(s) as well" when it is still used. Also check "Do 'emergency' pausing 
of real-time tasks" and insert the corresponding values.

Real-time deploy: Does not deploy changes from Graphic Hub Manager "Replace Reference" to 
prevent error situations:

Solution: Use Graphic Hub Manager's DDC to re-synch the content.

Real-time deploy/content not completely synched: In rare cases the content couldn't be synched by 
Graphic Hub Deploy Agent:

Solution: Execute server differences via Graphic Hub Manager and deploy the content 
manually, restart the deploy task or restart the Graphic Hub Deploy Agent service again to 
reinitialize the synchronization.

Real-time task stops when source/destination servers are offline or connection is lost:

Solution: Task will be restarted when all servers are available again. Please check event log 
"Vizrt" if task does not start and/or restart Graphic Hub Deploy Agent in this case

Task hangs or does not copy a file:

Solution: Check source and destination server with Graphic Hub Managers "Check server" 
Utility and fix corrupted files. Restart the task afterwards.

High availability disconnecting does not work (high availability partner lost):

Solution: Stop Graphic Hub Deploy Agent and delete the file DeployAgentConfig.cfg in the 
Graphic Hub Deploy agent installation directory. All Graphic Hub Deploy Agent settings will 
be lost in that process. Start Graphic Hub Deploy Agent again and re-configure your current 
Graphic Hub Deploy Agent via Graphic Hub Manager.

Real-time deploy on sub folder or project: Rebuilds the complete project and folder structure on 
the destination server.

Scheduled deploy tasks do not start if Main server is shut down in a cluster setup (VIZGH-7136): 

Problem: When using GH as a cluster any scheduled deploy task (Pilot & GH data) only copies 
files if the original Main server is running. If the Main server is shut down the deploy task is 
running but not copying files.
Note: Real time tasks are not affected by this issue, they continue running also in case of 
cluster failover.
Solution: After restoration of the cluster these tasks resume normal operation.

Graphic Hub Manager
Viz 2.x Archive Import
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If dongle driver Sentinel 7.6.5 (installed by Viz World 14) is installed, Graphic Hub Manager 
may fail to import viz 2.x archives. Install Sentinel dongle driver version 7.5.1 to fix this 
problem!

Search-based Deploy Tasks

While all settings in the search filter are overtaken when creating a new Search-based Deploy 
Task the date ranges for the Create date and Modification Date do not follow this behavior, 
since for Search-based Deploy Tasks, those ranges are relative and should be expressed as 
intervals. Therefore, if you want to restrict the result of Search-based Deploy Tasks by those 
dates, you have to manually set corresponding intervals in the tab 'Search criteria' under 
'Created within the last' and 'Modified within the last'.
When creating a search based deploy task where add-ons are searched, there are no results 
if free text is checked. If the status of the Deploy Agent is 'lost' press search to establish the 
connection. 
Cancel and Pause are only working on established Deploy Agents.

Multi-finger Touchpad Events

May freeze Graphic Hub Manager when used in Explorer view, archive view or search results 
view.

Installation
Problem: Graphic Hub REST could not be updated, installation fails with "There is a problem with 
thin Windows installer package. A script required for this install to complete could not be 
run...". (VIZGH-6800)

Background: The configuration data for Graphic Hub REST are put into the C :
\ProgramData\Vizrt\Viz GH Rest\ directory. We have seen that in very rare cases the access 
rights to this folder become corrupted, making it impossible to complete installation.
Workaround: Delete the complete C:\ProgramData\Vizrt\Viz GH Rest\ folder manually. Then 
start the installation again.

Problem: While uninstalling, the message "Warning 1910.Could not remove Shortcut XXXXX.lnk. 
Verify that the shortcut file exists and that you can access it." shows. Which results in temporary 
deleted shortcuts from the desktop.

Solution 1: After a Windows restart delete the desktop shortcut manually.
Solution 2: Due unspecified behavior in Windows the file <SystemDisk>:
\<Users>\<PublicUser>\Desktop\desktop.ini has been set to read-only. Therefore, unset the 
read-only attribute before uninstalling results in expected uninstallation behavior.

Problem: Installation fails with permission errors reported during installation. Installation will not 
work as expected if user does not have administrative rights.

Solution: The user that performs the installation requires administrative rights and requires 
to approve any UAC dialog during installation. 

Problem: Installation fails with "Sentinel HASP Run-time installation" warning.

Workaround:
Install Graphic Hub without dongle drivers:
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Start the Graphic Hub installation again.
Choose Custom installation.
Uncheck Dongle drivers.
Proceed with install.

OR remove the dongle drivers and install again:
download from ftp.vizrt.
Extract the haspdinst.exe from the .zip file to C:\.

Open a command shell (cmd) and type C:\haspdinst.exe -fremove .

Reboot the workstations.
Start the Graphic Hub installation again.
Install Graphic Hub as desired.

2.9.2 Troubleshooting Networks, Virtual Adapters and Session 
Disconnects

Some network settings can prevent the Graphic Hub applications from finding other running 
Graphic Hub Terminals on the network. To locate a machine which is running the Graphic Hub 
Terminal, try pinging that machine. If the host is not reachable across the network, the Graphic 
Hub Terminal is not reachable either.

It is necessary to run Graphic Hub Terminal in a local network where the settings shown below are 
identical on every workstation running the terminal application.

To Check Network Settings
On the server machine, go to Start > Run > cmd.

In the console, enter ipconfig /all  and press ENTER.

Browse to the current connected network adapter.
Check Subnet Mask and Default Gateway.
Repeat steps 1-3 on the client machine, and see that the Subnet Mask and Default Gateway 
are identical between client and server.

To Solve Network and Firewall Problems
Make sure that the client can broadcast to other clients and to the Graphic Hub Server. This 
means all firewalls between server and clients need to allow broadcast.
Make sure the following port settings for the Graphic Hub Terminal are open to firewall 
traffic in between all clients and servers:

TCP Port
UDP Port
Graphic Hub Server Port

Make sure that local firewall applications allow traffic for all Viz products.

IMPORTANT!  While the Graphic Hub and/or the Naming Service are running, the server's 
network adapter status(es) and IP address(es) may NOT be changed.



ftp://ftp.vizrt.com/products/Vizrt%20Drivers/HardlockDongle/Sentinel_LDK_6.50_Run-time_cmd_line.zip
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Server Unreachable in Dual Network Setup
If installed on a server with two network cards, the Graphic Hub is normally operating on both 
networks. However, in certain hardware configurations, Graphic Hub versions 2.4.0, 2.4.1 and 
2.4.2 may become unavailable or unresponsive on one of the networks. If this is the case, please 
submit a Support Request, making sure to include all the required information.

Sessions Keep Disconnecting from the Graphic Hub
Symptoms: Viz Engine is reporting disconnections and reconnect attempts on the console when 
loading data from the Graphic Hub. This may cause some delay when the session was 
disconnected (as it needs to reconnect first), as the Graphic Hub pings the client periodically and 
disconnects the session if it cannot reach it for 90 seconds. In addition, it causes load on the 
Graphic Hub, a sessions are disconnected periodically and log in again.

This can be caused by the client side firewall, different subnets with restrictions in routing or 
invalid or missing DNS records for the clients.

Client side firewalls may cause issues when the Viz Engine/Artist version is below 3.8.2 or the 
Graphic Hub version is below 3.0.0, since the communication protocol used was two-way and 
required the firewall on the client side to be open for the Artist/Engine processes. However, it is 
not required to disable the firewall completely, just certain ports need to be open for Artist/
Engine.

See List of Ports Used for Graphic Hub Network Connectivity
See the Ports and Connections section of the Viz Engine Administrator Guide

How to Determine Connection Issues
You can verify that clients stay connected with GH Manager in the active session view: 
see Server Information. 
Have a look at the login times of the sessions and if they disappear after some time (more 
than 90 seconds).
Have a look at the Graphic Hub journal messages with GH Manager: Journal Panel.
Filter by Alerts and look for messages with Level 751, 802 and 961 which indicate client 
connection loss.

How to Fix the Issue
Check firewall settings on the client and ensure the required ports are open for Viz Artist 
and Viz Engine processes.
Verify that clients are properly registered at the DNS and reachable from the GH server.

2.9.3 Restoring Corrupted Files
Any save operation from a client (e.g. Viz Artist) via Viz Engine triggers Graphic Hub to back up the 
old file and create a new one. The new file is streamed to the server until the client informs the 
server that the operation is complete. After that, Graphic Hub Server deletes the backup file.

http://documentation.vizrt.com/viz-engine
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A file is corrupted if Graphic Hub does not get the message from the client indicating that the save 
operation is done. For example, this can occur if the client application crashes during the save 
operation.

To Restore Corrupted Files
In Graphic Hub Manager, log into the server where the corrupted file is located.

Perform a search with filters in the Journal Panel for Alert numbers 810  and 910 .

Browse through all the results and click the P button in the Details panel. If a file has been 
corrupted, you are prompted to restore it.
Click Restore.
Repeat steps 3 and 4 until all corrupted files have been restored.
To make sure that the file has been completely restored, you can do a search to check that 

the restored file’s checksum is not 0 . 

See also

Import External Images

2.9.4 Graphic Hub Manager and Viz Artist Troubleshooting
This page contains the following topics:

Viz Artist Does Not Respond
To Restore a Locked or Corrupt File after Viz Artist Stopped Responding

Graphic Hub Manager and/or Viz Artist Cannot Find Servers
Solution

Graphic Hub Manager or Viz Artist Does Not React in Server Tree

Viz Artist Does Not Respond
If Viz Artist stops responding, files that were open keep their locks. Graphic Hub usually releases 
the session within a certain interval, but you should check if Viz Artist is responding to the session 
release attempt.

To Restore a Locked or Corrupt File after Viz Artist Stopped Responding
In Graphic Hub Manager, log into the server where the corrupted file is located.
Check the Active Session to see how long it takes for the server to clean up the session.
Check the Application Name and IP address in the Server Information's Active Sessions 
window.
Once all processes are complete, all related files are unlocked and checked in, and you can 
continue with Restoring Corrupted Files.

Graphic Hub Manager and/or Viz Artist Cannot Find Servers
When searching for servers, the system cannot detect any.
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Solution
Disable all network blocking applications, like firewalls, anti-virus software, VPNs, virtual 
network adapters, etc.
Ask your system administrator to open necessary ports on the company’s firewall between 
the Graphic Hub Server, Graphic Hub Manager and/or Viz Artist.

Graphic Hub Manager or Viz Artist Does Not React in Server Tree
Sometimes you cannot get into the server tree. This is mostly due to a lost server connection. If 
you suspect the server connection is lost, a good first step is to click around the server tree. If it 
does not update, exit the application and log back in.

See Also

Troubleshooting Networks, Virtual Adapters and Session Disconnects
Replication Troubleshooting

2.9.5 Replication Troubleshooting
Most problems with replications can be solved by having a stable network environment. This 
means that applications which are causing drag on network performance, like global network 
updates or global virus scans, should not be performed in a replication environment.

To prevent data loss or conflicts between the main and replication servers, the server checks the 
network card for timeouts. If the timeout is too long, the server shuts down.

This page contains information on the following topics:

Main Server Is Not Available
To Solve Cluster Timeouts

Cluster Not Up and Running
To Restore a Healthy Cluster Environment

Cluster Configuration on Graphic Hub Terminal
To Refresh the Connection Settings

Journal Log Flooded with Replication Error Messages
To Synchronize Data Directories

Both Main and Replication Servers Have Open Transactions
Both Running As Main Shutdown Error
Port Already Used Startup Error

Main Server Is Not Available
The main server often shuts down because network connections become unavailable. If this is a 
common occurrence, perform the procedure below.

To Solve Cluster Timeouts
Open Graphic Hub Terminal and open the Advanced Settings.



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  197

2.

1.
2.

3.

4.

5.

1.
2.

1.
2.
3.
4.
5.
6.

Configure the Additional Advanced Settings for Cluster Configurations, enabling the timeout 
settings and setting the cluster timeout to a higher value.

Cluster Not Up and Running
A server can become unavailable due to hardware problems, network problems, and so on.

To Restore a Healthy Cluster Environment
Open Graphic Hub Terminal on one of the cluster servers.
Check the status field. If the status does not say Cluster is up and running, start the 
server(s) that is shut down.
Wait until the server resumes its former role. If it was the main server, this may take some 
time while all open transactions are deployed and the server switches back to its original 
state.
The status field should now state Cluster is up and running, and Open transactions should 

be 0 .

Open the Graphic Hub Manager and Detect and Solve Server Differences.

Cluster Configuration on Graphic Hub Terminal
In Graphic Hub Terminal, the message You are already connected to a cluster appears, even 
though the other server in the cluster is not running anymore. Graphic Hub Terminal has most 
likely not received an automatic update from the other Terminal.

To Refresh the Connection Settings
In Graphic Hub Terminal, click Refresh.
Start the cluster. If it still does not work, exit Graphic Hub Terminal and restart it. To start or 
stop the Graphic Hub Terminal, use the Start Terminal Service and Stop Terminal Service
shortcuts located in the Start menu’s Vizrt folder, or by using the Windows Service Control 
Manager.

Journal Log Flooded with Replication Error Messages
This may occur if your data directories are not properly synchronized.

To Synchronize Data Directories
Shut down the replication server (see Graphic Hub Shut Down).
Back up, then delete the replication server’s data directory.
Shut down the main server.
Copy the main server’s data directory to the replication server’s (now empty) directory.
Start up the replication server.
Check the Journal for error messages. 

Caution: Consult a Vizrt CA professional before enabling this functionality.
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Both Main and Replication Servers Have Open Transactions
Open the Graphic Hub Terminal and start the main and replication servers. The Terminal 
detects if both have open transactions when the second server starts, and present a dialog 
where the transactions can be backed up or deleted. Select backup or delete. The Terminal 
then attempts to restart.
If the above does not work, rename the VizDbRecover directory inside the data directory on 
the server that has the least number of open transactions.

Start both servers.
Wait until both servers report no open transactions, has switched back to real time 
replication status, and returned to their original modes.
Bring servers in sync again using the Graphic Hub Manager server differences tool.

Both Running As Main Shutdown Error
When a running main server shuts down with this message when starting the replication server, 
the problem may be caused by the replication server being unable to reach the main server, even 
though the main server is able to reach the replication server.

Check that both servers can reach each other on the network.
Check the network environment.
Try to log in from replication/main to the other machine using Graphic Hub Manager.

Port Already Used Startup Error
Open Task Manager (Start > Run > Task Manager) and check if VizGHNamingService.exe or 
VizGH.exe is running.
Restart the Terminal service using the Stop and Start Terminal Service shortcuts from Start > 
Vizrt > Graphic Hub.
If still not working check for conhost.exe or cmd.exe processes and terminate them. These 
are the console processes that can linger in some cases and keep ports bound.

2.9.6 Deploy Troubleshooting
This page contains information on the following topics:

DDC Data Does Not Transfer Correctly
Deploy Agent Does Not Transfer All Data
Deploy Agent Does Not Run

To Maintain the Deploy Agent Service
Deploy Task Runs for Too Long

To Release a Hanging Deploy Task
Deploy Task Floods Journal with Corrupt File Detected Message
Some files Cannot Be Processed Deploy Task Error
Deploy Agent Service Cannot Be Started During Installation
Deploy Agent Service Cannot Be Started After Installation

Caution: The server must not be running while renaming the directory!
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Deploy Agent Is Not Reachable from Graphic Hub Manager
Real-time Deploy Task Does Not Start

DDC Data Does Not Transfer Correctly
DDC data may not be transferred correctly in the following cases, which are also visible in the DDC 
Action Log:

The connection between servers is lost
A file is locked or checked in
In other cases, it is necessary to file a bug report. Make sure that you include the exact error 
code and messages.

Deploy Agent Does Not Transfer All Data
A Deploy Agent task may not transfer all data correctly in the following cases:

A file is locked or checked in.
In other cases, review the unsuccessful task details and check all affected files.

Deploy Agent Does Not Run

To Maintain the Deploy Agent Service
Click Start > Vizrt > Graphic Hub > Deploy Agent > Stop Viz GH Deploy Service to stop the 
Deploy Agent Service, then Start Viz GH Deploy Service to start the service back up.
On your Windows desktop of the machine where the Deploy Agent is installed, right-click My 
Computer and select Manage. The Computer Management window appears:

In the left panel, expand the node Service and Applications.
Click Services.
In the right panel, right-click GH Deploy Agent and select Properties.
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Click the General tab and then click the Start button.
If the Deploy Agent service still does not run, continue with the following steps.
Click the Log On tab.
Click the This account radio button.
Click Browse.
In the field Enter the object name to select, enter Administrator and click OK.
Enter and confirm the valid password for Administrator.
Click OK.
Start the Graphic Hub Deploy Agent again.
If it still does not run, make sure the Deploy Agents have been stopped.
Browse to the Deploy Agent directory and delete the folder Open Tasks and the 
deployagent.cfg file.
Start the Graphic Hub Deploy Agent again.

Deploy Task Runs for Too Long

To Release a Hanging Deploy Task
In Graphic Hub Manager, log into the source server and open the Active Sessions window.
Check the Graphic Hub Deploy session for locked files.
If there are locked files, cancel the affected deploy task. The task should restart on its own.

Deploy Task Floods Journal with Corrupt File Detected Message
If the Deploy Agent encounters corrupted files during operation, it attempts to restore these files 
on the source server. This causes the Deploy Agent to log Corrupt file detected to the Journal.

Some files Cannot Be Processed Deploy Task Error
If the Deploy Task fails to start or pauses with an error stating that some files cannot be 
processed, investigate the journals and finished deploy task messages for files with identical 
names, but with different UUIDs on the destination server.

Deploy Agent Service Cannot Be Started During Installation
Check if Service Control Manager is open and close it.

Deploy Agent Service Cannot Be Started After Installation
Use the Service Control Manager to restart the Deploy Agent service. If the service cannot be 
restarted this way, contact Vizrt CA.

Deploy Agent Is Not Reachable from Graphic Hub Manager
Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual 
network adapters, etc.
Request from the system administrator that necessary ports on the company’s firewall are 
opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.
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Real-time Deploy Task Does Not Start
Check the target server for duplicate folders and projects with identical names with different 
UUIDS.
Check if there are non-UTF-8 characters in folder or project names.

2.9.7 Graphic Hub Terminal Server Startup Issues

Graphic Hub Terminal Does Not Start the Server
This may occur if Graphic Hub is installed as a service but not started as a service.

To Start Graphic Hub as a Service
Exit Graphic Hub Terminal.
Wait until Graphic Hub Terminal starts itself automatically.

Graphic Hub Terminal Service Does Not Start

To Start the Graphic Hub Service
On your Windows desktop of the machine where the Deploy Agent is installed, right-click My 
Computer and select Manage. The Computer Management window appears.

In the left panel, expand the node Service and Applications.
Click Services.
In the right panel, right-click Viz GH Terminal Service Properties and select Start.
Wait for the Graphic Hub Terminal to start up.

2.9.8 Pilot Clients Have No Database Connection
Check if Graphic Hub REST is running and configured.
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Check if the Graphic Hub is Running.
Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual 
network adapters, etc.
Request from the system administrator that necessary ports on the company’s firewall are 
opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.

2.9.9 Troubleshooting Graphic Hub REST
This page contains the following topics:

Service Cannot Be Started During Installation
Service Cannot Be Started After Installation
REST Is Not Reachable or REST Cannot Connect to Graphic Hub
REST Is Returning Unexpected Data
REST Is Unresponsive to Requests or Requests Are Timing Out

Service Cannot Be Started During Installation
Check if Service Control Manager is open. If it is, close it.

Service Cannot Be Started After Installation
If the REST agent is installed on a machine that is already hosting an application on port 80, 
the agent fails to startup and terminates. To fix this issue, manually change the port in the 
Web Server Configuration Settings. The GH REST web server configuration file can be found 
in the REST agent installation directory at .\config\rest.conf. After changing the value of 

server.port = [new_port] , open the configuration page http://127.0.0.1:[new_port]/

config.html to configure Graphic Hub REST.
If the standard browser login appears, please close it. Click logout and login with your 
Graphic Hub administrator account. Check the user name and password (case sensitive) 
through a login to your configured Graphic Hub via Graphic Hub REST.
Use the Service Control Manager to restart the REST service. If the service cannot be 
restarted this way, contact Vizrt CA.

REST Is Not Reachable or REST Cannot Connect to Graphic Hub
Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual 
network adapters, etc.
Request from the system administrator that necessary ports on the company’s firewall are 
opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.

Tip: If having trouble with the configuration page, please try to upgrade the web browser. 
For optimal performance, the Chrome browser is recommended.
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REST Is Returning Unexpected Data
Open the REST configuration page.
Check which Graphic Hub server the REST service is bound to. If REST is bound to the wrong 
Graphic Hub server, change the binding.

REST Is Unresponsive to Requests or Requests Are Timing Out
Use the Service Control Manager to restart the REST service.

2.9.10 Browser Troubleshooting
This page contains information on the following topics:

Safari with Authentication Enabled on Windows
Internet Explorer Issues with Default Security Settings
Internet Explorer IP Issues with Default Security Settings

Safari with Authentication Enabled on Windows
Safari on Windows cannot be used for cluster configurations with authentication enabled on 
Windows. This is because Safari since version 5.1.7 does not support the Access-Control-Expose-
Header, which is required for the Web Interface to access the Authentication header. 
Authentication is solely handled by the GUI itself, without the browser being involved.

As development of Safari on Windows has been discontinued by Apple, a newer version will not be 
available anytime soon.

Internet Explorer Issues with Default Security Settings
The Web Interface has issues with cross-origin HTTP requests (CORS) to multiple hosts when using 
the default security settings.

Known issues:

GH Terminal does not show information of the partner server of a cluster configuration, 
because the Web UI is not able to retrieve the status of the partner server and therefore 
reporting it as ‘not reachable’ or 'Unable to connect to Graphic Hub Terminal on host 
XXX:19399'.
GH REST reports the GH status as ‘not reachable’ or 'Unable to connect to Graphic Hub 
Terminal on host XXX:19399'.

•
•

Note: From version 3.8 we do not support other browsers than:
Google Chrome (recommended): 45+ (tested with 91)
Microsoft Edge (96+)
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This is no issue and can be ignored, as it is just a status display in the Web UI.
GH ImEx Agent is unable to show proper status of configured GH RESTs.

This is no issue and can be ignored, as it is just a status display in the Web UI.

For most cases, enabling Access data sources across domains should resolve the issue:

In Internet Explorer , click Tools and then click Internet Options.
In the Internet Options dialog box, on the Security tab, click Custom Level.
In the Security Settings dialog box, do the following:

Select Enable for Miscellaneous > Access data sources across domains.
Click OK.

In the Confirmation dialog box, click Yes.

This needs to be done for both the Internet and Local intranet zone. Internet Explorer always uses 
the settings of the Internet zone if a site is opened using an IP address no matter if the site is 
actually a local one or not!

Internet Explorer IP Issues with Default Security Settings
If the Web-UI is opened using the IP address and the requests are based on hostnames, then this 
violates Zone Policies.

The reason is the Cross-Domain and Zone Policy (see https://msdn.microsoft.com/en-us/library/
ms537505(v=vs.85).aspx#xdomain ), which blocks cross-origin HTTP requests (CORS) requests to 
a different host using a hostname, while the Web-UI is opened with an IP address as these requests 
violate the Zone Policy settings.

Known issues:

In GH Terminal when the Web-UI is opened with IP, but the loaded cluster configuration is 
based on hostnames, then the status is ‘not reachable’ or 'Unable to connect to Graphic Hub 
Terminal on host XXX:19399'.

A workaround for this issue is to add the Web-UI URL to the Trusted Sites:

In the Internet Options dialog box, on the Security tab, select Trusted sites.
Click Sites.
Disable Require server verification (https:) for all sites in this zone and click Add.
Click Close.

Make sure Miscellaneous > Access data sources across domains is also set to Enabled for the 
Trusted Sites zone.

2.9.11 List of Ports Used for Graphic Hub Network Connectivity
The Graphic Hub server requires a limited number of open network ports. The following table lists 
the ports used for Graphic Hub server connectivity:

Port Number Protocol Used for

Other components

427 TCP, UDP OpenSLP

https://msdn.microsoft.com/en-us/library/ms537505(v=vs.85).aspx#xdomain
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22352 TCP, UDP Codemeter 

Graphic Hub & Graphic Hub Terminal

19394 UDP Manager for Terminal 2

19395 TCP Terminal 2

19396 TCP, UDP Naming service

19397 TCP, UDP Graphic Hub

19399  (configurable) TCP Terminal 3 (HTTP)

Graphic Hub REST Service

19398  (configurable) TCP REST service (HTTP)

Deploy Agent

19391 TCP, UDP Deploy Agent High Availability

19392 UDP Deploy Agent

19393 TCP Deploy Agent

ImEx Agent

19390  (configurable) TCP ImEx Agent (HTTP)

Additional Ranges

Since Graphic Hub Deploy Agent 2, Graphic Hub Manager 5, GH REST 2, and Viz Artist 3.8.2, these 
clients do not require any port exemption rules on the client side firewall configuration. However, 
for earlier versions, all ports must be open on the client side.
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2.9.12 Frequently Asked Questions
Question: Can a Graphic Hub Deploy Agent deploy outside local network boundaries, for 
example, different subnets and gateways?

Answer: Yes. Log Graphic Hub Manager on with the IP address instead of the host 
name. Then schedule a deploy task.

Question: Can a replication cluster work outside local network boundaries, if the main and 
replication servers are not in the same local network?

Answer: No. Use the Deploy Agent instead.

Question: Can I share a single data directory over multiple servers?
Answer: No.

Question: Can deleting or creating files within a data directory solve problems?
Answer: No.

Question: Can I do a backup of the data directory while the server is still running?
Answer: No. The server must be shut down before copying the data directory.

Question: Can a localhost database be accessed from another machine?
Answer: From Viz Artist, no. A single-user database is only available on the machine it 
runs on.

Question: Do all Graphic Hub Naming Services on the network contain information about all 
servers? Why is there a need for more than one Naming Service on the network?

Answer: A Graphic Hub Naming Service only contains information about the servers 
that have been applied to it. Before a Graphic Hub Server is started, a Graphic Hub 
Naming Service must be applied to it. Either a local Naming Service that is started 
together with the server can be applied, or another available Naming Service in the 
network is applied. A server cannot be started without connecting to a running 
Naming Service.

Question: Can I terminate the VizDb.exe process?
Answer: No, never. Only use Graphic Hub Terminal or Graphic Hub Manager to shut 
down a server.

Question: Can I shut down Windows while VizDb.exe is still running?
Answer: No. Use Graphic Hub Terminal or Graphic Hub Manager to shut down a server 
before exiting Windows.

Question: Why is the content of the selected folder not listed in the Graphic Hub Manager’s 
File panel?
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Answer: First, make sure that the selected folder contains files. Next, make sure that 
All or the correct file type is selected from the Show drop-down list in the Toolbar.

Question: For an antivirus definition, we need the list of all file extensions used by Viz 
Graphic Hub.

Answer: List of file extensions for Graphic Hub data directories:
.idx
.fid
.dat
.vdb
.upd
.txt
.tmp
.conf
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3 Graphic Hub Deploy Agent
The method to copy and synchronize a database is the Direct Deploy Copy (DDC) functionality. The 
Graphic Hub deploy solution makes it possible to copy folders/projects/files with all necessary 
data (referenced folders/projects/files) and all Pilot data from one server to another. For example, 
if a scene is to be deployed, all files that are referenced by this scene (images, materials, and so 
on) are also deployed.

The Deploy Agent enables the configuration of scheduled deploy tasks, and is run from the 
Graphic Hub Manager.

This section contains information on the following topics:

Deploy Agent Modes
Deploy Agent Properties
Rebuild Original Structure
Copy to Target Folder Only
Schedule a Deploy Task
Maintain Deploy Agents and Tasks

3.1 Deploy Agent Modes
The Deploy Agent supports two modes:

Standard Mode: Creates only folders on the destination server which contain files that have 
to be copied by the task. This mode ensures that the folders on the source and destination 
servers have the same UUID if possible. I.e. folders outside of the original structure which 
contain references and/or folder links of files inside the structure have new UUIDs assigned 
if their original UUIDs are present on the destination server.
Direct Deploy Copy Mode: Also creates only folders on the destination server which contain 
files that have to be copied by the task. This mode ignores the UUID of folders and makes 
sure that all folders have the correct name in the structure

This page contains the following topics:

Standard Mode Supported Options
Direct Deploy Copy Mode Supported Options
Additional Information on Data Modes
Standard and DDC Supported Options

3.1.1 Standard Mode Supported Options
The standard mode supports these options:
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Options Supported Item

Schedule Options Real-time
Time steered
User triggered

Data Mode Options Folder based (Only a single folder can be selected per task)
File based: in ‘Copy to target folder only’ mode (Multiple 
files can be selected per task, folders are not allowed)
Search criteria based: in ‘Copy to target folder only’ mode 
(Copies all files that result from executing the search 
criteria, folders are ignored)

Real-time Options Rebuild original structure
Rebuild structure under target folder
Support for: Removal of deleted objects on target 
server(s), Synchronization users, groups, keywords, add-on 
templates, etc.

Time Steered Options Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

User Triggered Options Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

3.1.2 Direct Deploy Copy Mode Supported Options
The Direct Deploy Copy Mode (DDC) mode supported these options:

Options Supported Item

Schedule Options Time steered
User triggered

Data Mode Options Folder based (Only a single folder can be selected per 
task)
File based (Multiple files can be selected per task, folders 
are not allowed)
Search criteria based (Copies all files that result from 
executing the search criteria, folders are ignored)

Note: Real-time is not supported in this mode.
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Options Supported Item

Time Steered Options Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

User Triggered Options Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

3.1.3 Additional Information on Data Modes
File based: The task is not able to execute if the objects to deploy contain folders
Search criteria based: The task ignores all folders that are contained in the result of the 
search.

3.1.4 Standard and DDC Supported Options

Data Mode Options Standard Mode DDC Mode

Real-
time

Time-
steere
d

User-
trigger
ed

Real-
time

Time-
steere
d

User-
triggere
d

Folder based Copy to target folder 
only

Rebuild original 
structure

Rebuild structure 
under target folder

File based Copy to target folder 
only

Rebuild original 
structure

Rebuild structure 
under target folder
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Data Mode Options Standard Mode DDC Mode

Real-
time

Time-
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d

User-
trigger
ed

Real-
time

Time-
steere
d

User-
triggere
d

Search 
criteria 
based

Copy to target folder 
only

Rebuild original 
structure

Rebuild structure 
under target folder

3.2 Deploy Agent Properties
The Deploy Agent properties panel shows the properties and configuration settings for the Deploy 
agent.

This page contains the following topics and procedures:

Properties of a Deploy Agent
Configuration Panel
Version Info Panel
High Availability Panel

3.2.1 Properties of a Deploy Agent
To access the properties of a Deploy Agent:

Navigate to Tools > Administer tasks > Running deploy tasks to show Running deploy tasks 
tab.
Right click a Deploy Agent.
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Click Properties of deploy agent. 

Statistics Panel
In the Statistics panel, Graphic Hubs currently in use shows Graphic Hubs currently used as Deploy 
Agents. These Graphic Hubs are the source servers of one or more deploy tasks. The Graphic Hub 
Deploy Agent automatically removes all unused Graphic Hub source servers.

In some cases, a Graphic Hub can be lost or cannot be contacted by a Graphic Hub Deploy Agent. 
If this happens the add and remove can be done manually.

To Add a Graphic Hub
(Which is not registered in the Deploy Agent)

Open the Properties of Deploy Agent window.
Open the Select Graphic Hub to add window.

Click Add, or
Right click in the Graphic Hubs currently in use box, and click Add.

Select a Graphic Hub to be added, from the drop down box.
Click OK or Apply.

Information: Configuring a Deploy Agent is only possible if logged in on this machine 
locally. This is by design for security reasons.



Note: A Graphic Hub Deploy Agent, which is configured as High Availability Partner 
originally, cannot remove or add Graphic Hubs.



Note: The added Graphic Hub status is to be added until OK or Apply has been 
clicked (when not highlighted, the to be added Graphic Hub shows purple).
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To Remove a Graphic Hub
Open the Properties of Deploy Agent window.
Click the Graphic Hub to be removed.
Remove the Graphic Hub:

Click Remove, or
Right click the selected Graphic Hub and click Remove selected from the context 
menu.

Click OK or Apply.

Note: If an added Graphic Hub does not contain a valid task for the current Graphic 
Hub Deploy Agent, the Graphic Hub is automatically removed again. It is not 
possible to add or remove multiple Graphic Hubs at once.



Note: The selected Graphic Hub status is to be removed until OK or Apply has been 
clicked (when not highlighted, the to be removed Graphic Hub shows red).
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Note: If a Graphic Hub to be removed contains any running tasks, the remove will 
not be successful. Either click Cancel or undo the change via the context menu. If a 
removed Graphic Hub is not reachable by Graphic Hub Deploy Agent, a message 
displays where it is possible to select a forced remove or cancel the action. It is not 
possible to add or remove multiple Graphic Hubs at once.
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3.2.2 Configuration Panel

Logging of additional/advanced runtime information
Log additional information to EventLog: Configures the Deploy Agent to log warnings 
and errors to the event log of the source server of the task that caused the issues.
Log additional information to journal on dedicated Log-Server: Configures the Deploy 
Agent to log warnings and errors of all tasks to the event log of a specified server.

Deploy agent work directory
Folder: Shows where the Deploy Agent keeps its configuration file and temporary data.
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Timeouts (related to communication with Graphic Hubs): Changing the values of the timeout 
settings may have a significant impact on how Deploy Agent works. The default values have 
been tested in a LAN setting as well as for long range deploy tasks and should only be 
changed if the Deploy Agent has problems with servers that are connected via a slow / 
congested network or have a high server load. Increasing the timeout values may solve the 
problems in this case, decreasing does not improve the general performance of the agent 
and is not recommended.

Establishing communication timeout (in seconds): Specifies the maximum amount of 
time for a Deploy Agent is allowed to connect to a server. If the server does not 
respond in this period due to network characteristics or server load, it is considered as 
offline.
Communication round trip timeout (in seconds): Specifies the maximum amount of 
time for the Deploy Agent to wait for a reply from the server. If the server does not 
respond in this period due to network characteristics or server load, the affected task 
may be paused by the agent.
Cluster failover timeout (in seconds): This option is relevant for agents that operate in 
a setting with a failover server. If a main server becomes unavailable, this timeout 
specifies the period that a task is waiting for a notification from the failover server to 
switch over. If this time exceeds, the agent attempts to manually connect to the 
failover server.
Transfer Buffer Size: Adjusts the buffer size used by the Deploy Agent for 
communicating with the Graphic Hub.

Expert settings
No. of attempts to reconnect to Graphic Hubs: Set the number of times the agent is to 
attempt to connect to Graphic Hubs
Time (in seconds) between attempts to reconnect: Set the time between each attempt 
to reconnect to Graphic Hubs
Do emergency pausing of real-time tasks: Click in the box to do emergency pausing of 
real-time tasks. Set the % of all objects or the number of objects.
Use original DDC behavior for non real-time tasks: This option is set globally for the 
Deploy Agent and affects all tasks. The major difference to the normal mode is that 
the “deploy under target folder” restriction of having no folder on source and 
destination that has the same UUID but an incompatible path does not apply. If the 
Deploy Agent discovers a folder with the same UUID but different path, a new folder 
with a new UUID is created in the expected path. This feature has a significant impact 
on the performance of the Deploy Agent, and should be chosen wisely as it affects all 
non-real-time tasks that are executed by the agent
Do not overwrite if destination file is newer: If set, the file on the destination server is 
not overwritten, if it has a modification date/time newer than the source file. The 
default setting (=option is not checked) is always overwrite the file with the source-file.

Communications ports
TCP port: Sets the TCP port number.
UDP port: Sets the UDP port number.
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3.2.3 Version Info Panel
The Version info panel shows the version information for:

The Deploy Agent.
The Tasks scheduler.
The Graphic Hub interface.

3.2.4 High Availability Panel
When a new High Availability Partner is configured, the configuration of these values automatically 
transfer to the High Availability Partner:

Timeouts
Establishing communication timeout (in seconds)
Communication round trip timeout (in seconds)
Cluster failover timeout (in seconds)

Expert settings
Do emergency pausing of real time tasks

Use the original DDC behavior for non real time tasks.

IMPORTANT! When disabling the High Availability partner, the configuration values 
return to their default values.



Note: Since Deploy Agent version 1.4.1, it is possible to configure high availability 
partners using host names or IP addresses.
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To Configure a High Availability Partner
Click in the Configure high availability partner check box.
Select the Deploy agent from the Partner drop down box.
Click the Use IP address instead of host name box, if required.

Click OK or Apply.

3.3 Rebuild Original Structure
This page details how to rebuild a database structure.

To Create a New File Based Deploy Task
Behavior

3.3.1 To Create a New File Based Deploy Task
The Options panel shows a deploy task configuration where folder B of Server 1 is deployed to 
folder U of Server 2.

Note: If the High Availability partner configuration is set to use IP addresses, the 
clients need to have static IP addresses.
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The Options panel offers various settings to configure the deploy task:

Behavior options
Rebuild original structure: The original folder structure and any folder links for the 
selected folder or project is recreated at the root level of the target server, including 
any parent folders. The selected folder or project is rebuilt including all sub-folders, 
sub-projects and objects contained therein.
Rebuild structure under target folder: The original folder structure is recreated using 
the target folder as root level.
Copy to target folder only: Recursively copies files only from the selected source 
folder to the selected target folder. See also Copy to Target Folder Only.
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Overwrite existing objects: If there is a file in folder B or any of its sub-folders and the 
same file exists on the destination server (a file with the same UUID), then the file is 
overwritten on the destination if the content is different.
Overwrite existing references: If there is a file F in folder B or any of its sub-folders 
with a reference to file R and file R exists on the destination server (a file with the 
same UUID), then file R is overwritten on the destination if the content is different.
Overwrite owner: If there is a file in folder B or any of its sub-folders and the same file 
exists on the destination server (a file with the same UUID), then the owner of the 
destination file is changed if it differs from the source file.
Overwrite creation date: If not chosen, files and folders in the deployed structure have 
their creation dates set to the deployment time if they were not present. If chosen, 
they preserve the creation dates of their source objects.
Overwrite modification date: If not chosen, files in the deployed structure have their 
modification dates set to the deployment time if they were not present. If chosen, they 
preserve the modification dates of their source files.

Multi-server Processing options
Parallel: If multiple destinations are selected, the destinations are synchronized in 
parallel.
Deploy all files to first server, then to the second, and so on: If multiple destinations 
are selected, the destinations are fully synchronized one at a time.
Deploy one file to all servers, then another file, and so on: If multiple destinations are 
selected, missing files are copied to all destinations one at a time.
The Schedule panel shows the settings that are available to schedule the new deploy 
task.

Apart from the general settings, Rebuild original structure/ Rebuild Structure Under Target Folder
tasks also support the deletion of files on the target server. Files are only deleted if they are 
removed from the source folder B or any of its sub-folders and the file also exists on the 
destination server in folder U or any of its sub-folders. If the file on the destination also has folder 
links outside folder U, then only the folder links inside the target structure are removed.
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Deploy agent: Select the Deploy Agent to be used. The version number and deploy mode of 
the selected Deploy Agent is shown below the drop down box.
Task: Enter a name and description for the new deploy task.

Schedule this task: Click to enable or disable the Schedule field.
Schedule: Create a schedule for the new deploy task:

Mode: Select either Once, Recurring or Recurring forever
Start at/End after: Options depend on the set Mode. Set the start and finish of a new 
deploy task
Each: Select how often the task should start from the drop down box.
Real-time: Click to enable or disable the Real-time options field.

Real-time options
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Remove deleted objects on target server(s) as well: If ticked then not only newly 
created files or modified files are deployed to the target server (Graphic Hub), but also 
files that get deleted on the source server (Graphic hub) are also removed/deleted on 
the target server.
Synchronize: Synchronize options can be chosen separately. Check each box as 
required. The Data panel shows that folder B is used as source for the new deploy 
task.

3.3.2 Behavior
The image below shows the before and after condition of the deploy task.

Before:

 

After:
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To create a consistent deployment, not only folder B and its sub-folders but the whole relevant 
folder structure of the source server is created under the target folder on the destination server. 
This means that there must not exist any folder or project on either server, apart from already 
synchronized folders with the correct path. The deploy task goes out of sync if such a 
configuration is discovered. This restriction does not apply to files, but one needs to pay attention 
that content of files outside the target structure may be changed by this task.

The images below show an example deployment of the same deploy task setup as described 
before, but the option Use original DDC behavior for non-real-time tasks has been enabled and the 
schedule has been changed from real-time to a recurring task (see Expert settings in the 
Configuration Panel).

Before:

 

After:
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This has the effect that only folders that are needed for deployment are created, in this case the 
task creates all folders on the path to folder B and additionally folder C as it contains either a 
reference or a folder link from a file that is deployed. Folders AB and ABC are skipped and not 
deployed to the destination server. Furthermore, folder X on the destination server already 
contained folders LAA, A and B, which means that the Deploy Agent had to create new folders with 
new UUIDs under folder U.

3.4 Copy To Target Folder Only
The image below shows the settings to deploy a folder from the source server to folder T on the 
destination server in Copy to target folder only mode.

Changed in Viz GH Deploy Agent 2.1.0: This behavior now also applies to deploy tasks 
using standard mode. In contrast to DDC mode, UUIDs of folders are retained if no clash 
occurs.
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In this case, the structure of the source server is ignored and all files from the source folder and 
its sub-folders are copied directly into folder T.

The image below shows that only files were deployed to folder T and no sub-folders were created.
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3.5 Schedule A Deploy Task
Deploy tasks can be scheduled to run on a regular basis. This is useful to replicate data for 
safekeeping on a regular basis.

To run scheduled Deploy Tasks the Viz Deploy Agent must be installed.

3.5.1 To Add a Deploy Agent for Use 

Open Tools > Edit preferences.
Navigate to Agents > Deploy.

Note: Referenced files outside the source structure are also deployed into the target folder. 
Since there might be files from multiple folders deployed into a single folder, it is possible 
that the target folder contains multiple files with the same name.
File properties like access rights, owner and creation/modification date of pre-existing files 
are not overwritten when using Copy to Target Folder Only.



IMPORTANT! To configure a scheduled deploy task when the servers or the Deploy Agent 
are on different sub-nets, each server must be logged on to with its IP address, not its host 
name. Sign out of all servers and log back on using the servers IP address (see Graphic 
Hub Login and Log Out).



IMPORTANT! Deploy Agents not reachable via UDP broadcast and / or for use in Login 
profiles need to be added manually. 
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Press Add.

Insert hostname or IP address.

Provide UDP port (default: 19392 ).
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Press OK. 

 

Confirm all open windows.

The Deploy Agent has been added to current configuration and can be found although not 
reachable via UDP broadcast.

3.5.2 To Schedule a Deploy Task
In Graphic Hub Manager, log-in to two or more servers.
Right-click a folder/project/file in the Servers and Folders panel or Files panel, and then from 
the menu that appears, select Create Deploy Task...
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Select one or more target servers.

Select one of the Behavior options:
Rebuild original structure: Copies an exact replicate of all selected folders/projects/
files and its references from source to destination server.
Rebuild structure under target folder: Copies an exact replicate of all selected folders/
projects/files and its references from the source server to the destination folder on 
the destination server.
Copy to target folder only: Copies all selected folders/projects/files and its references 
from the source server to the destination folder on the destination server.
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Enable/disable the following Behavior options:
Overwrite existing objects (does not apply to referenced files)
Overwrite existing references
Keep original owner

Select one of the following Processing options:
Deploy all files to the first target server, then the next server in the queue, and so on.
Deploy one file to all target servers, then the next file in the queue, and so on.

Tip: For Copy to target folder only and Rebuilt structure under target folder, 
you can also drag folders or projects into the field beside the Behavior options
drop down menu.
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In the left panel, click Schedule.

From the Deploy agent drop down box, select a Deploy Agent.

Name and describe the task in the fields provided.
Check the Schedule this task check box.

Tip: If you have several Deploy Agents installed on various machines, and you intend 
to schedule many tasks, use a different Deploy Agent for each task for the purpose 
of load balancing.
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From the Mode drop down menu, select one of the following options:
Once.
Recurring.
Recurring forever.

In the Start at drop down menu, click to select a date from the calendar, and if necessary, 
adjust the time.

If your mode is Recurring, in the End after drop down menu, click to select a date from the 
calendar, and if necessary, adjust the time.
Select one of the following radio button options:

Each: Select an interval.
Realtime: The deploy task occurs every time there is a change in the database. With 
this selection, you can optionally Remove deleted objects on the target server as well.

In the left panel, click Data and drag any additional folders or files into the right panel, as 
necessary.

Click OK to create the deploy task.

Note: If you uncheck this box, the deploy task executes right away, rather than 
waiting for a scheduled time.



Note: You cannot schedule tasks to begin in the past.

Note: Real-time tasks cannot be modified later.

Caution: Do not drag sub-folders of any folders that are already in the right panel.

Note: You cannot drag files into the right panel for Real-time tasks.

IMPORTANT! Scheduled tasks always trigger on the Server's UTC time, not the client time!
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3.5.3 Two-way Real-time Deploy to a Remote Graphic Hub
Below are recommendations and step by step instructions how to set up a two-way real-time 
deploy to a remote Graphic Hub (for example, on a remote location or cloud location).

3.5.4 Basic Setup of a Two-way Real-time Deploy (Summary)
Install a Deploy Agent on each of the two Graphic Hub nodes.

Enable Deploy Agent emergency pausing to avoid accidental deletion due to deploy 
task or Graphic Hub downtimes (see details below).

Synchronize the two Graphic Hubs via Graphic Hub Manager (Server Diff).
The initial source server must have all content from the destination or both Graphic 
Hubs need to be equal in terms of file data when starting the sync. This is important 
as the task make the destination Graphic Hub equal to the source Graphic Hub, which 
can cause loss of data when it is only on the destination Graphic Hub.

Configure one real-time deploy job from one server to the other and vice versa.
After the initialization phase, the Deploy Agents start deploying the differences.

Note: Usually real-time deploy is meant to be used for one-way deployments of changes. 
Clients on other locations are typically working on a central Graphic Hub cluster and only 
have a local, one-way synchronized mirror for playout. However, in some cases this is not 
possible and client are working on their local Graphic Hubs where changes need to be 
synchronized then in both directions. The subsequent documentation needs to be followed 
for a two-way real-time deployment to avoid unwanted side effects.
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To Configure a Local Cluster with a Two-way Synchronized Remote Graphic Hub
Install the Graphic Hub on a remote location in multiuser mode or as main/replication 
cluster (referred to as GH-REMOTE). The remote host needs to be able to handle the number 
of expected clients.
Set up a local Deploy Agent (DA-LOCAL).
Set up a remote Deploy Agent (DA-REMOTE).
In Graphic Hub Manager in the Deploy Agent Properties, open the Configuration Panel and 
configure “Do emergency pausing of real-time tasks” to 1% of all objects or one object. This 
prevents the deploy task from accidentally deleting content created while the Graphic Hub 
has been unavailable and becomes available again, or the connection was interrupted and is 
reconnected.

This is a global setting for all tasks on the deploy agent and needs to be set on DA-LOCAL 
and DA-REMOTE.

In Graphic Hub Manager in the Deploy Agent Properties in the Configuration Panel it is 
possible to set the option “Do not overwrite if destination file is newer” too if desired. This is 
a global setting and applies to all tasks on the deploy agent. 

Schedule a real-time deploy task (see sections above) from Central Graphic Hub "/data" to 
GH-REMOTE using DA-LOCAL with the following settings:

Options:

Behavior options: Rebuild original structure
When timestamps should be preserved check "Overwrite creation date" and "Overwrite 
modification date"
All other settings as is 

Note: Resuming operation when a Graphic Hub or Deploy Agent was down requires manual 
interaction (see below).



Note: If the task pauses, it shows status Paused in the Scheduled Deploy Tasks panel
(you need to be logged in to Central Graphic Hub and GH-REMOTE) and creates a 
message in the Finished Deploy Tasks panel with Paused because objects will be 
deleted. The task then needs to be resumed manually with Graphic Hub Manager by 
right clicking on the paused task and selecting continue deploy task.



Tip: You can configure e-mail alerts for these messages to get notified by mail when 
this happens (Application: Viz Graphic Hub Deploy, Level: 20).



Note: System time synchronization is required on Main/Replication Graphic Hub and 
the GH-REMOTE, otherwise this feature does not behave as expected.
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Schedule:

Deploy agent: DA-LOCAL
Give it a proper name: For example, CENTRAL to REMOTE
Mode: Recurring forever
Tick Schedule this task
Select Realtime
Tick Remove deleted objects on target server(s) as well
Select all Synchronize options

Wait for the task to start, synchronize and enter the IDLE state.

Schedule a real-time deploy task from GH-REMOTE "/data" to Central Graphic Hub using DA-
REMOTE with the following settings:

Options:

Behavior options: Rebuild original structure
When timestamps should be preserved check "Overwrite creation date" and "Overwrite 
modification date".
All other settings as is

Schedule:

Deploy agent: DA-REMOTE
Give it a proper name: For example, REMOTE to CENTRAL
Mode: Recurring forever
Tick Schedule this task
Select Realtime
Tick Remove deleted objects on target server(s) as well
Select all Synchronize options

Wait for the task to start, synchronize and enter the IDLE state.
The synchronization is now up and running.

To Check Deploy Agent Connections
Log on to the Central Graphic Hub and GH-REMOTE with Graphic Hub Manager.

Caution: The task makes GH-REMOTE equal to the Central Graphic Hub. If there is content 
that needs to be preserved, copy all content to the Central Graphic Hub.



Note: The task might pause and requires a manual resume (continue) with Graphic 
Hub Manager, because of the emergency pausing on delete.
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Open the Active sessions window. This provides an overview of all logged in users and active 
sessions, and to which host they are connected.
Look out for the Deploy Agent connection on both GHs and verify that they are stable and 
keep connected (Logged in since) for at ten minutes.

This is to ensure that the connection is stable.

To Check that Synchronization is Working Properly
Log on to the Central Graphic Hub and GH-REMOTE with Graphic Hub Manager.
Create a project/folder and copy a file on Central Graphic Hub and validate that it is 
synchronized to GH-REMOTE.
Create a project/folder and copy a file on GH-REMOTE and validate that it is synchronized to 
Central Graphic Hub.

To Check Deploy Agent emergency pausing is working properly
Create a dummy folder/project or file and wait until it is synchronized
Pause the deploy task or stop the deploy agent service
Delete the dummy item
Resume the task or start the deploy agent service
Validate that it pauses on startup with a warning: “Task paused because too many files 
would be deleted in real time”
Continue the task.
Validate that it resumes and processes the deletes to the destination.

To Resume a Paused Deploy Task or a Graphic Hub that was Down or a Connection 
was Lost

 Prior to starting a Graphic Hub that was down pause the deploy tasks or the deploy agent 
services before it is started

This makes sure nothing gets deleted or overwritten when the Graphic Hub is brought back 
up and running.

Log in to Central Graphic Hub and GH-REMOTE with Graphic Hub Manager.
From the main menu, select Server > Differences and click Diff All

 To ensure that content that was changed on both servers does not get overwritten by the 
deploy task or files that were deleted don’t get restored a manual synchronization is 
required prior to resuming the deploy tasks.

Synchronize differences until one side is on the latest and desired state (for example, 
Central GH).
Resume deploy tasks one after the other starting from the one that was brought in sync.
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1.

2.

For example, Central Graphic Hub was synchronized. Start CENTRAL to REMOTE first and 
wait until it is IDLE. Afterwards start REMOTE to CENTRAL and wait until it is IDLE.

The synchronization is now up and running again.

3.6 Maintain Deploy Agents And Tasks
This page details the maintenance of Deploy Agents and configured Deploy Tasks in the following 
procedures:

To View Deploy Tasks
To Modify a Deploy Task
To Search Scheduled Deploy Tasks
To Search Finished Deploy Tasks
To Maintain Deploy Agents

3.6.1 To View Deploy Tasks
Click Tools > Administer Tasks > Running deploy tasks.
Click Tools > Administer Tasks > Scheduled deploy tasks.
Click Tools > Administer Tasks > Finished deploy tasks.

All selected deploy tasks are shown in the Journal.

3.6.2 To Modify a Deploy Task

Make sure you are logged into the source server for which you wish to modify the deploy 
task.
Show the deploy tasks in the Journal, in accordance with one of the procedures above.

Note: Modifications do not affect tasks that are currently running. If you modify such a 
task, the changes only take place at the next interval. Realtime tasks can NOT be modified.
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Right-click the task and select Properties. The Schedule Deploy Task window is shown.

Continue to schedule a Deploy Task from step 3 onward.
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3.6.3 To Search Scheduled Deploy Tasks
Click Tools > Administer Tasks > Scheduled deploy tasks.
The Journal is enabled for searching scheduled deploy tasks.

From the Filter, using the Server drop down box, select a server.
In the Details like field, enter free text like name of the task, name of the agent, or any 
description that may figure in the task.
In the Journal, click the Search button. The search results are shown in the panel below. The 
Triggers in column shows when the scheduled deploy task is set to run next. When one is 
selected, the deploy task’s details are shown in the panel to the right.

To modify the deploy task, do one of the following:
Right-click the deploy task in the results panel and select Properties.
In the details panel, click the Properties button.

Continue to schedule a Deploy Task from step 3 onward.
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1.

3.6.4 To Search Finished Deploy Tasks
Click Tools > Administer Tasks > Finished deploy tasks.
The Journal is enabled for searching deploy tasks.

From the Filter, using the Server drop down box, select a server.
Select a task Status. Your options are:

Only unsuccessful
Only successful
Both

From the Date drop down box, select one of the following options:
Anytime
From: Selecting this option prompts you to also enter a beginning date and time.
Until: Selecting this option prompts you to also enter an ending date and time.
Between: Selecting this option prompts you to also enter a beginning and ending date 
and time.

In the Details like field, enter free text like name of the task, name of the agent, or any 
description that may figure in the task.
In the Details not like field, enter free text like name of the task, name of the agent, or any 
description that you want to exclude from the task search.
In the Journal, click the Search button. The search results are listed in the main panel. When 
a result is selected, the finished deploy task’s details are shown in the Details of finished 
deploy task panel to the right. There are general details as well as any errors and warnings.

If the Deploy Agent encounters corrupted files, it attempts to restore files on the source server. In 
such cases, an error message is logged in the journal if the restoration fails. If the log level is set 
to All, successful restore operations are also logged.

3.6.5 To Maintain Deploy Agents
Launch the Graphic Hub Manager on the machine where the Deploy Agent is to run.
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Log into the source server(s) and view the deploy tasks.

In the left panel, right-click the relevant Deploy Agent and select Properties.
The Deploy Agent properties window is shown (Statistics is selected by default). The data 
shown here is for information purposes only.
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Click Configuration.

Configure the following parameters as necessary:
Log additional information to EventLog: Select this option to include debugging 
information, as well as records of the start of tasks, in the Windows event log.
Log additional information to journal on dedicated log server: Select this option to 
include debugging information, as well as records of the start of tasks, in the Graphic 
Hub server log, on one of the servers available in the Dedicated Log Server drop down 
box.
Deploy agent work directory: The path and folder which acts as the temporary buffer 
for the Deploy Agent. The Deploy Agent process must have full access rights on the 
selected directory. This directory location can not be changed.
Timeouts: Set the timeouts times for each file as required.
Expert settings: Consult your Vizrt CA representative before changing any of these 
settings:
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10.

Do ‘emergency’ pausing of realtime tasks: In the event that there is a risk of too many 
files being deleting on the destination server, select this option and assign a threshold 
as a percentage or number of files beyond which the Deploy Agent pauses the task. If 
such a task is paused, you can find it when searching for finished Deploy tasks. You 
are always able to resume the task.

TCP port: Default is 19393 . Change only after consultation with your network 

administrator, if there are firewall issues.

UDP port: Default is 19392 . Change only after consultation with your network 

administrator, if there are firewall issues.

Click Version Info.

When reporting a problem, make sure to include this version information.
Click High Availability.

To configure a high availability partner, select the respective check box.

From the Partner drop down box, select the alternative to take over in case of failover.

Note: Changing TCP or UDP setting requires changes to the Graphic Hub 
Manager preferences: click Tools > Edit preferences and in the left panel select 
Deploy.
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Click OK.
Click Close.

Note: In general, it is recommended that you use the default TCP port.
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4 Graphic Hub ImEx Agent
The Graphic Hub ImEx Agent (Import / Export agent) is a service that imports image media assets 
from file-system folders or HTTP sources to the Graphic Hub.

The Media Sequencer uses the ImEx Agent to stage image media assets for play-out, from HTTP 
sources. This reduces the load on Viz Engine as images are already available on the Graphic Hub 
with pre-computed mip-map levels, and must not be loaded through HTTP on actual play-out. The 
service depends on the Graphic Hub REST, which is used to import the images into the Graphic 
Hub. In addition file-system folders can be watched for image media assets to be imported.

The ImEx Agent uses projects or folders on the Graphic Hub to upload content, called destination 
directories. They are configured and managed by UUID. The destination directory path must be 
below the /data root folder, for example e.g. /data/imex/MyDestinationDirectory or /data/
imexDestinationDirectory.

The ImEx Agent can be used in two ways:

The Media Sequencer triggers activity in the ImEx Agent by creation of Distribution 
Plans based on playlists.
Importing images from a configured Watchfolder into the Graphic Hub. This also creates so 
called watchfolder distribution plans.
A Watchfolder is an ordinary folder on the file-system which is watched by the ImEx Agent 
and actively monitored. Image media assets are imported into the Graphic Hub on creation 
or overwritten when changed.

A Distribution Plan represents a set of image media assets that should be available on a number of 
destination directories during a specified period of time (1) or until they are cleaned up manually 
(2).

Availability Reports contain the content of an import operation, including additional information 
about the state and location of the media asset.

Housekeeping for uploads triggered by the MSE is done by setting expiration dates on the 
imported image assets on the Graphic Hub (watchfolder imports currently lack this feature). 
During the Cleanup of Expired Items Task, which must be enabled and configured in the Graphic 
Hub Terminal, all expired files are deleted.
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4.1 Supported Import Media Types
The following category and mime-types are supported by the ImEx Agent:

image/jpeg
image/gif
image/png
image/bmp
image/tiff
image/tga
image/vnd.radiance
image/x-exr

4.2 Notable Limitations
GH REST version 2.0.1 and Graphic Hub version 3.0.1 or later are required. For HDR and EXR 
images, GH Rest version 2.4.0 or higher is required.
The number of publishing points specifically used for media staging via Media Sequencer is 
limited to one per Viz Engine (Graphic Hub the Engine is connected to).
Currently, a maximum of 5000 assets is recommended for a single watchfolder based 
import.  
Folders on a network share can be used as watchfolders if it is mounted as drive with the 
SYSTEM user, because the ImEx Agent service is running under the SYSTEM user.
Currently, cleaning up images uploaded from a watchfolder must be done manually.
Resolving file name conflicts between the watchfolder(s) and the destination directory on the 
Graphic Hub must be done manually.
The watchfolder may NOT be renamed.

4.3 User Interface
The Graphic Hub ImEx Agent user interface consists of:

Note: The import configuration for MSE based imports (distribution plans, asset import 
schedules, availability report) is not persistent, and is thus lost when you stop or restart 
the ImEx Agent service.
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The Menu Bar (1):
Import
Options
Report
Help and About

The System Status Panel (2):
System Status Panel

The Status bar beneath the menu bar displays concrete information about the current status and 
page displayed.

The Status page displays information of the overall status of the ImEx Agent service. The Status 
icon can be either of the following:

 Running: Everything is OK.
 Warning: There are warnings which may require user interaction.
 Error: There are errors which require user interaction.

The main menu has the following sections:, and a status panel that provides a quick overview of 
the system status:

Import
Destination directories: Manage configured destination directories that can be used by 
the ImEx Agent and the Media Sequencer for imports.
Watchfolders:  Manage watchfolders that can be used to import images from the file-
system.

Options
Configuration: Manage the ImEx options (webserver, connection, import and log 
settings).
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GH REST hosts: Manage configured GH REST services (and Graphic Hubs) the ImEx 
Agent can use for imports.
Pre-Authenticated Hosts: Manage configured credential information for external 
import sources (e.g. Viz One) the ImEx Agent uses for authentication.
Change ImEx password: Change the ImEx Agent specific password that is required 
when "Use authentication" in enabled in the Configuration under Webserver 
Configuration.

Report
Logs: Displays searchable ImEx log content.
Distribution plans: Displays the active and expired Distribution plans with current 
status information.
Availability report: Displays search and filterable information of assets to import.
Export: Possibility to generate reports which contain all relevant log files and state 
information.

Help: Opens the Graphic hub manual.
About

Versions: Displays information of the currently installed ImEx version and connected 
GH RESTS and Graphic Hubs.

4.4 Initial Setup
When installation of the ImEx Agent is complete, the default web browser opens http://
127.0.0.1:19390/index.html  for initial configuration.

4.4.1 Quick Start
Install the ImEx Agent.
View web interface on http://127.0.0.1:19390/index.html.

http://127.0.0.1:19390/index.html
http://127.0.0.1:19390/index.html
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The initial configuration wizard displays if no destination directories exist.

Select a Graphic Hub REST host to use for importing assets. You can also enter the host 
manually, in the format http://resthost:port/. Graphic Hub REST must be bound and 
connected to a running Graphic Hub.

Note: When using a Main - Replication cluster make sure BOTH servers are running at 
the time ImEx is configured!



Note: Only use Hostnames for Graphic Hubs when configuring Graphic Hub REST and 
ImEx Agent, using IP Addresses does not work with ImEx!



Note: Graphic Hub REST version 2.0.1 or newer and Graphic Hub version 3.0.1 or 
newer are required.
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5. Providing a valid Graphic Hub REST host enables the Login panel. Provide a valid Graphic 
Hub username and password from the Graphic Hub you are connecting to.
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6. Select a destination directory (folder or project), by clicking the browse icon (...) on the right 
side. You can also create new projects or folders using the directory browser.
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7. Save the selected destination directory by pressing OK, then Add.

After successful configuration, the ImEx status page opens.
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4.4.2 Configure ImEx for Media Staging
The following describes how to configure ImEx for media staging using (third-party) search 
providers. For a guide on how to setup related Viz products for media staging, see Basic Media 
Sequencer Configuration.

After setting up ImEx (see Quick Start), a search provider in Pilot Data Server and other media 
staging related Viz products, also add the fitting pre-authenticated host to ImEx's pre-
authenticated hosts list, see Manage Pre-Authenticated hosts.

4.4.3 Basic Media Sequencer Configuration
The following list describes how to setup Media Sequencer for media staging via ImEx Agent.

Setup Viz Pilot and Media Sequencer, see Basic Viz Pilot and Media Sequencer setup using, 
for example, a Viz One as search provider.
Open http://localhost:8580/app/stagingconfig/StagingConfig.html to setup basic staging 
functionality.

Media Sequencer Configuration with Configuration Files
Open the Media Sequencer configuration file named default.xml in an editor of your choice. 
By default, this file is located in C:\ProgramData\vizrt\Media Sequencer.
Disable the http_resource_poller by adding:

mode="disabled"

In the scheduler section of the configuration file, add the following node:

<handler type="vme" name="imex_image_staging">
    <entry name="service_document">http://my-imex-host:my-imex-port/</entry>
    <entry name="log_level">50</entry>
    <publish_media_type>image</publish_media_type>
</handler>

Here, my-imex-host and my-imex-port need to be set to the relevant ImEx host name in 

lowercase format (e.g. imex-host) and the relevant port that ImEx uses (e.g. 19390 ), 

respectively.
When using a single Graphic Hub/Viz Artist: Add a single publishing point to Media 
Sequencer by adding/configuring the following node in the config section of the 
configuration file:

<entry name="global_publishing_points">
    <entry name="image">
        <entry name="uri">http://my-imex-host:my-imex-port/publishingpoint/my-
pp-uuid</entry>
        <entry name="atom_id">MY-PP-UUID</entry>
    </entry>

http://localhost:8580/app/stagingconfig/StagingConfig.html
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</entry>

Here, my-imex-host, my-imex-port, my-pp-uuid and MY-PP-UUID need to be set to the host 
name in lowercase format used in bullet 3, the port used in bullet 3, the UUID of the relevant 
publishing point in lowercase formatted as xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx 
(e.g. c94a50d8-867b-11e7-bb31-be2e44b06b34) and the used publishing point UUID in 
uppercase format (e.g. C94A50D8-867B-11E7-BB31-BE2E44B06B34).
When using multiple Graphic Hubs/Viz Artists: To distribute images used for media staging 
to several Graphic Hubs, first remove the global_publishing_points node from the config
section of the configuration file. Then, add a distinct publishing point for each Viz Engine by 
adding the following nodes to the handler sections of type viz in the configuration file:

<entry name="image_publishing_point_uri">http://my-imex-host:my-imex-port/
publishingpoint/my-pp-uuid</entry>
<entry name="image_publishing_point_atom_id">MY-PP-UUID</entry>

The Viz handlers can be configured in Director, see the Profile Configuration page in 
the Director Configuration section of the Viz Pilot User Guide. Again, set my-imex-host, my-
imex-port, my-pp-uuid and MY-PP-UUID (see bullet 4).

Examples
When using a single Graphic Hub/Viz Artist: Add the following node to the scheduler section 

to enable the ImEx Agent on host imex-host and port  19390  for media staging:

<handler type="vme" name="imex_image_staging">
    <entry name="service_document">http://imex-host:19390/</entry>
    <entry name="log_level">50</entry>
    <publish_media_type>image</publish_media_type>
</handler>

Then, add the following node to the config section to enable a publishing point with 
UUID c94a50d8-867b-11e7-bb31-be2e44b06b34:

<entry name="global_publishing_points">
    <entry name="image">
        <entry name="uri">http://imex-host:19390/publishingpoint/
c94a50d8-867b-11e7-bb31-be2e44b06b34</entry>
        <entry name="atom_id">C94A50D8-867B-11E7-BB31-BE2E44B06B34</entry>
    </entry>
</entry>

Note: For each Viz handler, add a publishing point on the Graphic Hub connected to 
the Viz Artist/Engine which corresponds to the currently relevant Viz 
handler. Adding an image publishing point to a solely configured Viz handler 
achieves the same effect as adding a global publishing point.
Again, the global_publishing_points node has to be removed from the config section 
to enable publishing points bound to Viz handlers.



http://documentation.vizrt.com/viz-pilot
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2.
Also, disable the htttp_resource_poller.
When using multiple Graphic Hubs/Viz Artists:

Add the following node to the scheduler section to enable the ImEx Agent on host imex-

host and port  19390  for media staging:

<handler type="vme" name="imex_image_staging">
    <entry name="service_document">http://imex-host:19390/</entry>
    <entry name="log_level">50</entry>
    <publish_media_type>image</publish_media_type>
</handler>

Next, navigate to each handler node of type viz and respectively add the corresponding 
image publishing points. In this example, two entities of Viz Artist (respectively connected to 
Graphic Hubs on gh-host1 and gh-host2) have been configured in Director. The Media 
Sequencer configuration reads:

<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
    <entry name="encoding">UTF-8</entry>
    <entry name="state"/>
    <entry name="renderer">
        <entry name="gh-host1">
            <entry name="active"/>
        </entry>
    </entry>
    <entry name="publishing_point_uri"/>
    <entry name="publishing_point_atom_id"/>
    <entry name="info"/>
    <command_timeout>20.</command_timeout>
</handler>

and

<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
    <entry name="encoding">UTF-8</entry>
    <entry name="state"/>
    <entry name="renderer">
        <entry name="gh-host2">
            <entry name="active"/>
        </entry>
    </entry>
    <entry name="publishing_point_uri"/>
    <entry name="publishing_point_atom_id"/>
    <entry name="info"/>
    <command_timeout>20.</command_timeout>

Info: This example demonstrates how to add two publishing points respectively 
residing on distinct Graphic Hubs. For other numbers of publishing points/Graphic 
Hubs proceed analogously.
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</handler>

Then, enable the publishing points with UUIDs b02cbb8e-87d6-11e7-bb31-be2e44b06b34
and d0053030-87d6-11e7-bb31-be2e44b06b34, which respectively reside on gh-host1
and gh-host2, by adding them to their correpsonding Viz handler. The configuration file 
should then read:

<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
    <entry name="encoding">UTF-8</entry>
    <entry name="state"/>
    <entry name="renderer">
        <entry name="gh-host1">
            <entry name="active"/>
        </entry>
    </entry>
    <entry name="publishing_point_uri"/>
    <entry name="publishing_point_atom_id"/>
    <entry name="image_publishing_point_uri">http://imex-host:19390/
publishingpoint/b02cbb8e-87d6-11e7-bb31-be2e44b06b34</entry>
    <entry name="image_publishing_point_atom_id">B02CBB8E-87D6-11E7-BB31-
BE2E44B06B34</entry>
    <entry name="info"/>
    <command_timeout>20.</command_timeout>
</handler>

and 

<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
    <entry name="encoding">UTF-8</entry>
    <entry name="state"/>
    <entry name="renderer">
        <entry name="gh-host2">
            <entry name="active"/>
        </entry>
    </entry>
    <entry name="publishing_point_uri"/>
    <entry name="publishing_point_atom_id"/>
    <entry name="image_publishing_point_uri">http://imex-host:19390/
publishingpoint/d0053030-87d6-11e7-bb31-be2e44b06b34</entry>
    <entry name="image_publishing_point_atom_id">D0053030-87D6-11E7-BB31-
BE2E44B06B34</entry>
    <entry name="info"/>
    <command_timeout>20.</command_timeout>
</handler>

Last, check if the global_publishing_points in the config section exists. If it does, it needs to 
be removed to enable the newly configured publishing points. Also, disable 
the http_resource_poller.
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4.5 Configuration
Use the Configuration page to make changes to the web server, connection, import, or log 
settings. This section provides information on the different configuration settings available, and 
describes how to perform the initial Graphic Hub ImEx Agent Configuration.

4.5.1 Webserver Configuration

Port: Set the HTTP port number the ImEx web server should listen to. The default port 

number is  19390 .

Thread pool size: Set the maximum number of concurrent threads for the ImEx Agent web 

server to handle requests. The default value is  80 .

Enable access log: Check the box to log information about connections and requests to the 
ImEx web server.
Use authentication: Check the box to enable HTTP basic authentication on ImEx Agent web 
server with ImEx Agent specific credentials. This makes a Login button appear in the top 
right corner. The default username is Admin, and the default password is VizDb.  You can 
change this in Options > Change ImEx password.

4.5.2 Connection Settings

General request timeout (ms): Set the default timeout in milliseconds for HTTP requests 

performed. The default timeout value is  10000 .

GH REST request timeout (ms): Set the timeout for Graphic Hub REST requests in 

milliseconds. The default timeout value is  10000 .
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4.5.3 Import Settings

Maximum RAM usage (Mb): Define the maximum amount of RAM allocated for caching 

temporary images in megabytes. The default value is  1500 .

Maximum parallel uploads: Set the maximum number of simultaneous uploads. The default 
value is 32.

Maximum parallel downloads: Set the maximum number of simultaneous downloads. The 
default value is 32.

Monitoring interval assets (ms): Set the interval in which the ImEx Agent checks the 
availability of all non-expired assets. In case an asset is accidentally deleted, the ImEx Agent 

automatically fetches the asset again. The default value is  10000 .

Monitoring interval REST agents (ms): Set the interval in which the ImEx Agent checks the 

availability of all configured GH REST agents. The default value is  10000 .

Monitoring interval staged assets (ms): Set the interval in which the ImEx Agent checks 
unavailable assets that have been staged. When the asset becomes available, the ImEx Agent 

automatically fetches the asset. The default value is  10000 .

4.5.4 Log Settings

Maximum size (all logs)(MB): The default value is 60.

Log lifetime in days: The default value is  28 .

Log level: Select which log messages should be reported.
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4.6 Manage Imports
This page contains information on import behavior and how to manage Destination directories, W 
atchfolders, GH REST hosts and Pre-Authenticated hosts.

Import Behavior
Manage Destination Directories
Manage Watchfolders
Manage GH REST Hosts
Manage Pre-Authenticated Hosts

The ImEx Agent can only upload content to the configured Graphic Hub’s destination directories.

4.6.1 Import Behavior
During import, handling of destination directories and images differs depending on the import 
variant.

When importing via media staging (MSE triggered):
A child folder with the title and id of the Distribution Plan is created in the destination 
directories. If the folder already exists, the existing folder is used.
The expiration date defined in the Distribution Plan is set as the expiration date for 
the project/folder on the Graphic Hub.
When an expired items cleanup task is enabled and configured in the Graphic Hub 
Terminal, the project/folder and its contents are deleted automatically when expired 
as soon as the expired items cleanup task is executed. 
Files are always imported with a unique name (file name with asset ID). Files are never 
overwritten during import.

When importing via watchfolder:
The images are saved directly in the destination directories.
Corresponding distribution plans do NOT expire. Images uploaded from a watchfolder 
have to be cleaned up manually.
Images which are deleted from a destination directory are automatically re-uploaded. 
To clean them up, first delete the corresponding file from the watchfolder and then 
delete it from the destination directory.
Importing different but identically named files from different watchfolders into the 
same destination directory leads to conflicts. These need to be resolved manually.
Overwriting images in the watchfolder leads to overwriting on the Graphic Hub if the 
checksums are different.
Renaming images in the watchfolder leads to upload of the renamed images. The 
image with the old name is not automatically deleted on the Graphic Hub.
Renaming or overwriting images in the destination directories re-uploads the versions 
in the watchfolder. The renamed file is not automatically deleted on the Graphic Hub.
Overwriting or deleting images from the watchfolder updates the corresponding 
distribution plan with the new information.
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By default, Add file extension is enabled. Images are named by appending their 
original names with an underscore and their respective file extension (e.g. image.bmp
> image_bmp). It is not advised to disable this option, see Add watchfolder for details.

4.6.2 Manage Destination Directories
Use the Import > Destination directories page to configure the destination directories used by the 
GH ImEx Agent.

Status: The current status of the configured destination directory. If a warning or an error is 
shown, hovering over the icon displays additional information.
Destination directory: The absolute path of the currently configured destination directory 
(project or folder on the Graphic Hub).
Graphic Hub: The configured Graphic Hub of the destination directory to which the GH REST 
is connected to.
GH REST: The GH REST service(s) used for importing assets to the destination directory.

Note: Click the  copy icon to open a dialog containing the import directory link to copy 
it for the Media Sequencer configuration .
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To Add a Destination Directory
Open Import > Destination directories.
Click Add destination at the bottom left (1). This shows the Add Destination dialog (2).

Select a Graphic Hub REST host to use for importing assets. You can also enter the host 
manually, in the format http://resthost:port/. The GH REST must be bound and connected to 
a running Graphic Hub.

Provide a valid GH username and password from the Graphic Hub you are connecting to.

Note: GH REST version 2.0.1 and Graphic Hub version 3.0.1 or higher are required.
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Select a destination directory (folder or project), by clicking the browse icon (... ) on the right 
side. You can also create new projects or folders using the directory browser.

Click Add to add the destination directory.
The new Destination directory appears in the Default directories list:

To Remove a Destination Directory
You can remove destination directories that are not in use.

Open Import > Destination directories.
Remove the desired destination directory by clicking the trash can icon at the far right of the 
watchfolder's destination directory.
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4.6.3 Manage Watchfolders
Use the Import > Watchfolders page to configure watchfolders which the ImEx Agent can use to 
import images from. 

Status: The current watchfolder status. If a warning or an error is shown, hovering over the 
icon displays additional information.
Destination directories: The absolute path of the destination directory. This is a project or 
folder in a Graphic Hub.
Watchfolder path: The absolute path of the watchfolder. This is a folder in the local file 
system or on a network share drive.
Interval: The scan interval in minutes. Determines in which intervals the watchfolder is 
scanned.
Extension: Shows if files have their file extension appended to their name.

To Add a Watchfolder 
Open Import > Watchfolders .
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Click Add watchfolder at the bottom left (1) to show the Add watchfolder dialog (2).

Select a watchfolder by clicking the browse icon (...) on the right side and choosing a folder. 
The folder list consists of folders on all local drives and correctly mounted network share 
drives.

Alternatively, manually enter the absolute path of the folder.
Choose the length of the additional scan interval in minutes by either entering a value 
manually or increasing/decreasing it using the up/down arrow buttons.
Choose if files have their file extension (i.e. file type) appended to their name by checking/
unchecking the Add file extension checkbox. (e.g. the files image1.jpg, image1.png and 
image2.bmp are imported as image1_jpg, image1_png and image2_bmp if the box is 
checked).

Select a destination directory from the drop-down menu by checking the directory. By 
checking multiple destination directories, images are imported to multiple 
destinations. More details regarding the destination directories is listed in the drop-down 
menu: Destination reads the absolute path of the destination directory on the 

Note: For a network share drive to appear in the folder list, it needs to be mounted 
as the SYSTEM user, because the ImEx Agent service is running under the SYSTEM 
user.



Note: It is not advised to deactivate file extension adding as files with identical 
names overwrite each other on upload. Which of these persists depends on its 
position in the upload queue (i.e. the last one that gets uploaded is then the file on 
the Graphic Hub).
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specified Graphic Hub.

Click Add to add the watchfolder. The new watchfolder appears in the Watchfolders list:

To Change Watchfolder Scan Interval
You can change scan intervals of your watchfolders. The ImEx Agent periodically scans the content 
in teh watchfolder in addition to the monitored update notifications from the file system. 

Open Import > Watchfolders .
Click on the watchfolder you want to re-configure the scan interval for.
Change the length of the scan interval in minutes by either entering a new value manually or 
increasing/decreasing it using the up/down arrow buttons.
Click Apply to apply the change. The new scan interval is applied to the watchfolder and is 
shown in the Interval column.
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To Remove a Watchfolder
Open Import > Watchfolders .
Remove the desired watchfolder by clicking the trash can icon at the far right of the 
watchfolder's entry.

4.6.4 Manage GH REST Hosts
Use the Options > GH REST hosts page to configure the Graphic Hub REST hosts used by the GH 
ImEx Agent.

 

Status: The current GH REST host status. If a warning or an error is shown, hovering over the 
icon displays additional information.
GH REST: The GH REST host URL.
Graphic Hub: The Graphic Hub to which the GH REST is connected.
Username: Graphic Hub username that is used.
Authentication: Authentication method (Basic means HTTP basic authentication).
Imports: The number of imports that are currently performed on this GH REST (refresh 
interval is five seconds).

To Add a GH REST Host
Open Options > GH REST hosts.
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Click Add GH REST host at the bottom left (1) to show the Add GH REST host dialog.

Select a Graphic Hub REST host to use for importing assets. A GH REST host can only be 
added once. Already configured hosts are disabled in the selection drop-down (A). You can 
also enter the host manually, in the format http://resthost:port/. The GH REST must be 
bound and connected to a running Graphic Hub.

Note: GH REST version 2.0.1 and Graphic Hub version 3.0.1 or higher are required.
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Provide a valid GH username and password from the Graphic Hub you are connecting to.
Click Add to add the destination directory. The new GH REST appears in the list.
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To Remove a GH REST Host
You can remove GH REST hosts that are not referenced/used by any of the configured import 
directories. You can view a list of GH REST hosts in use under Import > Destination directories.

Open Options > GH REST hosts.
Remove the desired host by clicking the trash can icon at the far right of the host's entry.

4.6.5 Manage Pre-Authenticated Hosts
Go to Options > Pre-Authenticated Hosts to view a list of configured pre-authenticated hosts that 
are used by the ImEx Agent to authenticate at external HTTP image sources.
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Status: The current Pre-Authenticated host status.
Host: The URL of the configured Pre-Authenticated host.
Username: Pre-Authenticated host username.
Password: Pre-Authenticated host password.
Authentication: Pre-Authenticated host authentication method.

To Add a Pre-Authenticated Host
Open Options > Pre-Authenticated Hosts.
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Click Add Pre-Auth host at the bottom left. This enables the Add Pre-Authenticated Host 
pane:

Enter the URL for the host you are pre-authenticating, as well as the Username and 
Password.
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Click Add. This adds the Pre-Authenticated host to the list view.

To Remove Pre-Authenticated Hosts
You can remove pre-authenticated hosts that are not in use.

Open Options > Pre-Authenticated Hosts.
Remove the desired host by clicking the trash can icon at the far right of the host's entry.

4.7 Monitor The Asset Import
You can view current import progress, asset availability and status from the Report menu.

4.7.1 Monitor Distribution Plans
A distribution plan describes the content, the storage location(s) (multiple destination directories) 
and the timeline of an import operation. A distribution plan represents a set of assets that should 
be available on a number of destination directories during a certain period of time.

Select Distribution plans from the Report menu, to display an overview of current distribution 
plans.

Note: The import configuration (distribution plans, asset import schedules, availability 
report) is not persistent and lost when the ImEx Agent service is stopped/re-started.
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The overview contains the following information:

Column Details

Status Displays the current status of the distribution plan.

 Green check mark: Everything is okay.
 Two arrows in a circle: The ImEx Agent is currently 

working.

 Hourglass icon: The distribution plan is waiting to 
start work.

 Orange warning icon: A set upload has warnings or 
errors.

 Red error sign: Destination directory error.
 Inactive symbol: For expired items.

Type Displays the type of the distribution plan.

 Calendar icon: Media staging (MSE triggered).
 Folder icon: Watchfolder.

Distribution plan The name of the current distribution plan (if set) or 
watchfolder location.
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Column Details

Earliest use Denotes the start time of this distribution plan. All assets 
should be available at this point in time.

Also used to prioritize imports. Does not apply to 
watchfolders.

Expires Denotes the end time of this distribution plan. Does not 
apply to watchfolders.

Destination The destination directories this distribution plan imports 
the assets to.

Availability Current progress / availability of all assets on all 
destination directories. 

4.7.2 Monitor Availability Report
An availability report contains the content of an import, including additional information about the 
state and location.

Select Availability report from the Report menu to display an overview of all assets that are 
scheduled for import.

 
The overview provides the following functionality:
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Area Details

1 Filter by asset status. Only assets with the selected states are displayed.

2 Filter by custom text, date, destination directory, title of distribution 
plan.

3 Grid view of assets.

Monitor Availability Report for a Specific Distribution Plan
Go to Report > Distribution plans.
Click the Availability column to View availability reports for a specific distribution plan. 

 
All assets for this specific distribution plan are shown:
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To investigate asset errors from this view, look at the Details column, which contains 
information about why an asset was not uploaded in case of an error. Use the filter buttons 
to display only assets in the desired state, as for example, errors or warnings.

4.8 Log And Report
A general GH ImEx Agent related log can be viewed under Report > Logs.
You configure the log level under Options > Configuration. 
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Furthermore, you can download an archive of all log and configuration files from Report > 
Export. This is particularly useful when troubleshooting and for support requests.

4.8.1 To View ImEx Agent Logs
Navigate to Report > Logs  to display the logs section. 
Search with custom text using the text field in the top right hand corner. 

4.8.2 To Manage Reports
Navigate to Report > Export.
The Export section displays all previously created report exports.

Select one or multiple exports
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4. Click Download to download a .zip file containing information about ImEx Agent settings 
and current configuration.

4.8.3 To Create a Report
Click Create (1) to immediately generate an report export. The newly generated report is added to 
the list (2). 

Note: The report archives are stored in a temporary directory of the operating system, not 
persistent, and are lost when you stop or restart the ImEx Agent service.
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4.9 Load Balancing
It is possible to bind multiple REST services to the same Graphic Hub. This can increase 
performance and decrease the workload of each GH REST by utilizing multiple GH RESTs. 
Furthermore, multiple GH RESTs ensure a higher degree of redundancy and fault tolerance.

The ImEx Agent automatically uses each configured GH REST that is available based on the 
connected Graphic Hub. It i possible to add GH REST services at any time and remove them if it is 
not utilized.

If multiple GH RESTs are used for an destination directory can be seen in:

Import > Media staging in column GH REST, which contains multiple values.
Options> GH REST hosts when the Graphic Hub column contains the same value.

The ImEx Agent detects if e.g. a GH REST is bound to a different Graphic Hub and operates with 
the currently available GH REST connections. If connection to a Graphic Hub is completely lost that 
has currently used destination directories on it then a proper error is reported.

4.9.1 ImEx Agent Related Configuration
There are certain configuration options in the GH ImEx Agent that influence the import behavior.

Navigate to the ImEx Agent configuration interface, for example, http://127.0.0.1:19390/
index.html
Go to Options > Configuration.
Look at the Import settings section.

 
The Maximum RAM usage in Megabyte defines the amount of RAM the ImEx Agent is 
allowed to use for caching downloaded files. If there is not enough RAM available, it uses the 
hard drive to cache files.

Note: It is recommended to configure the bound REST services to have identical content 
size limits. The ImEx Agent does not automatically distribute assets to RESTs with 
appropriate content size limits.



Warning: The default settings ensure a properly working ImEx Agent. Changing these 
values may decrease ImEx Agent performance.
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4.9.2 GH REST Related Configuration
There are certain configuration options in the GH REST that influence the GH ImEx Agent import 
behavior.

Navigate to the GH REST configuration interface, for example, http://127.0.0.1:19398/
config/index.html.
Go to Configuration > Viz GH Rest. 

4.10 Troubleshooting GH ImEx Agent
This page provides help for troubleshooting the following scenarios:

Unable to Connect to GH ImEx Agent Service
Cluster Configuration Report Errors
Status Box Displays an Error
Status Box Displays a Warning
Media Staging Status Shows an Error
Media Staging Status Shows a Warning

Warning: Please be aware that a mis-configured Graphic Hub REST service may cause the 
system to not work properly.



Warning: Keep the default values, and only reduce them if resource demand is too 
high. Increasing these values is not recommended, as this can cause system 
instability.



http://127.0.0.1:19398/config/index.html
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4.10.1 Unable to Connect to GH ImEx Agent Service
This indicates that the GH ImEx Agent HTTP server is not accessible or that the service is not 
running.

Press WINDOWS + R.
A Run window opens in the bottom left corner.

Enter services.msc  and click OK. An overview of services opens.

Check whether the Viz GH ImEx Agent service is in Running status.



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  282

5.

6.

1.

2.

3.

If the service is not running, right click the Viz GH ImEx Agent service and 
select Start or Restart. 

In the ImEx Agent web interface, click Retry to connect or refresh the page in the browser.

4.10.2 Cluster Configuration Report Errors
Check Graphic Hub REST and ImEx configuration. Change to use Hostnames instead of IP 
Addresses.
When configuring, the Cluster has to be running and Main and Replication have to be 
reachable from GH REST Host and ImEx Host.
When either the Main or Replication server in a cluster is down, the UI reports an error even 
if ImEx is importing just fine. Make sure the cluster is running properly!
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4.10.3 Status Box Displays an Error
Click on the error icon to get forwarded the page where you can investigate the error.

In this example, we are taken to the GH REST hosts overview page. Hover the mouse over the 
error to display more information, for example, Request failed: Status='502'. 

The status code 502 Bad Gateway is returned because the Graphic Hub or REST host used in 
a Distribution plan is either not running or reachable.
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4.10.4 Status Box Displays a Warning
Click on the warning icon to get forwarded the page where you can investigate the warning.

In this example we are taken to the GH REST hosts overview page. Hover the mouse over the 
error to display more information, for example, GH-Rest not reachable.

Note: ImEx displays a warning although GH REST is not reachable. This is proper behavior, 
because the given host (here, http://TUTORIAL02:19398) is not referenced by any import 
jobs, as you can tell from the enabled trash can icon.
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4.10.5 Media Staging Status Shows an Error

Hover over the error icon to get further information:
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2. In this example, the destination directory /data/ImportDirectory01 has been deleted. To 
resolve the error, select an existing folder by clicking the browse (...) icon.
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3. Selecting an existing folder/project resolves the error:
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1.

2.
3.

4.10.6 Media Staging Status Shows a Warning
Hover over the warning icon to get further information:

In this example, the current folder has been renamed.
To remove the warning, click the warning icon and Acknowledge to remove the warning.
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5 Graphic Hub Manager
The Graphic Hub Manager is the administrative tool for the Graphic Hub. It enables the 
administration of files and folders over multiple Graphic Hubs, for such tasks as searching, and 
working with Deploy Agents.

This section contains information on the following topics:

Main Menu
Preferences
Explorer
Servers and Folders
Graphic Hub Login and Log Out
Add-ons Panel
Journal Panel
Alerts
Archives Panel
Action Log
Graphic Hub Manager Customization
Enable a Graphic Hub for a Virtual Studio

5.1 Main Menu
The main menu contains the following items:

Server Menu
View Menu
Tools Menu
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Extra Menu
Pilot Menu
Info Menu

5.1.1 Server Menu

Login...: Opens the Login window, used to log on to one or more Graphic Hubs.
Logout: Opens the Log out window used to log out from a Graphic Hub.
Terminals...: Opens the Terminals Window. The Terminals monitor window can be used to 
monitor available terminals on the network.

Shutdown...: Opens the Shutdown window, used to remotely shut down servers (see Graphic 
Hub Shut Down ).
Check...: Opens the Check Server window where a search for Data Errors in the internal 
structure can be performed. Requires the user to be logged on as an Administrator.
Import

Viz 2.x data: Opens the Import window. From this window it is possible to import a 
Viz 2.x data folder to the selected database.
Viz 2.x archive(s): Opens the Import window. From this window it is possible to import 
one or more Viz 2.x archives from a folder to the selected database.
Manually selected Viz 2.x archive(s): Opens the Import window. From this window it is 
possible to import one or more Viz 2.x archives to the selected database.
Resume from canceled or crashed import: Opens the Import window. From this 
window it is possible to resume from a failed import by using an automatically created 
import backup file.

Note: Terminal monitoring is only supported for Graphic Hub Terminal versions prior 
to version 3. For Terminal 3, connect to the Terminal’s web interface.
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Edit preferences: Opens the import Preferences window. From this window it is 
possible to define various preferences for the import operation, for example the root 
directory for import log files.

Differences: Opens the Server Diff window. From this window it is possible to detect 
differences between two servers, or the servers in a cluster environment (see Detect and 
Solve Server Differences).
Administer journal entries: Shows/hides the Administer Journal Entries panel in the Main 
window (see Journal Panel ).
Configure Alerts: Opens the Alerts panel, where e-mail notifications and recipients can be 
configured for an event where errors occur in the system (see Alerts ).
Exit: Automatically logs out from all connected Graphic Hubs, and closes the Graphic Hub 
Manager.

5.1.2 View Menu

Toolbars: Select which tool bars to view:
Main
Servers and Folders
Folders and Files
Quick Search
Layout

Panels: Select which Panels to view:
Servers and Folders
Search Panel (see Import External Images)
Add-ons Panel

Archives: Open the Archives Panel
Messages (Chat): Show/hide the chat panel in the main window.
Logging panel: Opens the Logging Panel, which shows logged messages, which includes:

Error messages
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Warning messages
Info
Update messages
Tick the Write to log-file to write the selected messages to the Graphic Hub log file, if 
required.

Duplicates: Open the duplicates window. From this window it is possible to locate duplicate 
server files (see Locate Duplicate Files ).
Object types: Opens the Object Types window.
Active sessions: Opens the Active Sessions window. From this window it is possible to 
monitor all active sessions.
Layouts: Select, save and maintain layouts:

Load layout: Select a layout to load.
Save current layout:
Save current layout as...: Save the current layout as a new layout.
Lock/Unlock current layout ‘xxx’: Lock or Unlock the current layout.
Maintain layouts: Opens the Maintenance of layouts window.

Refresh explorer: Refreshes the Explorer.

5.1.3 Tools Menu

Monitor servers: Opens the Monitor Servers window. This window shows an overview of all 
the servers Graphic Hub Manager is logged in to.
Administer users and groups: Opens the Administer Users and Groups window. From this 
window it is possible to manage users and groups on the various servers (see User and 
Group Management ).
Administer keywords: Opens the Keywords window. From this window it is possible to 
manage the Keywords in the database.
Administer add-ons: Opens the Add-ons Panel.
Administer tasks

Running deploy tasks: Shows/hides the Running Deploy Tasks panel in the Main 
window.
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Scheduled deploy tasks: Shows/hides the Scheduled Deploy Tasks panel in the Main 
window.
Finished deploy tasks: Shows/hides the Finished Deploy Tasks panel in the Main 
window.

Search by UUID: Opens the Search by UUID on server window, used to search for files in the 
connected databases using universally unique identifiers.
Configure deploy agent: Opens the Properties of Deploy Agent dialog box. From this dialog 
box it is possible to define various Graphic Hub Deploy agent settings (see Deploy Agent 
Modes). This menu-option is only available in setups with an installed Graphic Hub Deploy 
agent.
Export settings (incl. layouts) to file: Opens a window from where it is possible to export all 
the workstation-based customizations to the Graphic Hub Manager, such as changes to any 
of the panels, column layout and visibility, as well as the user interface in general.
Import settings (incl. layouts) from file: Opens a window, from where it is possible to import 
all the workstation-based customizations to a Graphic Hub Manager, such as changes to any 
of the panels, column layout and visibility, as well as the user interface in general.
Edit preferences: Opens the Preferences window. From this window it is possible to define 
various system preferences.

5.1.4 Extra Menu

Viz VR Studio Setup: Allows you to import the enabling XML file so that Graphic Hub can 
support a virtual set environment (see Enable a Graphic Hub for a Virtual Studio).
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5.1.5 Pilot Menu

Differences...: Opens the Pilot data differences panel.
Create Pilot deploy task...: Opens the create Pilot data deploy task panel.
Import...: Opens the import Pilot data panel (see Main and Replication Servers).

5.1.6 Info Menu

License info: Opens the License Info window. From this window it is possible to monitor the 
license information for the available servers.
About: Shows the software version and build number of the Graphic Hub Manager.
Help: Opens the Graphic Hub online help file.

5.2 Preferences
The Preferences window, located under Tools > Edit Preferences, shows all the system preferences 
and is divided into the following panes:
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General
Import
Viz
Monitor Servers
Agents
Archives

5.2.1 General
The General preferences consist of:

Login
Login Profiles
Timeouts and Buffer Settings
Deploy Direct Copy
Startup
CSV Export
Look

Login
In the Login panel, set the Start-up and Login preferences.
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TCP Port used for Logins: Sets a TCP port to be used for Log-ins. Click Set default to set the 

TCP Port back to its default value ( 19396 ).

Auto Login
Use Auto Login: Enables Auto Login when box is checked.
Protect Auto Login with Password: Sets a master password for auto Login.
Confirm Auto Login: Checks to require login confirmation for the Graphic Hubs which 
are part of the Auto Log-in list.

En-/disable servers for Auto login and change Auto login order: Selects which servers to use 
Auto Login.
Up/Dn./Top/Bot.: Changes the Auto login order of available servers.
Pre-check availability of servers before login: Contacts servers designated for Auto login 
before actual login when selected. If they cannot be contacted, they are automatically 

Note: This option is not available if Protect Auto Login with Password is 
enabled. When Protect Auto Login with Password is checked, automatic login is 
disabled.
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unchecked for Login and diagnostic information shows in the according line of the server in 
the login window.
Enable 'Login to multiple servers' using Auto login at any time: Provides the option Login > 
to multiple servers in the main menu, under Server when selected.
Enable 'Logout for all Servers': Provides the option Logout > from all servers in the main 
menu, under Server when selected.

Login Profiles
Click this tab to configure different Login Profiles for use with Auto Login. Use Login Profiles to 
configure which servers and associated Deploy Agents should be logged onto by Auto Login.

Login profiles: Selects, creates or deletes login profiles.
Choose servers for use in login profile <login profile>: Selects which servers to include with 
the login profile.

Note: Complete automatic login to Graphic Hubs is only available if Auto login is not 
protected with a (master) password, if a Login profile does not exist and if Confirm 
Auto log-in is not checked. And even if all those conditions apply, automatic login is 
not started if Precheck availability of servers before login is ticked and not all of the 
servers seem to be available for some reason.
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Choose deploy agents for use in login profile <login profile>: Selects which Deploy Agents to 
include with the login profile. If no Deploy Agents are selected for the Login Profile, Deploy 
Agent configuration and deploy tasks are unavailable for the duration of session. If no 
Deploy Agent is configured in the Agents section, this list is empty.
Revert: Reverts settings before Apply or OK is clicked, if required.

Timeouts and Buffer Settings
From this panel it is possible to define various timeout values related to communication with 
Graphic Hubs. Changing the values of the timeout settings may have a significant impact on how 
the Deploy Agent works. The default values should only be changed if the Deploy Agent has 
problems with servers connected through a slow or congested network, or that have an unusually 
high server load. Increasing the timeout values may solve the problems in such cases. Decreasing 
the values does not improve the general performance of the agent, and is not recommended.

Related to communication with Graphic Hubs:
Establishing communication timeout (in seconds): Sets the maximum amount of time 
for a Deploy Agent to connect to a server. If the server does not respond in this set 
time, due to network characteristics or server load, it is considered as offline.
Communication round trip timeout (in seconds): Sets the maximum amount of time 
for the Deploy Agent to wait for a reply from the server. If the server does not respond 
in this set time, due to network characteristics or server load, the affected task may be 
paused by the Deploy Agent.
Cluster failover timeout (in seconds): Specifies the period that a task is waiting for a 
notification from the failover server to switch over if a main server becomes 
unavailable. If this time exceeds, the agent attempts to manually connect to the 
failover server. This option is relevant for Deploy Agents that operate in a setting with 
a failover server.

Deploy Direct Copy
In the Deploy Direct Copy panel set the Direct Deploy Copy defaults.
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Default Behavior options: Set the defaults for Deploy Direct Copy:
Rebuilds original structure,
Rebuilds structure under target folder,
Copies to target folder only.

Overwrite existing objects: Overwrites files with the same name existing in the target folder.
Overwrite existing references: Overwrites the file references if the same file name exists in 
the target folder.
Overwrite owner: Keeps the original owner of deployed files when selected. If the file existed 
already on the server, the owner of the pre-existing file is overwritten.
Overwrite creation date: Keeps the original creation date when selected. If the file existed 
already on the server, the creation date of the pre-existing file is overwritten. If not selected, 
the creation date is set to the time of deployment.
Overwrite modification date: Keeps the original modification date when selected. If the file 
existed already on the server, the modification date of the pre-existing file is overwritten. If 
not selected, the modification date is set to the time of deployment.
Default Multi-server processing options:

Deploys all files to the first server, then to the second, and so on.
Deploys one file to all servers, then another file and so on.

Startup
In the Startup panel, specify if the listed windows should automatically open on a new start of the 
Graphic Hub Manager. Also, specify if this should depend on if those windows were open when the 
Graphic Hub Manager was last exited.
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Automatically open windows that were visible on last exit: Opens all windows listed below, if 
they were open on the last exit when selected. If not ticked select which windows to open 
from the list below:
Automatically open 'Monitor servers' / 'Active sessions' / 'Terminals': Opens a window on 
start-up when selected.

But only if it was open the last time: Opens the window at start up only if it was open 
on last exit.

CSV Export
In the CSV Export panel, specify the default settings used when exporting search results (explorer 
and archive search).

Value separator: Determines value separator used in the generated CSV file (one of ".", ";", 
TAB or user defined)
Export with/without column-names: Assigns a header row to the CSV file when set.
Export of currently visible or all columns: Does not export hidden and removed columns by 
default (can be enabled in configuration).

Look
In Look panel set the style of the User interface.
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Visual Style: Sets the user interface style from the drop-down list.
Docking Tab Colors: Assigns tab colors in the GUI.

5.2.2 Import
In the Import panel, set the data directory for log files and temporary files used for the import of 
Viz 2.x data and archives (see Import Viz 2.x Data and Archives).

It is also possible to disable the auto-import when an import resumes after a canceled or crashed 
import procedure.

Directories: Shows the root directories for log and temporary files. Select Browse to change 
the directories if required.
Behavior: Starts import automatically if the system is resumed when selected.
Troubleshooting: Shows the location of an alternate import executable (viz_import.exe) if 
there are problems with the Graphic Hub Manager. This field normally should be empty. 

Note: This alternate import executable could either be an older one than the one 
that came with the installation or a newer/updated one sent out by Vizrt.
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5.2.3 Viz

General
In the Viz panel, define the TCP port and Viz executable to use within the "Preferences" dialogue in 
the files, folder or search results view. This enables Graphic Hub Manager to send transfer control 
protocol commands to the viz executable to re-save files and folders.

5.2.4 Monitor Servers
In the Monitor Servers panel, define various disk and memory warnings, related to free disk space/
memory. It is also possible to define warnings when the license expiration date approaches.

Warnings
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5.2.5 Agents
The Agents panel is used to set the preferences for automatic updates on running Deploy Agents.

Deploy

Search for deploy agents on these UDP ports: Enter the UDP port where to search for 

available Deploy Agents. Deploy agents are configured to listen on port 19392 , by default. 

If they are configured to listen on another port, this port should be added here

Use this timeout for receiving answers from deploy agents: Sets the timeout (milliseconds) 

for a Deploy Agent search. Default is 100  ms.

Deploy agents not reachable via UDP broadcast and/or for use in Login Profiles: Manages 
Deploy Agents (Add, Remove, Modify or change the order of listed Agents) that are running 

Note: With a UDP search, the Graphic Hub Manager only finds Deploy Agents which 
listen on the ports which are added here, and only those which are running on 
machines within the same subnet as the machine running the Graphic Hub Manager 
itself.



Tip: If there are problems with the network condition, try to increase the default 
value.
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on a machine, which is outside the subnet of the machine on which the Graphic Hub 
Manager is running. If Deploy Agents are to be used in Login Profiles, they must be added 
here even if they are on the same subnet.

When Add or Modify is clicked it opens the Deploy Agent window:

IP address: Enter an IP address or host name.
UDP port: Enter the UDP port number.
Received timeout: If the Deploy Agent does not answer in the given timeout or does so 
only sometimes, you may increase this timeout value here to make sure that the 
Graphic Hub Manager can always contact the Deploy Agent.
Name: Name of the host/machine (auto filled).

Intervals (in seconds): Timeouts for answers from Deploy Agents:
Interval to get updated info for running tasks: Sets the interval, in seconds, in which updated 
information about tasks executed by the Deploy Agents should be requested.
Interval to try to reconnect to lost agents: Sets the interval, in seconds, in which the Graphic 
Hub Manager should try to recontact Deploy Agents for which communication with them was 
broken.

5.2.6 Archives
In the Archives panel set the preferences for the import and export of Archives as well as some 
general preferences.
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General Preferences

Watched folders: Lists all Watched folders.

Add...: Adds a new Watched folder.

Remove selected: Removes a Watched Folder (this removes the folder as a Watched folder, 
but the folder stays in the Graphic Hub Manager Customization).

Note: The Archives view automatically lists all (Viz 3.x) archives (extension 'via') 
which it finds in any of the given watched folders. Sub-folders of watched folders are 
not automatically watched, make sure to specify each single folder, as required.



Tip: If a folder shows as yellow, there are no Viz Archives in that folder. If a folder 
shows as red, it currently is not accessible or does not exist.
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Import Preferences

Default settings...

Import mode: Sets the import mode:
Rebuilds original structure.
Rebuilds structure under target folder.
Copies to target folder only.

Overwrite mode: Sets the overwrite mode:
Overwrite: Overwrites all files on import. Files are not overwritten if the destination file 
has exactly the same content.
Duplicate: Imports with a new file name if a file with the same name exists.
Skip: Does not import if a file already exists.
Force link name creation: Creates links to all links from the original and imported file 
if the file to be imported has the same data, but has different file links.
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Select which data from the source file is applied at import:
Overwrite owner.
Overwrite name.
Overwrite create date.
Overwrite access rights.
Import add-ons.
Import keywords.

Export Preferences
In the Archives Export panel, create new and view Archive export Templates.

Note: Overwrite options (Overwrite owner, name, create date, access rights): Defining 
whether the previous owner, name, create date or access rights of the file should be 
overwritten with the current owner, name, create date, access rights after a successful 
import. If the file already existed on the target server the parameters of the existing file 
are kept and not overwritten. The file parameters on the target server are overwritten if a 
successful import did happen and the file was newly created on this server.



Note: As these settings are under the import section, they change the parameters of the 
file being imported.
For example, if a file has a Owner = Owner1 and Creation Date = yesterday and you import 
it to another server today, then: If the settings Overwrite Owner and Overwrite Creation 
Date are set, the Owner is changed to Owner2 and Creation Date is changed to today at 
successful import. The overwrite is not file-based, it is based on the file parameters 
selected at import.





Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  309

•
•
•

•

•
•

•

•

Templates for creating name of new archives: Selects a template from the list.
Remove: Removes a selected template.
Add: Adds a new template. First create the new template in New Template.

New template: Creates a new template. Select tokens to add from the Add token drop-down 
(use separators as required between the tokens).
Preview: Shows a preview of the new template.
Default template for creating name of new archive: Selects a default Template from the list 
of Templates.
Export all linknames: Enables an export of all linknames when checked. Unchecking this 
exports only the linknames from the folder/project, the file is dragged from.
Allow extended header: Enables / disables extended header functionality for archive 
creation. 

See Also

IMPORTANT: Enable this for a system with all clients at least version 3.0.0. The 
extended header flag generates incompatible archives for pre 3.0.0 versions.
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Graphic Hub Deploy Agent
Archive Folders
Graphic Hub Archives

5.3 Explorer
Below the main menu is the Explorer of the Graphic Hub Manager.

The Explorer is automatically updated immediately after changes made to files and/or folders, but 
a manual refresh of the Explorer is sometimes necessary, for example after re-enabling columns. 
To refresh the Explorer, select View > Refresh Explorer or press F5.

This page contains information on the following topics:

Explorer Columns
Column Headings

To Hide, View, Remove or Add Columns
Explorer Icons
Tool Bar

Main
Servers and Folders
Folders and Files
Quick Search
Layout

Tip: The panels in the Explorer are resizable, and they can be dragged around. Also, it is 
possible to navigate through the trees in the Explorer with the mouse pointer, arrow keys, 
or by typing the first character of the required folder/file.
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Display Files as Icons

5.3.1 Explorer Columns
When server files are shown in the Explorer view, columns are used to show information about the 
files.

There are two mandatory columns, Name and UUID (these can be hidden if required), and then 
additional columns which can be added or removed as required. Each column can be moved to a 
new position as required.

Column customization works for:

Explorer
Search results
Journal
Server differences
Scheduled tasks
Action Logs
Running tasks
Finished tasks

5.3.2 Column Headings

Name: Shows the name of the file.
Size: Shows the size of the file.
Type: Shows the file type, for example material.
Date Modified: Shows the date and time when the file was modified the last time.
Modified by: Shows the name of the user that modified the file the last time.
Date Created: Shows the date and time when the file was created.
Owner: Shows the name of the user that owns the file.
Checked out by: Shows the name of the user that has checked it out, if the file is checked 
out.
Locked by: Shows the name of the user that is working on it, if the file is session locked.
Access rights (U/G/W): Shows the access rights for user, group, and world (see User and 
Group Management).
Folder links: Shows the number of folder-links (number of folders the file is placed in).
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2.

To Hide, View, Remove or Add Columns
Right-click on the column bar.

Add, remove, hide or show columns, as required.

To customize the column order, drag the column to the required location.

5.3.3 Explorer Icons
The following icons are used in the Explorer:

Icon Description Icon Description

Regular Folder Image

Project Folder Material

Audio Material advanced

Base font Scene

Font Video

Geometry

Note: In Remove Column, UUID and Name are grayed out. They cannot be removed, 
but they can be hidden.
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5.3.4 Tool Bar
At the top of the Explorer is the Tool Bar.

Main

 Show Servers and folders: Show/hide the Servers and Folders, or click View > Servers and 
Folders.

 Show search: Show/hide the Preferences.
 Show add-ons: Show/hide the Add-ons Panel.

Servers and Folders

 One level up: Jump one level up in the Servers and Folders tree structure.
Address: Shows the current folder path.

From the drop-down list, it is possible to see the history of all folders that have been used within 
this session. To re-open to one of these folders, select it from the list. The format in which the 
history is shown is <ServerNumber>:\data\<path>.  The history of a server that has been 
disconnected is no longer available.

Folders and Files

Type: Filter file types. Click the arrow to the right to toggle between the options.

 Show/Hide project and folders: If enabled, the subprojects/sub-folders of the selected 
folder show in the Explorer list.

 Display icons/Details: Toggles between showing files in the Explorer with details or as 
icons.

Quick Search

Search in: Graphic Hub Quick search function. Select a server to search in, enter a search 

string and press ENTER or click on  to start a Free text search on the selected server.
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Layout

Layout: Loads a saved layout. Options:
System Clean (Locked): (Basic standard layout)
System Default: (as last saved (default layout)

Save: Saves the current layout.
Save as...: Saves as a new layout.

5.3.5 Display Files as Icons
By default, the files in the Explorer are presented with detailed information. To view the files as 

icons, toggle the  (As Icons) button in the Tool Bar.

 
When files are viewed as icons, in the lower right corner of the icon characters show the file type:

Icon Description Icon Description

Audio Image

Base font Material

Default Material advanced

Font Scene

Geometry Video

Additional information may also be shown on the icon:

Icon Description Icon Description

File holds more than one folder-
link

File is checked out

Note: A Layout is local for the current machine in use.

Note: The icons can also be enabled from the shortcut menu of the Explorer.
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Icon Description Icon Description

File is session locked File is both session locked and 
checked out

See Also

Graphic Hub Manager Customization

5.4 Servers And Folders
The Servers and Folders panel displays folders, and the servers they are on, in a tree structure.

 
Right-click a server folder in the tree to open a context menu. From this menu, the folder tree can 
be expanded or collapsed, and, for example, new folders created or access rights set.

The server tree order can be changed by drag and drop. The server order changes, but server 
numbers stay the same.
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This page contains information on the following topics:

Folders
Tree Structure

To View the Content of a Folder
Working with Folders

To Expand Folders
To Collapse Folders
To Create a New Folder
To Rename a Folder
To Move a Folder
To Change the Owner of a Folder
To Set Rights for a Folder
To Delete a Folder

Folder Properties
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To View the Properties of a Folder
To View the Properties of Multi-selected Folders
General Properties
Add-Ons Properties

Working with Files
Overwrite Files
To Create Linked Files
To Create Duplicate Files
To Create Duplicate Files Including Referenced Objects
To Move Files
To Overwrite Files
To Re-save with Viz Executable

File Properties
To View the Properties Assigned to a File
General Properties
Keyword Properties
References and Link Properties
Duplicates
Total Size Properties
Advanced Properties
File History
File Availability
File Add-ons

Folder and File Expiration Dates
To Set an Expiration Date

Illegal Characters

5.4.1 Folders
The server tree can contain two types of folders:

Project folders, displayed with a blue folder icon.
Regular folders, displayed with a yellow folder icon. Project folders cannot be created inside 
a regular folder, but can contain regular folders. Both types of folders can be dragged 
around after being added to the server tree. Also, project names must be unique and in 
compliance with the list of illegal characters.

 
In Viz Artist, the difference between a regular folder (2) and a project folder (1) is that by defining 
a working project, the tree can be collapsed so that only the currently selected project and its sub-
folders and sub-projects folders are shown.
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5.4.2 Tree Structure
Within the database, files are organized in a virtual structure of project and regular folders. This 
structure is shown as a tree in the Servers and Folders panel.

 
In this panel, all connected servers are shown as root entries. These entries show the name of the 
Graphic Hub Server, the Graphic Hub Naming Service the server is registered on, and the current 
user name.

The level below the root entry contains the data project, which other clients refer to. New projects 
or regular folders/files can be added under the data project.

The data directory holds folders that the server files are stored in.

To View the Content of a Folder
Click the folder in the tree, or
Double-click a subfolder in the Explorer, or
Right-click the folder, and select Open.

The server files in the selected folder are then shown in the Explorer.

5.4.3 Working with Folders

To Expand Folders
After logging in, the branch representing this database is collapsed. To expand the branches, use 
one of the following options:

Click to the left of the branch.
Double-click the branch to be expanded.
Right-click the required branch and select Expand.

Tip: It is possible to create folders on the same hierarchy level as data, but these folders 
are not accessible from client applications such as Viz Artist. In these folders, it is practical 
to move data that should not be worked on anymore, yet is not ready to be deleted.
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Right-click the required branch and select Expand Completely to expand the branch and all 
its subbranches.

To Collapse Folders
Use one of the following options:

Click to the left of the branch.
Double-click the branch to be collapsed.
Right-click the required branch and select Collapse.
Right-click the required branch and select Collapse Completely to collapse the branch 
and all its subbranches.

To Create a New Folder
Use to create new Regular or Project Folders.

Right-click on a folder, or select the folder and right-click in the Explorer.
Select New > Project or Folder.

To Rename a Folder
Right-click the folder and select Rename.

To Move a Folder
Drag the folder from either the servers and folder or the Explorer onto the target 
destination. The Action Log for moving folders is shown.
Click Duplicate. You can also use standard Windows functions CTRL + X, CTRL + V and Right-
click > Cut/Paste.

To Change the Owner of a Folder
Right-click the folder.

Note: A new project folder cannot be created in a regular folder.

Note: The data project below the server root entry cannot be renamed. Folder names 
must be unique, and in compliance with the list of illegal characters below.



Note: This procedure only applies to moving a folder within a single server. For 
information about moving folders between multiple servers, see Schedule a Deploy Task.
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Select Set Owner. 

Select the new owner from the drop down list.
Select the Apply to all subfolders and objects check box, if required.
Click Set.
The Action Log opens.
Click Set owner.
Click Close.
The owner of a folder can also be assigned from the folder Properties window.

To Set Rights for a Folder
Right-click the folder.
Select Set access.

User: The owner of the folder.
Group: All the members of the group the owner belongs to.
World: All database users.

Define the new rights.
Click Set.
The Action Log for changing the rights is shown.
Click Set access.
The rights for a folder can also be assigned from the folder Properties window.

To Delete a Folder
Select the folder.
Delete the folder:

Press Delete, or right-click the folder and select Delete...
The Action Log opens.

Click Delete.
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Click Close.

5.4.4 Folder Properties
The Folder Properties window lists available properties of each folder.

To View the Properties of a Folder
Right-click a folder.
Select Properties.

To View the Properties of Multi-selected Folders
Multi-select the required folders (1).

Right-click folders with CTRL pressed, or
Select a range of folders with right-click with SHIFT pressed

Right-click on one of the selected folders.
Select Properties.
The Properties window shows the Generally combined contents of all selected folder (2) and 
is for information only.

Add-ons are not available.

Note: Only empty projects or folders can be deleted. Also, by deleting a folder from 
the Graphic Hub, the respective folder-links in the properties of the files are deleted 
too.
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General Properties

Name: Shows the name of the folder. Folder names must comply with the list of Illegal 
Characters.
Type: Shows if the folder is a regular folder or a project folder.
UUID: Shows the automatically generated UUID of the folder.
Path: Shows the path of the folder within the data directory of the database.
Name: Shows the name of the folder. To rename the folder, type a new name in the box.
Owner: Shows owner of the folder. To reassign the folder to a new user, select a user from 
the list.
Created: Shows the date and time when the folder was created.
Expires: Set an expiration date for the selected folder or file.
Contains: Shows a summary of all folders and files contained in the selected folders.
Access Rights: Shows the access rights for the folder. To change the rights, enable/disable 
one or more check boxes (see User and Group Management).
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Add-Ons Properties

 
The following folder properties are available in the Add-ons panel:

Name: Folder name.
Type: Project or Regular Folder.
UUID: Automatically generated UUID of the folder.
Text tab: Assigned add-ons as text.
Edit tab: Enables editing and assignment of add-ons.
XML tab: Assigned add-ons as XML.
Search: Search text within assigned add-ons.
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5.4.5 Working with Files

Overwrite Files
When a file type is to be linked or duplicated in another folder, and the same file type with the 
same name already exists in the destination folder, the Overwrite Existing File dialog menu opens.

Select an option from the window:

Yes: Overwrites the existing file.
Yes to All: Overwrites all existing files.
No: Does not overwrite the existing file, and create a new file.
No to All: Does not overwrite all existing files and create new files.
Cancel: Cancels the action.

To Create Linked Files
A link to the file is created in the destination folder.

Linked files have the benefit of saving disk space and enhancing system performance. It is 
especially useful when a file is referenced in many places. For example, a station logo is best to be 
referenced as a link rather than duplicated in many locations.

Select the required file.

Drag the file to the target folder and release.
In the Action Log click Link.

If the same file type, with the same name, already exists in the destination folder select to 
overwrite, or not overwrite, the existing file.

Note: Multiple files can be selected.
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Click Close.
or

Select the required file.

Create a linked shortcut:
Right-click and select Link (create shortcut), or
Press CTRL + Y.

Select the target folder.
Link the file:

Right-click on the target folder and select Link here, or
Right-click in the folder area and select Paste

In the Action Log click Link.
If the same file type with the same name already exists in the destination folder select to 
overwrite, or not overwrite, the existing file.
Click Close.

To Create Duplicate Files
Select the required file.

Press CTRL and drag the file to the target folder and release.
In the Action Log click Duplicate.

If the same file type, with the same name, already exists in the destination folder select to 
overwrite, or not overwrite, the existing file.
Click Close.
or

Select the required file(s).
Copy the selected file(s).
Select the target folder.
Duplicate the file:

Right-click on the target folder and select Duplicate here, or
Right-click in the folder area and select Paste

Note: Multiple files can be selected.

Note: Multiple files can be selected.
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In the Action Log click Duplicate.
If the same file type with the same name already exists in the destination folder select to 
overwrite, or not overwrite, the existing file.
Click Close.

To Create Duplicate Files Including Referenced Objects
Select the required files. Right-click and drag files to target servers folder.
Select Copy here (DDC!). 
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3. In the Deploy Direct Copy dialog after Analyzing and checking Behavior 
options, Click Continue. 
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Click Deploy. 

 
The selected files are being deployed including all references.

To Move Files
If a the same file type, with the same name, exists in the destination folder, the moved file is set 
with a new name (for example: Yellow would be renamed Yellow(1)).

Select the required file(s).
Hold Shift and drag the selection to the target folder.
In the Action Log click Move.

Click Close.
or

Select the required file(s).
Cut the selected file(s).
Select the target folder.
Move the file(s):

Right-click on the target folder and select Move here, or
Right-click in the folder area and select Paste.

In the Action Log click Move.
Click Close.
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To Overwrite Files
A file can only be overwritten if it is in the same folder and of the same type.

Select the required file.
Drag the file to the file to be overwritten and release.

In the Action Log click Overwrite.

Click Close.

To Re-save with Viz Executable
The menu action Re-save with viz... execution starts viz.exe (if not already running) and re-save the 
selected files through Viz Engine. Be sure to define a proper Viz executable path in Tools > Edit 
preferences > Viz > General.

Note: Source and target file must be of the same type.
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Click Set..., Continue... and Re-save to initiate the viz.exe re-save.
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5.4.6 File Properties
This section describes the available properties of each file.

To View the Properties Assigned to a File
Double-click a file in the Explorer, or
Right-click a file and select Properties.

General Properties

Name: Shows the name of the file. File names must comply with the list of Illegal Characters.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
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Original name: Shows the name of the file. To rename the file, type a new name in the box. 
If changing the name of a file that has more than one folder-link, only the name of this link 
is altered. In other folders, the name is not changed.
Owner: Shows the name of the user that owns the file. To reassign the file to a new user, 
select a user from the list.
Checked out by: If the file is checked out, shows the name of the user that has checked it 
out. To check out the file, click the Check Out button. To check in the file, click the Check In
button.
Locked by: If the file is session locked, shows the name of the user that is working on it. To 
session lock the file, click the Lock button. To unlock the file, click the Unlock button.
Size: Shows the size of the file.
Created: Shows the date and time when the file was created.
Modified: Shows the date and time when the file was modified the last time.
Modified by: Shows the name of the user that modified the file the last time.
Expires: Set a date for the select file to expire.
Folder links: Shows the number of folder-links (number of folders the file is placed in). The 
box below shows the paths to folders where the file is linked.
Link name: Shows the name of the folder-link. By default, the folder-link name automatically 
equals the file name.
Access rights: Shows the access rights for user, group, and world. User refers to the owner 
of the file, group refers to all the members of the group the owner belongs to, and world 
refers to all database users.

Keyword Properties

Name: Shows the name of the file.
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Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
There is a search field for locating keywords and you can assign and remove keywords from 
the selected file.

References and Link Properties

Name: Shows the name of the file.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
References: Shows the files which are contained in the current file. For example, if you check 
the references for a scene, you see images, geometries, etc., that are used in this scene. 
Drilling down, the references of the images show the images used in that file. And so on.
File links: Shows the files where the current file is referenced. For example, with an image 
used in different scenes, all those scenes appear as file links.
Folder links: Shows all folders where the same file is linked (all shortcuts).

Duplicates

Name: The name of the selected item.
Type: Shows the item type, for example, BASE_FONT.
UUID: Shows the item’s UUID.
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Total Size Properties

Name: Shows the name of the file.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
Filters

View by Reference or View by Size.
Sort by Name, Size, Type and Name, Type and Size. 
The file’s total size in KB, MB or GB is shown. Using the tree, you can see all the 
component parts and their respective sizes.
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Advanced Properties

Name: Shows the name of the file.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
Checksum: A server-generated value to detect duplicates and differences between similar 
files. Useful for importing and replicating and deploying files; when two files are very 
similar, you can use the checksum to determine whether to overwrite or allow a parallel 
instance.
Original file csum: The file’s original checksum from before it was imported to the Graphic 
Hub. This is used to determine if a specific file has already been imported, and to improve 
duplicates discovery.
Version: Version is the last client application version that changed the file/wrote to the file. 
This should be the same as the last entry in the history.
Units: The component units of a file. A file consists of multiple units that form part of the 
internal data. Used in troubleshooting.
Attributes: Each unit has specific attributes describing it. Used in troubleshooting.
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File History

Name: Shows the name of the file.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
The file’s transaction history is shown with columns for date, user, changes and serial 
number.

File Availability
If you are logged into multiple servers, you are able to check whether a file exists and is identical 
among instances.

Name: Shows the name of the file.
Type: Shows the file type, for example material.
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UUID: Shows the UUID of the file.
Modified at: Displays last date and time modified.
Modified by: Displays last user to modify the file.
Checksum: Indicates whether the file is the identical on every server.
Availability on other servers where logged in: The availability of the same file on other 
servers where you are logged in. Even if the file name is different, if the UUID and checksum 
are the same, the file figures in this panel, shown as OK.

File Add-ons

Name: Shows the name of the file.
Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
Text tab: Assigns add-ons as text.
Edit tab: Enables editing and assignment of add-ons.
XML tab: Assigns add-ons as XML.
Search: Searches text within assigned add-ons.

5.4.7 Folder and File Expiration Dates
Each folder (and its contents) and files can be set an expiration date.

When a Clean-up of Expired items Scheduled Tasks is performed, folders and files with an 
expiration date on or before the date configured in the task are deleted. The following exceptions 
apply:

Note: Folders are deleted recursively.
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If a folder, which has expiration date before a due Clean-up operation, contains a folder or 
files that have an expiration date set after a due Clean-up operation, it is ignored in the 
delete operation. The expired folder is not deleted, although it is expired.
The deletion of a folder only happens when all folder contents, and any linked content, have 
reached their expiration date.
Any files and folders, in an expired folder, that do not have a set expiration date get deleted.
An expired folder or files, with file links, can only be deleted if all linked files are inside the 
expired folder.

After a clean-up task has completed, a log file is created: %ProgramData%\Vizrt\Viz GH 
Terminal\CleanupExpired.log. The log file contains:

Timestamp for when the task was performed.
Expired items that were found.
Number of deleted items (folders/projects/file links).
Duration of cleanup operation.
Number of physically deleted files grouped by file type.
List of errors that occurred during the cleanup operation.
List of UUIDs that got physically deleted by file type. If an expiration date is removed before 
running the Cleanup of Expired Items task, the folder and its contents, or files, are not 
deleted.

To Set an Expiration Date
Right-click the folder or file.
Select Properties...

Example: If a scene, which includes an image that is inside of an expired folder, is 
not included in the expired directory, the image cannot be deleted because it has file 
links to the scene which has not expired.
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Check the Expires box.

Click on the drop-down arrow and set an expiration date and time.

Click OK.

5.4.8 Illegal Characters
The following list of characters are not allowed in folder or file names:

Colon: (:)
Semicolon: (;)
Period: (.)
Comma: (,)
Question mark: (?)
Asterisk: (*)

Note: Click the drop-down or highlight a date number and change it, to set the date. 
Click on the hour or minutes to change the time.
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Quotation marks: (“ ”)
Angle brackets: (< >)
Braces: ({{{ }}})
Tab key escape character: (\t)
Newline key escape character: (\n)
Blank space: ( )

See Also

Graphic Hub Manager Customization
User and Group Management

5.5 Graphic Hub Login And Log Out
To log in or logout from a Graphic Hub Server the Graphic Hub Manager must be running. Before 
the Graphic Hub Manager is started make sure that the a Graphic Hub is started first (see Graphic 
Hub Startup).

This page contains information on the following topics:

Single Server Login Start Up
Multiple Server Login Start-up
Replication Server Login
Auto Login
Logout

5.5.1 Single Server Login Start Up
When the Graphic Hub Manager starts up a User Login window opens. Use this to log on to a single 
server.

Once the Graphic Hub Manager has started, more servers can be logged on to.

To Start the Graphic Hub Manager with a Single Server Login
Open the Graphic Hub Manager:

Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic 
Hub Manager, or

Note: For start up with a single server login, Auto Login must be disabled. If Auto Login is 
enabled, the start up login window is for Multiple Server Login Start-up.
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Double-click the Graphic Hub Manager desktop icon.

From the Host drop down box, select the host name of the machine where the Naming 
Service is running.

If the Naming Service host is configured for more than one Graphic Hub server, select the 
server to connect to from the Hub drop down box.
If Auto Login is required, check the Enable for Auto login check box.
From the Name drop down box, select a user from the list of users registered in the 
database, on the selected server.
In the Password field, enter the correct password.

Click LOGIN.

To Login to More Servers
After the Graphic Hub Manager Start Up, login to more servers, if required.

Click Server > Login...

5.5.2 Multiple Server Login Start-up
When the Graphic Hub Manager starts up a User Login window opens. Use this to login to a single 
server or multiple servers.

Note: Available Graphic Hub servers are shown in white. Unavailable Graphic Hub 
servers (available servers on a different sub-net), which are configured for auto-login, 
are shown in yellow.



Note: The default password for administrators is VizDb.
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When there are several Graphic Hub servers configured in the Graphic Hub Manager, it is possible 
to login to:

A single Graphic Hub Server, or
Several Graphic Hub Servers at the same time. 

If there are Login Profiles defined, select a profile to have a defined subset of servers and Deploy 
Agents to login to.

To Start Graphic Hub Manager with a Multiple Server Login
Open the Graphic Hub Manager:

Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic 
Hub Manager, or
Double-click the Graphic Hub Manager desktop icon.

Select the servers to log on to, or check the Use Login profile box and select a login profile.
Click Login.

To Login to More Servers
Click Server > Login > to one server... or to multiple servers...

Note: For start up with multiple servers (or a single server) login, Auto Login must be 
enabled (see Login in Preferences). If Auto Login is disabled the start up login window is 
for Single Server Login Start Up.



Note: Available Graphic Hub servers are shown in white. Unavailable Graphic 
Hub servers (available servers on a different sub-net), which are configured for 
auto-login, are shown in yellow.
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5.5.3 Replication Server Login
When logged to the Replication server, the administrator has rights to login to the Main server in 
the Cluster and to change the content of the host.

This is helpful to manually deal with synchronization issues in a Main/Replication server (Cluster). 
But this can also create risks for synchronization between the servers in a Cluster.

To Start Graphic Hub Manager in a Cluster on a Replication Server
Open the Graphic Hub Manager:

Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic 
Hub Manager, or
Double-click the Graphic Hub Manager desktop icon

In the Host drop down box, select the host name of the machine where the server or Naming 
Service is up and running.
In the Hub drop down box, select the name of the running server.
In the Name drop down box, select your user from the list of users registered in the 
database on the selected server.
Enter the password in the Password field.

To log in as system administrator, check the As system administrator check box.

If Auto Login is required, check the Enable for Auto login check box.

Caution: To avoid unwanted synchronization errors, leave the As system administrator
check box unchecked. Login as system administrator only when absolutely necessary.



Note: The default password for administrators is VizDb.

IMPORTANT! Use this feature sparingly and with caution.
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Click Login.

5.5.4 Auto Login
Auto login allows an automatic login to one or more Graphic Hubs, with the option of bypassing 
the credentials, as well as requiring a password for each and every server in the network.

A global password can be set for all registered servers as well.

To Enable Auto Login
Click Server > Login.
Click Preferences... in the main Login window.
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Click the Use Auto login box in the Login panel of the Preferences window that opens.

To set a global password, select the Protect Auto login with password box, and click the Set 
password button. In the dialog box that opens, enter a password, and then click the OK
button.

Alternatively, with no global password set, select the Confirm Auto login box, and then 
select the servers to include in the auto-login process. When logging in, you are prompted to 
confirm each server to be logged into. To remove a server from the auto login process, 
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right-click the server, and then from the list that appears, select Remove selected.

Click the OK button.

To Disable Auto Login
Click Server > Login > to one server...
Open the Login preferences window: Click Tools > Edit Preferences...

Note: The Login preferences window can also be opened in the main Login window. 
Click Preferences...
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Clear the Use Auto login box (1), in the Login panel of the Preferences window that opens.
Click OK.

5.5.5 Logout
This section describes how to logout of one or all servers from Graphic Hub Manager.

To Logout of One Server
Open the logout window:

Click Server > Logout > from one server... or
Press F8, or
Press CTRL + O.

Select the server from the drop down box.
Click OK.

To Logout of All Servers
If Enable Logout from all servers is configured under Tools > Edit preferences > Login:

Note: Click Server > Exit, to logout of all servers and exit Graphic Hub Manager at the same 
time.
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Click Server > Logout > from all servers... 

Click Yes.

5.6 Add-Ons Panel
The add-ons panel shows the following properties for all published Add-ons.

In the Text Tab, you can search for text within published add-ons. This search facility includes 
matching case and whole words. Text found is highlighted.
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From the Edit Tab, you can assign, unassign and edit published add-ons for currently selected and 
multiple files.
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In the XML tab, you can search for text within published add-ons. This search facility includes 
matching case and whole words. Text found is highlighted.

5.7 Journal Panel
From the Journal panel it is possible to search for journal entries and view their details. Journal 
entries are log files created according to various alert levels.

 
The Journal is a good place to start for troubleshooting problems encountered in Graphic Hub. The 
Journal records all server activities. When faced with troubleshooting scenarios, the journal is a 
good place to search for clues. The activities logged in the journal are the creation, modification 
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and deletion of objects in Viz Artist, as well as other information messages, warnings, errors and 
deploy task information.

This page contains the following topics:

Journal Tool Bar
Search the Journal

To View the Journal
To Search the Journal with Filter Settings
To View a Live Feed of Server Activities

Automatic Journal Backup
To Schedule Automatic Journal Backup

Export and Import of Journal Entries
To Export Selected Journal Entries
To Import Journal Entries

5.7.1 Journal Tool Bar

 
The Journal tool bar (1) has these options:

 Search: Search for journal entries based on the preferences defined in the Journal Filter 
frame

 Optimize search for faster export: If enabled, backup files with a large number of 
journal entries are optimized for export, by not containing all available information about 
these entries

 Import journal entries: Opens a dialog box, from where it is possible to select an XML 
journal backup file to import

 Export selected entries: Allows you to export only the entries that you choose

 Backup task: Opens the Configure Journal Backup Task window

 Switch to feed mode: Allows you to receive journal updates in real time

 Show/hide entry properties: Shows/hides the Journal Properties frame

 Show filter: Shows/hides the Journal Filter frame
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5.7.2 Search the Journal

To View the Journal
Click Server > Administer journal entries.

To Search the Journal with Filter Settings
Open the Journal panel.
In the Journal filter, from the Server drop down box, select a server.
Select an application. Your options are:

Any: Searches System and GH Deploy.
System: Graphic Hub Server. Any work done on Graphic Hub is logged in the system.
GH Deploy: All Graphic Hub Deploy Agent tasks, successful or failed, plus warnings 
and other pertinent information, are logged in the journal.

Optionally, enter a UUID of a folder or file.

From the Date drop down box, select one of the following options:
Anytime
From: Selecting this option prompts you to also enter a beginning date and time
Until: Selecting this option prompts you to also enter an ending date and time
Between: Selecting this option prompts you to also enter a beginning and ending date 
and time

In the Details Like field, enter free text like name of the task, name of the agent, or any 
description that may figure in the task.
In the Details Unlike field, enter free text like name of the task, name of the agent, or any 
description that you want to exclude from the task search.
Check the Alerts check box if you wish to filter by selected alerts. There are various Action 
Logs, information messages, warnings and errors to choose from.
Optionally, click Optimize Search (2) for Faster Export button.

Note: Adding a UUID to the search criteria may provide hints toward finding and 
resolving corrupted files.
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In the Journal, click the Search (1) button.

 
The search results are shown in the panel below. When one is selected, the details are shown 
in the panel to the right.

To View a Live Feed of Server Activities
Search in the Journal with Filter Settings.
In the Journal tool bar, click the Feed button (1).

The journal is updated in real time.

Green: New journal entries.
Yellow: Warnings.
Red: Errors.

Only the Level and Subject columns are colored in red or yellow when there are warnings and 
errors to report

5.7.3 Automatic Journal Backup
To automatically backup all Journal entries, Enable journal backup must be enabled in Journal/
Logging Settings.

To Schedule Automatic Journal Backup
Open the Journal panel: Click Server > Administer journal entries.

IMPORTANT! Once an automatic backup task has completed, all journal entries are deleted.
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Click the backup task (1) button.

Set the Start time.

Set a frequency Interval.
In the Graphic Hub Terminal, check that Enable journal backup is enabled under Options > 
Journal/Logging settings. This option is enabled by default.
Click OK.

5.7.4 Export and Import of Journal Entries
With the export of journal entries select one, or as many as required, entries to be 
exported. Exported journal entries can be imported by other users for help with troubleshooting.

To Export Selected Journal Entries
Search in the Journal with Filter Settings.

Tip: Click the drop-down or highlight a date number and change it, to set the date. 
Click on the hour or minutes to change the time.
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In the journal, select the entries to be exported.

Export the selected entries by clicking the export button , or by right-clicking the 
selection and select Export Selected.

Select a location, optionally enter a file name.
Click Save.

To Import Journal Entries
Open the Journal panel: Click Server > Administer journal entries.

Tip: Press CTRL + A to select all entries.

Note: From the context menu, Export and Delete Selected can also be selected. This 
frees up disk space and increase performance.
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Click the Import Journal Entries   button.

Select the required file.
Click Open. The file is loaded into the journal.

5.8 Alerts
Email can be sent about specific types of Journal entries. This section details how to define email 
notifications that should be sent when errors occur in the system. 

To send email:

E-mail must first be enabled in the Graphic Hub Terminal email Configuration Options. On a 
cluster setup with main and replication this needs to be done for both Graphic Hub 
Terminals.
Use the Graphic Hub Manager to configure which and when messages are to be sent. On a 
cluster setup this only needs to be done when logged in to the main server when the cluster 
is running. Changes are replicated on the cluster setup.

Configured alert settings can also be imported and exported.

5.8.1 Server Alerts
The Graphic Hub Server issues alert messages in the following scenarios:

GH needs administrative attention.
License errors or expiration.
Low memory.
Low disk space.

Refer to Monitor Servers for details on how to monitor such situations.
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5.8.2 To Configure Send E-mail
Open the Alerts panel: Click Server > Configure alerts...  or SHIFT + CTRL + F7.

Select one or more subjects to receive e-mails from.
Click Configure.

Edit the Subject and Description fields as required.
From the drop down box in the lower-right corner, enter or select the address or addresses 
to which the e-mail alerts are to be sent.
At the bottom left, if you wish to override the default, enter an interval in minutes or select a 
predefined interval from the drop down box. Data is collected and messages are sent at this 
frequency.
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Click OK. Messages to be sent appear in the Alerts window.

5.8.3 Importing and Exporting Alert Settings
E-mail alert settings can be imported or exported in the Alerts window. To import previously 
configured settings, click the Import button or the keyboard shortcut F6. To export such settings, 
select the settings to be exported from the list in the Alert window, and click the Export button or 
F7.

See Also

Email Configuration Options in Graphic Hub Terminal.

5.9 Archives Panel
This section contains details about the archive panel of the Graphic Hub Manager.

In the Archives Panel, archives can be imported and exported with drag and drop. It also offers 
other functionality:

An archive search function.
View the contents of an archive.
Import single files from an archive.
View archive details.

In the Tool bar click on View > Archives to open the Archive panel.
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The Archives panel consists of:

Archives View (1): Shows archives in folders (User selected (see Graphic Hub Manager 
Customization).
Search View (2): Search in all or selected archives.
Archive Contents View (3): Shows the content of the selected archive.
Archive Details View (4): Shows the details of a selected archive.

Go to Graphic Hub Archives for detailed information about:

Archives View
Search View
Contents View
Details View
Archive Folders
Import Archives
Export Archives
Import Viz 2.x Data and Archives

5.10 Action Log
The Action Log is automatically activated when certain operations are done in the Graphic Hub 
Manager, for example, the duplication and /deletion of files and folders, or when user rights are 
modified.
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The action to be done is shown in the window title, and an icon which symbolizes the action shows 
below the file list. For example, a trash can icon is used if files or folders should be deleted.

This page contains information on the following topic and procedures:

Action Log Parameters
To Add Additional Files
To Action the Operation

5.10.1 Action Log Parameters

Close this window automatically if no problem occurred: If enabled, the Action Log is closed 
when the required operation finishes successfully.
Reuse this window for same actions: By dragging files or projects/folder onto the Action 
Log, the action is also performed on these elements.
Do not insert entries that are already in the list: Prevents the addition of duplicate entries.

Warn me about not inserted: Enable to notify when duplicate entries have been detected.

5.10.2 To Add Additional Files
Add additional files that the same action should be completed on. Drag files from the Explorer or 
the search results onto the list of elements in the Action Log.

Note: This option is only available if Reuse this Window for Same Actions is enabled.

Note: This option is only available if both Reuse this Window for same Actions and 
Do not Insert Entries that are Already in the List are enabled.
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5.10.3 To Action the Operation
Add the required to the Action Log.
Click the button corresponding to the operation that should be done. When the operation 
has completed, the Action Log provides feedback. If the operation has been successful, a 
check mark, is shown to the left of the file name. If the operation has failed, an X shows. 
Status information in text form is also shown in the Info column.

5.11 Graphic Hub Manager Customization
The GUI has two default layouts but it can be customized with different layouts in the 
workspace. In addition to the Layouts function, the look and feel of the Graphic Hub interface can 
also be customized. The Graphic Hub GUI has several options to modify its look and feel. In the 
Look panel of the system Preferences change the overall look from the drop down list. Also the 
color of the text for a selected server can be modified as required.

This page contains the following topics:

Default Layouts
System-Clean (locked)
System-Default
Locked/Not Locked Layouts

Layout Maintenance
To View the Layout Maintenance Window
Layouts Maintenance Properties

Layout Procedures
To Save a Layout
To Save a New Layout
To Load a Layout
To Drag and Drop Layout Panels
To Load a New Look
To Change the Color of a Server Text

Import and Export Custom Settings
To Export Local Graphic Hub Manager Settings
To Import Local Graphic Hub Manager Settings



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  364

•

•

5.11.1 Default Layouts

System-Clean (locked)
The System Clean layout is always identical to the presented layout when the Graphic Hub Manager 
is opened after a fresh install.

System-Default
System-Default is the default layout if a User does not create or save layouts. This layout is, by 
default, not locked, which means, that if a User opens the archives pane and then close the 
Graphic Hub Manager then on next startup the archives pane is shown.

Locked/Not Locked Layouts
Each layout can be set to locked or unlocked:

Not locked: When the Graphic Hub Manager is closed the last used layout is stored and when 
the Graphic Hub Manager is started this last stored layout is used.
Locked: If a User modifies a locked layout, the layout must be saved or the modifications are 
not saved.
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5.11.2 Layout Maintenance

To View the Layout Maintenance Window

Layouts Maintenance Properties

Load selected layout: Opens the selected layout.
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Save selected layout as...: Create a new layout from the selected layout.
Lock/Unlock selected layout: See Locked/Not Locked Layouts (not available for System-
Clean).
Remove selected layout: Delete the layout (not available for System-Clean and System-
Default).
Initialize selected layout: Set the selected layout to the same layout as System-Clean (not 
available for System-Clean.

5.11.3 Layout Procedures

To Save a Layout
Click View > Layouts > Save current layout < layout name >, or
Click the Save button in the Layout bar

To Save a New Layout
Open the Save as window:

Click View > Layouts > Save current layout < layout name > as..., or
Click the Save as button in the Layout bar

Type a new layout name.

Tick the Save it as locked box, if required.
Click Save.

To Load a Layout
Click View > Layouts > Load layout > <layout name>, or
In the Tool Bar, click the Layout button and select a previously saved layout.

To Drag and Drop Layout Panels
Click and hold the title bar of the element to be moved.
Drag and drop the panel in a new position. Options are:

Tip: Also save a new layout to an existing layout, if required. Existing layouts are 
listed in the drop down menu.
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• Drag the panel to a symbol which shows possible target positions. When a valid place 
is reached, that area is highlighted:
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• Drag the panel to the title bar of another panel. When a valid place is reached, that 
area is highlighted:

Note: When a series of elements are docked together, they show as tabs.
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Drag to white space. When released the panel becomes a floating panel:

To Load a New Look
Click Tools > Edit Preferences > Look . 

Select a visual style from the drop-down.
If colored tabs are required, tick the Docking Tab Colors box.
Click Apply or OK.

To Change the Color of a Server Text
Change the color of the text for the selected server, in the Server Tree.

Tip: A right-click on a server in the Servers and Folders also opens the Color window - go 
to step 3.
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Click Tools > Edit Preferences > Login . 

Right-click a server and select Text color in Explorer...
Select a color (Standard or Custom) from the color picker.
Click OK.

In the Preferences window, click Apply or OK.

5.11.4 Import and Export Custom Settings
All workstation-based customizations to the Graphic Hub Manager, such as changes to any of the 
panels, column layout and visibility, as well as the user interface in general can be exported (and 
subsequently re-imported on another machine).

Note: All folders and files in the Server show the selected text color in the Graphic 
Hub GUI.
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To Export Local Graphic Hub Manager Settings
Click Tools > Export settings (incl. layouts) to file.
Select a file name and location, and click Save.

To Import Local Graphic Hub Manager Settings
Click Tools > Import settings (incl. layouts) from file.
Select a settings file with the .vghms extension, and click Open.

5.12 Enable A Graphic Hub For A Virtual Studio
The XML necessary to support a virtual set environment is generally obtained from Vizrt Support. 
The following procedure indicates how to import or export such an XML file.

5.12.1 To Import or Export a Virtual Studio Settings File
From the main menu, select Extra > Viz VR Studio Setup. The Viz VR Studio Setup window 
opens.

On the tool bar, click the Import or Export button.
Select the XML file and click Open or Save.

Note: The settings are saved with a file extension of .vghms.
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6 Graphic Hub REST
The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data 
to and from Graphic Hub via HTTP requests. The Graphic Hub REST configuration page is loaded 
automatically after installation:

Select the Graphic Hub the REST service should connect to from the drop-down list, and click 
Apply. This opens an authentication window:

Tip: The configuration page can be opened manually by navigating a browser to http://
127.0.0.1:19398/config.html.
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In the GH username and GH password fields, enter a user name and password for the Graphic Hub, 
then click OK.

A popup window appears, informing about the successful configuration of the Graphic Hub REST 
service:

 
Click OK. This opens the REST status page:

Tip: User names and passwords are case sensitive.
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The GH REST Configuration Settings and Web Server Configuration Settings is accessible from this 
page. However, the default settings can in most cases be left unchanged.

The following topics are covered in this section:

Graphic Hub REST API Documentation
Web Server Configuration Settings
Graphic Hub Failover Servers
Change Graphic Hub Server
Maintain Graphic Hub REST Bindings
Report
Failover/Load Balancing
SSL in REST

6.1 Graphic Hub REST API Documentation
The Graphic Hub REST API documentation provides a programmer with the necessary information 
to use the Graphic Hub REST API. The API documentation can be accessed by selecting Viz GH REST 
API from the Help menu, or entering http://127.0.0.1:19398/doc/documentation.html in the web 
browser address bar.

6.1.1 GH REST Configuration Settings
To make changes to the default REST configuration settings, select Viz GH REST from the 
Configuration menu. Any changes made are highlighted by the parameter name changing color. 
Click Apply to apply any changes, or Back to go back to the main configuration page.

Note: Any changes to the GH REST configuration do not take effect until the Graphic Hub 
REST service has been restarted.
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VIZ GH REST CONFIGURATION 
Request timeout (ms): If the defined timeout is exceeded, the HTTP daemon 

disconnects the request. The default value is 120000 .

Max. sessions per user: Sets the maximum number of sessions per user connecting to 
the Graphic Hub. The default value is 10.

Default max search results: Sets the default number of maximum search results. The 

default value is 20 .

Max journals: Sets the maximum number of buffered journals. By setting the value to 

0 , buffered journals are disabled. The default value is 500 .

Max journals days: Defines the maximum days to retrieve journals, subtracted from 

the current date. The minimum value is 1 . The default value is 2 .

Content size limit in MB: Defines the upper limit of the amount of memory in MB the 

REST service can allocate for processing content. The default value is 200 .

Log Levels Check the box to include the required logs:

Debug: Prints and logs debug messages. Off  by default.

Trace: Prints and logs trace messages (needs trace enabled). Off  by default.

Information: Prints and logs informational messages. On  by default.

Warning: Prints and logs warnings messages. On  by default.

Error: Prints and logs error messages. On  by default.

Critical: Prints and logs critical messages. On  by default.
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ACE: Prints and logs Viz GH Interface ACE messages. Off  by default.

VIZ GH REST IMAGE UPLOAD CONFIGURATION 
Max. used system Memory in %: The maximum memory (as a percentage) VizGHRest 
allocates for processing parallel image and archive uploads.
Default compression: Select the default compression for imported images: 

AUTO ,  NONE ,  DXT1 , or  DXT5 . The default setting is  AUTO .

Max. number of parallel uploads: Maximum number of images that can be uploaded in 

parallel. If the value exceeds 12 , a performance loss can occur.

REVERSE PROXY SETTINGS
Enable URL rewriting: Rewrites URLs in responses with the configured protocol, 
host:port and base-path when enabled, where the requested URL contains the 

configured base-path. Disabled  by default.

URL protocol: Selects which protocol to use in responses where a requested URL 

contains the configured base-path. Valid values are http  and https . The default 

value is http .

URL base-path: Defines the URL base-path (prefix) to use in responses when the 
requested URL contains the configured base-path (as, for example, when requested 
from a proxy). When URL rewriting is enabled, this field cannot be empty. The path 
must be an absolute path, excluding protocol, host and port. The base-path cannot be 

‘ / ’. The base-path format is /base-path/path .

URL host:port: Defines the URL host and port to use in responses when the requested 
URL contains the configured base-path (for example, when requested from a proxy). If 
empty, host and port will be taken from the HTTP Host header.

6.2 Web Server Configuration Settings
This window is used to customize certain settings for the Graphic Hub REST service web server. 
Any changes made are highlighted by the parameter name changing color. Click Apply to apply 
any changes, or Back to go back to the main configuration page.

Example: /my-media-base-path/content

Note: When URL rewriting is enabled, it only operates and rewrites on REST API 
level. It is not intended that the Web UI works or can be opened when 
accessing a rewrite enabled endpoint. When requesting the root (/) it usually 
302 redirects to config/index.html or provides the service document based on 
the provided content type in the accept header. When URL rewriting is 
enabled, no redirects happen on the root (for example, base-path is /gfx/) and 
it downloads the service document (intended behavior without proper accept 
header).
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Port: The port of the web server. The default value is 19398 .

Configuration directory: The directory where the web server configuration files are located.
Upload directory: Sets the directory where uploaded files are temporarily stored.
Document root: The web server document root directory, where the html files reside.
Error log: Set the location of the error log files for the web server.
Default index: Set the default index file name for directory requests. The default value is 

index.* .

Local endpoint: The local endpoint defines which IP address(es) the web server listens to. 

The default value is 0.0.0.0 , which means that it listens on all installed adapters.

Log directory: The directory for Viz GH REST and web server log files.
Thread pool size: Set the maximum simultaneous connections (threads) the web server can 
process.
Use keep-alive: Enable or disable keep-alive header handling on the web server. This is 
enabled by default.

Note: Changing the port to 1  or 65535  causes the web user interface to cease 

functioning in Chrome, UC Broswer, Opera and Firefox, as these browsers block 
requests on these ports.
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Use SSL https connection: Enable or disable SSL handling of incoming requests. This is 
disabled by default. See also SSL in REST.

Socket timeout (ms): When handling keep-alive requests, this timeout closes the socket after 

the defined number of milliseconds. A value of 0  disables timeout, and leaves the socket 

open forever. The default value is 15000 .

6.3 Graphic Hub Failover Servers
A Graphic Hub failover server can be added in addition to the currently connected Graphic Hub. 
Graphic Hub failover servers must have fully synchronized content with the currently configured 
Graphic Hub. Synchronizing the content between multiple Graphic Hubs can be achieved by using 
the Graphic Hub Deploy Agent.

To add a new failover server, click the Add failover server button, and enter the Naming Service, 
Server and Port details:

Naming Service: Failover Graphic Hub Naming Service.
Server: Failover Graphic Hub server
Port: Failover Graphic Hub port.

Note: When activating SSL, the user is automatically redirected to the new site. When 
disabling SSL, automatic redirects are not possible due to requirements in the HTTPS 
protocol.



Note: Any changes to the web server configuration do not take effect until the 
Graphic Hub REST service has been restarted.
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1.

2.

To remove a failover server from the list, select the trashcan icon. Click Apply to apply any 
changes, or Back to go back to the main configuration page.

6.3.1 Methods to Test Failover Servers
Perform a request to Graphic Hub REST, for example by navigating a browser to http://
127.0.0.1:19398/users/.
Shut down the configured Graphic Hub.
Perform the same request to Graphic Hub REST again.

If the first failover server is configured correctly, the response (error code and content) should 
match.

6.4 Change Graphic Hub Server
You can change the binding between the Graphic Hub REST and Graphic Hub server.

 Navigate to Configuration > Change Graphic Hub server.

Select a Graphic Hub server from drop-down menu or enter the address manually in form of 

VizDbServer@GHServer:19396  to bind to Graphic Hub server
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3.

4.

Confirm with Apply.

The server has been successfully changed and the binding to the previous server is removed.

6.5 Maintain Graphic Hub REST Bindings
Select Maintenance from the main menu to show information about the currently configured 
Graphic Hub connection, its bindings, and failover Graphic Hubs. Graphic Hub REST is 
automatically registered and the configuration is stored when connecting to a Graphic Hub for the 
first time.
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The Graphic Hub REST to Graphic Hub bindings enable third party applications to discover the 
currently connected Graphic Hub REST servers on a Graphic Hub.

Protocol: The protocol used to connect to the specified Graphic Hub REST.
Hostname: The host name or IP address for the specified Graphic Hub REST.
Port: The port of the specified Graphic Hub REST web server.
Service doc path: The path where the service doc is configured on the specified Graphic Hub 
REST.
Service doc accept type: Defines the http request headers accept type used to retrieve the 
service document on the configured service document path.

Click Apply to apply any changes, or Back to go back to the main configuration page. If Graphic 
Hub REST runs as a replication cluster (failover or load balanced), you must also change the 
configuration of the proxy.

Click the trashcan icon to remove a Graphic Hub REST binding from the list. Accidentally deleted 
Graphic Hub REST bindings can be re-applied by configuring the deleted Graphic Hub REST again.

6.6 Report

Use the Report menu to access the Export functionality of Graphic Hub REST. This feature creation 
and download of a system export file, as well as the possibility to view log files.
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6.6.1 To Manage Reports
Click Report. The Export panel displays all previously created report exports, as well as the 
error.log and latest log files.
Click Create to generate a new export.

Select one or multiple exports, then click Download to download a .zip file containing 
information about REST settings and current configuration (or click Delete to remove all 
selected exports). 

 To view the desired file

Click the Eye icon next to error.log

or 
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b. gh_rest_YYYY-MM-DDThh-mm-ssZ.log.

6.7 Failover/Load Balancing
It is possible to configure Graphic Hub REST to support failover and load balancing. Graphic Hub 
REST is a standard HTTP server, so there is no need for integrated failover or load balancing logic. 
This requires setting up a failover and load balancing cluster. A network professional must 
configure a proxy and the DNS failover.
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The proxy covers only the redundancy of Graphic Hub REST. It does not cover redundancy for Pilot 
or the Media Sequencer.

6.7.1 Important Notes
Never call the configuration site through the proxy URL. Always use the direct server 
configuration URL instead.
In a failover/load balancing proxy setup, always configure all Graphic Hub REST nodes to 
connect to the same Graphic Hub.

For very large installations only: Use multiple automatically synchronized Graphic 
Hubs to increase the performance of big Graphic Hub REST clusters. You achieve this 
by utilizing the Graphic Hub Deploy Agent.

Do not run a proxy on the same server as any Graphic Hub REST node.
Add all IP addresses to the proxy configuration on servers with multiple network adapters.
Some API calls do not work with a cluster configuration or multiple Graphic Hubs in a 
cluster:

The REST resource monitoring and statistics do not work in a cluster.
The Graphic Hub statistics, journals, and sessions, do not work in a cluster with 
clustered Graphic Hub RESTs connected to multiple Graphic Hubs.

The API documentation states proxy cluster compatibility information for every endpoint.

6.8 SSL In REST
SSL/TLS can be activated in GH REST by enabling Use SSL HTTPS connection in Web Server 
Configuration Settings. This encrypts connections to the REST interface using the HTTPS protocol. 
If the HTTPS page includes content retrieved through a regular HTTP connection, the connection is 
only partially encrypted. Most popular browsers block mixed content by default. 

In the Web Server Configuration panel the SSL/TLS versions, to be supported by the server, can be 
chosen from the option list once the Use SSL https connection option is enabled.

Information: The certificate, private key and password can be changed by modifying the 
current GH REST installation.
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6.8.1 SSL/TLS Configuration
To configure GH REST to support HTTPS (HTTP over SSL/TLS) connections the following 
information is needed:

Certificate, Private Key and Password.
Vizrt Viz GH REST SSL/TLS Configuration.
Verification of New SSL/TLS Configuration.

Certificate, Private Key and Password
The certificate and private key files must be .pem filetype. The generation of those files is in the 
responsibility of the customer.

OpenSSL for Windows (Optional)

IMPORTANT! Self-signed certificates are highly discouraged for production because they 
are meant for testing purposes only.
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Optionally, for testing purposes, OpenSSL for Windows can be utilized to create a self-signed 
Certificate Signing Request (CSR) which generates the certificate and private key files.

OpenSSL for Windows can be downloaded and installed from https://slproweb.com/
products/Win32OpenSSL.html:

 

Using the command line the installation of OpenSSL can be verified using:

openssl version  

 

A self-signed CSR, combined with a password (which should not be forgotten), can be 
generated using:

openssl req -x509 -newkey rsa:4096 -keyout server_key.pem -out 

server_cert.pem -days 365  

https://slproweb.com/products/Win32OpenSSL.html
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The newkey  option can also be rsa:2048 .

The file pair, of certificate and private key, can be found in the directory where the above 
command was executed:

 

How Graphic Hub REST looks in a browser with a self-signed certificate (left) compared to vizrt.com
(right):

http://vizrt.com
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An invalid self-signed certificate indication (left) compared to a valid one (right).
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Vizrt Viz GH REST SSL/TLS Configuration

The certificate, private key and password can be changed in GH REST by modifying the 
installation:

In modern Windows versions, Settings > Apps > Vizrt Viz GH REST > Modify can be 
used.

 

In older Windows versions, Control Panel > Programs and Features > Vizrt Viz GH 
REST > Change can be used.
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In the Change, repair or remove installation phase click Change:

 

Click Next a few times to navigate the installation wizard to the SSL Configuration phase and 
place the file paths and password in the fields:

Important: Files with limited accessibility (unprivileged or from network shares) may 
cause access issues in GH REST where the installer is unable to complete or start the 
server.
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Click Next a few times and then click Change:
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When the installer completes click Next, then Finish:

Verification of New SSL/TLS Configuration
The status of the new configuration can be tested using OpenSSL (for example, to test 
TLSv1.2):

openssl s_client -connect localhost:19398 -tls1_2  
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• As a verification, the specified protocol in the command is displayed in the output under 
SSL-Session > Protocol:

6.8.2 GH Terminal
While the Graphic Hub REST interface can run with SSL/TLS encryption, Graphic Hub Terminal
cannot. Because of this, the connection between them is considered mixed content and hence 
blocked. This may cause an Unable to connect error message:
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This is not an issue and can be ignored, as it is just a status display in the Web UI. If desired, it can 
be resolved by adding a security exemption, which is not recommended. The steps to do this 
depend on the browser in use:

Google Chrome
Click the shield icon in the right of the address bar, or

Start Chrome from the command line using the additional flag --allow-running-

insecure-content .

Internet Explorer
Scroll to the bottom of the screen and click Show all content.

Mozilla Firefox
Click the shield icon to the left of the address bar.
Click the arrow next to the Connection is Not Secure warning, and select Disable 
protection for now.
For details on how to show mixed content in other browsers, please refer to the 
documentation for the browser in question.
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7 Graphic Hub Terminal
Graphic Hub Terminal is the web based user interface used to configure, start, stop, or restart The 
Graphic Hub server and the Graphic Hub Naming Service. This chapter describes the Terminal’s 
user interface, and how to use the Graphic Hub Terminal to configure and run the Graphic Hub.

The Graphic Hub Terminal User Interface consists of:

The Menu Bar (1):
Graphic Hub Modes
Backup and Restore
Reports
Options
Help and About

The System Status Panel (2):
System Status Panel

The Event Log (3):
Event Log Panel

The Menu Bar provides access to the configuration of the Graphic Hub server and Naming Service, 
backup and restore, reports, and settings. The icon on the left hand side of the menu lets the 
viewer know in a glance if both of, one of, or none of the Graphic Hub server and Naming Service 
are running:

 Both the Graphic Hub server and Naming Service are running.

 Only the Graphic Hub server is running.

 Only the Naming Service is running.
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6.
7.

8.

9.

1.

 Neither Graphic Hub nor Naming Service are running.

 Directory Agent only mode active.

7.1 Graphic Hub Mode Configuration
The Mode menu is used to show information about the current configuration, create a new 
configuration, or revert to a previous configuration. As the Graphic Hub server cannot be 
configured or reconfigured while running, the Mode menu is inactive while the Graphic Hub server 
is running. Shut down the server to access the configuration settings.

This page details the configuration of all the Graphic Hub Modes, and is divided in the following 
sections:

Localhost, 5/4 Free, and Multiuser Configuration
Cluster Configuration
Graphic Hub Configuration Parameters
Naming Service Only Modes
Directory Agent Only Configuration

7.1.1 Localhost, 5/4 Free, and Multiuser Configuration
From the Mode menu, select the desired configuration mode and click Create new 
configuration.
Click the Configuration button.
Enter the Server name as it should be registered with the Naming Service. Click the reload 

button  to reset to the default name, VizDbServer .
Enter the Data directory path where the Graphic Hub should store the data elements:

Enter the parameters for a Naming Service:
In 5/4 Free and Multiuser modes, the Naming Service host name must be entered 
unless Connect to local Viz GH Naming service is checked. For Graphic Hubs in 
Localhost mode, this parameter cannot be changed.

Enter the Naming Service Port number. The default port is 19396 .

Uncheck the Connect to local GH Naming Service if only a server start is required.
Select a Network Adapter if the system has more than one adapter installed, or choose to 
run the Graphic Hub on all adapters (default).
Enter the Server Port number on which the Graphic Hub listens to. The default port is 

19397 .

Click Apply.

7.1.2 Cluster Configuration
From the Mode menu, select Cluster and click Create new configuration.
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Select the Main and Replication server from the drop-down list.

If Graphic Hub Terminal HTTP authentication is enabled, log on to the servers:

Click Create. This enters a two-step process, where the Step 1 is setting the parameters for 
the Main server. Step 2 is setting the parameters for the Replication server.

Set the parameters for the Main Server. The parameters are described in the Localhost, 
5/4 Free, and Multiuser Configuration section. Click Next.
Set the parameters for the Replication server.

Click Finish to return to the System Status panel, which should show the status for both 
servers. The currently logged on to server is signified by it’s panel casting a shadow:

IMPORTANT! If HTTP authentication is enabled, it must be enabled on both servers, 
and the user name and password must be identical on both servers.
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7.1.3 Graphic Hub Configuration Parameters
This section details the configuration parameters for running the Graphic Hub server in Localhost, 
5/4 Free, Multiuser, and Cluster (Main and Replication) modes. The Graphic Hub configuration 
parameters can only be changed when the Graphic Hub server is not running. In the Graphic Hub 
Terminal, click the Configuration button in the System Status panel to open the configuration 
window (here for mode Multiuser):

Graphic Hub
Server Name: Sets the Graphic Hub server name.
Data Directory: Sets the path to the Graphic Hub data directory.

Connection Settings
Connect to local Viz GH Naming Service: Starts a Naming Service on the local machine when 
checked. When disabled, the Graphic Hub starts in server only mode when started. However, 
this is only available for servers running in 5/4 free or multiuser mode. In such a case, the 
hostname or IP address of a Naming Service server must be provided.
Naming Service Hostname: The host name or IP address of the server running the Naming 
Service to connect to. Can only be edited when not connecting to a local Naming Service.

Naming Service Port: Sets the port the Naming Service uses to directly communicate with the 

other applications in the network. The default port is 19396 .

IMPORTANT! Scheduled tasks do not trigger when the Graphic Hub and Naming 
Service are not running on the same host (Naming Service only mode)!
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Network Adapter: Selects which network adapter the Graphic Hub should use. For maximum 
performance, always choose the fastest network card available. Virtual connections tend to 
be the slowest. When the network adapter is restricted, any connecting Viz Artist client must 
connect to the IP address, not the host name.

Server Port: Sets the port the Graphic Hub server listens to. The default port is 19397 .

Advanced Settings
In most cases, there is no need to change the advanced settings. Click the Advanced Settings title 
bar to open the Advanced settings panel.

Performance Settings
Search instances: Determines the number of search threads that are generated, limited 
by the number of CPUs. The number of threads available for the Graphic Hub to 
execute a search (the range is 1 to the number of CPU cores in the system). The 
default value corresponds to the number of CPU cores in the system. Applies only to 
Graphic Hub servers running in Multiuser, Main or Replication mode.
Process priority: Sets the Graphic Hub process priority level (Low, Below Normal, 
Normal, Above Normal, High, Realtime)

Log Settings
Log server state: Enables logging of additional call information on the Graphic Hub 
when checked.
Journal level: Sets the system journal entry level. Available journal levels:

No Logging: Disables all logs.
All: Logs all the entries listed below.
Errors: Logs Fatal Errors, Replication Errors, and so on.
Warnings: Logs Errors and Warnings.
File news: Logs Errors, Warnings, and new file entries.
File updates: Logs Errors, Warnings, and updated file entries.
File deletes: Logs Errors, Warnings, and deleted file entries.

Graphic Hub Timeout Settings:

Server to Client timeout (sec/10): The recommended setting is 2 .

License Settings 
Applies only to Graphic Hub servers running in Multiuser, Main or Replication mode.

Tip: Make sure that the selected port is not in use by any other applications.

Caution: Increasing the process priority level may cause system instability.
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WIBU license location: Sets the WIBU license container location.

Local/Network: Prioritizes WIBU system licenses from a local license container. If no 
valid license is found locally, the system switches to a network container.
Network/Local: Prioritizes WIBU system licenses from a license server on the network. 
If no valid license is found on the network, the system switches to licenses to a local 
container.
Local: Sets a local license container as the license location. This container may be:

a file-based container on the local system,
or a WIBU dongle-based container connected/bound to the local system.

Network: Sets a network license container as the license location. The license servers 
search list can be configured in CodeMeter Runtime WebAdmin. This container may 
be:

a file-based container on a configured license server on the network,
or a WIBU dongle-based container connected/bound to the license server on the 
network.

Container: Sets a dedicated container as the license location based on the container 
mask and serial.

When this option is selected the WIBU Container setting is shown:

The dropdown is pre-filled with automatically discovered container entries that 
contain a Graphic Hub Core license.

The WIBU container to use needs to be specified in the form "MASK-
SERIAL,LOCATION" where mask and serial are positive integers and 
location is 0 for local and 1 for network.

When the container is empty a search in Local/Network is performed.
Image Library Extension: Allocates a Graphic Hub Image Library Extension license to enable 
this feature when checked.

Additional Advanced Settings for Cluster Configurations
These settings apply to Main Server and Replication Server modes only.

Note: Since Graphic Hub 3.7.0 the only available license system choice is WIBU and 
requires the CodeMeter Runtime to be installed, running and configured on all affected 
systems. The license system configuration option is hidden and only shown if an old 
configuration still uses Sentinel.



Note: Details regarding the types of containers are listed in the Local and Network 
descriptions below.
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Graphic Hub Timeout Settings

Server to Client timeout (sec/10): The recommended setting is 2 , which is 0.2 

seconds.

Cluster timeout (sec/10): The recommended setting is 300 , which is 30 seconds.

Cluster idle switchback time (sec): Defines how long the Graphic Hub waits for no 

activity from clients to return from a failover or switchback. The range is 1  to 30

seconds. The default value is 15  seconds.

Naming Service Timeout Settings

Timeout Responsiveness (s): Sets the timeout responsiveness. Must be 1  or greater.

Check frequency (s): Sets how often to check for unresponsive Naming Service servers.
Unbinding Time (s): Sets the delay after which unresponsive servers are unbound.
No. of Loops Used: Determines the number of loops for unresponsive server 

recognition. Must be 1  or greater.

Performance Settings: Sets the number of Search instances and the Process priority
level, as described for Localhost, 5/4 Free and Multiuser above.

7.1.4 Naming Service Only Modes
The Naming Service is a discovery service that provides client applications with the location of one 
or more Graphic Hubs on the network. The most common configuration involves each Graphic Hub 
server running its own Naming Service, a configuration option which is valid for all Graphic Hub 
Modes. It is also possible to configure one Naming Service for Multiple Servers. However, this 
configuration is only valid for 5/4 Free and Multiuser modes.
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To Start in Naming Service Only Mode
Open the Graphic Hub Terminal.
Go to Mode > GH Naming Service only > Create new configuration.

In the Graphic Hub Naming Service configuration screen, Enter the port number for the 

Naming Service to communicate through. The default port number is 19396 . The host 
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4.

name is the name of the local machine, and cannot be changed:

Click Apply, then Start Naming Service when the Terminal has returned to the main page to 
start in Naming Service Only mode.

Naming Service for Multiple Servers
Two or more Graphic Hubs running in different modes can be connected to one Naming Service. 
The following example configuration utilizes three machines: one as Naming Service server, and 
the other two as Graphic Hub servers.
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To Configure One Naming Service for All Servers

On the Naming Service server, start the Graphic Hub Terminal in Naming Service only mode.
Open the Graphic Hub Terminal on the servers that are intended to connect to the Naming 
Service.
Create a new 5/4 Free or Multiuser configuration.

 

IMPORTANT!  Scheduled tasks do not trigger when the Graphic Hub and Naming Service 
are not running on the same host (Naming Service only mode)!
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Click Configuration.

Uncheck the Connect to local Graphic Hub Naming Service checkbox.

In the Naming Service Hostname field, enter the IP address of the server running the Naming 
Service.

Click Apply.
Click Start to start in Server Only mode.

IMPORTANT! Unique names are required for each Graphic Hub server on the 
network. This means it is not possible to start two Graphic Hubs configured with 
identical Naming Service and Graphic Hub server names.
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7.1.5 Directory Agent Only Configuration
When the Graphic Hub is in Directory Agent only mode, the Service Location Protocol (SLP) service 
is configured to run as a Directory Agent. The Directory Agent collects information from other 
Graphic Hub Terminals on the network, configured as SLP Service Agents, and presents this 
information when asked. A correctly configured SLP service presents Graphic Hubs available on the 
network or other networks to client applications on the same subnet without performing multicast 
or broadcasting.

A Graphic Hub Terminal configured in Directory Agent only mode cannot simultaneously be used 
as a Graphic Hub. However, Directory Agent functionality can be enabled in parallel when a 
Graphic Hub is running, under the Service Discovery Settings of the Terminal.

7.2 Backup And Restore
The Backup menu shows the backup, restore and data recovery options. As the Graphic Hub server 
cannot be backed up or restored while running, the server must be shut down to enable changes 
to the configuration settings.

 
The internal backup and restore operations of the Graphic Hub are incremental processes. If one 
backup or restore operation succeeds, all subsequent operations copy the difference from the 
successful backup/restore to the current operation. Restore points are created to accomplish this 
process.

The first restore point holds information about the original data directory.
The second point holds information about changes from the startup to the first backup.
The third point holds information from the first to second backup, and so on. If no changes 
have been made since the previous backup, the Graphic Hub does not create a new restore 
point.

There are two kinds of backup, internal and external, both of which are configured in the 
Graphic Hub Terminal. Make sure to shut down the Graphic Hub before configuring a 
backup.

Example: The first backup finished successfully at 01.01.2009 00:00:10 and the 
second at 01.01.2009 12:00:00. Between the backups, one scene was modified: 
MyScene. The latest restore point would then only contain data regarding this scene. 
If restoring to the previous point, only MyScene resets to its status at 01.01.2009 
00:00:10.
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7.2.1 Internal Backup
Internal Backups are incremental backups as described above. It is possible to limit the number of 
restore points after a backup. Reducing the amount of restore points vastly reduces the amount of 
disk space required on the server.

7.2.2 External Backup
External backups are executed via a command line call of the Graphic Hub Terminal. It is a full 
backup, and requires the creation of a batch file for execution. Output from the batch file to the 
console is visible in the Terminal logging window. 

This example batch file copies the data directory to C:\COPY:

external-backup-example.bat

Backup Configuration
This section details the parameters and configuration of the backup and restore system.

Go to Backup > Backup > Configuration to open the Backup configuration window:

@ECHO off1
echo Starting copy of data dir: "%~1"2
IF [%1] == [] (3
    echo ERROR: NO DATADIR SET4
    EXIT 15
)6
robocopy "%~1." "C:\COPY" /MIR /COPY:DAT /DCOPY:T7
echo "robocopy exit code: %ERRORLEVEL%"8
IF %ERRORLEVEL% LEQ 7 (9
    echo FINISHED SUCCESSFULLY10
    EXIT 011
) else (12
    echo ERROR DETECTED13
    EXIT 114
)15

Tip: Backup can only be configured when the Graphic Hub server is not running.
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Backup Configuration
Disabled: Disables backup.
Internal Backup: Activates internal backup.

Backup Directory: Determines backup directory path. Only local drives are allowed as 
backup directory path.
Cleanup restore points: Enables limits to the number of stored restore points when 
checked. All restore points beyond the maximum are deleted. This can save 
considerable hard disk space.
Maximum restore points: Sets the maximum number of restore points.

External Backup: Activates external backup.
Batch file path: Sets the path to and name of the batch file to execute.

Automatic Backup Settings
This is used in combination with a shut down task to do periodic automated backups:

Automatic backup after successful shutdown: Performs automatic backup on server 
shutdown when checked.
Start after backup: Starts the server automatically upon completion of the automatic backup 
when checked.

Note: As Graphic Hub Terminal runs as a service under the SYSTEM account, it 
cannot access network drives mapped by another user. Make sure that the 
destination path for the external backup is a local drive.
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To Configure Backup
Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut 
Down procedure.
Open the Graphic Hub Terminal.
Go to Backup > Show Configuration.
Select the required backup type, Internal or External.
For Internal Backup:

Select Internal Backup.
Enter the Backup Directory path.
If required, check the Cleanup restore points checkbox and set the maximum number 
of restore points.

For External Backup:
Select External Backup.
Enter the Batch file path.

Select as required:
Automatic backup after successful shutdown
Start after backup.

Click Apply to perform the backup operation.

7.2.3 Perform Database Backup
This section details the backup of a Graphic Hub database. The procedure depends on whether an 
internal or an external backup has been configured.

Note: Start after backup is only applicable when shutting down the server through 
the Graphic Hub Manager or when the server is shut down by Scheduled Tasks.
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To Do an Internal Backup
Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut 
Down procedure.
Open the Graphic Hub Terminal.
Select Backup > Create backup now.
The backup is created in the directory specified in the backup configuration, as indicated by 
the Create backup now link.

To Do an External Backup
Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut 
Down procedure.
Make sure that the a batch file has been created and is available.
Open the Graphic Hub Terminal.
Select Backup > Create backup now (External Backup).
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7.2.4 Restore Files
To open the Restore Points panel, open the Graphic Hub Terminal and select Restore from the 
Backup menu. The panel contains information about the restore points available according to the 
current backup configuration, such as the date and time the restore point was created, how many 
files it contains, and the location.

The Restore Points panel is accessible when the Graphic Hub is running. However, it is not possible 
to perform a restore task while the Graphic Hub is running.

Restoring Files: Best Practices
When files are restored, observe these best practices:

Data directories: It is not recommended to restore files to an already existing data directory. 
Create a new directory and restore the files there. Then start a new configuration of the 
Graphic Hub Server using the location of the restored files as data directory.

To Restore Backup Files
Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut 
Down procedure.
In the Graphic Hub Terminal, go to Backup > Restore.
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Select which restore point to restore.
In the Restore directory field, enter the location which the files should be restored to, or 
press the browse button to browse to the desired location. New directories can be created 
either by typing in a non-existing path in the Restore directory field, or by right clicking the 
directory tree while browsing and selecting New folder.

Click Restore. The Restore progress window appears, providing information about the 
restore process.

7.2.5 Safe Mode
The Graphic Hub Terminal should be started in Safe Mode if the database has crashed and needs 
to be restarted. Rebuilding the database in Safe Mode can take several hours, depending on the 
amount of data that needs to be reconstructed. The recovered directory cannot be accessed by 
clients such as Viz Artist. It can only be accessed by a system administrator using the Graphic Hub 
Manager.

To Prepare for Database Repair
Back up the current data directory.
Close all Graphic Hub Deploy Agent connections to the server.

Caution: Do not restore files to an existing data directory, as this overwrites any 
existing data. Instead, create a new directory and restore the files there.



Caution: Do not use Safe Mode for valid data directories.
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Close all Graphic Hub Rest Agent connections to the server.
Make sure that the instance is not part of a Graphic Hub Cluster environment.
Make sure that the latest version of Graphic Hub is installed.

To Start Graphic Hub Terminal in Safe Mode
Prepare the repair procedure as described above.
In the Graphic Hub Terminal, go to Backup > Data recovery (Safe Mode): 

Carefully read the information, then click Start to proceed.

Check the configuration settings, then click Start.
This begins the rebuild process. Rebuilding a large database may take several hours to 
complete.
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When the data has been rebuilt, the Graphic Hub Manager contains a folder called 
RECOVERED_AT_YYYY-MM-DD_HH_MM_SS. The date and time in the folder name serves as a 
timestamp for the last modification.

Successful Restore Operation
The database has been successfully restored when:

The red console panel shows that the server is up and running.
All processed files are listed in Reports.
Files can be viewed in the Graphic Hub Manager.



Graphic Hub Administrator Guide -  3.8

Copyright © 2023  Vizrt                                                          Page  418

•

•
•
•
•

Depending on the severity of the database corruption, it might be required to run a full 
server check on the recovered data. Found issues can then be repaired from there (see Data 
Errors).

7.3 Reports

 
Use the Report menu to access system information, the Graphic Hub log, or Graphic Hub console. 
In addition, the Export menu item allows the creation of a system export file, and shows all 
previous created report export files.

System information: View the Process List and System information panels.
Graphic Hub Log: View the current Graphic Hub Server log.
Graphic Hub console: View the Graphic Hub Console.
Export: Create, download or delete system export files.

IMPORTANT! A Graphic Hub server in a production environment must never run in 
Safe Mode. Safe Mode is only for restoring a corrupted database. This instance can 
now serve as a source for rebuilding an empty destination database through the 
DDC functionality (see Graphic Hub Deploy Agent).
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7.3.1 System Information

 
The Process List panel provides an overview of the processes running on the machine and their 
resource use. If required, the CPU usage can also be measured, by checking the Measure CPU 
Usage check box in the upper right corner. The Process list lists the following information:

The process identifier (PID) and name of the process executable.
The number of handles and threads used by the process.
The current and peak Working Set (WS) size in bytes.
The number of input/output (IO) operations performed in read (RO), write (WO) and other 
(OO) operations.
The number of input/output (IO) bytes read (RT), written (WT) and other (OT) transfers.
The number of page faults.
The current and peak pagefile usage.
Estimated CPU usage (if enabled).

The system information panel lists details regarding the current system’s hardware and software 
configuration. This includes:

Other installed Graphic Hub applications, such as the Graphic Hub Manager and Graphic Hub 
Deploy Agent.
The amount and usage of system RAM.
The installed network adapters and their IP addresses and connectivity status.
Information about the installed hard disk drives.
Information about the system CPU(s).
Further information about the workstation configuration, the configured network, operating 
system and installed software.
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7.3.2 Export File Parameters
Reports are essential troubleshooting tools when there is any kind of system error. The generation 
of a report should be one of the first actions performed when a system problem occurs, as it can 
provide valuable information and help to find a solution. Reports can also be generated 
automatically in case of an unexpected server shutdown.

The Export file panel shows all report files created for export:

Click the download icon (1) to download the selected export file.
Click the trashcan icon (2) to delete the selected export file.

To Manually Generate a Report
Click Report > Export.

IMPORTANT! In the reports folder, there is a file called SystemInfo.txt. Before this file is 
sent anywhere, make sure to read it and remove any information that could compromise 
company security policies and interests.



Tip: On a cluster setup, exporting the report from the Main server automatically generates 
and downloads two reports, one for each of Main and Replication servers. Both reports are 
required for troubleshooting.
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Click Create.

Select to Open or Save the created file.

To Automatically Create Reports of Unexpected Shutdown
Click Options > Journal/Logging settings.
In Report Settings, check the Report on unexpected Graphic Hub shutdown checkbox.

Click Apply. The report is exported to the directory selected as Report Export directory.

7.3.3 Report Content
A report consists of the following files and information:

Graphic Hub version information (VersionInfo.txt).
Windows event logs (vizrt.evt, system.evt, application.evt).
Graphic Hub log files (LogFiles directory in export).
Graphic Hub HQL tables with journals (*.dat, *.idx, *.idx.fid).
Terminal log files (Terminal directory in export).

OpenSLP configuration.
Terminal configuration (Terminal/Configuration Files directory).
Naming Service and Graphic Hub configuration (*.cfg).
Configuration backup files (*.reg).
Terminal log files (*.log, Terminal/Log Files directory).

Journal backup files (VizGHJournalBackup.xml).
System information (SystemInfo.txt), containing:

Graphic Hub Applications registry settings.
Network adapters.
Drives.
CPU, Workstation, Operating System.
Installed Programs and Updates.

Running processes information (ProcessInfo.txt).
Crash dump files if available (Crash Dumps directory in export).
Timestamps when report export was generated (timeinfo.txt).
Current data directory (datadirectory.txt).
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Graphic Hub Application related firewall information (Firewall.txt).

7.4 Options

 
Use the Options menu to access a range of configurations and settings, as well as schedule tasks 
in the Graphic Hub Terminal:

Service Discovery Settings
Directory Agent Only Configuration
Service Location Protocol (SLP)

To Configure Multiple Isolated Subnets
Proposal for Performance Improvement

Journal/Logging Settings
E-mail Configuration

E-mail Settings
To Enable E-mail

Scheduled Tasks
Scheduled Tasks Parameters
Task Types
To Schedule a Journal Backup Task
To Schedule a Cleanup of Expired Items Task

Advanced Settings
Change Terminal Password

7.4.1 Service Discovery Settings
The Graphic Hub Terminal publishes a service through the Service Location Protocol (SLP) on the 
network. This enables clients to find Graphic Hubs running on the local network or other 
connected networks without knowing their host names or IPs.

The Graphic Hub Terminal can be used to configure the SLP service, letting it act as a Service 
Agent. Configuring the SLP service as a Directory Agent speeds up searching, because the server 
acts as a service cache on its own subnet, responding to requests from clients without 
broadcasting (multicast).
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Registration check interval (s): Interval in which to check for Graphic Hub Terminal service 
registration status.
The Graphic Hub Terminal periodically checks that the Service Location Protocol service 
(slpd) is running and attempts to restart the service if it has stopped. The Terminal re-
registers a previously registered service if:

The slpd service is restarted.
The registration is about to time out, based on lifetime provided at registration and 
registration time.
The slpd service process start time is after the registration time, meaning the slpd has 
been restarted between re-registration checks.

Lifetime (s): The initial Graphic Hub service lifetime until the service registration expires.
If set to immediate (65535, Maximum), the service remains registered for the lifetime 
of the Graphic Hub Terminal service process and is immediately unregistered when 
the Terminal process ends.

Directory Agent: Enable or disable the Service Location Protocol service to function as a 
Directory Agent. It is recommended to read the OpenSLP Users Guide before enabling this 
setting. Consider the following:

Only a few Directory Agents should exist per subnet.
Do not add any local IP addresses or the hostname to the list of Directory Agent 
addresses.
When enabled, the Directory Agent sets the slpd configuration file tag (net.slp.isDA). It 
automatically creates a slpd configuration file if one does not previously exist, 
however, it does not change an existing configuration file or restart the slpd service if 
nothing is changed.

Directory Agent Addresses: Define a list of IP addresses with the location of one or more 
Directory Agents. Click the list button to display a list of all Directory Agents discovered on 
the network.

This is useful if the Directory Agent cannot be discovered via multicast or broadcast.
When empty, no predefined Directory Agent is used and automated discovery is 
performed. Forces local User Agents and Service Agent to use the specific Directory 
Agents and disables dynamic Directory Agent discovery.

http://openslp.org/doc/html/UsersGuide/index.html
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Creates a slpd configuration file if it does not exist yet.
Sets the slpd configuration file tag net.slp.DAAddresses.
Does not change the configuration file or restart the slpd service if nothing has been 
changed.

Interfaces: List of IP addresses to listen for Service Discovery requests. This is useful on a 
system with multiple interfaces.

When empty, all interfaces are used to advertise the Graphic Hub Terminal service.
If set, the slpd service listens for unicast and multicast or broadcast SLP requests on 
the interfaces that are listed, rather than on the default interface or all interfaces.
Sets the slpd configuration file tag net.slp.interfaces.
Creates a slpd configuration file if it does not exist yet.
Does not change the configuration file or restart the slpd service if nothing has been 
changed.

Client request timeout(s): Set the maximum combined timeout allowed for SLP client 
requests in seconds. Adjusts multiple timeout values: Unicast, multicast and Directory Agent 
discovery timeout.
Re-initialize: Re-start the Service Location Protocol service.

Note: The Graphic Hub Terminal service is advertised on all interfaces by 
default.
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Directory Agent Only Configuration
From the Mode menu, select Directory Agent only.

The System automatically configures the SLP service to run as Directory Agent.
Press Start.

Service Location Protocol (SLP)
SLP is used by devices to announce services on a local network using "service URLs". In addition 
there may be attributes set, basically key-value pairs.

SLP has three different roles for devices. They can also have two or more roles at the same time.

User Agents (UA): search for services
Service Agents (SA): announce one or more services
Optional: Directory Agents (DA): cache services information, therefore they are used in larger 
networks to reduce traffic

Example

URL: service:terminal.vizrt:http://GHSERVER:19399/terminal.svc

Attributes: x-version=3.0.3.71516, x-ip-addresses=10.211.2.150, x-
operation=SERVER, x-ns-name=GHSERVER, x-server-name=GHSERVER
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Possible operation of SLP:

UA obtained the location of DA: UA unicasts a request to DA to resolve a particular request. 
DA unicasts a reply to UA. If DA cannot service the request (e.g. no information) it returns a 
response with zero values, possibly with an error code set.
UA does not have knowledge of DA or no DA's available: UA multicasts a request to the 
service-specific multicast address, service responds. All the SA's which are listening to this 
multicast address respond, provided they can satisfy UAs request. SAs which have no 
information for the UA must not respond.

To Configure Multiple Isolated Subnets
Routing of multicast packets across subnet boundaries is by default disabled or more accurate 
blocked.

Therefore when SAs and UAs are on different subnets steps need to be initiated:

Set up organizational or geographical DAs (per subnet).
Configure SAs and UAs to use them.
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Proposal for Performance Improvement
Use of DAs has several Advantages:

UAs receive faster responses.
Less network bandwidth used.
Minimum multicast messages are issued.

Improve performance in Large Networks:

Use more DAs to enhance Service Location Protocol performance.

Creates roughly duplicate repositories of service information without requiring any formal 
database synchronization between them.
UAs can choose any available DA to issue requests to, the load is shared among DAs.
Provide robustness in cases where one fails or becomes overloaded.

7.4.2 Journal/Logging Settings
This section details the parameters and configuration of the Graphic Hub Journal.
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Journal Backup Settings
Enable Journal Backup: Check the box to enable scheduled journal backup tasks. By 
default, the journal backup interval is set to once a week, starting one week from 
01.01.2007 at 00:00:00.
Directory: Set the directory where the journal backup file (VizGHJournalBackup.xml) is 
created.
Truncate: Check the box to create one backup file only, which is truncated and 
overwritten on each backup. If not checked, every journal backup task creates a new 
backup file, with the date and time of the backup in the file name.

Report Settings
Report Export Directory: Set the directory where the exported reports should be 
stored.
Report on unexpected Graphic Hub shutdown: Check the box to enable automatically 
generated reports in the event of an unexpected shutdown of the Graphic Hub server.

Graphic Hub Terminal Log Settings:
Log event history length: Sets the maximum event history log length.
Log file history count: Sets the maximum number of logged operations per log file.
Log file log event count: Maximum of log events per log file to keep

7.4.3 E-mail Configuration
The Graphic Hub can be configured to send notifications about specific types of journal entries via 
email. The type of journal information that can be sent as an email includes:

Action Log
Information
Warnings
Errors
Deploy task information
The Graphic Hub Terminal is used to enable and configure the email settings for the Graphic 
Hub. Go to Options > Email settings to configure the outgoing email server settings. Then 
use the Graphic Hub Manager to configure which alerts should trigger an email notification.
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E-mail Settings

Enable mail sending: Send an email to defined recipients when unexpected server shutdowns 
occur, or if the license is not valid or about to expire. The system also sends email according 
to the defined log level.
Mail server host: Enter the hostname or IP address of the SMTP server. This field is required.
Mail server port: Enter the SMTP server port.
Use SSL: Check the box to enable Secure Sockets Layer (SSL) encryption when connecting to 
the specified SMTP server.

Username/Password: Set the username and password used to authenticate the sender on the 
outgoing email server, if required.
From: Enter the email sender address. Required field.
To: Enter the email address(es) that the messages should be sent to, one per line. Press 
enter to store an entry. Required field.
Send mail after successful server start: Check the box to send notifications when the server 
is successfully started. This is in addition to the default and log level emails.
Send mail after server emergency shutdown: Check the box to send an email when the 
Graphic Hub server is shut down through the Terminal. This is in addition to the default and 
log level emails.
Send Test Mail: Click the button to send an email to the defined recipients for testing 
purposes.

Note: Supports only the SMTP Service Extension for Secure SMTP over Transport 
Layer Security as defined in RFC 320 with STARTTLS.
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To Enable E-mail
In the Graphic Hub Terminal, click Options > Email settings. 

Check the Enable mail checkbox.
In Mail Server host, enter the SMTP server hostname or IP address.
Enter the Mail Server port.
Check the Use SSL checkbox if SSL encrypted connection is required.
In From, enter the sender email address.
In To, enter one or more recipient addresses.
Click OK.
If required, check the boxes to include:

Send mail after successful server start
Send mail after server emergency shutdown

Click Apply.
Optional: To check the email settings, click Send Test Email.
Go to Alerts in the Graphic Hub Manager and configure email alerts.

7.4.4 Scheduled Tasks
This section details how to create scheduled tasks for Shutdown, Journal backup, and Cleanup of 
expired items.
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Scheduled Tasks Parameters

 
The ACTIVE panel contains rows of defined scheduled tasks, and provides an easy overview of the 
configured settings for each task specified in each column:

Active: A green check mark indicates that the task is active.
Task: The task type.
Mode: The task mode can be Once, Recurring or Recurring forever.
Start at: Contains the time and date for the first instance of the task.
End after: Defines the number of repetitions or the end date and time. Only applicable when 
task mode is set to Recurring.
Each/Interval: Defines the time between each instance of a recurring task, in hours, days or 
weeks. Only applicable when task mode is set to Recurring or Recurring forever.
Detail: Provides additional information about the task, such as the next scheduled 
occurrence.

Click on a task to open it in the EDITOR panel and to configure its settings. The available settings 
depend on the task selected. The Mode, Start at, End after and Each parameter all correspond to 
the columns in the ACTIVE panel. In addition, the following settings can be edited:

Checkbox: Check the box to activate the scheduled task. Applies only to the Shutdown task 
type.

IMPORTANT! Scheduled tasks always trigger on the Server's UTC time, not the client time.

IMPORTANT! Scheduled tasks do not trigger when the Graphic Hub and Naming Service are 
not running on the same host (Naming Service only mode)!
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Info: Provides information about the selected task, such as the next scheduled run or if the 
task has expired.
Cleanup of Pilot data elements task type only:

Cleanup of data elements older than: Sets the time range of kept Pilot elements and 
library elements of Cleanup of library elements are also checked. All entries older than 
this setting are deleted upon execution of the task.
Cleanup of library elements: Checking this box enables cleanup of the Pilot library 
elements in addition to the cleanup of data elements.
Cleanup of invalid elements (integrity cleanup): Checking this box enables cleanup of 
invalid Pilot data elements with broken integrity.

Task Types
Shutdown: View scheduled server shutdowns.
Journal Backup: View scheduled Journal backups (see Journal Panel).
Cleanup of expired Items: Tick the box to enable a cleanup of expired items after a journal 
backup (see General Properties in Servers and Folders). This task can only be enabled or 
disabled in the Advanced Settings.
Cleanup of Pilot data elements: This task deletes all data elements that are older than the 
configured timespan when the task is executed. Optionally, deletion of library elements and 
invalid elements can be enabled in the task settings. This task can only be enabled or 
disabled in the Advanced Settings. 

Cleanup of pilot changelog: This task deletes all Pilot changelog entries that are older than 
the configured timespan when the task is executed. This task can only be enabled or 
disabled in the Advanced Settings.

To Schedule a Journal Backup Task
Make sure that the Enable journal backup checkbox in Journal/Logging Settings is checked.
Go to Options > Scheduled tasks > Journal backup.
Set a Start Time and select an Interval for the backup. The Info displays information about 
the next scheduled journal backup.
Click Apply to commit the changes.

To Schedule a Cleanup of Expired Items Task
Go to Options > Advanced settings.

Note: When weeks are used as unit for the "Cleanup of data elements older than" 
setting, they are converted to months if they are a multiple of four. This means four 
weeks are treated as one month, 12 weeks as three months and 52 weeks as 13 
months.



Note: The cleanup tasks do not run on a Replication server, except when it is 
running in the Main mode and the tasks are enabled in the Graphic Hub Terminal.
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Make sure that the Enable cleanup checkbox is checked for the selected cleanup task.
Go to Options > Scheduled tasks > Cleanup of expired items.
Set a Start Time and select an Interval for the cleanup task. The Info displays information 
about the next scheduled cleanup task.

7.4.5 Advanced Settings

Start and Shutdown Settings
Start server on Terminal service start: Automatically start the last successful server 
configuration when the Terminal service starts
Automatic restart Graphic Hub server on unexpected termination: Automatically start 
the last successful configuration if the Graphic Hub terminates unexpectedly. If the 
Graphic Hub has been restarted three times and an unexpected shutdown occurs 
within 30 minutes after the last startup, the automatic restart is skipped. An entry is 
added to the event log of the Graphic Hub Terminal, as well as to the Graphic Hub 
server log file.

GH Terminal HTTP Connection Settings: The web server is restarted after applying any 
changes to the HTTP connection settings, which may take some time.

HTTP port: Set the Graphic Hub Terminal port. The default port is 19399 . The port 

can only be changed while the Graphic Hub server is not running, or during 
installation of the Graphic Hub.
HTTP authentication: Enable or disable authentication for the Graphic Hub Terminal. 
The username is Admin and the default password is VizDb (case sensitive). The 
password can be changed after applying changes, by selecting Options -> Change 
Terminal password.

Cleanup Settings
Cleanup of expired Items: Check the box to enable scheduled cleanup of expired 
items.
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Cleanup of Pilot data elements: Enable cleanup of old Pilot data elements by the 
Graphic Hub Terminal. In addition, a cleanup task for Pilot data elements must be 
configured. When the cleanup of Pilot data elements task is performed by the 
Terminal, it deletes all data elements that are older than the configured timespan 
when the task is executed (for example, all data elements older than one week are 
deleted when the task is run). Optionally, deletion of library elements can be enabled 
in the task settings. After the cleanup task, a log is written to the file 

CleanupPilotDataelements.log . If e-mail notifications are enabled in the Terminal 

options, this operation triggers a notification.
Cleanup of Pilot changelog: Enable cleanup of old Pilot changelog by the Graphic Hub 
Terminal. In addition, a cleanup task for the Pilot changelog must be configured. When 
the cleanup of Pilot changelog task is performed by the Terminal, it deletes all Pilot 
changelog entries that are older than the configured timespan when the task is 
executed (for example, all changes older than one day are deleted when the task is 
run). After the cleanup task, a log is written to the file CleanupPilotChangelog.log. If e-
mail notifications are enabled in the Terminal options, this operation triggers a 
notification.

GH Terminal Connection Settings
Global timeout (s): Global timeout for Graphic Hub Terminal’s connection to Graphic 

Hub. Default: 30 seconds .

Connect timeout (s): Global timeout for Graphic Hub Terminal to initialize the 

Connection to Graphic Hub. Default: 15 seconds .

7.4.6 Change Terminal Password

 
Change Terminal password is used to change the password of the Terminal’s Admin user. HTTP 
authentication must be enabled in the Advanced Settings to change the Terminal password. On a 
cluster, both Terminals must have the same user names and passwords. If the passwords are not 
identical, automatic start of the partner server does not work.
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7.5 Help And About

Help: Opens the Graphic Hub documentation in a new window.
About

Versions: Opens the Versions window, which lists the version numbers for the core 
components of the Graphic Hub. It also displays the number of emails that have been 
sent or failed to send since the Graphic Hub was started.
Graphic Hub License: Opens the Graphic Hub License information window, which 
displays information about the license and expiry date, and can be used to update the 
license string.
Third party licenses: Opens the Graphic Hub third party license information window, 
which displays the Graphic Hub copyright information as well as the copyright and 
licensing information for any third party material.

7.5.1 Graphic Hub License
For all Graphic Hub modes except Localhost and 5/4 Free, a license is required. A license is 
normally acquired when the product is purchased. To get additional or updated licenses, contact 
the local Vizrt representative. The Graphic Hub Terminal License window is used to register a 
license for the Graphic Hub server, whether it is the first or a renewed license. A new license can 
also be applied using the Graphic Hub Manager.

To Apply a New or Renewed License
Make sure that the correct license USB dongle is inserted in the machine.
In the Graphic Hub Terminal, go to About > Graphic Hub License.

Tip: To avoid service interruptions, make sure to update the license before it expires.

Note: If this is the first time a license is registered, or if the previously registered 
license has expired, the license details display Expired! instead of an expiration date.
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Check that:
The Dongle ID in the License Information file matches the Serial Number in the License 
details window.
The license string has 32 pairs of characters, separated by a single space.
No empty spaces have been added at the end of the license string.

Copy the license string from the License Information text file.
Paste the license string in the License string field of the License window.

Make sure that the license key has not been entered twice.
Check that the whole string is pasted.

Click Set.

Setting Authenticate with a Graphic Hub Administrator account, check the details again and 
confirm that you want to apply the new license.
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If the license is successfully set, a dialog is displayed:

 
If there is an error in setting the license, an appropriate message is displayed.
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The updated license information is displayed in the Graphic Hub License Details window.

If the updated license information does not display immediately, try to refresh the license 
information by clicking the Refresh button.

7.6 System Status Panel
The System Status screen shows the current mode configuration and its menu options.

Mode panel (1): Shows the current status of the configured mode:
Panel Border Color: The color of the panel border may indicate a warning state when 
orange. The shadow around the panel indicates the machine the web interface is 
currently opened on, allowing for quick identification on cluster setups.
Naming Service/Server Name/Mode/Version: Information on the current configuration. 
If the hostname exceeds 20 characters, it is truncated. However, the tooltip displays 
the name in its entirety.
Naming Service/Server Status: Displays current server status.
Data Path: Displays the path to the Graphic Hub data directory.
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Shutdown Task: Displays the status of configured shutdown tasks.
Automatic Backup: Displays the status of automatic backup tasks.
Journal Level: Displays the current journal level.

Start Server / Emergency Shutdown (2): The button label and function changes depending on 
if the Graphic Hub server is running or not. When the server is not running, click the button 
to start it. When the server is running, a Graphic Hub Emergency Shutdown can be executed 
by clicking the button.

Show Configuration (2): Open the Graphic Hub Mode Configuration panel.
Show GH Log (2): Open the Graphic Hub Server Log panel, which displays the contents of the 
server log file.

See Also

Graphic Hub Manager
Graphic Hub Shut Down

7.7 Event Log Panel

The Event Log panel contains messages, warnings, and error messages from the Graphic Hub 
server. To view the event log panel, click the double arrow icon in the lower left corner of the 
Terminal window. When the event log panel is minimized, it displays the last entry in the log only.

The event log panel view can be customized by clicking the Messages, Warnings and Errors
buttons. A pressed button means log messages of that type are included in the event log listing.

Warning: An Emergency shutdown shuts down the server almost immediately. For a 
controlled shutdown of the server, use the Graphic Hub Manager to shut it down.
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